Rozwiązania najczęstszych problemów związanych z wyświetlaniem plików PDF z witryny.

Objawy 

Najczęstsze objawy w przypadku braku możliwości wyświetlenia pliku PDF z witryny:

  • Pusta strona w przeglądarce internetowej
  • Czerwony znak X
  • Wskaźnik przerwanego łącza, taki jak czerwony kwadrat, niebieski trójkąt lub niebieski okrąg
  • Błąd: „Uruchomionego programu Adobe Acrobat/Reader nie można używać do wyświetlania plików PDF w przeglądarce internetowej. Wymagany jest program Adobe Acrobat/Reader w wersji 8 lub 9. Zakończ i spróbuj ponownie.”

Aby rozwiązać niektóre z najczęstszych problemów związanych z wyświetlaniem plików PDF, wykonaj następujące czynności w określonej kolejności: zaktualizuj program Reader lub Acrobat, rozwiąż problemy z plikiem PDF, sprawdź ustawienia przeglądarki, napraw instalację lub ponownie zainstaluj program Reader lub Acrobat.

Aktualizowanie programu Reader lub Acrobat

Firma Adobe wydaje bezpłatne aktualizacje zabezpieczeń co kwartał. Zaktualizuj program Reader lub Acrobat do najnowszej dostępnej wersji. Te aktualizacje często rozwiązują najczęściej występujące problemy. Pobierz najnowszą bezpłatną aktualizację.

  1. Uruchom program Reader lub Acrobat.

  2. Wybierz polecenia Pomoc > Sprawdź uaktualnienia. 

    Program Acrobat w wersji 9 i starszej: jeśli dostępna jest nowa aktualizacja, zostanie zainstalowana automatycznie.

    Program Acrobat X i XI: kliknij przycisk Aktualizuj, a następnie Instaluj.

    Acrobat DC: przejdź do następnego kroku.

    Sprawdzanie dostępności aktualizacji
  3. Po wyświetleniu okna dialogowego Updater kliknij przycisk Pobierz.

    Aktualizowanie programu Acrobat
  4. Po zakończeniu pobierania kliknij ikonę instalacji programu Acrobat. W oknie dialogowym Acrobat Updater kliknij przycisk Instaluj.

    Aktualizacja jest gotowa
  5. Po zakończeniu instalacji ponownie uruchom komputer i ponownie otwórz plik PDF, aby sprawdzić, czy można go wyświetlić.

Rozwiązania związane z plikami PDF

Odświeżanie lub ponowne wczytywanie strony

Często odświeżenie strony w przeglądarce umożliwia pełne wczytanie pliku PDF.

  • Przytrzymaj klawisz Shift i w przeglądarce naciśnij przycisk Odśwież lub Załaduj ponownie.

Wyświetlanie innego pliku PDF

Spróbuj wyświetlić inny plik PDF. Na przykład, czy w przeglądarce można wyświetlić ten przykładowy formularz. Jeżeli w programie Acrobat lub Reader można otworzyć przykładowy formularz, może to oznaczać, że pierwszy plik PDF jest uszkodzony lub mogą występować problemy z serwerem WWW. W razie możliwości skontaktuj się z osobą lub firmą odpowiedzialną za witrynę.

Wyświetlanie pliku PDF zapisanego na dysk twardy

Sprawdź, czy przeglądarka internetowa może otworzyć plik PDF z lokalnego dysku twardego zamiast z witryny. Aby przeprowadzić ten test, trzeba zapisać plik PDF na dysku komputera.

  1. W przeglądarce internetowej wykonaj jedną z następujących czynności:

    • Mac OS: wybierz polecenia Plik > Otwórz (lub Otwórz plik).
    • Windows: naciśnij kombinację klawiszy Control + O.
  2. Kliknij przycisk Przeglądaj.

  3. (Tylko system Windows) W polu Pliki typu z listy wybierz pozycję Wszystkie pliki.

    Wybór wszystkich plików
  4. Znajdź plik PDF na dysku komputera, zaznacz go, a następnie kliknij przycisk Otwórz.

    Jeśli plik PDF zostanie wyświetlony, może występować problem w przeglądanej witrynie. Skontaktuj się z osobą lub firmą odpowiedzialną za witrynę.

Rozwiązania związane z przeglądarką i jej ustawieniami

Korzystanie z innej przeglądarki internetowej

Niektóre warunki środowiskowe komputera, takie jak ustawienia zabezpieczeń lub ustawienia plików cookie w przeglądarce, mogą uniemożliwiać wyświetlanie plików PDF. Często najszybszym rozwiązaniem jest próba otwarcia strony w innej przeglądarce. Wypróbuj dowolną z następujących przeglądarek:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Listę przeglądarek zgodnych z programem Reader i Acrobat można znaleźć na stronie Zgodne przeglądarki internetowe.

Przełączanie na widok zgodności (Internet Explorer)

Niektóre witryny wyświetlają się lepiej w widoku zgodności przeglądarki Internet Explorer. W widoku zgodności strony są wyświetlane, tak jak w starszych wersjach przeglądarki.

Więcej informacji o przełączaniu na ten widok można znaleźć na stronie Rozwiązywanie problemów wyświetlania za pomocą widoku zgodności.

Ponowna próba otwarcia pliku PDF po ponownym uruchomieniu komputera

Ponownie uruchom komputer, po czym otwórz witrynę ponownie. Ponowne uruchomienie powoduje wyczyszczenie pamięci i pamięci podręcznej komputera. Częste ponowne uruchamianie komputera może pozwolić rozwiązać problemy z wyświetlaniem.

Usuwanie tymczasowych plików internetowych (Internet Explorer, Firefox i Chrome)

Wyczyść pamięć podręczną przeglądarki (czasem nazywaną tymczasowymi plikami internetowymi), aby upewnić się, że wyświetlana jest najnowsza wersja strony. 

Zachowaj ostrożność, zaznaczając opcje. Wyczyść tylko pamięć podręczną przeglądarki. Wyczyszczenie wszystkich tymczasowych plików internetowych może spowodować usunięcie plików cookie zawierających dane logowania i preferencje witryn. Większość przeglądarek umożliwia wybór typu usuwanej zawartości.

Czyszczenie historii
Okno dialogowe Wyczyść całą historię przeglądarki Firefox umożliwia usunięcie tylko pamięci podręcznej przeglądarki.

Więcej informacji o czyszczeniu pamięci podręcznej przeglądarki można znaleźć w następujących artykułach: 

Firefox: Usuwanie historii przeglądania, wyszukiwania i historii pobierania

Chrome: Usuwanie pamięci podręcznej, historii i innych danych przeglądarki

Internet Explorer w wersji 8–11: Przeglądanie i usuwanie historii przeglądarki

Internet Explorer 7Usuwanie historii przeglądania stron sieci Web

Resetowanie ustawienia wyświetlania plików PDF w preferencjach przeglądarki (Acrobat/Reader X lub starsze wersje)

Spróbuj zresetować preferencje wyświetlania w przeglądarce, aby rozwiązać problem związany z wyświetlaniem.

  1. W programie Reader lub Acrobat kliknij prawym przyciskiem myszy okno dokumentu i wybierz polecenie Preferencje wyświetlania strony.

    Preferencje wyświetlania strony
  2. Z listy po lewej stronie wybierz pozycję Internet.

    Wybór polecenia Preferencje internetowe
  3. Usuń zaznaczenie Wyświetl PDF w przeglądarce, a następnie kliknij przycisk OK.

    Usuwanie zaznaczenia opcji Wyświetl PDF w przeglądarce
  4. Ponownie spróbuj otworzyć plik PDF w witrynie.

Wyświetlanie plików PDF w 32-bitowej wersji przeglądarki Internet Explorer lub Safari (tylko system Windows Vista)

Procedura dotyczy tylko użytkowników systemu Windows Vista z przeglądarką Internet Explorer w wersji 9 lub starszej.

W systemie Windows programy Acrobat lub Reader są aplikacjami 32-bitowymi. W przypadku próby otwarcia pliku PDF w 64-bitowej wersji przeglądarki Internet Explorer zostanie on otwarty w programie Acrobta lub Reader, a nie w przeglądarce Internet Explorer.

Uwaga:

Przeglądarka Internet Explorer 9 jest obsługiwana tylko przez programy Reader lub Acrobat w wersji 10.1 i nowszej.

Aby sprawdzić, czy używana jest 32-bitowa wersja przeglądarki Internet Explorer, wykonaj następujące czynności:

  1. W przeglądarce Internet Explorer wybierz polecenia Pomoc > Internet Explorer — informacje. (W niektórych wersjach przeglądarki Internet Explorer wybierz znak zapytania w górnym prawym rogu okna, aby móc wybrać polecenie Internet Explorer — informacje.)

    Internet Explorer 9 — informacje

    Jeśli obok numeru wersji jest tekst „Wersja 64-bitowa”, przejdź do kroku 2.

    Internet Explorer w wersji 64-bitowej
  2. Aby przełączyć się na przeglądarkę Internet Explorer w wersji 32-bitowej, najpierw zamknij przeglądarkę Internet Explorer w wersji 64-bitowej. Następnie kliknij dwurkrotnie ikonę programu w wersji 32-bitowej:

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    Internet Explorer w wersji 32-bitowej

Rozwiązania związane z programami Reader i Acrobat

Naprawianie instalacji programu Reader lub Acrobat

Instalacje programu Reader lub Acrobat mogą zostać uszkodzone. Naprawa instalacji jest szybkim środkiem rozwiązywania problemów.

Naprawa z poziomu programu Reader lub Acrobat

Wybierz polecenia Pomoc > Napraw instalację programu.

Pomoc, Napraw instalację programu

Naprawa za pomocą narzędzia Panel sterowania (system Windows)

Instalację programu Acrobat lub Reader można również naprawić za pomocą narzędzia Panel sterowania systemu Windows.

  1. Zamknij program Reader lub Acrobat.

  2. Kliknij polecenia Start > Panel sterowania.

    Otwieranie Panelu sterowania z menu Start
  3. W zależności od wersji systemu Windows w oknie Panel sterowania wykonaj jedną z poniższych czynności:

    • (Windows 8/7/Vista) Kliknij polecenie Programy, a następnie Programy i funkcje.
    • (Windows XP) Kliknij dwukrotnie ikonę Dodaj lub usuń programy.
  4. Na liście programów zaznacz pozycję Adobe Reader lub Adobe Acrobat.

  5. Kliknij przycisk Zmień i postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, aby naprawić instalację aplikacji.

    Kliknięcie przycisku Zmień w celu naprawy
  6. Po ukończeniu procesu kliknij przycisk Zakończ.

Rozwiązania zaawansowane

Jeśli żadne z rozwiązań w poprzedniej części nie pozwoliło rozwiązać problemu z wyświetlaniem plików PDF, można wypróbować następujące czynności dla zaawansowanych użytkowników.

Włączane dodatku przeglądarki do obsługi plików Adobe PDF (Internet Explorer w wersji 8 i nowszej)

Sprawdź, czy dodatek przeglądarki do obsługi plików Adobe PDF jest włączony.

  1. Otwórz przeglądarkę Internet Explorer i wybierz Narzędzia > Zarządzaj dodatkami.

  2. W obszarze Rodzaje dodatków wybierz Paski narzędzi i rozszerzenia.

  3. Z listy Pokaż wybierz pozycję Wszystkie dodatki.

    Wszystkie dodatki
  4. Na liście dodatków zaznacz pozycję Adobe PDF Reader.

    Uwaga:

    Jeśli dodatku Adobe PDF Reader nie ma na liście, wybierz inne pozycje z listy. W niektórych systemach dodatek ten jest dostępny po wybraniu pozycji Uruchom bez uprawnień.

  5. Kliknij przycisk Włącz.

    Uwaga:

    Jeśli etykieta przycisku to Wyłącz, oznacza to, że dodatek jest już włączony. Etykieta przycisku zmienia się między Włącz i Wyłącz, w zależności od stanu zaznaczonego dodatku.

    Naciśnięcie przycisku Włącz umożliwi dodatkowi Adobe PDF Reader otwieranie plików w przeglądarce.

    Naciśnięcie przycisku Wyłącz spowoduje wyłączenie dodatku i tym samym uniemożliwi mu otwieranie plików PDF w przeglądarce.

    Włączanie dodatku Acrobat Reader

Włączanie dodatku przeglądarki do obsługi plików Adobe PDF (Firefox)

Sprawdź, czy dodatek przeglądarki do obsługi plików Adobe PDF (nppdf32.dll) jest włączony.

  1. W pasku adresu przeglądarki Firefox wpisz: about:plugins.

  2. Przewiń w dół do części o nazwie Adobe Acrobat.

    Włączone w przeglądarce Firefox
  3. Sprawdź, czy w polu Plik jest tekst „nppdf32.dll” i „Adobe Acrobat Plug-In for Firefox and Netscape”.
    Jeśli ten wpis jest niedostępny, zainstaluj najnowszą wersję programu Reader lub Acrobat.

Uruchamianie programu Acrobat lub Reader na nowym koncie administratora lokalnego

Utwórz konto użytkownika o tych samych uprawnieniach, co konto używane w chwili wystąpienia problemu. Ewentualnie utwórz konto administratora lokalnego. Jeśli problem nie wystąpi ponownie po zalogowaniu na nowe konto, oznacza to, że pierwotne konto użytkownika jest uszkodzone.

Więcej informacji o konfiguracji konta użytkownika można znaleźć w następujących zasobach lub kontaktując się z administratorem sieci:

Windows XP: Dodawanie nowego użytkownika komputera

Windows Vista/7/8: Tworzenie konta użytkownika

Mac OS X: Tworzenie nowych użytkowników na komputerze Mac

Optymalizowanie dużych plików PDF

Jeśli wielkość pliku PDF to 4 MB lub więcej, poproś dostawcę o zoptymalizowanie pliku PDF. Więcej informacji o optymalizowaniu plików PDF można znaleźć na stronie Optymalizowanie plików PDF.

Sprawdzanie ścieżki rejestru programu Acrobat lub Reader (system Windows)

Wyłączenie odpowiedzialności: w rejestrze przechowywane są informacje związane z systemem, które mają znaczenie do prawidłowej pracy komputera i aplikacji. Przed modyfikacją rejestru wykonaj jego kopię zapasową. Firma Adobe nie oferuje pomocy technicznej związanej z problemami, które mogą wynikać z nieprawidłowej modyfikacji rejestru. Firma Adobe zaleca, aby modyfikacje rejestru były przeprowadzane przez osobę z doświadczeniem w edycji plików systemowych. Więcej informacji o rejestrze można znaleźć w dokumentacji systemu Windows. Można je też uzyskać, kontaktując się z firmą Microsoft.

  1. Wybierz polecenia Start > Uruchom.

  2. Wpisz polecenie regedit i kliknij przycisk OK.

  3. Przejdź do klucza HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Upewnij się, że w wartości klucza (Domyślna) jest wprowadzona ścieżka instalacji programu Acrobat lub Reader.

    • Domyślna ścieżka programu Reader to: „C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe”.
    • Domyślna ścieżka programu Acrobat to: „C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe”.

    Uwaga:

    Jeśli program Acrobat lub Reader są zainstalowane w lokalizacji innej niż domyślna, sprawdź, czy wartość klucza (Domyślna) wskazuje rzeczywistą lokalizację.

Wideo przestawiające procedurę można znaleźć na stronie Sprawdzanie poprawności ścieżki w rejestrze.

Jeśli powyższa pozycja rejestru nie istnieje w systemie, wykonaj następujące czynności:

  1. Wybierz polecenia Start > Uruchom.

  2. Wpisz polecenie regedit i kliknij przycisk OK.

  3. Utwórz kopię zapasową rejestru:

    • W oknie dialogowym Edytor rejestru wybierz polecenia Plik > Eksportuj.
    • Wpisz nazwę pliku i wybierz lokalizację.
    • W obszarze Zakres eksportu zaznacz opcję Wszystko.
    • Kliknij przycisk Zapisz.
  4. Wybierz polecenia Edycja > Nowy > Klucz i utwórz brakujący klucz HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. Wybierz polecenia Edycja > Nowy > Wartość ciągu i wpisz nazwę tego klucza: (Domyślna).

  6. Zaznacz wartość (Domyślna), a następnie wybierz polecenia Edycja > Modyfikuj. W polu „Dane wartości” wpisz domyślną ścieżkę (wskazaną powyżej) programu.

  7. Ponownie uruchom komputer.

Naprawianie klucza rejestru HKCR\AcroExch.Document (system Windows)

Klucz może być uszkodzony, wskazywać nieużywaną wersję programu Acrobat lub Reader lub wskazywać przeglądarkę plików PDF innej firmy.

Wyłączenie odpowiedzialności: w rejestrze przechowywane są informacje związane z systemem, które mają znaczenie do prawidłowej pracy komputera i aplikacji. Przed modyfikacją rejestru wykonaj jego kopię zapasową. Firma Adobe nie oferuje pomocy technicznej związanej z problemami, które mogą wynikać z nieprawidłowej modyfikacji rejestru. Firma Adobe zaleca, aby modyfikacje rejestru były przeprowadzane przez osobę z doświadczeniem w edycji plików systemowych. Więcej informacji o rejestrze można znaleźć w dokumentacji systemu Windows. Można je też uzyskać, kontaktując się z firmą Microsoft.

  1. Wybierz polecenia Start > Uruchom, w oknie dialogowym Uruchamianie w polu Otwórz wpisz regedit, a następnie kliknij przycisk OK.

  2. Utwórz kopię zapasową rejestru:

    • W oknie dialogowym Edytor rejestru wybierz polecenia Plik > Eksportuj.
    • Wpisz nazwę pliku i wybierz lokalizację.
    • W obszarze Zakres eksportu zaznacz opcję Wszystko.
    • Kliknij przycisk Zapisz.
  3. Przejdź do klucza HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Kliknij prawym przyciskiem klucz AcroExch.Document i wybierz polecenie Usuń. Upewnij się, że zaznaczony jest poprawny klucz i po wyświetleniu monitu kliknij przycisk Tak.

  5. Kliknij prawym przyciskiem klucz AcroExch.Document.7 i wybierz polecenie Usuń. Upewnij się, że zaznaczony jest poprawny klucz i po wyświetleniu monitu kliknij przycisk Tak.

  6. Odpowiednie czynności przedstawia to wideo.

     

Zmiana nagłówka content-type na serwerze WWW (administrator witryny)

Jeśli użytkownik jest administratorem WWW lub ma uprawnienia administratora do witryny, można skonfigurować serwer WWW, tak aby w przypadku plików PDF były wysyłane nagłówki content-type „application/pdf”. Więcej informacji można znaleźć w dokumentacji dostarczonej z serwerem WWW lub w tym artykule pomocy technicznej firmy Microsoft.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online