Program Acrobat zmniejsza rozmiar pliku PDF bez utraty jakości. Narzędzie kompresji Acrobat PDF pozwala równoważyć zoptymalizowany rozmiar pliku względem oczekiwanej jakości obrazów, czcionek i innej zawartości pliku.

Compress PDF files online

Szybko zmniejsz rozmiar pliku PDF online.

Wypróbuj teraz bezpłatnie


Zapisywanie za pomocą optymalizatora PDF (Acrobat Pro)

Narzędzie Optymalizator PDF zapewnia wiele możliwości zmniejszania rozmiarów plików PDF. Niektóre z ustawień Optymalizatora plików PDF są podobne do ustawień dostępnych podczas tworzenia plików PDF za pomocą programu Distiller. To, które z nich zostaną wybrane w konkretnej sytuacji, zależy po części od przeznaczenia pliku, a po części od jego własności.

W większości wypadków najbardziej efektywne są ustawienia domyślne. Mówiąc zaś nieco konkretniej, do typowych zabiegów zmniejszających rozmiary plików należą: usuwanie osadzonych czcionek, kompresja obrazów i usuwanie elementów niepotrzebnych. Przed rozpoczęciem optymalizacji warto przeprowadzić inspekcję zawartości dokumentu. Wyniki inspekcji mogą stanowić wskazówkę co do tego, które elementy warto poddać kompresji. Rozmiar pliku PDF można zmniejszyć również za pomocą polecenia Zmniejsz rozmiar pliku.

Uwaga:

  • Zastosowanie pewnych metod kompresji obrazów może uniemożliwić ich poprawne drukowanie. Z tego względu przed przystąpieniem do kompresji użytkownik powinien wypróbować różne ustawienia.
  • Optymalizator PDF nie jest dostępny, jeśli w menu Widok jest zaznaczona opcja Zawijaj.

Krótki samouczek wideo

Dowiedz się, jak kompresować pliki PDF w celu zmniejszenia ich rozmiaru za pomocą programu Adobe Acrobat DC w systemach Windows lub na komputerach Mac.

Wideo (0:27)

Inspekcja zawartości dokumentu PDF (Acrobat Pro)

W wyniku inspekcji zawartości dokumentu jest generowany raport o ilości pamięci (liczbie bajtów) zajmowanej przez poszczególne elementy dokumentu, w tym czcionki, obrazy, zakładki, formularze, nazwane miejsca docelowe i komentarze. W raporcie są uwzględniane wartości bezwzględne (rzeczywiste liczby bajtów), jak i wartości względne (procentowy udział poszczególnych elementów w całkowitej wielkości pliku).

  1. Wybierz kolejno Plik > Zapisz jako inny > Zoptymalizowany plik PDF lub przejdź do menu Narzędzia > Optymalizuj dokument PDF, a następnie kliknij opcję Zaawansowana optymalizacja. Wyświetlone zostanie okno Optymalizatora PDF.

  2. Kliknij przycisk Sprawdź zużycie miejsca w górnej części okna dialogowego.

Uwaga:

Możesz również sprawdzić zużycie miejsca przez plik PDF w panelu Zawartość. Wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Zawartość. Wybierz Sprawdź zużycie miejsca z menu opcji panelu Zawartość .

Optymalizacja dokumentu PDF (Acrobat Pro)

  1. Otwórz dokument PDF w programie Acrobat DC.

  2. Wybierz kolejno Plik > Zmniejsz rozmiar pliku lub Kompresuj plik PDF.

    Uwaga:

    Firma Adobe testuje uproszczoną funkcję optymalizacji plików PDF pod dwiema innymi nazwami: Zmniejsz rozmiar pliku i Kompresuj plik PDF. Po aktualizacji programu do najnowszego wydania zostanie wyświetlona opcja Kompresuj plik PDF lub opcja Zmniejsz rozmiar pliku. Obie opcje mają taką samą funkcję.

  3. Wybierz lokalizację, aby zapisać plik, i kliknij przycisk Zapisz. Program Acrobat DC wyświetli komunikat informujący o pomyślnym zmniejszeniu rozmiaru pliku PDF.

    Komunikat o pomyślnym zmniejszeniu rozmiaru pliku

  1. W programie Acrobat DC przejdź do menu Narzędzia > Optymalizuj dokument PDF.

  2. Rozwiń na pasku narzędzi listę Zmniejsz rozmiar pliku i kliknij opcję Zmniejsz rozmiar wielu plików.

    Zmniejszanie rozmiaru wielu plików

    Uwaga:

    Firma Adobe testuje funkcję zmniejszania rozmiaru plików w pasku narzędzi Optymalizuj dokument PDF pod dwiema nazwami: Zmniejsz rozmiar pliku i Kompresuj plik PDF. Po aktualizacji programu do najnowszego wydania zostanie wyświetlona opcja Kompresuj plik PDF lub opcja Zmniejsz rozmiar pliku. Obie opcje mają taką samą funkcję.

  3. W oknie dialogowym Organizuj dokumenty kliknij kolejno Dodaj pliki > Dodaj pliki.

    Wybieranie i dodawanie plików
  4. W oknie dialogowym Dodaj pliki wybierz pliki, które chcesz dodać, kliknij przycisk Otwórz, a następnie kliknij przycisk OK.

  5. Określ zgodność wersji zależnie od potrzeb, a następnie kliknij przycisk OK.

    Uwaga: jeśli masz pewność, że wszyscy użytkownicy posiadają program Acrobat DC lub Adobe Acrobat Reader DC, ograniczenie zgodności pliku do najnowszej wersji pozwoli dodatkowo zmniejszyć jego rozmiar.

  6. W oknie dialogowym Opcje wyjściowe określ preferencje dotyczące folderu oraz nazwy pliku i kliknij przycisk OK.

  1. Otwórz okno dialogowe narzędzia Optymalizator plików PDF (Plik > Zapisz jako inny > Zoptymalizowany plik PDF lub przejdź do menu Narzędzia> Optymalizuj dokument PDF i kliknij opcję Zaawansowana optymalizacja).

  2. Aby użyć ustawień domyślnych, wybierz z menu Ustawienia opcję Domyślne, a następnie przejdź do kroku 6. Zmiana jakichkolwiek ustawień w oknie dialogowym Optymalizator PDF spowoduje automatyczne przełączenie menu Ustawienia na Własne.

  3. Z menu Utwórz zgodny z wybierz polecenie Zachowaj istniejący, aby zachować bieżącą wersję pliku PDF, lub wybierz wersję programu Acrobat. (W zależności od dokonanego wyboru w panelach mogą być dostępne różne opcje.)

  4. Zaznacz pole wyboru obok panelu (np. Obrazy, Czcionki lub Przezroczystość), a następnie zaznacz opcje w tym panelu. Aby zapobiec wykonywaniu wszystkich opcji z panelu podczas optymalizowania, usuń zaznaczenie pola wyboru odpowiadającego temu panelowi.

  5. Jeśli zachodzi potrzeba zapisania dostosowanych ustawień, kliknij Zapisz i określ nazwę ustawień. (Aby usunąć zapisane ustawienie, należy je wybrać w menu Ustawienia i kliknąć Usuń).

  6. Po zakończeniu konfigurowania opcji kliknij OK.

  7. W oknie dialogowym Zapisz zoptymalizowany jako kliknij Zapisz, aby zastąpić oryginalny plik PDF jego wersją zoptymalizowaną bądź też wybierz nową nazwę lub nowe miejsce zapisania pliku.

    Uwaga:

    Aby zoptymalizować kilka dokumentów jednocześnie, skorzystaj z opcji wyjściowych kreatora operacji.

Opcje Optymalizatora plików PDF (Acrobat Pro)

Aby zmniejszyć rozmiar pliku PDF, skorzystaj z opcji dostępnych w panelach w oknie dialogowym Optymalizator PDF.

Panel Obrazy

Panel Obrazy w oknie dialogowym Optymalizator PDF umożliwia ustawianie opcji próbkowania obrazów w dół oraz kompresji obrazów kolorowych, obrazów w skali szarości i obrazów monochromatycznych.

Opcje Optymalizatora plików PDF w programie Acrobat
Zmiana zgodności ze standardem PDF w panelu Obrazy w oknie dialogowym Optymalizator PDF w programie Acrobat Pro

Określ następujące opcje stosownie do potrzeb:

Próbkowanie w dół

Rozmiar pliku jest zmniejszany w efekcie procedury zmniejszania rozdzielczości obrazów poprzez łączenie pikseli sąsiadujących ze sobą w nowe, większe piksele.

Uwaga: obrazy maskowane i obrazy o rozmiarze mniejszym niż 16 na 16 pikseli nie są próbkowane w dół.

Kompresja

Rozmiar pliku jest zmniejszany w efekcie procedury usuwania niepotrzebnych lub nadmiarowych danych dotyczących pikseli. Kompresja JPEG i JPEG 2000 daje najlepsze wyniki w przypadku obrazów o ciągłych przejściach między kolorami (takich jak fotografie). Format ZIP jest lepszym wyborem w przypadku ilustracji zawierających duże obszary jednolitego, płaskiego koloru lub wzorków utworzonych z takich kolorów. W przypadku obrazów monochromatycznych metoda JBIG2 — dostępna w oknie Optymalizator PDF, ale niedostępna w programie Distiller — zapewnia lepsze wyniki niż metoda CCITT.

Jakość

Opcja dostępna tylko w przypadku formatów JPEG i JPEG 2000. Te metody są zwykle stratne, co znaczy, że w ich wyniku pewne dane dotyczące pikseli są trwale usuwane. W przypadku obrazów kolorowych stratna kompresja JPEG i JPEG 2000 może być stosowana na różnych poziomach (minimalnym, niskim, średnim, wysokim i maksymalnym). Dla kompresji JPEG 2000 można ustawić metodę bezstratną, dzięki czemu nie będą usuwane żadne dane dotyczące pikseli. Kompresja obrazów monochromatycznych jest bezstratna za wyjątkiem metody JBIG2, która zapewnia tryb stratny i bezstratny.

Rozmiar fragmentu

Opcja dostępna tylko w przypadku formatu JPEG 2000. Dzieli kompresowany obraz na fragmenty o zadanej wielkości. (Jeżeli wysokość lub szerokość obrazu nie stanowi równego iloczynu wielkości fragmentu, to na krawędziach zostaną wstawione niepełne fragmenty). Dane obrazu w każdym fragmencie są osobno kompresowane i mogą być osobno dekompresowane. Zalecane jest użycie domyślnej wartości 256.

Optymalizuj obrazy tylko w przypadku zmniejszenia rozmiaru

Jeśli ustawienie obrazu będzie powodować zwiększenie rozmiaru pliku, wybranie tej opcji spowoduje pominięcie tego obrazu podczas optymalizowania.

Panel Czcionki

Aby dopasowanie do dokumentu źródłowego było dokładne, można osadzić wszystkie czcionki używane w dokumencie. Jeśli dokładne dopasowanie nie jest wymagane i jeśli jest preferowany niewielki rozmiar pliku, można zrezygnować z osadzania czcionek dla tekstu napisanego alfabetem łacińskim lub w języku wschodnioazjatyckim (chińskim tradycyjnym, chińskim uproszczonym, koreańskim i japońskim). Gdy w systemie nie zainstalowano czcionki oryginalnej, jest ona zastępowana czcionką podstawioną. Panel Czcionki w oknie dialogowym Optymalizator PDF zawiera dwie listy czcionek: listę czcionek, których osadzenie można cofnąć, i listę czcionek, których osadzenie ma zostać cofnięte. W przypadku niektórych czcionek rezygnacja z ich osadzenia nie jest możliwa; czcionki te nie są wyświetlane w panelu Czcionki. Aby zrezygnować z osadzania czcionek w dokumencie, należy zaznaczyć wybrane czcionki na liście Czcionki osadzone i kliknąć na przycisk Usuń osadzanie. Jeśli podzbiory osadzonych czcionek nie mają być osadzane, należy usunąć zaznaczenie pola wyboru Utwórz podzbiór wszystkich osadzonych czcionek. Aby zapobiec cofaniu osadzania wszystkich czcionek w dokumencie, należy wybrać pozycję Nie cofaj osadzania żadnej czcionki.

Panel Przezroczystość

Jeśli dokument PDF zawiera obiekty przezroczyste, to przy użyciu predefiniowanych ustawień w panelu Przezroczystość Optymalizatora plików PDF można spłaszczyć przezroczystość i zmniejszyć rozmiar pliku. (Operacja spłaszczania polega na dzieleniu obiektów przezroczystych na obszary reprezentowane wektorowo i za pomocą rastrów). Opcje przezroczystości są stosowane do stron dokumentu (wszystkich) przed zastosowaniem jakichkolwiek innych ustawień optymalizacji.

Po wybraniu opcji zgodności Acrobat 4.0 i nowsze panel Przezroczystość jest aktywny i wszelka przezroczystość w pliku zostaje spłaszczona podczas optymalizacji. Pozwala to uzyskać pliki zgodne z programem Acrobat 4.0 i jego starszymi wersjami, które nie obsługują przezroczystości.

Utworzone samodzielnie predefiniowane ustawienia spłaszczania są wyświetlane w panelu Przezroczystość razem z domyślnymi ustawieniami predefiniowanymi.

Uwaga:

Po zapisaniu pliku operacja spłaszczania przezroczystości nie może zostać cofnięta.

Panel Pomiń obiekty

Panel Pomiń obiekty pozwala określić obiekty, które mają być usunięte z pliku PDF, a ponadto umożliwia optymalizację krzywych na rysunkach CAD. Można pomijać zarówno obiekty utworzone w programie Acrobat, jak i w innych aplikacjach. Zaznaczenie obiektu powoduje usunięcie z dokumentu PDF wszystkich wystąpień tego obiektu.

W obszarze Pomiń obiekty są dostępne między innymi następujące opcje:

Odrzuć wszystkie operacje przesyłania formularzy, importu i resetowania

Wyłącza wszystkie operacje dotyczące przesyłania lub importowania danych formularzy oraz kasuje pola formularzy. Ta opcja zachowuje obiekty formularzy, z którymi związane są operacje.

Spłaszcz pola formularzy

Powoduje, że pola formularza stają się nieużyteczne, ale zachowują swój wygląd. Dane formularza są łączone ze stroną i stają się jej zawartością.

Odrzuć wszystkie operacje JavaScript

Powoduje, że z pliku PDF są usuwane wszystkie operacje JavaScript.

Odrzuć wszystkie obrazy zastępcze

Są usuwane wszystkie wersje obrazu oprócz tej, która jest przeznaczona do wyświetlania na ekranie. Niektóre dokumenty PDF zawierają wiele wersji tego samego obrazu o różnym przeznaczeniu, na przykład wersje przeznaczone do drukowania i wersje przeznaczone do wyświetlania w niskiej rozdzielczości.

Pomiń osadzone miniatury stron

Są usuwane osadzone miniatury stron. Jest to użyteczne w przypadku obszernych dokumentów, kiedy rysowanie wszystkich miniatur (po kliknięciu przycisku Miniatury stron) trwa bardzo długo.

Pomiń znaczniki dokumentu

Są usuwane znaczniki wyznaczające strukturę dokumentu, co sprawia, że dokument staje się mniej dostępny (np. nie może być zawijany).

Konwertuj gładkie linie na krzywe

Zmniejsza liczbę punktów kontrolnych wykorzystywanych do tworzenia krzywych na rysunkach CAD, dzięki czemu plik PDF jest mniejszy i szybciej się wyświetla.

Wykryj i połącz fragmenty obrazów

Są wyszukiwane obrazy pofragmentowane, a ich fragmenty są scalane.

Pomiń osadzone ustawienia druku

Usuwa z dokumentu osadzone ustawienia druku, takie jak skalowanie strony i tryb dupleksowy.

Pomiń osadzony indeks wyszukiwania

Usuwa osadzone indeksy wyszukiwania, co zmniejsza rozmiar pliku.

Pomiń zakładki

Usuwane są wszystkie zakładki zawarte w pliku PDF.

Panel Pomiń dane użytkownika

Panel Pomiń dane użytkownika pozwala usunąć wszelkie informacje osobiste, które nie powinny być rozpowszechniane ani udostępniane innym użytkownikom. Jeśli informacji osobistych nie można znaleźć, być może są one ukryte. Tekst ukryty oraz informacje związane z użytkownikiem można zlokalizować przy pomocy polecenia Zbadaj dokument (Narzędzia > Redaguj > Oczyść dokument, a następnie wybierz opcję Usuń ukryte informacje).

Odrzuć wszystkie komentarze, formularze i multimedia

Z pliku PDF są usuwane wszystkie komentarze, formularze, pola formularzy i zawartość multimedialna.

 

Pomiń informacje o dokumencie i metadane

Usuwane są informacje ze słownika informacji o dokumencie oraz strumienie metadanych. (Polecenie Zapisz jako umożliwia przywrócenie strumieni metadanych w kopii pliku PDF).

 

Pomiń wszystkie dane obiektów

Usuwane są wszystkie obiekty zawarte w pliku PDF.

 

Pomiń załączniki

Usuwane są wszystkie załączniki, w tym załączniki dodane do pliku PDF jako komentarze. (Optymalizator PDF nie optymalizuje załączników).

 

Pomiń zewnętrzne odnośniki

Usuwane są łącza do innych dokumentów. Łącza do innych miejsc w pliku PDF nie są usuwane.

 

Pomiń dane specyficzne dla innych aplikacji

Z dokumentu PDF są usuwane te informacje, które są istotne tylko z punktu widzenia aplikacji, w której go utworzono. Opcja ta nie wpływa na funkcje dokumentu PDF, ale zmniejsza rozmiar jego pliku.

 

Pomiń ukrytą zawartość warstw i warstwy spłaszczone

Zmniejszany jest rozmiar pliku. Dokument zoptymalizowany wygląda jak źródłowy plik PDF, ale nie zawiera żadnych informacji o warstwach.

Panel Wyczyść

Opcje dostępne w panelu Wyczyść Optymalizatora plików PDF umożliwiają usunięcie z dokumentów elementów bezużytecznych. Obejmuje to elementy nieaktualne i zbędne dla planowanego przeznaczenia dokumentu. Usunięcie niektórych elementów ma istotny wpływ na funkcjonalność pliku PDF. Domyślnie zaznaczane są tylko takie elementy, których usunięcie jest nieszkodliwe. Jeśli nie ma pewności co do skutków usunięcia innych opcji, należy użyć domyślnych zaznaczeń.

Opcje kompresji obiektów

Umożliwia określenie sposobu stosowania kompresji Flate w pliku.

Zakoduj niezakodowane strumienie za pomocą kompresji Flate

Kompresja Flate jest stosowana do wszystkich strumieni, które nie są zakodowane.

W przypadku strumienia używających kodowania LZW stosuj kompresję Flate

Powoduje zastosowanie kompresji Flate do wszystkich strumieni zawartości i obrazów używających kodowania LZW.

Odrzuć nieprawidłowe zakładki

Z dokumentu są usuwane zakładki wskazujące na strony, które zostały uprzednio usunięte.

Odrzuć nieprawidłowe łącza

Są usuwane łącza, które prowadzą do nieaktualnych miejsc docelowych.

Odrzuć nazwane miejsca docelowe bez odniesień

Z dokumentu PDF są usuwane nazwane miejsca docelowe, do których nie odwołują się żadne obiekty w tym dokumencie. Ponieważ ta opcja nie powoduje sprawdzania łączy z innych plików PDF czy witryn internetowych, nie jest odpowiednia w niektórych obiegach pracy.

Optymalizuj zawartość strony

Powoduje konwersję wszystkich znaków końca wiersza na spacje, dzięki czemu poprawia się wydajność kompresji Flate.

Optymalizuj plik PDF do szybkiego podglądu w Internecie

Dokument PDF jest restrukturyzowany, tak aby można było pobierać go z serwerów WWW strona po stronie.

Włączanie Szybkiego podglądu w Internecie w pliku PDF

Uaktywnienie funkcji Szybki podgląd w Internecie powoduje taką przebudowę struktury dokumentu Adobe PDF, aby można było pobierać go z serwerów WWW strona po stronie. Funkcja ma tę zaletę, że serwer internetowy wysyła do użytkownika tylko wybraną stronę, a nie cały dokument PDF. Ta opcja jest szczególnie ważna w przypadku dużych dokumentów, których pobieranie z serwera jest czasochłonne.

Skontaktuj się z administratorem witryny, aby upewnić się, że oprogramowanie serwera internetowego obsługuje pobieranie pojedynczych stron. Aby zagwarantować, że dokumenty PDF w witrynie internetowej będą pojawiały się w starszych przeglądarkach, należy utworzyć do nich łącza HTML (zamiast używać skryptów ASP lub metody POST) i użyć względnie krótkich nazw ścieżek (do 256 znaków).

Sprawdzanie dostosowania istniejącego pliku PDF do funkcji Szybkiego podglądu w Internecie

  1. Otwórz plik PDF w programie Acrobat i wybierz polecenie Plik > Właściwości. W prawym dolnym rogu panelu Opis poszukaj ustawienia Szybki podgląd w Internecie (Tak lub Nie).

Sprawdzanie ustawienia Preferencje szybkiego podglądu w Internecie

Opisana niżej procedura zapewnia uruchomienie Szybkiego podglądu w Internecie podczas tworzenia plików PDF.

  1. W oknie dialogowym Preferencje, w sekcji Kategorie, wybierz Dokumenty.

  2. Upewnij się, że w prawej części okna dialogowego, w sekcji Zapisz ustawienia, jest zaznaczona opcja Polecenie Zapisz jako optymalizuje do szybkiego podglądu w Internecie, a następnie kliknij OK.

Włączanie Szybkiego podglądu w Internecie dla istniejącego pliku PDF

Procedura powinna być zastosowana po sprawdzeniu ustawienia preferencji szybkiego podglądu w Internecie i atrybutów PDF w celu upewnienia się, że dany plik nie jest już gotowy do Szybkiego podglądu w Internecie.

  1. Otwórz plik PDF.

  2. Wybierz polecenie Plik > Zapisz jako. Zaznacz taką samą nazwę pliku i jego położenie.

  3. Po wyświetleniu ostrzeżenia dotyczącego nadpisania pliku wybierz OK.

Uwaga:

W programie Acrobat Pro można także w łatwy sposób włączyć funkcję szybkiego podglądu w Internecie w folderach zawierających pliki Adobe PDF za pomocą operacji Przygotuj do opublikowania w Internecie. Patrz Uruchamianie operacji.