Uwaga:

W przypadku programu Photoshop CS6 funkcje związane z grafiką 3D były dostępne tylko w wersji Photoshop Extended. Wszystkie funkcje programu Photoshop Extended zostały dodane do programu Photoshop CC. Program Photoshop CC nie jest dostępny osobno w wersji Extended.

Omówienie plików 3D i sposobów ich wyświetlania

Program Photoshop umożliwia rozmieszczanie i animowanie modeli 3D, edytowanie tekstur i oświetlenia oraz udostępnia kilka trybów renderowania.

Podstawy pracy w 3D

Pliki 3D zawierają następujące składniki:

Siatki

Siatki stanowią podstawową strukturę modelu 3D. Siatka jest zwykle wizualizowana jako szkielet zbudowany z tysięcy wielokątów. Model 3D zawsze ma co najmniej jedną siatkę. Może być złożony z wielu siatek. Program Photoshop umożliwia wyświetlanie siatek w różnych trybach renderowania i edytowanie każdej oddzielnie. Nie można zmieniać wielokątów w siatce, ale można zmieniać orientację siatki i przekształcać siatkę, skalując wzdłuż różnych osi. Korzystając z udostępnionych kształtów lub konwertując istniejące warstwy 2D, można również tworzyć własne siatki 3D. Zobacz Ustawienia siatki 3D.

Uwaga:

Siatkę wielokątów modelu 3D można edytować tylko w programie do tworzenia grafiki 3D.

Materiały

Wygląd siatki jest (w całości lub w części) zależny od materiałów. Z siatką można skojarzyć jeden materiał lub kilka materiałów. Ostateczny wygląd materiału zależy od składników podrzędnych określanych jako mapy tekstur. Mapy tekstur są plikami obrazów 2D wpływającymi na cechy obrazu, na przykład kolor, wzorek, połyskliwość czy nierówności. Wygląd materiału w programie Photoshop można zdefiniować przy użyciu maksymalnie 9 różnych map tekstur. Zobacz Ustawienia materiałów 3D.

Światła

Dostępne typy świateł to: Światło nieskończone, Światło punktowe, Światło ze źródłem punktowym, a także Światła z obrazem, które „zawijają się” wokół sceny. Można przesuwać światła oraz dopasowywać kolory i intensywność istniejących świateł, a także dodawać nowe światła do sceny 3D. Zobacz Ustawienia świateł 3D.

Otwieranie pliku 3D

Program Photoshop może otwierać pliki w następujących formatach 3D: DAE (Collada), OBJ, 3DS, U3D i KMZ (Google Earth).

  1. Wykonaj jedną z następujących czynności:

    • Aby otworzyć plik 3D jako osobny dokument, wybierz polecenie Plik > Otwórz, a następnie wybierz plik.

    • Aby dodać plik 3D jako warstwę w otwartym pliku, wybierz polecenie 3D > Nowa warstwa z pliku 3D, a następnie wybierz plik 3D. Nowa warstwa przyjmuje wymiary otwartego pliku; przedstawiony jest na niej model 3D widoczny na przezroczystym tle.

Wydajność 3D i preferencje wyświetlania

  1. Wybierz polecenie Edycja > Preferencje > 3D (Windows) lub Photoshop > Preferencje 3D (Mac OS).

  2. Aby uzyskać informację o dowolnej z opcji, zatrzymaj nad nią wskaźnik myszy i zapoznaj się z treścią sekcji Opis w dolnej części okna dialogowego.

Narzędzia do obsługi obiektów i kamer 3D

Po wybraniu warstwy 3D aktywne stają się narzędzia związane z obiektami i kamerami 3D. Korzystając z narzędzi do manipulowania obiektami 3D, można zmieniać położenie modelu 3D i skalować go. Narzędzia do sterowania kamerą 3D pozwalają zmieniać widok sceny. Jeśli system obsługuje technologię OpenGL, można też manipulować modelami i kamerami 3D przy użyciu osi 3D. Zobacz Korzystanie z osi 3D.

Przesuwanie, obracanie lub skalowanie modelu przy użyciu narzędzi do manipulowania obiektami 3D

Narzędzia do manipulowania obiektami 3D umożliwiają obracanie, przenoszenie i skalowanie modelu. Podczas przekształcania modelu 3D widok kamery nie zmienia się.

Uwaga:

Aby włączyć wyświetlanie wskazówek poszczególnych narzędzi 3D, wybierz polecenie Opcje panelu z menu panelu Informacje , a następnie zaznacz opcję Pokaż podpowiedzi narzędzi. Aby wyświetlić szczegółowe informacje dotyczące narzędzia w panelu Informacje, kliknij narzędzie i umieść kursor w oknie obrazu.

Narzędzia i opcje dotyczące obiektów 3D w programie Photoshop
Narzędzia i opcje dotyczące obiektów 3D

A. Powrót do początkowego położenia obiektu B. Obrót C. Przetaczanie D. Panoramowanie E. Przesuwanie F. Skalowanie G. Menu Położenie H. Zapisanie bieżącego położenia I. Usunięcie bieżącego położenia J. Współrzędne położenia 
  1. Kliknij narzędzie do manipulowania obiektami 3D na panelu Narzędzia i przytrzymaj przycisk myszy, aby wybrać jeden z typów narzędzi:

    Uwaga:

    Aby ograniczyć działanie narzędzia Obrót, Panoramowanie, Przesuwanie lub Skalowanie do jednego kierunku ruchu, przytrzymaj klawisz Shift.

    Obrót

    Aby obrócić model wokół jego osi X, przeciągnij w górę lub w dół. Aby obrócić model wokół jego osi Y, przeciągnij w bok. Aby przetoczyć model, przeciągnij kursor, przytrzymując klawisz Alt (Windows) lub Option (Mac OS).

    Przetaczanie

    Aby obrócić model wokół jego osi Z, przeciągnij w bok.

    Panoramowanie

    Przeciągaj kursor na boki, aby przesuwać model w poziomie; albo w górę i w dół, aby przesuwać go w pionie. Aby przesunąć w kierunku x/z, przeciągnij kursor, przytrzymując klawisz Alt (Windows) lub Option (Mac OS).

    Przesuwanie

    Przeciągaj kursor na boki, aby przesuwać model w poziomie; albo w górę lub w dół, aby przybliżyć go lub oddalić. Aby przesunąć w kierunku x/y, przeciągnij kursor, przytrzymując klawisz Alt (Windows) lub Option (Mac OS).

    Skalowanie

    Przeciągaj kursor w górę lub w dół, aby powiększyć lub zmniejszyć model. Aby skalować w kierunku z, przeciągnij kursor, przytrzymując klawisz Alt (Windows) lub Option (Mac OS).

Aby przywrócić pierwotny widok modelu, kliknij ikonę Wróć do początkowego położenia  na pasku opcji.

Aby dopasować położenie, obrót lub skalę za pomocą określonych wartości, wprowadź je z prawej strony paska opcji.

Przesuwanie kamery 3D

Korzystając z narzędzi do sterowania kamerą 3D, można przesuwać widok kamery bez zmieniania położenia modelu 3D.

Uwaga:

Aby włączyć wyświetlanie etykietek poszczególnych narzędzi 3D, wybierz polecenie Opcje panelu z menu panelu Informacje , a następnie zaznacz opcję Pokaż podpowiedzi narzędzi. Aby wyświetlić szczegółowe informacje dotyczące narzędzia na panelu Informacje, kliknij narzędzie i umieść kursor w oknie obrazu.

Narzędzia i opcje dotyczące kamer 3D w programie Photoshop
Narzędzia i opcje dotyczące kamer 3D

A. Powrót do początkowego położenia kamery B. Obrót C. Przetaczanie D. Panoramowanie E. Przesuwanie F. Powiększanie G. Menu Widok H. Zapisanie bieżącego widoku kamery I. Usunięcie bieżącego widoku kamery J. Współrzędne położenia kamery 
  1. Kliknij narzędzie do sterowania kamerą 3D na panelu Narzędzia i przytrzymaj przycisk myszy, aby wybrać jeden z typów narzędzi:

    Uwaga:

    Aby podczas korzystania z narzędzia Obracanie, Panoramowanie lub Wodzenie zachować stały kierunek ruchu kursora, przytrzymuj klawisz Shift.

    Obrót

    Przeciągaj, aby obracać kamerę w kierunku x lub y. Przytrzymując klawisz Alt (Windows) lub Option (Mac OS) przeciągnij kursor, aby przetoczyć kamerę.

    Przetaczanie

    Przeciągaj, aby uzyskać efekt toczenia.

    Panoramowanie

    Przeciągaj, aby wodzić kamerą w kierunku x lub y. Przytrzymując klawisz Alt (Windows) lub Option (Mac OS) przeciągnij kursor, aby wodzić w kierunku x lub z.

    Przesuwanie

    Przeciągaj, aby przesuwać kamerę (translacja względem osi z i obrót względem osi y). Aby przesuwać kamerę w kierunku z/x, podczas przeciągania przytrzymuj wciśnięty klawisz Alt (Windows) lub Option (Mac OS).

    Powiększanie

    Przeciągaj, aby zmieniać wielkość pola widzenia kamery. Maksymalne pole widzenia to 180.

    Kamera perspektywiczna (tylko powiększanie)

    Pozwala wyświetlić linie równoległe łączące się w punktach zbiegu.

    Kamera ortogonalna (tylko powiększanie)

    Linie równoległe są zachowywane bez efektu zbiegania. Powoduje wyświetlenie modelu w prawidłowej skali, bez żadnych zniekształceń perspektywy.

    Głębia pola (tylko przy powiększeniu)

    Umożliwia ustawienie głębi pola. Odległość określa, jak daleko od kamery znajduje się pole, na które jest ustawiona ostrość. Rozmycie powoduje, że pozostały obszary obrazu stają się słabo czytelne.

    Uwaga:

    Animacja głębi pola umożliwia symulowanie efektów zmiany ogniskowej w kamerze.

Wartości liczbowe na pasku opcji odpowiadają współrzędnym x, y i z kamery 3D. W celu dopasowania widoku kamery można ręcznie edytować te wartości.

Zmiana lub tworzenie widoków kamery 3D

  1. Wykonaj jedną z następujących czynności:

    • Wybierz predefiniowany widok kamery z menu Widok.

    Uwaga:

    We wszystkich predefiniowanych widokach kamery jest używane rzutowanie ortogonalne.

    • Aby dodać własny widok, umieść kamerę 3D w odpowiednim położeniu za pomocą narzędzi do sterowania kamerą 3D, a następnie kliknij przycisk Zapisz na pasku opcji.

    Uwaga:

    Aby przywrócić domyślny widok kamery, wybierz narzędzie kamery 3D i kliknij na pasku opcji polecenie Powrót do początkowego położenia kamery .

Oś 3D

Oś 3D wskazuje bieżącą orientację modeli, kamer, świateł i siatek w przestrzeni 3D — względem osi X, Y i Z. Oś jest wyświetlana po wybraniu dowolnego narzędzia 3D i stanowi alternatywny mechanizm manipulacji zaznaczonym elementem.

Oś 3D w programie Photoshop
Oś 3D z wybranym narzędziem Obracanie siatki

A. Wybrane narzędzie B. Minimalizowanie lub maksymalizowanie osi 3D C. Przesuwanie elementu wzdłuż osi D. Obracanie elementu E. Ściskanie lub wydłużanie elementu F. Zmienianie rozmiaru elementu 

Uwaga:

W celu wyświetlenia osi 3D należy włączyć technologię OpenGL. 

Pokazywanie lub ukrywanie osi 3D

  • Wybierz polecenie Widok > Pokaż > Oś 3D.

Minimalizowanie, przywracanie, przesuwanie lub zmienianie rozmiaru osi 3D

  1. Umieść wskaźnik nad osią 3D, aby wyświetlić pasek sterowania.

  2. Wykonaj jedną z następujących czynności:

    • Aby przesunąć oś 3D, przeciągnij pasek sterowania.

    • Aby ją zminimalizować, kliknij ikonę minimalizacji.

    • Aby przywrócić normalny rozmiar, kliknij zminimalizowaną oś 3D.

    • Aby zmienić rozmiar, przeciągnij ikonę powiększenia.

Przesuwanie, obracanie lub skalowanie zaznaczonych elementów przy użyciu osi 3D

Aby użyć osi 3D, umieść wskaźnik myszy nad elementem sterującym osi w celu podświetlenia go, a następnie przeciągnij:

Uwaga:

Dostępne elementy sterujące osi różnią się w zależności od bieżącego trybu edycji (obiekt, aparat, siatka lub światło).

  • Aby przesunąć zaznaczony element wzdłuż osi X, Y lub Z, podświetl stożkowy koniec jednej z tych osi. Następnie przeciągnij wzdłuż osi w dowolnym kierunku.

  • Aby obrócić element, kliknij zakrzywiony segment obrotu znajdujący się wewnątrz końca osi. Pojawi się żółty okrąg wskazujący płaszczyznę obrotu. Przeciągnij w prawo lub w lewo wokół środka osi 3D. Aby obracać precyzyjniej, odsuń kursor myszy od środka osi 3D.

  • Aby zmienić rozmiar elementu, przeciągnij środkowy sześcian osi 3D w górę lub w dół.

  • Aby ścisnąć lub wydłużyć element wzdłuż osi, przeciągnij jeden z kolorowych sześcianów przekształceń do środkowego sześcianu lub od niego.

  • Aby ograniczyć ruchy do płaszczyzny obiektu, umieść kursor myszy w miejscu przecięcia dwóch osi, blisko środkowego sześcianu. Między dwiema osiami pojawi się żółta ikona płaszczyzny. Przeciągnij w dowolnym kierunku. Można też uaktywnić ikonę płaszczyzny, umieszczając wskaźnik nad dolną częścią centralnego sześcianu.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online