The Titler is a versatile tool enabling you to create not just titles and credits, but animated composites as well.

The Titler is a collection of related panels. You can close the panels within the Titler without closing the Titler. You can dock the panels to each other or to other parts of the interface. When the panels are not docked to the main workspace, they appear over the other panels, or float.

 

You can load more than one title into the Titler. You can choose the title you want to view by choosing its name in the Title tab menu. You can reopen a title when you want to change it or to duplicate it and base a new version on it.


Create new titles

Create a title from scratch, or use a copy of an existing title as a starting point.

Create a title

  1. Do one of the following:
    • Choose File > New > Title.

    • Choose Title > New Title and then choose a title type.

    • In the Project panel, press the New Item button and choose Title.

  2. Specify a name for the title and click OK.
  3. Use the text and shape tools to create a file or to customize a template.
  4. Close the Titler or save the project to save the title.

Note:

Titles are added to the Project panel automatically and are saved as part of the project file.

Create a title based on the current title

  1. In the Titler, open or select the title on which you want to base a new title.
  2. In the Title Quick Properties panel, click New Title Based On Current Title .
  3. In the New Title dialog box, enter a name for the new title and click OK.
  4. Change the new title as desired.
  5. Close the Titler or save the project to save the title.

Create a title in Indic language

Premiere Pro CC includes support for Indic languages, such as Hindi. You can now create titles using Indic text.

The Premiere Pro Titler supports text composition in the following languages:

  • Latin and western scripts
  • Chinese, Japanese, and Korean (CJK) languages
  • Indian languages

In Premiere Pro CC, the World-Ready composer is integrated with Titler. You can call the Indic text engine and set a title for a project. Any subsequent title you create within that project uses the Indic text engine.

The Indic text engine supports the following Indian languages:

  • Bengali
  • Gujarati
  • Hindi
  • Kannada
  • Malayalam
  • Marathi
  • Oriya
  • Punjabi
  • Tamil
  • Telugu
You cannot change an Indic title. You can find out what kind of title it is by right-clicking and choosing Properties.
 
To create a title in Indic text:
  1. Choose Edit > Preferences > Title.

  2. Enable the Indic radio button.

    Enable the Indic radio button
  3. Click OK.

  4. To create a title, choose File > New > Title.

    To create a title, choose File, New, Title
  5. Click OK.

  6. Choose the Mangal font and type a text string in Hindi into the Titler. You can do so in two ways:

    1. Enable Hindi keyboard and download the necessary font.
    2. Copy a text string in Hindi and paste it into the Titler.

    The Indic text engine makes the Indic alphabets, such as Hindi alphabets, appear properly in the Titler, without any text overflows.

    Titles panel

Open, import, or export a title

Open a title for editing

  • Double-click the title in the Project panel or in a Timeline panel.

    Note:

    Titles open in the Titler, not the Source Monitor.

Import a title file

You can import a title file as you would any other source file.

  1. Choose File > Import.
  2. Select a title and click Open.

    Note:

    In addition to importing Premiere Pro titles and Premiere Elements titles with the .prtl extension, you can import titles with the .ptl extension, created in earlier versions of Adobe Premiere. The imported titles become part of the current project file.

Export a title as an independent file

You can export titles as independent files that use the .prtl filename extension.

  1. In the Project panel, select the title you want to save as an independent file.
  2. Choose File > Export > Title.
  3. Specify a name and location for the title and click Save.

About safe margins in the Titler

The title-safe and action-safe margins in the drawing area of the Titler designate the safe zones. These margins are enabled by default.

Safe zones are useful when you edit for broadcast and videotape. Most TVs overscan the picture. Overscanning places the outer edges of the picture outside the viewing area. The amount of overscanning is not consistent across TVs. To ensure that everything fits within the area that most TVs display, keep text within the title-safe margins. Keep all other important elements within the action-safe margins.

Note:

If you are creating content for the web or for CD, the title-safe and action-safe margins do not apply to your project. The entire image is displayed in these media.

Choose, create, and import title templates

The title templates included with Premiere Pro provide numerous themes and preset layouts that make it quick and easy to design a title. Some templates include graphics pertinent to certain subjects, such as new-baby or vacation themes. Others include placeholder text that you can replace to create credits for your movie. Some templates have transparent backgrounds, represented by dark gray and light gray squares. You can see your video beneath the title. Other templates are opaque.

You can easily change any element in the template by selecting the element and either deleting it or overwriting it. You can also add elements to the template. After you modify the template, you can save it as a title file for use in current and future projects. Alternately, you can save any title you create as a template.

You can also import title files from another Premiere Pro project as templates. If you share templates between computers, make sure that each system includes all the fonts, textures, logos, and images used in the template.

If you do not have title templates, see this document. After following instructions, your title templates will be restored.

Note:

When you apply a new template, its content replaces any content currently in the Titler.

Note:

Before Premiere Pro 2.0, Premiere Pro saved all titles as independent files separate from the project file. You can import titles created in older versions of Premiere Pro just as you import any footage. When you save the project, the imported titles are saved with the project.

Andrew Devis shows how to use, customize, and save title templates in this video tutorial on the Creative COW website.

Load a template for a new title

  1. Choose Title > New Title > Based On Template.
  2. Click the triangle next to a category name to expand it.
  3. Select the template, and then click OK.

Import a saved title file as a template

  1. With a title open, choose Title > Templates.
  2. Choose Import File As Template from the Templates panel menu.
  3. Select a file, and click Open (Windows) or Choose (Mac OS). You can import only Premiere Pro title files (.prtl) as templates.
  4. Give the template a name and then click OK.

Set or restore a default template

  1. With a title open, click the Templates button and select a template.
    • To set the selected template as the default template, choose Set Template As Default Still from the Templates panel menu. The default template loads each time you open the Titler.

    • To restore the default set of templates, choose Restore Default Templates from the Templates panel menu.

  2. Click OK.

Rename or delete a template

  • With a title open, click the Templates button  and select a template.
    • To rename the selected template, choose Rename Template from the Templates panel menu. Type a name in the Name box, and click OK.

    • To delete a template, choose Delete Template from the Templates menu, and then click OK.

    Note:

    If you delete a template using this procedure, it is removed from the hard disk.  

Create a template from an open title

  1. With a title open, click the Templates button .
  2. Click the Templates menu button . Choose Import Current Title As Template.
  3. Enter a name for the title template, and then click OK.

Show video behind the title

You can view a frame of footage in the drawing area as you create the title. Viewing the frame helps you place elements in your title. The video frame is for your reference only; it is not saved as part of the title.

Use the timecode controls in the Titler to specify the frame you want to display. The Titler displays the frame under the current-time indicator in the active sequence. Setting the frame in the Titler also moves the current-time indicator in the Program Monitor and Timeline panel. Moving the current-time indicator in the Program Monitor or Timeline panel changes the frame displayed in the Titler.

Note:

If you want to superimpose a title over another clip, add the title to the track directly above the clip. The title’s background becomes transparent, revealing the image of clips in lower tracks.

  • In the Titler panel, select Show Video.
    • To change the frame interactively, drag the time value next to Show Video until the frame is visible in the drawing area.

    • To display the frame by specifying its timecode, click the time value next to Show Video and enter the frame’s timecode in the active sequence.

    Note:

    The Show Video value uses the same time display format specified in the project settings. For example, if 30-fps Drop-Frame Timecode is specified in Project Settings, 30-fps Drop-Frame Timecode is displayed in Show Video.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy