Learn how to create motion graphics and titles with the Graphics workspace in Premiere Pro.

The Graphics workspace and Essential Graphics panel in Premiere Pro provide a powerful titling and motion graphics workflow that allows you to create titles, brand identities, and other graphics directly within Premiere Pro, as well as customize Motion Graphics templates (.mogrt files) that have been created in After Effects or Premiere Pro. 

Essential Graphics Panel in Premiere Pro

Essential Graphics Panel in Premiere Pro
Watch this video to learn about how to use the Essential Graphics Panel in Premiere Pro.

Create graphics in Premiere Pro

You can create graphics such as titles, lower thirds, and bumpers directly within Premiere Pro using the Graphics workspace. Graphics can be created directly in the Program monitor using the Type tool and shape tools, then refined with the features in the Essential Graphics panel.

To use the graphics workflow in Premiere Pro:

  1. Open the Graphics workspace. 

  2. Click Graphics in the workspace bar at the top of the screen or select Window > Workspaces > Graphics from the main menu. 

  3. You can also open the Essential Graphics panel directly from Window > Essential Graphics if you prefer to arrange your own workspace.

Motion Graphics Templates in Premiere Pro CC

Motion Graphics Templates in Premiere Pro CC
Watch this video to know about how to use Motion Graphics templates.

  • Graphic clips can contain multiple text and shape layers, similar to layers in Photoshop, and can be edited as a single clip in your sequence. When you first create a text or shape layer, a graphic clip containing that layer gets created in your timeline at the playhead location. If you already have a graphic clip selected in your sequence, then the text or shape layer you created gets added to the existing graphic clip.
  • Use the Essential Graphics panel to see your layers and adjust your graphic, including adjusting the appearance of individual layers, changing layer order, and taking advantage of the Responsive Design features for time and position.
  • Add animation to your graphics by keyframing the layers in the Effect Controls panel.
  • Any graphics you create in Premiere Pro can be exported as a Motion Graphics template (.mogrt) to Creative Cloud libraries or your local disk for sharing or reuse. 
  • The Essential Graphics panel also allows you to browse Motion Graphics templates (.mogrt) saved locally or in your Creative Cloud Libraries. 
Adjust text and appearance
Adjust text and appearance

Create text layers

  1. Select the Type tool (T) or Vertical Type tool from the tools panel. 

  2. Click the Program Monitor where you want to position your text, and start typing. A single click creates text on a point, while a drag-and-drop creates text in a box. 

  3. Use the Selection tool (V) to manipulate text and shape layers directly in the Program Monitor. You can adjust the position of a layer, change the anchor point, change the scale, change the size of the text box, and rotate. 

  4. Adjust the appearance of your text using the Edit tab of the Essential Graphics panel, including font, font size, and a variety of format and appearance controls.

    Type Tool
    Type Tool

Create shape layers

Premiere Pro has a Rectangle tool, an Ellipse tool, and a Pen tool for creating free-form shapes and paths.

To create a shape layer:

  1. To create a shape or path, use the desired shape tool in the Program monitor. 

    Note:

    Hold down the shift key while dragging to create a shape with locked dimensions such as a square or circle, or to create a straight line with the pen tool.

  2. Use the Selection tool (V) to directly manipulate your shape, including changes to position, scale, rotation, and anchor point. 

  3. The Pen tool (P) can be used to manipulate the vertices and handles of a shape.

  4. Adjust the appearance of shapes using the Edit tab of the Essential Graphics panel.

    Shape Tool
    Shape Tool

Create clip layers

You can add image and video sources as layers within your graphic. 

To create a clip layer

  1. Select Essential Graphics>Select from File>New Item.

  2. You can also create a clip layer by selecting the graphic clip in your timeline and dragging the video or image Master Clip from your Project panel into the layer pane of the Essential Graphics panel to create a clip layer in your graphic.

Animate layers in your graphics

Text layers, shape layers, and paths can be animated using keyframes in the Effects Control panel. To add animation to your graphics:

  1. Locate the layer you want to animate in the Effect Controls panel.

  2. Click the Stopwatch icon to toggle animation for the desired property.

  3. Click Add/Remove keyframes to achieve the effect you want. 

  4. Right click a keyframe to access interpolation settings such as Bezier curves and Ease In/Ease Out.

Add Responsive Design features to your graphics

Responsive Design for Motion Graphics makes it possible to design rolls and graphics that respond intelligently to changes in duration and layer positioning.

Responsive Design - Time

You can preserve animations that are typically used as intros and outros.

Preserve Intro and Outro Animations

You can define segments of your graphics that preserve intro and outro animations, even when the overall duration of the graphic changes. Keyframes that fall within these time ranges get pinned to the beginning and end of the clip, so that you can change the overall duration of the graphic clip, while maintaining its entrance and exit animations.

A transparent white overlay on your graphic clip in the timeline and in the Effect Controls panel indicate the intro and outro segments of the clip. These segments can be defined either in the Essential Graphics panel or in the Effect Controls panel.

Set Responsive Design - Time
Set Responsive Design - Time

To define intro and outro segments and preserve animations in these segments using the Essential Graphics panel:

  1. Select the graphic in your timeline and navigate to the Edit tab of the Essential Graphics panel.

     

  2. Make sure that the graphic that you just selected has none of its individual layers selected.

  3. Under Intro duration, specify the amount of time that you want to define as the intro/entrance section using the timecode controls.       

  4. Under outro duration, specify the amount of time that you want to define as the outro/exit section using the timecode controls.

To define intro and outro segments and preserve animations in these segments using the Effect Controls panel: 

Preserve animations for intro and outro segments

  1. Select the graphic in your timeline and navigate to the Effect Controls panel.

  2. At the top of the Effects Control panel above the controls for Motion, you see a small blue handle at the beginning and end of the selected clip.

  3. Drag the left handle out to define the intro/entrance segment. You see a transparent white overlay that covers all of the keyframes that fall within the specified time range.

  4. Drag the right handle out to define the outro/exit segment. You see a transparent white overlay that covers all of the keyframes that fall within the specified time range.

Keyboard Shortcuts to specify intro and outro duration

You can set keyboard shortcuts for specifying Intro and Outro duration using the keyboard shortcut map under Premiere Pro CC > Keyboard Shortcuts. These keyboard shortcuts are not assigned by default. These commands are used to assign keyboard shortcuts:

  • Set Intro End
  • Set Outro Start

To use your keyboard shortcuts for Intro and Outro duration:

  1. Select the graphic clip in the timeline for which you want to preserve an intro or outro animation.

  2. Position the playhead to the position that you want to set the Intro or Outro setting and click the keyboard shortcut that was assigned.

    Note:

    The keyboard shortcuts get enabled only when the timeline is selected.

Create rolls

You can create title or credit rolls that move vertically over the screen by enabling Roll. When Roll is enabled, you see a transparent blue scroll bar in the Program Monitor.

This scroll bar allows you to scroll the text and graphics in your credit roll for easier editing, without the need to move the playhead/CTI in the timeline to a specific position.

To enable rolls for your graphics:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.

    Enable Rolls
    Enable Rolls
  2. Make sure that the graphic you selected has none of its individual  layers selected.

  3. Select the check-box next to Roll to enable credit rolls.

  4. Specify whether you want the graphics to start or end offscreen.

  5. Adjust the timing for preroll, postroll, ease in, and ease out using the timecode for each property.

    Roll scroll bar
    Roll scroll bar

Responsive Design - Position

Position-based controls for Responsive Design allow users to define relationships between layers in a graphic with each other or with the video frame itself. By applying specific Responsive Design designations for Position, you can design your graphics so that they automatically adapt when changing the number of characters in your title or lower third, or so that one layer tracks the position and scale properties from another layer.  

Small blue pins on the Program Monitor indicate whether the currently selected layer is pinned to another layer.

To define positional relationships between layers:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.

  2. Select a layer that you want to make responsive to the changes in another layer.

  3. Under Responsive Design – Position>Pin To, specify which layer the currently selected layer should be pinned to. The currently selected layer gets parented by the layer you choose from the drop-down list.

  4. Use the diagram on the right side to define which edge the child layer should be pinned to, namely Top, Bottom, Left or Right of the parent. 

    Note:

    Use the square in the center to quickly toggle on or off pinning for all edges.

  5. The selected layer now responds in position, length/width, and scale based on changes to its parent layer. When you select this layer in the program monitor, it's parent layer displays small blue pins on the pinned edges. 

    Set Responsive Design - Position
    Set Responsive Design - Position

Master Styles

Master Styles allow you to define text properties such as font, color, and size as presets so that the style can be quickly applied and rippled out across multiple layers in different graphics in your timeline. Once you apply a Master Style to a graphic clip or to a text layer within a graphic clip, the text automatically inherits all changes to the Master Style, allowing you to quickly make changes to multiple graphics at once.

Update Layer to Master Styles
Update Layer to Master Styles

To create a Master Style:

Master Styles allow you to define text properties such as font, color, and size as presets so that the style can be quickly applied and rippled out across multiple layers in different graphics in your timeline. Once you apply a Master Style to a graphic clip or to a text layer within a graphic clip, the text automatically inherits all changes to the Master Style, allowing you to quickly make changes to multiple graphics at once.

To create a Master Style:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.      

  2. Select a text layer and give it the stylistic properties that you want for font, size, and appearance.

  3. When you have the desired look, select Create Text Style under the Master Styles section from the drop-down list.

  4. Name your text style and click OK.

  5. The Master Style appears in your project panel and is available in the Master Style drop-down list so you can quickly apply to other text layers and graphic clips in your project.

    Applying Master Styles on Graphics
    Applying Master Styles on Graphics

When you create a Master Style, a thumbnail image of the style gets added to your project panel. Drag- and-drop this thumbnail onto one or more graphic objects in the timeline to update all the text layers in that graphics at once.

You can also update individual text layers of a title to a particular style by selecting the text layer in the Essential Graphics panel, then choosing the desired Master Style from the drop-down list.

Master Graphics

You can use the Upgrade to Master Graphic option to create a Master Clip item in your Project Panel from a graphic clip in your sequence. Any graphic clips made from that Master Graphic, including the one you upgraded it from, are duplicates of each other. Any changes made to the text, style, or contents in an instance of a Master Graphic get reflected in all other instances of the Master Graphic.

To create a Master Graphic:

  • Select Graphics > Upgrade to Master Graphic.

Export a Motion Graphics template from Premiere Pro

  • Select Graphics>Export Motion Graphics template to turn your current graphic clip, including all animations, into a .mogrt for future reuse or to share. 

    Note:

    This export feature is only available for graphics created in Premiere Pro, not for .mogrt files that were originally created in After Effects. 

    Export as Motion Graphics Template
    Export as Motion Graphics Template

Motion Graphics Templates and Adobe Stock

Premiere Pro allows you to export your .MOGRT files to Adobe Stock and also use .MOGRT files that are available in Adobe Stock.

Motion Graphics and Adobe Stock

Motion Graphics and Adobe Stock
Watch this video to learn about the Motion Graphics Templates and Adobe Stock workflow

Premiere Pro allows you to export your .MOGRT files to Adobe Stock and also use .MOGRT files that are available in Adobe Stock.

  1. You can export and publish .MOGRT files from Premiere Pro to Adobe Stock. To publish your Motion Graphics template, select Edit>Export Settings>Publish>Adobe Stock

  2. To use Motion Graphics templates (.MOGRT files) that are available in Adobe Stock, open the Creative Cloud Library (Libraries panel), click Window > Libraries

  3. Click Cart to license and import the Motion Graphics template file into the current library. 

Add Motion Graphic Templates to a Sequence

  1. To add a template from the Essential Graphics panel, open Essential Graphics panel and click the Browse tab.

  2. Select the template that you want to use and drag it into a video track in your sequence.

  3. When you add a template to a sequence, Premiere Pro shows the media as offline until the template completes loading. If the templates that you added requires fonts that have not been installed, you can resolve the fonts that are missing.

  4. To convert a track item template to a master clip project item, drag-and-drop from the Timeline panel to the Project panel.

  5. After adding a template to your sequence, you can control the parameters of the template in the Essential Graphics panel to modify its appearance.    

How to adjust your Motion Graphics Template

  1. To control a template, select the template in your sequence.

  2. Select Essential Graphics panel > Edit to change the template controls as desired. 

  3. The templates get updated as you change the controls. 

Create graphics using Titler

You can easily create titles directly on your video using the Essential Graphics panel in Adobe Premiere Pro. You can add text, shapes, and so on, to layers that you can rearrange and adjust. The title can also be saved as a Motion Graphics template which can be reused and shared.

Use Premiere Pro Titler to create graphics

Use Premiere Pro Titler to create graphics
Watch this video to learn about how to use Premiere Pro Titler and create graphics

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy