Fel: "Hjälpsystemet kan inte startas" när du försöker öppna Hjälp | Dreamweaver CS4 | Windows

Senast uppdaterad den 27 apr. 2021

Problem

När du försöker öppna Hjälp i Adobe Dreamweaver CS4 på Windows returnerar programmet felet "Hjälpsystemet kan inte startas eftersom hjälpmappen saknas."Installera hjälpmappen eller installera om Dreamweaver."

Orsak

Windows-registerposterna som lagrar inställningar för Hypertext Transfer Protocol (HTTP) saknas eller är skadade.

Lösning

Logga in på din dator som administratör.Gör sedan en eller båda av följande lösningar.

Lösning 1: Ställ in din föredragna webbläsare som systemstandard.

Så här anger du en standardwebbläsare i Windows 7/Vista:

Stäng alla program.
Välj Start > Kontrollpanelen.
Gör något av följande:
  • Om Kontrollpanelen är i vyn Kontrollpanelens startsida eller Kategori klickar du på Program.På nästa skärm klickar du på Standardprogram.
  • Om Kontrollpanelen är i klassisk vy dubbelklickar du på Standardprogram.
Välj Ange programåtkomst och datorstandardvärden
I listan Välj en konfiguration klickar du på Anpassad.
Under Välj en standardwebbläsare väljer du Internet Explorer, Firefox, Google Chrome eller Opera.
Klicka på OK.

Så här ställer du in en systemstandard webbläsare på Windows XP:

Stäng alla program.
Välj Start > Kontrollpanelen (eller Start > Inställningar > Kontrollpanelen).
Dubbelklicka på Lägg till eller ta bort program.
I den vänstra rutan i Lägg till eller ta bort program väljer du Ange programåtkomst och standardvärden.
I listan Välj en konfiguration klickar du på Anpassad.
Under Välj en standardwebbläsare väljer du Internet Explorer, Firefox, Google Chrome, Opera eller Safari.
Klicka på OK.

Lösning 2: Återskapa HTTP-nyckeln i Windows-registret.

Ansvarsfriskrivning: Stegen i denna lösning kräver att du ändrar Windows-registret.Registret innehåller systemrelaterad information som är viktig för din dator och dess program. Innan du ändrar registret ska du alltid göra en säkerhetskopia av det. Adobe tillhandahåller inte support för problem som orsakas av felaktiga ändringar i registret. Mer information finns i dokumentationen för Windows eller kontakta Microsoft Technical Support eller datorns tillverkare för information om Windows-registret.

Stäng alla program.
Gör något av följande:
  • Windows 7/Vista: Välj Start > Alla program > Tillbehör.Högerklicka sedan på Command Prompt och välj Kör som administratör.
  • Windows XP: Välj Start > Alla program > Tillbehör > Command Prompt.
I Command Prompt-fönstret skriver du följande kommando exakt som det visas och trycker sedan på Retur:



reg export HKCR\http "%userprofile%\AdobeHelpBackup.reg"

Obs: Command Prompt kan returnera felet "Systemet kunde inte hitta den angivna registernyckeln eller värdet." Detta är ett förväntat meddelande om HTTP-nyckeln saknas i Windows-registret. Om detta fel visas går du till steg 6, annars fortsätter du till steg 5.

 
Skriv följande kommando exakt som det visas och tryck sedan på Retur:



reg delete HKCR\http /f
Skriv ett av följande kommandon exakt som det visas och tryck sedan på Retur (skriv kommandot som motsvarar webbläsaren där du vill visa Dreamweaver CS4-hjälpen):



Obs: Om du väljer en annan webbläsare än Internet Explorer måste den webbläsaren vara installerad innan du skriver kommandot.



  • Internet Explorer

    reg add HKCR\http\shell\open\command /ve /f /d "\"%programfiles%\Internet Explorer\iexplore.exe\" "\"%1\""
  • Firefox

    reg copy HKCR\FirefoxURL\shell HKCR\http\shell /s /f
  • Opera

    reg copy HKCR\Opera.HTML\shell HKCR\http\shell /s /f
  • Safari

    reg copy HKCR\SafariURL\shell HKCR\http\shell /s /f
  • Google Chrome

    reg copy HKCR\ChromeHTML\shell HKCR\http\shell /s /f
Stäng Kommandotolken.