Príručka používateľa Zrušiť

Optimize Photoshop performance

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop on the iPad
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
    29. Auto adjustment commands in Photoshop on the iPad
    30. Smudge areas in your images with Photoshop on the iPad
    31. Saturate or desaturate your images using Sponge tool
    32. Content aware fill for iPad
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
    19. Generate Image
    20. Generate Background
    21. Reference Image
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
    3. Generate image with descriptive text prompts
    4. Generate background with descriptive text prompts
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Blur Gallery
    2. Filter basics
    3. Filter effects reference
    4. Add Lighting Effects
    5. Use the Adaptive Wide Angle filter
    6. Use the Oil Paint filter
    7. Use the Liquify filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

Try the tips and techniques outlined in this document if Photoshop is running slower than expected on your machine

  Discontinuation of 3D features in Photoshop

Photoshop’s 3D features will be removed in future updates. Users working with 3D are encouraged to explore Adobe’s new Substance 3D collection, which represents the next generation of 3D tools from Adobe. Additional details on the discontinuation of Photoshop’s 3D features can be found here: Photoshop 3D | Common questions on discontinued 3D features.

Broad steps to boost performance

Every user's setup is unique and may require a different combination of techniques to get the most efficient performance from Photoshop. From the suggestions documented in this article, consider which ones to implement within the context of your computer setup, the types of files you use, and your particular workflow. There are four primary ways to affect performance in Photoshop — Optimize your hardware setupOptimize your operating system for PhotoshopSet performance-related preferences, and Fine-tune Photoshop features.

The easiest way to improve performance, without spending money, is to set your Photoshop preferences and fine-tune its features to take advantage of your work and the type of files you typically work with.

The most dramatic way to increase performance is by investing in faster and more powerful hardware. Your computer must meet certain minimum system requirements to run Photoshop optimally. Running Photoshop on underpowered or unsupported hardware—for example, on a computer having an incompatible graphics processor (GPU), may result in performance issues. 

Set performance-related preferences

Watch this short video to learn how to quickly optimize performance-related preferences in Photoshop.

Photoshop provides a set of preferences (Preferences > Performance) to help you make optimum use of your computer's resources, such as memory, cache, graphics processor, displays, etc. Depending on your primary use case for using Photoshop and the types of documents you generally work with, different combinations of these settings may suit you.

Additional settings such as Scratch Disks, available on other tabs of the Preferences dialog, may also directly impact your computer's running speed and stability.

Performance preferences in Photoshop

Adjust the memory allocated to Photoshop

You can improve performance by increasing the amount of memory/RAM allocated to Photoshop. The Memory Usage area of the Performance preferences dialog (Preferences > Performance) tells you how much RAM is available to Photoshop. It also shows the ideal Photoshop memory allocation range for your system.

By default, Photoshop uses 70% of available RAM.

  1. Increase the RAM allocated to Photoshop by changing the value in the Let Photoshop Use box. Alternatively, adjust the Memory Usage slider.
  2. Restart Photoshop to enable your changes.

To find the ideal RAM allocation for your system, change it in 5% increments and monitor performance in the Efficiency indicator. 

We don't recommend allocating more than 85% of your computer's memory to Photoshop. Doing so may affect performance by leaving no memory for other essential system applications.

Poznámka:

If you experience out-of-RAM or out-of-memory errors in Photoshop, try increasing the amount of RAM allocated to Photoshop. However, setting the RAM allocation for Photoshop too high (>85%) could affect the performance of other running applications, making your system unstable. 

The best solution to this issue is to increase the amount of RAM to your computer. Check with your computer manufacturer for RAM specifications and compatibility.

Adjust cache levels

Cache basics

Photoshop uses image caching to speed up the redrawing of high-resolution documents while you're working on them. You can specify up to eight levels of cached image data and choose one of the four available cache tile sizes.

Increasing cache levels improves Photoshop’s responsiveness while you work, although images may take longer to load. The cache tile size determines the amount of data on which Photoshop operates at a time. Bigger tile sizes speed up complex operations, such as sharpening filters. Smaller changes, such as brush strokes, are more responsive with smaller tile sizes.

Cache presets

Three cache presets are available in the Performance preferences. Choose the one that matches your primary use case/purpose of using Photoshop:

  • Web/UI Design: Choose this option if you use Photoshop primarily for web, app, or screen design. This option is appropriate for documents having numerous layers of low-to-medium pixel dimension assets.
  • Default/Photos: Choose this option if you use Photoshop primarily to retouch or edit moderate-sized images. For example, use this option if you normally edit photos originating from your mobile or digital camera in Photoshop.
  • Huge Pixel Dimensions: Choose this option if you work extensively with heavy documents in Photoshop; for example, panoramas, matte paintings, etc.

Cache levels

For finer control, specify cache levels manually; the default value is 4.

  • If you use relatively small files—roughly 1 megapixel or 1280 by 1024 pixels—and many layers (50 or more), set Cache Levels to 1 or 2. Setting Cache Levels to 1 disables image caching; only the current screen image is cached.
  • If you use files with larger pixel dimensions—say, 50 megapixels or larger—set Cache Levels higher than 4. Higher cache levels speed up redrawing.
Poznámka:

You may not get high-quality results with some Photoshop features if you set Cache Levels to 1.

Limit history states

You can save scratch disk space and improve performance by limiting or reducing the number of history states Photoshop saves in the History panel. The amount of space you save varies depending on how many pixels an operation changes. For example, a history state based on a small paint stroke or a non-destructive operation, such as creating or modifying an adjustment layer, consumes little space. Applying a filter to an entire image, on the other hand, consumes much more space.

Photoshop can save up to 1,000 history states; the default number is 50.

To reduce that number, go to the Performance preference dialog. In the History & Cache
section, set the the number of History States to a lower value.

Set graphics processor (GPU) settings

The best way to optimize GPU acceleration, which speeds up screen redraws, is to keep your video adapter driver up to date.  For instructions on updating video adapter drivers

See Update Graphics Driver.

For more information how Photoshop leverages the graphics processor, tested cards, and minimum graphics processor and display requirements. 

See Photoshop GPU and video card FAQ.

GPU preferences

Photoshop provides you with dedicated GPU settings in both the Performance and 3D sections in the Preferences dialog.

Settings in the Preferences > Performance section

If a graphics card is detected on your system, its name and model will appear under Detectected Graphics Processor in the Graphics Processor Settings area of the Performance section.

  • If your graphics card is supported, the "Use Graphics Processor" checkbox is enabled and checked by default.
  • If your graphics card isn't supported, the checkbox will be grayed out and not checked by default.
  • If your graphics card is supported, and the "Use Graphics Processor" checkbox becomes unchecked, this is likely because Photoshop has detected a crash caused by a defective graphics driver or configuration. See Troubleshoot Photoshop graphics processor (GPU) and graphics driver issues.

Additional advanced settings:

  • Use OpenCL: Turn this off if Blur Gallery, Smart Sharpen, Select Focus Area, or Image Size with Preserve Details do not work as expected.
  • Anti-Alias Guides and Paths: Disable if guides and paths are appearing too heavy or too wide
  • 30 Bit Display: Enable to increase the color fidelity on a monitor which supports 30 bit.
Disable Open CL

Poznámka:

Turning on OpenCL is likely to improve performance if you use these Photoshop features:

  • Blur Gallery - Field Blur, Iris Blur, Tilt-Shift, Path Blur, Spin Blur (OpenCL accelerated)
  • Smart Sharpen (Noise Reduction – OpenCL accelerated)
  • Select and Mask (OpenCL accelerated)

Settings in the Preferences > 3D section

The 3D section of the Performances dialog box contains a VRAM slider similar to the memory control located in the Performance section. Use the slider to determine the upper limit of the video RAM (VRAM) available to the Photoshop 3D engine. The total value is a percentage of the overall VRAM available. A setting of 100% will still reserve a portion of the overall VRAM for use with the operating system. Higher values will help with overall 3D performance but may compete with other GPU-enabled applications.

3D: Memory usage

Manage scratch disks

Poznámka:

If Photoshop cannot launch because the scratch disk is full, hold down the Cmd + Option keys (macOS) or Ctrl + Alt keys (Windows) during launch to set a new scratch disk.

While working on your creative process in Photoshop, you might get a scratch disk error due to which you are unable to complete your desired task. But what is a scratch disk?

To learn more about managing scratch disk preferences and recommended settings, see Set up scratch disks.

To learn more about troubleshooting scratch disk errors, see Troubleshoot scratch disk errors in Photoshop.

The Efficiency indicator

Watch the Efficiency indicator to monitor performance while you work in Photoshop. Click the pop-up menu at the bottom of the image window and choose Efficiency from the pop-up menu.

If the value in the indicator is below 100%, Photoshop has used all available RAM and is using the scratch disk, which slows performance. If the efficiency is less than 90%, allocate more RAM to Photoshop in Performance preferences. Or, add more RAM to your system.

The Efficiency indicator

Fine-tune Photoshop features for performance

Disable Rulers and Overlays

Having rulers and overlays (such as Grids, Slices and Smart Guides) visible can slow some operations, such as painting, transform, and dragging layers on the canvas.

  • To disable rulers, in the View menu, deselect Rulers.
  • To disable overlays, go to the View > Show menu, select None or disable the individual items.

See Show or hide non-printing Extras.

Work within file-size limitations

Very large files are often the cause of performance problems.

Photoshop supports a maximum file size of 300,000 x 300,000 pixels, except for PDF files, which are limited to 30,000 x 30,000 pixels and 200 x 200 inches, and Camera Raw, which supports images up to 65,000 pixels long or wide and up to 512 megapixels.

File size capability for Photoshop:

  • PSD files: 2 GB
  • TIFF files: 4 GB
  • PSB files: 4 exabytes (4096 petabytes or 4 million terabytes)
  • PDF files: 10 GB (pages are limited to a maximum size of 200 inches)

Close unnecessary document windows

If you receive an “out of RAM” error message or if Photoshop is running slowly, it could be caused by having too many open images. If you have several windows open, try closing some of them.

Reduce the number of presets

To reduce the amount of scratch disk space Photoshop uses, minimize the number of presets you keep loaded. Patterns and brush tips are some of the largest presets. Save presets you don’t require right now to a preset file, then remove them, and only load them when you need them.

To find out more about managing presets, see Presets.

Minimize or turn off panel preview thumbnails

Each time you change a document, Photoshop updates all the thumbnails visible in the Layers and Channels panels. This update can affect responsiveness when you’re rapidly painting, moving, or nudging layers. The more thumbnails are visible, the greater will be this effect.

To minimize or disable these thumbnail previews, click the Panel menu and choose Panel Options. Select a smaller thumbnail size or select None, and then click OK.

Change file compatibility options

If you don’t need to work with your PSD and PSB files in older versions of Photoshop or in applications that don’t support layers, you can turn off a file compatibility feature to speed up document saving:

  1. In Preferences > File Handling, for 16-bit and 32-bit PSD and PSB documents, select Disable Compression of PSD and PSB Files.

  2. From the Maximize PSD and PSB File Compatibility menu, choose Ask or Never.

Work in 8-bit image mode

Photoshop can perform many operations on 16-bit and 32-bit images. However, these images require more memory, scratch space, and time to process than 8-bit images.

To convert your image to 8 bits per channel, choose Image > Mode > 8 Bits/Channel.

See Bit dept and preferences.

Poznámka:

Converting to 8 bits per channel deletes data from your image. Save a copy of the original 16-bit or 32-bit image before you convert to 8 bits per channel.

Turn off font preview

To speed font processing in Photoshop, turn off the font preview list by choosing Type > Font Preview Size > None.

Reduce image resolution

The greater the image resolution, the more memory and disk space Photoshop requires to display, process, and print an image. Depending on your final output, higher image resolution does not necessarily provide higher final image quality, but it can slow performance, use additional scratch disk space, and slow printing. The optimal resolution for your images depends on how the images will be displayed or printed. 

For images presented onscreen, think in terms of total pixel dimensions. To reduce the image dimensions of an image, choose Image > Image Size. In the Image Size dialog box, make sure that the Resample option is selected. Enter a new value for the dimensions Width or Height (entering a value for one changes both).

For printed images, increasing resolution beyond about 360 DPI brings marginal if any benefits in most cases. If you produce many prints, experiment to find a resolution that gives you pleasing results. To reduce the resolution of an image, choose Image > Image Size. In the Image Size dialog box, select Resample. Change the Width and Height values to reflect the physical size of your printed document. Then, decrease the Resolution value, and click OK.

If you are going to increase the image resolution for printing rather than decrease it, perform this resolution increase as one of your last steps before printing the image. That way, you don’t have to process all this extra information in earlier steps.

Purge memory

You can improve system performance by freeing up unused memory and scratch disk space from Photoshop to make it available to other programs. To do so, choose one of these options:

  • Edit > Purge > All
  • Edit > Purge > Undo
  • Hold down Option (macOS) or Alt (Windows) and choose About Photoshop

If other programs are actively trying to allocate or use the memory, freeing up memory in Photoshop will improve performance. Freeing up scratch disk space will be beneficial if you're out of space on a disk volume. If you free up significant memory or disk space, Photoshop will be slower the next time you open large files, while Photoshop allocates space.

If you want Photoshop to always use less memory, choose Edit > Preferences > Performance (Windows) or Photoshop > Preferences > Performance (macOS) and move the Memory Usage slider to the left.

See Adjust memory usage.

Poznámka:

Activity monitors, task managers, and disk utilities may take several seconds to register the change. In fact, for some utilities, you may need to explicitly request the update.

Purge the clipboard

The contents of the clipboard are often large if you’ve been copying and pasting data within large documents. And, those contents are of little use when you’re done pasting. To free up RAM being used by image data in the clipboard, choose Edit > Purge > Clipboard.

Poznámka:

The Purge command cannot be undone.

Use the Filter Gallery

The Filter Gallery allows you to test one or more filters on an image before applying the effects, which can save considerable time and memory.

See Filter Gallery overview.

Drag between files rather than copy and paste

Dragging layers or files is more efficient than copying and pasting them. Dragging bypasses the Clipboard and transfers data directly. Copying and pasting can potentially involve more data transfer and is much less efficient.

Save TIFF files without ZIP compression

For added speed when exporting TIFF files, do not choose ZIP compression. (ZIP compression produces the smallest TIFF files, however.)

Don’t export the clipboard

The Export Clipboard option causes Photoshop to make the contents of the clipboard available to other programs. If you copy large amounts of data in Photoshop, but won’t paste it into other applications, save time by turning off this option:

  1. Choose Photoshop > Preferences > General (macOS) or Edit > Preferences > General (Windows).

  2. Deselect Export Clipboard.

  3. Click OK.

Disable the Libraries panel

  1. From the Libraries flyout menu, choose Close.

  2. Restart Photoshop.

Disable Generator

  1. Choose Edit > Preferences > Plug-ins.

  2. Deselect Enable Generator.

  3. Click OK.

Photoshop compositing

Compositing is the process of combining multiple visual elements together into a single frame that represents your document. The internal compositor in Photoshop calculates itself thousands of times while you use the program, constantly displaying every change made to your image together as a single composite.

Multithreaded compositing

With the April 2022 release of Photoshop 22.3, you can now activate multithreaded compositing by going to Preferences > Performance and enabling the Multithreaded compositing checkbox. You don't need to restart Photoshop for this change to take effect. 

Multi-threaded compositing

Adjustment layers, layer masks, blending modes, filters, styles, and effects each add processing complexity to your document that can chip away at Photoshop's processing speed. You may notice various slider adjustments not updating the screen as fast as they used to before all those layers and effects were added. Multithreaded compositing helps CPU and GPU-based compositing tasks work faster by subdividing computing work into smaller parts that can be run in parallel, often faster than they could be computed in a single 'thread'.

While there are many reasons that documents might become less responsive when being worked in Photoshop, speeding up compositing between 100% and 250% with multithreaded compositing goes a long way toward ensuring Photoshop can be as responsive and fluid as it needs to be.

If you notice redrawing errors and you suspect multithreaded compositing to be an issue, you can turn the feature off in Preferences > Performance. If you have a question to ask or want to share your issue with this setting, notify us on the Adobe Photoshop community. We'd love to hear from you!

Poznámka:

Multithreaded compositing takes the place of the earlier warning about the removal of legacy compositing which is no longer required and now has been removed.

GPU-accelerated compositing

With the April 2022 release of Photoshop 22.3, GPU compositing was added to Photoshop to improve the responsiveness of certain layer operations within a document. GPU compositing can only be used if Photoshop properly detects your GPU on startup. To confirm this, go to Preferences > Performance, and verify that your GPU is listed in the section titled Graphics Processor Setting with a checkmark next to Use Graphics Processor.

To find the checkbox to turn GPU compositing on or off, click the Advanced Settings... button. 

GPU compositing

With smaller, less complex documents containing few layers and layer-based adjustments (e.g., blending modes, adjustment layers), you may not notice any performance degradation when turning on or off blending modes or layer visibility. But as the complexity and size of your documents increases, the compositor in Photoshop can be required to do more real-time processing, and the time it takes to display the results to the screen can start to take longer. With very complex documents, you may have noticed that moving the contents of a layer or changing opacity takes a fraction of a second longer for the screen to update to show you the results. With GPU compositing enabled, Photoshop will use more of your GPU's processing power to speed up the compositing and give you a more fluid editing experience.

If you encounter unexpected results when making these layer-based edits, you can try turning off GPU compositing to see if that changes the results. 

Have a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in the Adobe Photoshop community. We'd love to hear from you!


 Adobe

Získajte pomoc rýchlejšie a ľahšie

Nový užívateľ?

Adobe MAX 2024

Adobe MAX
Konferencia o kreativite

14. – 16. októbra Miami Beach a online

Adobe MAX

Konferencia o kreativite

14. – 16. októbra Miami Beach a online

Adobe MAX 2024

Adobe MAX
Konferencia o kreativite

14. – 16. októbra Miami Beach a online

Adobe MAX

Konferencia o kreativite

14. – 16. októbra Miami Beach a online