Odinštalujte aplikáciu podľa týchto pokynov.
Pozrite si, ako môžete opraviť videoaplikácie, ktoré sa po prejdení na systém macOS Sonoma (verzia 14) nespúšťajú.
Problém
Videoaplikácie Adobe sa v systéme macOS Sonoma (verzia 14) nedarí spustiť, pričom sa zobrazuje nasledujúca chybová správa:
Aplikácia Adobe Premiere Pro 2024 je poškodená a nedá sa otvoriť. Mali by ste ju presunúť do koša.
Tento problém sa týka všetkých verzií aplikácií Adobe a nesúvisí s novou aktualizáciou verzie z roku 2024, takže prejdením na nižšie verzie z roku 2023 sa nevyrieši. Táto chyba sa síce častejšie vyskytuje u používateľov systému Sonoma, ale môže sa objaviť aj v prípade, že používate predchádzajúcu verziu systému macOS.
Príčina
Tento problém vzniká v dôsledku technológie zabezpečenia Gatekeeper od Apple. Apple vyžaduje, aby boli všetky aplikácie podpísané vývojárom v záujme zabezpečenia ich pravosti. Čokoľvek, čo zmení obsah balíka aplikácie po tom, ako ho vývojár podpíše, povedie k bezpečnostnému varovaniu od Apple. Je to dobré, lebo vďaka tomu sa zabráni šíreniu malvéru, ktorý by sa zmocnil aplikácie s cieľom škodiť. Gatekeeper je už niekoľko rokov súčasťou systému macOS, ale spoločnosť Apple posilnila bezpečnostné opatrenia v systéme macOS Sonoma, preto je väčšia pravdepodobnosť, že sa táto chyba vyskytne v systéme Sonoma. Táto chyba sa môže zobraziť aj v predchádzajúcich verziách systému macOS.
Niektorí vývojári doplnkov a rozšírení tretích strán inštalujú do balíka aplikácií komponenty, ako sú predvoľby a iné nastavenia, ktorý spúšťa mechanizmus zabezpečenia od Apple a bráni spusteniu príslušnej aplikácie.
Po spustení programu na odinštalovanie aplikácie Adobe zostane na disku schránka aplikácie s týmito komponentmi tretích strán, pretože Adobe odinštaluje iba súbory, ktoré tam vložil náš pôvodný inštalátor. Keď sa pokúsite o preinštalovanie, chybné súbory tam zostanú a problém pretrváva aj po preinštalovaní.
Riešenie
Inštalácia aplikácie bez komponentov tretích strán
-
-
Odstránením celého priečinka aplikácie a celého jeho obsahu sa uistite, že v ňom nič nezostalo: /Applications/Adobe Premiere Pro 2024.
-
Znovu obvyklým spôsobom nainštalujte aplikáciu z počítačovej aplikácie Creative Cloud. Tu sa dozviete, ako si stiahnuť aplikácie Creative Cloud.
-
Neinštalujte chybný softvér tretej strany.
Používanie aplikácie s komponentmi tretích strán
Nemožnosť používať niektoré nástroje tretích strán nie je práve ideálna. Odporúča sa kontaktovať vývojára tretej strany a požiadať ho o aktualizáciu príslušného inštalačného programu tak, aby nevkladal komponenty do balíka Aplikácie. Spolupracujeme aj s vývojármi tretích strán, aby sme ich o tomto probléme informovali. Ak musíte v dôsledku svojho pracovného postupu používať nástroje tretích strán, vyskúšajte nasledujúce riešenie.
Ak existuje možnosť, že do niektorej aplikácie Adobe vo vašom zariadení bol vložený malvér, povoľte jeho spustenie podľa ďalej uvedených pokynov. Postupujte opatrne a inštalujte aplikácie a nástroje len od renomovaných a dôveryhodných vývojárov.
-
Otvorte aplikáciu.
-
Keď sa zobrazí chybové hlásenie: „Aplikácia Adobe Premiere Pro 2024 je poškodená a nedá sa otvoriť. Mali by ste ju presunúť do koša.“, prejdite do umiestnenia Systémové nastavenia > Súkromie a bezpečnosť.
-
Uistite sa, že ste skontrolovali upozornenie, v ktorom je uvedená príslušná aplikácia Adobe, a vyberte položku Otvoriť aj tak.