Windows için Dreamweaver 8 FTP giriş ayarlarını kaybediyor

Son güncelleme: 27 Nis 2021

Sorun

Bazı Windows kullanıcıları, Dreamweaver site tanımlarındaki FTP kullanıcı adları ve parolalarının Dreamweaver 8'i kapattıklarında ve yeniden açtıklarında veya makinelerini yeniden başlattıklarında silindiğini bildiriyor. Bu sorun Dreamweaver'ın önceki sürümlerinde görülmez. (Ref. 205051, 210466)

Neden

Bu sorunun bilinen iki nedeni var:

  • En yaygın neden, Internet Explorer 7 (IE 7)'nin Dreamweaver 8 ile aynı makineye yüklenmiş olmasıdır.

  • Daha az olası neden ise şu kayıt defteri anahtarının eksik olması veya boş olmasıdır:



    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\AppData

Çözüm

Internet Explorer 7 yüklüyse

Internet Explorer 7 yüklüyse, Dreamweaver 8.0.2 Güncelleyicisi'ni yüklemek bu sorunu çözmelidir. Dreamweaver 8.0.2 Güncelleyicisi'ni yüklemeden önce, özellikle sunucu taraflı sayfalar (ASP, PHP, ColdFusion, vb.) oluşturuyorsanız iş akışınızı etkileyebilecek değişiklikler için Dreamweaver 8 Gelişen Sorunlar TechNote'unu kontrol etmeniz önerilir veya Flash içeriği ekleyin

Not: Dreamweaver 8.0.2 Güncelleyicisi'ni yükledikten sonra, güncelleyicinin başarıyla yüklendiğini doğrulayın. Bazı kullanıcılar 8.0.2'yi yüklediklerini düşünürken, aslında güncelleyici yüklemesi gerçekleşmemiştir.Dreamweaver'da Yardım > Dreamweaver Hakkında > bölümüne gidin ve sürüm numarasını görmek için kayan metne tıklayın. Dreamweaver 8.0.2 yazmalıdır. Hâlâ Dreamweaver 8.0 veya 8.0.1 yazıyorsa, lütfen Güncelleyici yükleyicisini iptal ettikten sonra Windows için Dreamweaver 8 güncelleyicileri yüklenemiyor (TechNote 785362aa) bölümüne bakın.

Not: Internet Explorer 7, Dreamweaver 8'den sonra piyasaya sürüldü ve bu nedenle Dreamweaver 8 ve önceki sürümlerle test edilmedi.

Internet Explorer 7 yüklü değilse veya Dreamweaver 8.0.2 Güncelleyicisi sorunu çözmezse

Bu sorun oluştuğu sırada Internet Explorer 7 yüklü değilse, yukarıda açıklandığı gibi Dreamweaver 8.0.2 Güncelleyicisi'ni yükleyin ve Windows Kayıt Defteri'ni düzenlemekte rahat hissediyorsanız aşağıdaki adımları uygulayın.

Uyarı: Windows Kayıt Defteri'ni yanlış düzenlemek, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilir. Adobe, kayıt defterini yanlış düzenlemenin neden olduğu sorunların çözülebileceğini garanti etmez. Kayıt defterini düzenleme riski size aittir.

Başlat düğmesine tıklayarak Kayıt Defteri Düzenleyicisi'ni başlatın, Çalıştır'ı seçin, ardından "regedit" yazın. Kayıt Defteri Düzenleyicisi'nde şu klasöre gidin:



HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\
Aşağıdaki ekran görüntüsünde gösterildiği gibi AppData adlı bir anahtar olup olmadığına bakın:



AppData anahtarını kontrol edin

Users Shell Folders kayıt defteri dalını aşağıdaki gibi yedekleyin:
Users Shell Folders klasörüne sağ tıklayın ve "Dışa Aktar" seçeneğini seçin.
"Dışa aktarma aralığı" bölümünde "Seçili dal" seçeneğini seçin.
.reg dosyasını masaüstüne kaydedin.
Kayıt defteri düzenlendikten sonra sorunlar oluşursa, .reg dosyasına çift tıklamak o kayıt defteri dalını yeniden kuracaktır.
AppData anahtarı eksikse, aşağıdaki adımları uygulayın. AppData anahtarı mevcutsa, 5. Adım'a atlayın.
Kayıt Defteri Düzenleyicisi gezgin panelinin sağ tarafında, listedeki son anahtarın altında herhangi bir boş alanda sağ tıklayın. Açılır menüyle "Yeni" yazan bir içerik menüsü almalısınız.
Açılır menüde "Genişletilebilir Dize Değeri" seçeneğini seçin ve yeni anahtarı AppData olarak adlandırın.
Yeni AppData anahtarına (veya zaten varsa mevcut olana) sağ tıklayın, Değiştir'i seçin ve Değer Verileri alanına şunları girin: %USERPROFILE%\Application Data. User Shell Folders dizininizdeki diğer anahtarların değerleri %USERPROFILE% ile başlamıyorsa, diğer anahtarlarınızın kullandığı değeri kullanın. Örneğin, Local Settings anahtarınızın u:\Local Settings değeri varsa, u:\Application Data kullanmayı deneyin.
Dreamweaver'ı açın, sitelerinizden biri için FTP giriş bilgilerini yeniden girin ve Dreamweaver'ı kapatıp yeniden açtığınızda FTP girişinin artık kaydedilip kaydedilmediğine bakın.

Yukarıdaki çözümler sorunu çözmezse, lütfen Adobe Teknik Desteği ile iletişime geçin veya hata raporu gönderin ve TechNote 3491671c'de açıklanan sorunu yaşadığınızı belirtin.