Dreamweaver Teslim Etme/Teslim Alma, WebDAV ve Subversion sistemini kullanarak dosyaları yerel ve uzak sunucularda teslim edin ve teslim alın.

İşbirliği ortamında çalışmıyorsanız, yerel ve uzak sunucularda dosya teslim edebilir ve teslim alabilirsiniz. Uzak sunucuda sadece siz çalışıyorsanız, dosyaları teslim etmeden veya almadan Koy ve Al komutlarını kullanabilirsiniz.

Not:

Al ve Koy işlevlerini test sunucusunda kullanabilirsiniz, ancak Teslim Et/Teslim Al sistemini test sunucusunda kullanamazsınız.

Dosyayı teslim almak, “Bu dosyada şu anda ben çalışıyorum, dosyaya dokunmayın!” demeye eşdeğerdir. Dosya teslim alındığında dosyayı teslim alan kişinin adı Dosyalar panelinde bir kırmızı onay işareti (dosyayı ekip üyesi teslim aldıysa) veya yeşil onay işareti (dosyayı siz teslim aldıysanız) ile görüntülenir.

Dosyayı teslim edildiğinde diğer ekip üyeleri tarafından teslim alınabilir ve düzenlenebilir. Dosyayı düzenledikten sonra teslim ettiğinizde yerel sürümünüz salt okunur olur ve dosyada değişiklik yapmanızı önlemek için Dosyalar panelindeki dosyanın yanında bir kilit simgesi görünür.

Dreamweaver, uzak sunucuda teslim alınan dosyaları salt okunur yapmaz. Dosyaları Dreamweaver'dan daha eski bir uygulamayla aktarırsanız, teslim alınan dosyaların üzerine yazabilirsiniz. Ancak, Dreamweaver'dan eski uygulamalarda bu tür yanlışlıkları önlemek için LCK dosyası dosya hiyerarşisinde teslim alınan dosyanın yanında görünür.

Teslim Etme/Teslim Alma sistemini ayarlama

Teslim Et/Teslim Al sistemini kullanabilmek için yerel sitenizi uzak sunucu ile ilişkilendirebilmeniz gerekir.

  1. Site > Siteleri Yönet'i seçin.
  2. Site seçin ve Düzenle'yi tıklatın.
  3. Site Kurulumu iletişim kutusunda Sunucular kategorisini seçin ve aşağıdakilerden birini yapın:
    • Yeni bir sunucu eklemek için Yeni Sunucu Ekle düğmesini tıklatın

    • Varolan bir sunucuyu seçin ve Varolan Sunucuyu Düzenle düğmesini tıklatın

  4. Temel seçenekleri gerektiği şekilde belirtin ve daha sonra Gelişmiş düğmesini tıklatın.
  5. Ekip ortamında çalışıyorsanız (veya tek başınıza ancak farklı makinelerde çalışıyorsanız) Dosya Teslim Almayı Etkinleştir'i seçin. Web siteniz için dosya teslim etme ve teslim almayı devre dışı bırakmak için bu seçeneğin işaretini kaldırın.

    Bu seçenek, diğerlerine dosyayı düzenlemek için teslim aldığınızı bildirmek ya da kendinize dosyanın daha yeni bir sürümünü başka bir makinede bırakmış olabileceğinizi anımsatmak için kullanışlıdır.

    Teslim Et/Teslim Al seçeneklerini görmüyorsanız, uzak bir sunucuda ayarlamamışsınızdır.

  6. Dosyaları Dosyalar panelinde açmak için çift tıklattığınızda otomatik olarak teslim almak istiyorsanız, Açarken Dosyaları Teslim Al seçeneğini belirleyin.

    Dosya açmak için Dosya > Aç seçeneğinin kullanılması, bu seçenek işaretli olsa bile dosyayı teslim almaz.

  7. Kalan seçenekleri ayarlayın:

    Teslim Alma Adı

    Teslim alma adı teslim alınan diğer dosyalarla birlikte Dosyalar panelinde görünür; böylece istedikleri bir dosya teslim alınmışsa ekip üyeleri doğru kişiyle iletişim kurabilir.

    Not:

    Farklı makinelerde tek başınıza çalışıyorsanız, dosyayı teslim etmeyi unutmanız durumunda dosyanın en son sürümünün nerede olduğunu bilmek için her makinede farklı bir teslim alma adı (örneğin, AynurH-EvMac ve AynurH-ŞirketPC) kullanın.

    E-posta Adresi

    E-posta adresi girerseniz, dosya teslim alırken adınız Dosyalar panelinde o dosyanın yanında bağ (mavi ve alt çizgili) olarak görünür. Ekip üyesi bu bağı tıklatırsa, ekip üyesinin varsayılan e-posta programı kullanıcının e-posta adresini ve dosyaya ve site adına karşılık gelen bir konuyu içeren yeni bir mesaj açar.

Uzak klasöre dosya teslim etme ve uzak klasörden dosya teslim alma

Teslim Et/Teslim Al sistemini ayarladıktan sonra Dosyalar panelini veya Belge penceresini kullanarak uzak sunucudaki dosyaları teslim edebilir ve teslim alabilirsiniz.

Dosyalar panelini kullanarak dosyaları teslim alma

  1. Dosyalar panelinde (Pencere > Dosyalar) uzak sunucudan teslim alacağınız dosyaları seçin.

    Not:

    Dosyaları Test Sunucusu görünümünde değil, Yerel veya Uzak görünümünde seçebilirsiniz.

    Kırmızı onay işareti, dosyayı başka bir ekip üyesinin teslim aldığını, kilit simgesi ise dosyanın salt okunur (Windows) veya kilitli (Macintosh) olduğunu gösterir.

  2. Dosyaları teslim almak için aşağıdaki işlemlerden birini gerçekleştirin:
    • Dosyalar paneli araç çubuğunda Teslim Al düğmesini tıklatın.

    • Bağlantıyı sağ tıklatın (Windows) veya Control tuşuna basarak tıklatın (Macintosh) ve ardından içerik menüsünde Teslim Al'ı seçin.

  3. Bağımsız Dosyalar iletişim kutusunda seçilen dosyalarla birlikte bağımlı dosyalar indirmek için Evet'i veya bağımlı dosyaları indirmekten kaçınmak için Hayır'ı tıklatın. Varsayılan değer bağımlı dosyaları indirmemektir. Bu seçeneği Düzen > Tercihler > Site seçeneklerinden de ayarlayabilirsiniz.

    Not:

    Yeni bir dosyayı teslim alırken bağımlı dosyaları indirmek genellikle iyi bir fikirdir ancak bağımlı dosyaların son sürümleri zaten yerel diskteyse bunları yeniden indirmek gerekmez.

    Yerel dosya simgesinin yanında dosyayı teslim aldığınızı gösteren bir yeşil onay işareti görünür.

    Not:

    O anda etkin olan bir dosyayı teslim alırsanız, dosyanın yeni teslim alınan sürümü dosyanın açık olan sürümünün üzerine yazar.

Dosyalar panelini kullanarak dosyaları teslim etme

  1. Dosyalar panelinde (Pencere > Dosyalar) teslim alınacak veya yeni dosyaları seçin.

    Not:

    Dosyaları Test Sunucusu görünümünde değil, Yerel veya Uzak görünümünde seçebilirsiniz.

  2. Dosyaları teslim etmek için aşağıdaki işlemlerden birini gerçekleştirin:
    • Dosyalar paneli araç çubuğunda Teslim Et düğmesini tıklatın.

    • Bağlantıyı sağ tıklatın (Windows) veya Control tuşuna basarak tıklatın (Macintosh) ve ardından içerik menüsünde Teslim Et'i seçin.

  3. Seçilen dosyalarla birlikte bağımlı dosyalar yüklemek için Evet'i veya bağımlı dosyaları yüklemekten kaçınmak için Hayır'ı seçin. Varsayılan değer bağımlı dosyaları yüklememektir. Bu seçeneği Düzen > Tercihler > Site seçeneklerinden ayarlayabilirsiniz.

    Not:

    Yeni bir dosyayı teslim ederken bağımlı dosyaları yüklemek genellikle iyi bir fikirdir ancak bağımlı dosyaların son sürümleri zaten uzak sunucudaysa bunları yeniden yüklemeniz gerekmez.

    Yerel dosyanın simgesinin yanında dosyanın salt okunur olduğunu gösteren bir kilit simgesi görünür.

    Not:

    O anda etkin olan dosyayı teslim ederseniz, ayarladığınız tercih seçeneklerine bağlı olarak dosya teslim edildikten sonra otomatik olarak kaydedilebilir.

Belge penceresinde açık bir dosyayı teslim etme

  1. Teslim etmek istediğiniz dosyanın Belge penceresinde açık olduğundan emin olun.

    Not:

    Tek seferde sadece bir dosya teslim edebilirsiniz.

  2. Aşağıdakilerden birini yapın:
    • Site > Teslim Et seçeneğini belirleyin.

    • Belge penceresi araç çubuğundaki Dosya Yönetimi simgesini tıklatın ve ardından menüden teslim Et'i seçin.

      Geçerli dosya Dosyalar panelindeki etkin sitenin bir parçası değilse, Dreamweaver geçerli dosyanın yerel olarak tanımlanmış sitelerden hangisine ait olduğunu belirlemeye çalışır. Geçerli dosya Dosyalar panelinde etkin olan siteden farklı bir siteye aitse, Dreamweaver söz konusu siteyi açar ve ardından teslim etme işlemini yapar.

    Not:

    O anda etkin olan dosyayı teslim ederseniz, ayarladığınız tercih seçeneklerine bağlı olarak dosya teslim edildikten sonra otomatik olarak kaydedilebilir.  

Dosya teslim alma işlemini geri alma

Dosyayı teslim alır ve daha sonra düzenlememeye (veya yaptığınız değişiklikleri iptal etmeye) karar verirseniz, teslim alma işlemini geri alabilirsiniz ve bu durumda dosya ilk durumuna döner.

Dosya teslim alma işlemini geri almak için aşağıdaki işlemlerden birini gerçekleştirin:

  • Dosyayı Belge penceresinde açın ve ardından Site > Teslim Almayı Geri Al'ı seçin.

  • Dosyalar panelinde (Pencere > Dosyalar) sağ tıklatın (Windows) veya Control tuşuna basarak tıklatın (Macintosh) ve ardından Teslim Almayı Geri Al'ı seçin.

    Dosyanın yerel kopyası salt okunur olur ve dosyada yaptığınız tüm değişiklikler kaybolur.

Dosyaları teslim etmek ve teslim almak için WebDAV kullanma

Dreamweaver, kullanıcıların uzak web sunucularındaki dosyaları iş birliği halinde düzenlemelerini ve yönetmelerini sağlayan HTTP protokolünün bir uzantılar kümesi niteliğindeki WebDAV'ı (Web Tabanlı Dağıtılmış Hazırlama ve Sürüm Oluşturma) kullanarak bir sunucuya bağlanabilir. Daha fazla bilgi için bkz. www.webdav.org.

  1. Henüz yapmadıysanız, proje dosyalarınızı depolamak için kullandığınız yerel klasörü belirleyen bir Dreamweaver sitesi tanımlayın.
  2. Site > Siteleri Yönet'i seçin ve sitenizi listede çift tıklatın.
  3. Site Kurulumu iletişim kutusunda Sunucular kategorisini seçin ve aşağıdakilerden birini yapın:
    • Yeni bir sunucu eklemek için Yeni Sunucu Ekle düğmesini tıklatın

    • Varolan bir sunucuyu seçin ve Varolan Sunucuyu Düzenle düğmesini tıklatın

  4. Temel ekranda, Şunu Kullanarak Bağlan açılır menüsünden WebDAV'ı seçin ve Temel ekran seçeneklerini gerektiği şekilde tamamlayın.
  5. Gelişmiş düğmesini tıklatın.
  6. Dosya Teslim Almayı Etkinleştir seçeneğini belirleyin ve aşağıdaki bilgileri girin:
    • Teslim Alma Adı kutusunda sizi diğer ekip üyelerine tanıtan adı girin.

    • E-posta Adresi kutusunda e-posta adresinizi girin.

      Ad ve e-posta adresleri WebDAV sunucusunda sahipliği tanımlamak için kullanılır ve iletişim amacıyla Dosyalar panelinde görüntülenir.

  7. Kaydet'i tıklatın.

    Dreamweaver siteyi WebDAV erişimi için yapılandırır. Teslim Et veya Teslim Al komutunu herhangi bir site dosyasında kullanırsanız dosya WebDAV kullanılarak aktarılır.

    Not:

    WebDAV, HTTP GET bunları teslim alınırken oluşturduğundan PHP etiketleri veya SSI'ler gibi dinamik içeriğe sahip dosyaları düzgün bir şekilde teslim alamayabilir.

Dosyaları almak ve teslim etmek için Subversion (SVN) kullanma

Not:

Dreamweaver CC 2017 ve sonraki sürümlerinde Subversion (SVN) desteği kaldırılmıştır.

Dreamweaver, kullanıcıların uzak web sunucularındaki dosyaları ortak olarak düzenlemesine ve yönetmesine olanak veren bir sürüm oluşturma kontrol sistemi olan Subversion (SVN) sistemini kullanan bir sunucuya bağlanabilir. Dreamweaver tam bir SVN istemcisi değildir ancak, kullanıcıların dosyaların en son sürümlerini almasına, değişiklik yapmasına ve dosyaları teslim etmesine olanak tanır.

Not:

Dreamweaver CSS, Subversion 1.6.6 istemci kitaplığını kullanır. Dreamweaver CS5.5 ise 1.6.9 istemci kitaplığını kullanır. Subversion istemci kitaplığının sonraki sürümleri tersine uyumlu değildir. Bir üçüncü taraf istemci uygulamasını (örneğin TortoiseSVN) Subversion'ın daha sonraki bir sürümüyle çalışacak biçimde güncellerseniz, güncellenmiş Subversion uygulaması yerel Subversion meta verilerini günceller ve Dreamweaver bundan sonra Subversion ile iletişim kuramaz. Subversion sunucusunda yapılan güncellemeler tersine uyumlu olduğundan, söz konusu güncellemeler bu soruna etki etmez. Subversion 1.7 veya üstüyle çalışan bir üçüncü taraf istemci uygulamasına güncelleme yaparsanız, Subversion'ı Dreamweaver ile tekrar kullanmadan önce Adobe'deki güncellemeleri kontrol etmeniz gerekir. Bu sorun hakkında daha fazla bilgi için bkz. www.adobe.com/go/dw_svn_en.

Adobe, SVN sürüm kontrollü dosyalarla çalışırken üçüncü taraf bir dosya karşılaştırma aracını kullanmanızı önerir. Dosyaların farklılıklarını karşılaştırdığınızda, diğer kullanıcıların dosyalarda ne tür değişiklikler yaptığını tam olarak öğrenebilirsiniz. Dosya karşılaştırma araçları hakkında daha fazla bilgi için, “dosya karşılaştırma” veya “farklılık” araçları aramak üzere Google Search gibi bir web arama motorunu kullanın. Dreamweaver birçok üçüncü taraf aracıyla çalışır.

SVN ve Dreamweaver ile çalışma hakkında bir video tanıtımı için bkz. www.adobe.com/go/lrvid4049_dw.

SVN bağlantısı kurma

Subversion (SVN) uygulamasını Dreamweaver ile bir sürüm kontrol sistemi olarak kullanmadan önce, bir SVN sunucusuyla bağlantı oluşturmanız gerekir. SVN sunucusu bağlantısını, Site Tanımı iletişim kutusunun Sürüm Kontrolü kategorisinde oluşturabilirsiniz.

SVN sunucusu, sizin ve diğer kullanıcıların dosyaları alıp teslim ettiği bir dosya deposudur. Dreamweaver ile yaygın olarak kullanılan uzak sunucudan farklıdır. SVN kullanılırken, uzak sunucu web sayfalarınız için "canlı" sunucu olarak kullanılmaya devam ederken, SVN sunucusu, sürüm kontrolü uygulamak istediğiniz dosya deposunu barındırmak üzere kullanılır. İş akışı genel olarak SVN sunucusu üzerinde dosyaları alıp teslim etmek ve bu dosyaları Dreamweaver aracılığıyla uzak sunucunuzda yayınlamaktan oluşur. Uzak sunucu kurulumu SVN kurulumundan tamamen farklıdır.

Bu kurulum işlemine başlamadan önce bir SVN sunucusuna ve bir SVN deposuna erişiminiz olmalıdır. SVN hakkında daha fazla bilgi için http://subversion.apache.org/ adresindeki Subversion web sitesine bakın.

SVN bağlantısını kurmak için aşağıdaki adımları uygulayın:

  1. Siteler > Siteleri Yönet öğesini seçin ve sürüm denetimi kurmak istediğiniz siteyi belirleyin, ardından Düzenle düğmesini tıklatın.

    Not:

    Bir Dreamweaver sitesi için henüz yerel ve uzak klasörler kurmadıysanız, işleme devam etmeden önce en azından bir yerel site kurmanız gerekir. (Bu aşamada uzak site gerekmemektedir; ancak, dosyalarınızı Web üzerinde yayınlamadan önce bu kurulumu gerçekleştirmeniz gerekir.) Daha fazla bilgi için bkz. Dreamweaver siteleriyle çalışma.

  2. Site Kurulumu iletişim kutusunda, Sürüm Denetimi kategorisini seçin.

  3. Erişim açılır menüsünden Subversion öğesini seçin.

  4. Erişim seçeneklerini aşağıdaki şekilde belirleyin:

    • Protokol açılır menüsünden bir protokol seçin. Mevcut protokoller, HTTP, HTTPS, SVN ve SVN+SSH'tir.

    Not:

    SVN+SSH protokolünün kullanımı özel yapılandırma gerektirir. Daha fazla bilgi için bkz. www.adobe.com/go/learn_dw_svn_ssh_en.

    • Sunucu adresi metin kutusuna SVN sunucusunun adresini girin (genellikle şu şekilde: sunucuadi.etkialani.com).

    • Depo yolu metin kutusuna SVN sunucusu üzerindeki depo yolunuzu girin (genellikle şu şekilde: /svn/your_root_directory. SVN deposu için kök klasörün adlandırılması sunucu yöneticisine bağlıdır.)

    • (İsteğe bağlı) Varsayılan sunucu portu dışında bir sunucu portu kullanmak isterseniz, Varsayılanı Kullanma öğesini seçin ve metin kutusuna port numarasını girin.

    • SVN sunucusu kullanıcı adınızı ve şifrenizi girin.

  5. Bağlantınızı test etmek için Test öğesini tıklatın veya iletişim kutusunu kapatmak için Tamam'ı tıklatın. Ardından, Siteleri Yönet iletişim kutusunu kapatmak için Tamam öğesini tıklatın.

Sunucu ile bağlantı sağlandıktan sonra SVN deponuz Dosyalar panelinde görüntüleme için hazırdır. Görüntülemek için, Görünüm açılır menüsünden Depo Görünümü'nü seçin veya genişletilmiş Dosyalar panelinde Depo Dosyaları düğmesini tıklatın.

Dosyaların son sürümünü alma

SVN deposundan herhangi bir dosyanın son sürümünü aldığınızda, Dreamweaver bu dosyanın içeriğini, ilgili yerel kopyanın içeriğiyle birleştirir. (Başka bir deyişle, dosya siz tarafından son kez teslim edildikten sonra başkası tarafından güncelleştirilirse, bu güncelleştirmeler, ilgili dosyanın bilgisayarınızdaki yerel sürümüyle birleştirilir.) Dosya yerel sabit diskinizde bulunmuyorsa, Dreamweaver dosyayı alır.

Not:

Depodan ilk defa dosya alırken, boş bir yerel dizinle çalışmanız veya depodaki dosyalarla aynı ada sahip dosya içermeyen bir yerel dizin kullanmanız gerekir. Yerel sürücüde adları uzak depodaki dosyalarla eşleşen dosyalar varsa, Dreamweaver depo dosyalarını ilk denemede yerel sürücüye yerleştirmez.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Aşağıdakilerden birini yapın:

    • Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.) Ardından, ilgilendiğiniz dosyayı veya klasörü sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Sürüm Denetimi > Son Sürümleri Al öğesini seçin.

    • Dosyalar panelindeki Görünüm açılır menüsünden Depo Görünümü'nü seçerek veya genişletilmiş Dosyalar panelindeki Depo Dosyaları düğmesini tıklatarak SVN deposu dosyalarını görüntüleyin. Ardından, ilgilendiğiniz dosyayı veya klasörü sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Son Sürümleri Al öğesini seçin.

Not:

Ayrıca, son sürümü almak için bir dosyayı sağ tıklatıp içerik menüsünden Teslim Al seçeneğini belirleyebilir veya dosyayı seçip Teslim Al düğmesini tıklatabilirsiniz. Ancak, SVN, teslim alma iş akışını desteklemediğinden, bu eylem dosyayı klasik anlamda teslim almaz.

Dosyaları teslim etme

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Aşağıdakilerden birini yapın:

    • Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.) Ardından, teslim etmek istediğiniz dosyayı seçin ve Teslim Et düğmesini tıklatın.

    • Dosyalar panelindeki Görünüm açılır menüsünden Depo Görünümü'nü seçerek veya genişletilmiş Dosyalar panelindeki Depo Dosyaları düğmesini tıklatarak SVN deposu dosyalarını görüntüleyin. Ardından, teslim etmek istediğiniz dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Teslim Et öğesini tıklatın.

  3. Teslim et iletişim kutusunda eylemleri inceleyin, gerekli değişiklikleri yapın ve Tamam'ı tıklatın.

    Eylemleri değiştirmek için, eylemlerini değiştirmek istediğiniz dosyayı seçip Teslim Et iletişim kutusunun alt kısmındaki düğmeleri tıklatın. İki seçenek vardır: teslim et veya yoksay.

Not:

Dosyalar panelindeki bir dosyada yeşil bir onay işareti bulunması, henüz depoya teslim edilmemiş olan değiştirilmiş bir dosyayı ifade eder.

Depodaki dosyaların veya klasörlerin durumunu güncelleştirme

Tek bir dosyanın veya klasörün SVN durumunu güncelleştirebilirsiniz. Güncelleştirme, görünümün tamamını yenilemez.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Dosyalar panelindeki Görünüm açılır menüsünden Depo Görünümü'nü seçerek veya genişletilmiş Dosyalar panelindeki Depo Dosyaları düğmesini tıklatarak SVN deposu dosyalarını görüntüleyin.

  3. Depodaki herhangi bir klasörü veya dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Durumu Güncelleştir öğesini seçin.

Yerel dosya veya klasörlerin durumunu güncelleştirme

Tek bir dosyanın veya klasörün SVN durumunu güncelleştirebilirsiniz. Güncelleştirme, görünümün tamamını yenilemez.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.)

  3. Dosyalar panelindeki herhangi bir klasörü veya dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Durumu Güncelleştir öğesini seçin.

Dosyaya yönelik uyarlamaları görüntüleme

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Aşağıdakilerden birini yapın:

    • Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.) Ardından, uyarlamalarını görmek istediğiniz dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Sürüm Denetimi > Uyarlamaları Göster öğesini seçin.

    • Dosyalar panelindeki Görünüm açılır menüsünden Depo Görünümü'nü seçerek veya genişletilmiş Dosyalar panelindeki Depo Dosyaları düğmesini tıklatarak SVN deposu dosyalarını görüntüleyin. Ardından, uyarlamalarını görmek istediğiniz dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Uyarlamaları Göster öğesini tıklatın.

  3. Uyarlama Geçmişi iletişim kutusunda, ilgilendiğiniz uyarlamayı veya uyarlamaları seçin ve aşağıdakileri uygulayın:

    • Seçilen uyarlamayı dosyanın yerel sürümüyle karşılaştırmak için Yerelle Karşılaştır öğesini tıklatın.

    Not:

    Dosyaları karşılaştırmadan önce, üçüncü taraf bir dosya karşılaştırma aracı yüklemeniz gerekir. Dosya karşılaştırma araçları hakkında daha fazla bilgi için, “dosya karşılaştırma” veya “farklılık” araçları aramak üzere Google Search gibi bir web arama motorunu kullanın. Dreamweaver birçok üçüncü taraf aracıyla çalışır.

    • Seçilen iki uyarlamayı karşılaştırmak için Karşılaştır öğesini tıklatın. Aynı anda iki uyarlama seçmek için Control tuşunu basılı tutarak tıklatın.

    • Seçilen uyarlamayı görüntülemek için Görünüm öğesini tıklatın. Bu eylem, aynı dosyanın geçerli yerel kopyasının üzerine yazmaz. Seçilen uyarlamayı herhangi bir dosyayı kaydettiğiniz şekilde sabit sürücünüze kaydedebilirsiniz.

    • Seçilen uyarlamayı deponuzdaki geçerli uyarlama yapmak için Yükselt öğesini tıklatın.

Dosyaları kilitleme veya kilidi kaldırma

SVN deposunda bir dosyayı kilitlemeniz, diğer kullanıcıların dosya üzerinde çalıştığınızı bilmesini sağlar. Diğer kullanıcılar dosyayı yerel olarak düzenleyebilirler ancak kilidini açmadığınız sürece dosyayı teslim edemezler. Depodaki bir dosyayı kilitlediğinizde, dosya üzerinde bir kilit açma simgesi görürsünüz. Diğer kullanıcılar tamamen kilitli bir simge görür.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Aşağıdakilerden birini yapın:

    • Dosyalar panelindeki Görünüm açılır menüsünden Depo Görünümü'nü seçerek veya genişletilmiş Dosyalar panelindeki Depo Dosyaları düğmesini tıklatarak SVN deposu dosyalarını görüntüleyin. Ardından, ilgilendiğiniz dosyayı sağ tıklatın (Windows) veya Ctrl tuşunu basılı tutarak tıklatın (Macintosh) ve Kilitle veya Kilidi Aç öğesini seçin.

    • Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.) Ardından, ilgilendiğiniz dosyayı sağ tıklatın (Windows) veya Control tuşunu basılı tutarak tıklatın (Macintosh) ve Kilitle veya Kilidi Aç öğesini seçin.

Depoya yeni bir dosya ekleme

Dosyalar panelindeki bir dosyada mavi bir artı işareti bulunması, SVN deposunda henüz mevcut olmayan bir dosyayı gösterir.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Dosyalar panelinde, depoya eklemek istediğiniz dosyayı seçin ve Teslim Et düğmesini tıklatın.

  3. Teslim Et iletişim kutusunda Teslim Et öğesi için dosyanın seçildiğinden emin olun ve Tamam'ı tıklatın.

Dosyaları taşıma, kopyalama, silme veya geri döndürme

  • Bir dosyayı taşımak için, yerel sitenizdeki hedef klasöre dosyayı sürükleyin.

    Bir dosyayı taşıdığınızda, Dreamweaver yeni konumdaki dosyayı bir Geçmiş ile Ekle işaretiyle, eski konumdaki dosyayı da bir Sil işaretiyle işaretler. Bu dosyaları teslim ettiğinizde, eski konumdaki dosya kaybolur.

  • Bir dosyayı kopyalamak için, dosyayı seçin, kopyalayın (Düzenle > Kopyala) ve yeni konuma yapıştırın (Düzenle > Yapıştır).

    Bir dosyayı kopyalayıp yapıştırdığınızda, Dreamweaver yeni konumdaki dosyayı bir Geçmiş ile Ekle işaretiyle işaretler.

  • Bir dosyayı silmek için dosyayı seçin ve sil'e basın.

    Dreamweaver, yalnızca dosyanın yerel sürümünü veya hem yerel sürümünü hem de SVN sunucusundaki sürümünü silme seçeneğini size sunar. Yalnızca yerel sürümü silmeyi seçerseniz, SVN sunucusundaki dosya etkilenmez. SVN sunucusundaki sürümü de silmeyi seçerseniz, yerel sürüm bir Sil işaretiyle işaretlenir ve silme işleminin gerçekleşmesi için dosyayı teslim etmeniz gerekir.

  • Kopyalanan veya taşınan bir dosyayı orijinal konumuna geri döndürmek için, dosyayı sağ tıklatın ve Sürüm Kontrolü > Geri Dön seçeneklerini belirleyin.

Çakışan dosyaları çözümleme

Dosyanız sunucu üzerinde diğer bir dosyayla çakışırsa, dosyayı düzenleyebilir ve çözümlendi olarak işaretleyebilirsiniz. Örneğin, diğer bir kullanıcının değişiklikleriyle çakışan bir dosyayı teslim etmeye çalışırsanız, SVN dosyayı teslim etmenize izin vermez. Dosyanın son sürümünü depodan alabilir, çalışma kopyanızda manuel olarak değişiklik yapabilir ve ardından dosyanızı teslim edebilmek için çözümlendi olarak işaretleyebilirsiniz.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.)

  3. Çözümlemek istediğiniz dosyayı sağ tıklatın (Windows) veya Control tuşunu basılı tutarak tıklatın (Macintosh) ve Sürüm Denetimi > Çözümlendi Olarak İşaretle öğesini tıklatın.

Çevrimdışı çalışma

Çevrimdışı çalışarak, diğer dosya aktarım eylemleri sırasında depoya erişimi önleyebilirsiniz. Bağlantı gerektiren bir eylem (Son Sürümleri Al, Teslim Et vb.) başlattığınız zaman Dreamweaver SVN deposuyla yeniden bağlantı sağlar.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.)

  3. Dosyalar panelindeki herhangi bir klasörü veya dosyayı sağ tıklatın (Windows) veya Control tuşunu basılı tutarak tıklatın (Macintosh) ve Sürüm Denetimi > Çevrimdışı Çalış öğesini seçin.

Yerel bir SVN sitesini temizleme

Bu komut, tamamlanmamış işlemlere devam edebilmeniz için dosyalardaki kilitleri kaldırabilmenizi sağlar. "Çalışma kopyası kilitli" hatalarını alırsanız, önceki kilitleri kaldırmak için bu komutu kullanmanız gerekir.

  1. SVN bağlantısını başarıyla oluşturduğunuzdan emin olun.

  2. Görünüm açılır menüsünden Yerel görünümü seçerek SVN dosyalarınızın yerel sürümünü Dosyalar panelinde görüntüleyin. (Genişletilmiş Dosyalar panelinde çalışıyorsanız, Yerel görünüm otomatik olarak görüntülenir.)

  3. Temizlemek istediğiniz dosyayı sağ tıklatın (Windows) veya Control tuşunu basılı tutarak tıklatın (Macintosh) ve Sürüm Denetimi > Temizle öğesini tıklatın.

Subversion tarafından kontrol edilen sitelerdeki dosyaları ve klasörleri taşıma hakkında

Subversion tarafından kontrol edilen sitelerdeki dosyaların veya klasörlerin yerel sürümlerini taşıdığınızda, SVN deposuyla senkronizasyon gerçekleştirmekte olan diğer kullanıcılar için sorun oluşturabilirsiniz. Örneğin, bir dosyayı yerel olarak taşıdıktan sonraki birkaç saat içinde bu dosyayı depoya teslim etmezseniz, başka bir kullanıcı dosyanın eski konumundan dosyanın daha eski bir sürümünü almaya çalışabilir. Bu nedenle, daima, dosyaları yerel olarak taşıdıktan hemen sonra, SVN sunucusuna teslim etmeniz gerekir.

Siz tarafından el ile silinmediği sürece dosya ve klasörler SVN sunucusunda saklanır. Bu nedenle, bir dosyayı farklı bir yerel klasöre taşıyıp teslim etseniz dahi, dosyanın eski sürümü sunucu üzerindeki önceki konumda saklanır. Karışıklıkları önlemek için, taşımış olduğunuz dosya ve klasörlerin eski kopyalarını silin.

Bir dosyayı yerel olarak taşıyıp SVN sunucusuna teslim ettiğinizde, dosyanın sürüm geçmişi silinir.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi