在 Animate 中變形及結合圖像物件

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

對物件進行變形

您可以使用「自由變形」工具或「修改 > 變形」選單中的選項,將圖像物件、群組、文字區塊和實體變形。依據選取的元素類型,您可以變形、旋轉、傾斜、縮放或扭曲元素。您可以在變形操作時更改或增加選取範圍。

在對物件、群組、文字方塊或實體進行變形的動作時,這個項目的「屬性」檢測器會顯示您對該項目的尺寸或位置所做的任何更改。

進行涉及拖曳動作的變形操作時,會出現一個範圍框。範圍框為矩形時 (除非使用「扭曲」命令或「封套」修改選項進行修改),它的邊緣在開始時就已經對齊「舞台」的邊緣。變形控制點位於每個轉角和每邊的中間。拖曳時,您可以在範圍框中預覽變形的結果。

移動、重新對齊、變更與追蹤變形點

在變形時,選取元素的中心會出現變形點。變形點在開始時會對齊物件的中心點。您可以移動該變形點、將它還原回預設位置,並移動預設的原始點。

根據預設,在對圖像物件、群組和文字區塊進行縮放、傾斜或旋轉時,進行拖曳的點對面的那一點就是原始點。例如,變形點即為預設的原始點。您可以移動預設的原始點,以進行變形。

  1. 選取「自由變形」工具 ,或選取「修改 > 變形」所顯示的其中一個命令。

    一旦開始變形操作,您就可以透過「資訊」面板與「屬性」檢測器來追蹤變形點的位置。

  2. 請執行下列其中一項:
    • 若要移動變形點,請將之從選取的圖像物件中往外拖曳。

    • 若要將變形點與元素的中心點重新對齊,請按兩下該變形點。

    • 若要在縮放變形或傾斜變形進行時切換原始點,請按住 Alt (Windows) 或 Option (Macintosh) 同時拖曳選定的物件控制點。

    • 在「資訊」面板中,您可以切換顯示「註冊點」和「變形點」。此按鈕會顯示為 ,表示正在顯示註冊點座標。按一下相同按鈕,就會變更為 ,表示正在顯示變形點座標。

    座標格線;變形模式中的資訊面板與註冊/變形點按鈕,以及可見的選取範圍變形點之 X 與 Y 座標。

使用自由變形工具

您可以執行個別的變形或將數個變形組合起來,如移動、旋轉、縮放、傾斜和扭曲。

註解:

「自由變形」工具不能對元件、點陣圖、視訊物件、聲音、漸層或文字進行變形。如果「多重選取範圍」包括任何上述的項目,只有形狀物件會被扭曲。若要對文字區塊進行變形,請先將字元轉換成形狀物件。

  1. 在舞台上選取圖像物件、群組、實體或文字區塊。
  2. 按一下「自由變形」工具

    將指標移動到選取範圍上方和四周,指標會更改,指出可以用的變形功能。

  3. 若要變形選取範圍,請拖曳該更改的指標:
    • 若要移動選取範圍,請將指標放在範圍框內的物件上,然後將物件拖曳到新位置。請勿拖曳變形點。

    • 若要設定旋轉中心或縮放中心,請將變形點拖曳到新的位置。

    • 若要旋轉選取範圍,請將指標放在轉角控制點外面一點點,然後開始拖曳。選取範圍會開始繞著變形點旋轉。按住 Shift 鍵並拖曳,將旋轉角度增加 45 度。

    • 若要以斜對角為中心旋轉,請按住 Alt 鍵 (Windows) 或 Option 鍵 (Macintosh) 不放,然後開始拖曳。

    • 若要縮放選取範圍,請將轉角控制點沿著對角線進行拖曳,進行二維縮放。拖曳時按住 Shift 不放,以固定比例調整大小。

    • 若只要沿著水平或垂直方向縮放,請沿著水平或垂直方向拖曳轉角控制點或邊緣控制點。

    • 若要傾斜選取範圍,請將指標放在變形控制點之間的外框上,然後開始拖曳。

    • 若要扭曲形狀,請按住 Control (Windows) 或 Command (Macintosh) 不放,然後開始拖曳轉角控制點或邊緣控制點。

    • 若要將物件「銳利化」(也就是將選取的轉角和相鄰的轉角各從其原始位置移動相同的距離),請 Shift+Control+按一下 (Windows) 或 Shift+Command+按一下 (Macintosh) 以拖曳轉角控制點。

  4. 若要結束變形,請按一下選取項目以外的地方。

扭曲物件

將「扭曲」變形套用至您選取的物件上時,若是拖曳範圍框上的轉角控制點或邊緣控制點,會移動轉角或邊緣,並重新對齊相鄰的邊緣。若要將扭曲限制為銳利化,請將該轉角與相鄰的轉角朝著相反方向移動相同的距離,即可按住 Shift 鍵並拖曳轉折點。相鄰的轉角指的是位於與拖曳方向相同軸上的轉角。按住 Control (Windows) 或 Command (Macintosh),即可拖曳邊緣上的中間點,自由移動整個邊緣。

您可以使用「扭曲」命令,扭曲圖像物件。您也可以在對物件進行自由變形時扭曲它。

註解:

「扭曲」命令不能修改元件、基本形狀、點陣圖、視訊物件、聲音、漸層、物件群組或文字。如果「多重選取範圍」包括任何上述的項目,只有形狀物件會被扭曲。若要修改文字,請先將字元轉換成形狀物件。

  1. 在舞台上選取一個或多個圖像物件。
  2. 選取「修改 > 變形 > 扭曲」。

  3. 將指標放在其中一個變形控制點上,然後開始拖曳。
  4. 若要結束變形,請在選取的物件外面按一下滑鼠按鍵。

使用封套修改選項修改形狀

「封套」修改選項可以讓您彎曲和扭曲物件。封套指的是包含一個或數個物件的範圍框。對封套之形狀所做的更改,會影響封套中的物件形狀。您可以調整封套的點和正切控制點,編輯封套的形狀。

註解:

「封套」修改選項不能對元件、點陣圖、視訊物件、聲音、漸層、物件群組或文字進行修改。如果「多重選取範圍」包括任何上述的項目,只有形狀物件會被扭曲。若要修改文字,請先將字元轉換成形狀物件。

  1. 在舞台上選取一個形狀。
  2. 選取「修改 > 變形 > 封套」。

  3. 對點和正切控制點進行拖曳,修改封套。

縮放物件

縮放物件時可沿水平、垂直方向 (或兩者同時) 放大或縮小物件。

  1. 在舞台上選取一個或多個圖像物件。

  2. 選取「修改 > 變形 > 縮放」。

  3. 請執行下列其中一項:
    • 若要同時沿著水平和垂直方向縮放物件,請拖曳其中一個轉角控制點。縮放時會維持固定比例。拖曳時按住 Shift 鍵不放,不按比例縮放。

    • 若要沿著水平或垂直方向縮放物件,請拖曳中心控制點。

  4. 若要結束變形,請在選取的物件外面按一下滑鼠按鍵。

    註解:

    當您同時增加數個項目的大小時,靠近範圍框邊緣的項目可能會移動到「舞台」以外。如果發生這個問題,請選取「檢視 > 貼上板」,查看在「舞台」邊緣以外的元素。

旋轉和傾斜物件

旋轉物件會讓物件繞著變形點轉動。變形點會和預設為物件中心的對齊點對齊,但是您可以透過拖曳方式移動它。

您可以透過下列方法來旋轉物件:

  • 使用「自由變形」工具進行拖曳 (您可以在相同的操作中傾斜和縮放物件)。

  • 在「變形」面板中指定角度 (您可以在相同的操作中縮放物件)。

透過拖曳方式旋轉和傾斜物件

  1. 在舞台上選取一個或數個物件。
  2. 選取「修改 > 變形 > 旋轉和傾斜」。

  3. 請執行下列其中一項:
    • 拖曳轉角控制點,旋轉物件。

    • 拖曳中心控制點,傾斜物件。

  4. 若要結束變形,請在選取的物件外面按一下滑鼠按鍵。

將物件旋轉 90 度

  1. 選取一個或數個物件。
  2. 選取「修改 > 變形 > 順時針旋轉 90 度」以便順時針旋轉;或選取「逆時針旋轉 90 度」以便逆時針旋轉。

傾斜物件

傾斜物件會讓物件沿著軸傾斜、變形。將物件傾斜的方法包括透過拖曳方式,或是在「變形」面板中輸入數值。

  1. 選取一個或數個物件。
  2. 選取「視窗 > 變形」。

  3. 按一下「傾斜」。
  4. 輸入水平值和垂直值的角度。

翻轉物件

您可以沿著物件的垂直軸或水平軸將物件翻轉過去,而不必移動物件在舞台上的相對位置。

  1. 選取物件。
  2. 選取「修改 > 變形 > 垂直翻轉」或「修改 > 變形 > 水平翻轉」。

還原變形物件

當您使用「自由變形」工具或「變形」面板,對實體、群組和文字進行縮放、旋轉與傾斜動作時,Animate 會儲存物件的原始大小和旋轉值。如此一來,移除套用的變形後即可還原成原始值。

當您選取「編輯 > 還原」時,只能還原最近一次執行的變形。在您取消選取物件之前,您可以按一下面板中的「移除變形」按鈕來移除所有變形。在您取消選取物件之後,原始值即會遺失,而您將無法移除變形。

將變形物件還原到原始狀態

  1. 確定變形物件仍為選取狀態。

  2. 執行下列其中一項:
    • 按一下「變形」面板中的「移除變形」按鈕

    • 選取「修改 > 變形 > 移除變形」

適用於向量和點陣內容的資源雕刻

Animate 19.0 版本已引進新的「資源彎曲」工具。您可以使用 Animate 中的資源彎曲工具,在形狀、繪圖物件和點陣圖上建立彎曲控制點。透過使用資源彎曲工具來拖曳彎曲控制點,即可將形狀、繪圖物件和點陣圖變形。 

資源彎曲工具
資源彎曲工具

透過使用物件上顯示的彎曲控制點,您可以調整特定物件區域的形狀或加以扭曲,同時讓其他區域維持不變。當您建立第一個彎曲控制點時,所有選取的物件都會群組在一起。在插入關鍵影格時,先前關鍵影格中的彎曲控制點會複製到新的關鍵影格。

當您使用資源彎曲工具將滑鼠停留在物件上時,會出現一些可供您參考的游標樣式。

- 當物件不支援資源彎曲工具時,就會出現這個游標。

- 這個游標表示您可以使用資源彎曲工具,在物件上建立彎曲控制點。

- 這個游標表示您可以按一下彎曲控制點,以便調整物件的形狀。

Cursor moveto

這個游標表示您可以旋轉物件。

使用資源彎曲工具

  1. 若要開始,請在舞台上建立形狀或匯入點陣圖影像。 

  2. 按一下工具列中的資源彎曲工具。

  3. 當您將滑鼠停留在形狀或繪圖物件上方時, 元件就會顯示。然後,您可以按一下以增加彎曲控制點。

    將滑鼠停留在形狀或繪圖物件上方
    將滑鼠停留在形狀或繪圖物件上方

  4. 資源彎曲工具會在形狀/繪圖物件上顯示為小實心圓。您可以視需要使用控制點,以便有效率地彎曲形狀。使用鍵盤中的刪除鍵可以刪除操控彎曲控制點。

    資源彎曲控制點
    資源彎曲控制點

  5. 「按住 Shift 鍵並按一下」操控彎曲控制點,以選取多個控制點。您可以使用資源彎曲工具拖曳控制點,隨意變形形狀。

    使用控制點將形狀變形
    使用控制點將形狀變形

    使用控制點將點陣圖變形

  6. 從兩個與彎曲控制點相關聯的模式中選擇一個。

        a.    開啟模式 – 變形期間,這個模式可在控制點周圍提供較大的自由度。這個模式中的控制點以白色實心圓表示。

        b.   固定模式 - 變形期間,這個模式在控制點周圍提供較小的自由度。這個模式中的控制點以黑色實心圓表示。

    若要在兩個模式之間切換,請在彎曲控制點上使用「按住 Alt 鍵並按一下」

關於資源彎曲的教學課程

了解如何在 Animate 中使用資源彎曲。

編輯基底形狀

基底形狀是套用任何彎曲前的形狀。資源彎曲適用於重疊在基底形狀上方的網格。此外,您也可以切換至選取工具,然後按兩下彎曲的形狀,藉此修改基底形狀。您對基底形狀進行的任何修改,都會套用到該形狀所有彎曲的實體上。這個功能僅適用於向量形狀。

資源彎曲形狀屬性
資源彎曲形狀屬性

適用於資源彎曲工具的補間動畫

您可以將傳統補間動畫與資源彎曲工具搭配使用。例如,您可以套用「傳統補間動畫」,以便為操控姿勢製作補間動畫。 

按一下這裡以深入了解傳統補間動畫。

註解:

若要為姿勢製作補間動畫,您應使用形狀中的同一組控制點。

組合物件

若要組合或變更現有物件來建立新的形狀,請使用「修改」選單內的「組合物件」命令 (「修改 > 組合物件」)。有時候,選定物件的堆疊順序會決定作業的運作方式。

每個命令適用於幾種特定類型的圖像物件,下面段落將會詳加敘述。合併形狀是利用設定為「合併繪圖」模式的工具所繪製的形狀。繪圖物件則是利用設定為「物件繪圖」模式的工具所繪製的形狀。

「組合物件」的命令如下:

聯集

結合兩個以上的合併形狀或繪圖物件。產生的結果是單一「物件繪圖」模式形狀,由這些形狀結合之前所有可見部分構成的。這些形狀的不可見或重疊部分則會被刪除。

 

註解:

這和您使用「群組」命令 (「修改 > 群組」) 的情況不同,您無法打散使用「聯集」命令結合的形狀。

交集

從兩個以上繪圖物件的交集建立一個物件。產生的結果是由所結合物件的重疊部分構成的「物件繪圖」形狀。形狀中任何未重疊的部分將會被刪除。產生的形狀將使用堆疊中最上層形狀的填色和筆畫。

打洞

移除選定繪圖物件的某些部分,如同其前面另一個選定繪圖物件與之重疊的部分所決定。繪圖物件中與最上層物件重疊的任何部分都將刪除,而最上層物件則會整個刪除。產生的物件仍然是單獨物件,不會結合成單一物件 (不像「聯集」或「交集」命令會將物件結合起來)。

裁切

使用某個繪圖物件的外框裁切另一個繪圖物件。裁切區域的形狀會定義前面或最上面的物件。下方繪圖物件中與最上層物件重疊的任何部分都將保留,下方物件的所有其他部分會被刪除,而最上層物件則會整個刪除。產生的物件仍然是單獨物件,不會結合成單一物件 (不像「聯集」或「交集」命令會將物件結合起來)。

Adobe 標誌

登入您的帳戶