計算工具可以為您計算影像中的物件數。若要手動計算物件,請選取「計算工具」並按一下影像,Photoshop 便會追蹤您的點選次數。計算編號除了會顯示在項目上,也會顯示在「計算工具」選項列上。儲存檔案時,也會將計算編號儲存起來。

Photoshop 也可以自動在影像內計算多個選取的區域,並將結果記錄在「度量記錄」面板中。請參閱執行度量

手動計算影像中的項目

  1. 選取「計算」工具 (位於「工具」面板中的「滴管」工具下方)。
  2. 選擇「計算」工具選項。

    計數群組

    當您將計算編號增加到影像時,會建立預設的計數群組。您可以建立多個計數群組,每個群組都有自己的名稱、標記及標籤尺寸和顏色。將計算編號增加到影像時,目前選取的計數群組會增量。按一下眼睛圖示來顯示或隱藏計數群組。按一下檔案夾圖示,可建立計數群組;按一下「刪除」圖示則可刪除計數群組。從「計數群組」選單中選擇「重新命名」,將計數群組重新命名。

    顏色

    若要設定計數群組的顏色,請按一下「檢色器」。

    標記尺寸

    輸入 1 到 10 之間的值,或使用小型滑桿來更改該值。

    標籤尺寸

    輸入 8 到 72 之間的值,或使用小型滑桿來更改該值。

  3. 在影像中按一下,增加計數標記和標籤:
    • 若要移動計數標記,請將指標移到標記或數字上方,直到游標更改為方向箭頭,然後再拖移。(按住 Shift 鍵再按一下,可強制以水平或垂直方向拖移。)

    • 按住 Alt 鍵 (Windows) 再按一下,或按住 Option 鍵 (Mac OS) 再按一下可以移除標記。計算總數會隨之更新。

    • 按一下選項列的「清除」,可以將目前選取之計數群組的計數重設為 0。

    註解:

    已經記錄於「度量記錄」中的計算,不會因為影像中的計算編號被清除而有所變更。

  4. (選擇性) 若要更改計數群組,請從「計數群組」選單中選取其他群組,或按一下檔案夾圖示以建立計數群組。再按一下就可更新目前選取的計數群組。
  5. (選擇性) 顯示或隱藏計算編號:
    • 選擇「檢視 > 顯示 > 計算」。

    • 選擇「檢視 > 輔助項目」、「檢視 > 顯示 > 全部」或「檢視 > 顯示 > 無」。

  6. (選擇性) 選擇「分析 > 記錄度量」,或按一下「度量記錄」面板中的「記錄度量」,將計算編號記錄到「度量記錄」中。

    註解:

    若要將計算記錄到「度量記錄」中,您必須已選取「計算」為度量資料點。請選擇「分析 > 選取資料點 > 自訂」,並在「計算工具」區域中選取「計算」資料點。

  7. (選擇性) 選擇「檔案 > 儲存」,將任何增加到影像的計算編號和計數群組儲存起來。

使用選取範圍自動計算

Photoshop 的自動計算功能,可以計算影像中多個選取範圍中的項目。請先以「魔術棒」工具或「顏色範圍」指令定義選取範圍區域。

  1. 選取「魔術棒」工具,或選擇「選取 > 顏色範圍」。
  2. 建立選取範圍,並囊括影像中您想計算的物件。為了取得最佳結果,影像中的物件最好能輕易地與背景分辨出來。
    • 如果使用的是「魔術棒」工具,請提高或降低「容許度」選項,將影像中要計算之物件的選取範圍最佳化。請取消選取「消除鋸齒」以及「連續的」選項。

    • 在「顏色範圍」中,設定「朦朧」和「選取的顏色」以對影像中選取的區域進行微調 (請參閱選取顏色範圍)。

  3. 選擇「分析 > 選取資料點 > 自訂」。
  4. 在「選取範圍」區域中,選取「計算」資料點並按一下「確定」。
  5. 選擇「視窗 > 度量記錄」。
  6. 選擇「分析 > 記錄度量」,或按一下「度量記錄」中的「記錄度量」。(如果無法使用此選項,請選取「計算」工具以外的其他工具)。

    Photoshop 會對選取範圍區域進行計算工作,並會在「度量記錄」中的「計算」資料欄中輸入編號。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策