Creating projects

Learn about project files, and how to create and manage projects in Premiere Pro.

A project file stores information about sequences and assets, such as settings for capture, transitions, and audio mixing. As you work, the project file records all your editing decisions, such as the In and Out points for trimmed clips and the parameters for each effect.  Edits are applied non-destructively, meaning that Premiere Pro does not alter the source files.

Premiere Pro creates a folder on your hard disk at the start of each project. By default, this is where it stores the files it captures, the preview and conformed audio files it creates, and the project file itself.

Premiere Pro does not store video, audio, or still image files in the project file—it stores only a reference to each of these files, a clip, which is based on the filename and location of the file at the time you imported it. If you later move, rename, or delete a source file, Premiere Pro can’t find it automatically the next time you open the project. In this case, Premiere Pro displays the Where Is The File dialog box.

By default, every project includes a single Project panel. This acts as a storage area for all clips used in the project. You can organize a project’s media and sequences using bins in the Project panel.

A project may contain multiple sequences, and the sequences within a project may differ from one another in their settings. Within a single project, you can edit individual segments as separate sequences, and then combine the segments into a finished program by nesting them into a longer sequence. Similarly, you can store multiple variations of a sequence, as separate sequences, in the same project.

Note:

There’s no need to save copies of a project when creating different segments or versions of the same video program. Simply create new or duplicate sequences within a single project file.

Create a project

Projects may contain more than one sequence, and the settings for one sequence may differ from that of another. Premiere Pro prompts you for settings for the first sequence every time you create a project. However, you can cancel this step to create a project containing no sequences.

  1. (Optional) If you plan to capture video from a device, connect the device to your computer using an IEEE 1394 or SDI connection. Then turn the device on, and do one of the following:

    • If the device is a camera, set it to the playback mode, which may be labeled VTR or VCR.

    • If the device is a deck, make sure that its output is set properly.

    Note:

    Don’t set a camera to any of the recording modes, which may be labeled Camera or Movie.

  2. Either choose New Project on the Start screen that appears when Premiere Pro starts up or, after the application is open, choose File > New > Project. (Windows: Ctrl+Alt+N, Mac: Opt+Cmd+N)

  3. Browse to a location where you want to save the project file, name the project, and click OK.
    Note:

    Whenever possible, specify a location and name that you won’t have to change later. By default, Premiere Pro stores rendered previews, conformed audio files, and captured audio and video in the folder where you store the project. Moving a project file later may require moving its associated files as well.

  4. Do one of the following:
    • Select a preset, or customize settings, for the first sequence of the project. For more information, see Create a sequence. Then, click OK.

    • To create a project without a sequence, click Cancel.

  5. (Optional) If you want to change where Premiere Pro stores various types of files, specify the scratch disk locations. See Specify scratch disks to improve system performance.
    Note:

    Premiere Pro supports high bit-depth (greater than 8 bits per channel) video necessary for editing standard and high definition footage.

Review project settings

All project settings apply to the whole project, and most can’t be changed after a project is created.

After you begin working in a project, you can review project settings, but you can change only a few of them. You can access these settings through the Project Settings dialog box.

  1. Choose Project > Project Settings > General, or Project > Project Settings > Scratch Disks.
  2. View or change settings as needed.
  3. Click OK.

Project Settings dialog box

  • Renderer: Specifies whether the software or hardware function of the Mercury Playback Engine is enabled or not. 

    On macOS, the available renderer engine preferences are:

    • Mercury Playback Engine GPU Acceleration (Metal) - Recommended 
    • Mercury Playback Engine GPU Acceleration (OpenCL) - Deprecated 
    • Mercury Playback Engine Software Only (available as an alternative for rendering and exporting in case of GPU issues)  

    On Windows, the available renderer engine preferences are:

    • Mercury Playback Engine GPU Acceleration CUDA (for NVIDA graphics)
    • Mercury Playback Engine GPU Acceleration OpenCL (for AMD and Intel graphics)
    • Mercury Playback Engine Software Only (available as an alternative for rendering and exporting in case of GPU issues)
  • Display Format (Video and Audio)For information about video and audio display formats, see their entries under General Settings in Sequence presets and settings.

  • Capture Format: For information about setting the capture format, see Set capture format, preferences, and tracks.

  • Title Safe Area: Specifies how much of the frame edge to mark as a safe zone for titles, so that titles aren’t cut off by television set overscan. A rectangle with cross hairs marks the title-safe zone when you click the Safe Margins button in the Source Monitor or Program Monitor. Titles are assumed to require a wider safe zone than action.

  •  Action Safe Area: Specifies how much of the frame edge to mark as a safe zone for action so that action isn’t cut off by television set overscan. A rectangle marks the action-safe zone when you click the Safe Margins button in the Source Monitor or Program Monitor.

For information about designating scratch disks, see Specify scratch disks to improve system performance.

Adobe logo

Sign in to your account