变换面板概述

使用“变换”面板查看或指定任一选定对象的几何信息,包括位置、大小、旋转和切变的值。“变换”面板菜单中的命令提供了更多选项以及旋转或对称对象的快捷方法。

注意:

“控制”面板中也提供有“变换”面板中的按钮和面板菜单命令。

“转换”面板
“转换”面板

A. 参考点定位器 B. 约束比例图标 C. 面板菜单 

显示变换面板

  1. 选择“窗口”>“对象和版面”>“变换”。

查看对象的几何信息

当选择对象时,其几何信息会出现在“变换”和“控制”面板中。如果选择多个对象,这些信息会将所有选定对象表示为一个计量单位。

  1. 选择一个或多个对象,并显示“变换”面板(“窗口”>“对象和版面”>“变换”)。

    位置信息与对象的标尺原点和参考点有关。角度信息与粘贴板有关,其中水平直线的角度为 0°。

更改变换设置

“变换”面板包括若干选项,用于确定变换对象的方式以及变换在“变换”和“控制”面板中的显示方式。

更改选定对象的参考点

所有变换都源自对象上或对象附近的某个固定点,称之为参考点。在变换工具(如缩放工具)处于活动状态时,将在参考点处显示图标

移动到中心的参考点(左)与放大的对象(右)
移动到中心的参考点(左)与放大的对象(右)

  1. 执行以下操作之一:
    • 要为选定对象指定其他参考点,请在“变换”或“控制”面板中单击参考点定位器 上九个点中的任意一个。


      当单击“变换”或“控制”面板上的不同参考点(左上和右上)时,选定对象的参考点会变化(左下和右下)。

       

    • 要将选定对象的参考点移动到特定位置,请选择旋转工具 、缩放工具  或切变工具 ,将工具置于参考点图标上,然后将其拖到新位置。或者,使用选定的上述工具之一,单击对象或页面上的任意位置。参考点将移动到该位置。

注意:

当选择变换工具时,远离对象单击不会取消选择该对象,而是会将其移动到参考点。请选择“编辑”>“全部取消选择”来取消选择对象。

参考点定位器上上次选择的参考点变成所有工具和对象的新默认参考点。如果将对象的参考点图标拖到自定位置(不在锚点上),则一旦取消选择当前对象,面板参考点将返回到默认位置。InDesign 会为新文档保留默认参考点位置,因此您不必重置参考点。

更改针对嵌套对象显示的相关信息

“变换”面板以跨页的粘贴板(其中水平直线的旋转角度为 0°)作为参考确定对象的方向。默认情况下,即使对象嵌套在已变换的容器对象内(也就是说,即使该对象是已变换组的一部分,或者被粘贴到已变换的框架内),情况也是如此。例如,如果您将一个没有旋转的图形粘贴到框架内,连同内部的图形一起将该框架旋转 10°,然后使用直接选择工具选择该图形,则“变换”面板将该图形的旋转角度显示为 10°。

显示对象相对于粘贴板的旋转角度
显示对象相对于粘贴板的旋转角度

如果愿意,您可以取消选择“整体变换”命令,以查看相对于嵌套对象容器的相同信息。在上面的例子中,如果您取消选择“整体变换”,则“变换”面板将图形的旋转角度(该图形相对于其旋转容器的角度)显示为零。

显示对象相对于容器对象的旋转角度
显示对象相对于容器对象的旋转角度

  1. 打开“变换”面板或“控制”面板。
  2. 在“变换”或“控制”面板菜单中,执行下列操作之一:
    • 保持“整体变换”已选中(默认值),以显示嵌套对象相对于粘贴板的变换值。

    • 取消选择“整体变换”,以显示嵌套对象相对于容器对象的旋转、缩放和切变的值。

测量选定对象的位置

“显示内容位移”命令决定了使用直接选择工具 选择的嵌套对象在“变换”面板中显示的 X 和 Y 值。“变换”和“控制”面板的参考点定位器中的选定参考点决定了选定对象上九个参考点中的哪一个将被当作文档的零点或容器框架的零点。容器框架的零点始终是其左上角。

从以下三个位置测量选定对象的位置:

  • 容器框架相对于文档零点的位置。打开或关闭“显示内容位移”,然后使用选择工具选择容器框架。

  • 嵌套对象相对于文档零点的位置。关闭“显示内容位移”,并使用直接选择工具选择嵌套对象。

  • 嵌套对象相对于其容器框架的零点(左上角)的位置。打开“显示内容位移”,并使用直接选择工具选择嵌套对象。

显示父级框架相对于文档零点的位置
显示父级框架相对于文档零点的位置

显示嵌套对象相对于文档零点的位置
显示嵌套对象相对于文档零点的位置

显示嵌套对象相对于容器框架的位置
显示嵌套对象相对于容器框架的位置

如果选择了“显示内容位移”,则嵌入对象的 X 和 Y 值将显示为相对于容器对象的值,且“变换”面板中的 X/Y 图标将变为 X+/Y+。如果取消选择此命令,嵌套对象的值显示为相对于标尺的值。

  1. 在“变换”或“控制”面板菜单中,选择或取消选择“显示内容位移”。

在测量中包括或排除描边粗细

描边粗细可以影响对象的大小和位置。您可以更改描边的对齐方式,然后选择“变换”面板是从描边的中心还是边缘开始测量对象的大小和位置。有关更改描边对齐方式的信息,请参阅描边面板选项

注意:

该选项没有更改缩放框架时描边粗细受影响的方式,只说明了更改是否会影响测量。

  1. 在“变换”或“控制”面板菜单中,执行下列操作之一:
    • 当您希望在面板测量中表示对象描边的外边缘时,请选择“尺寸包含描边粗细”。例如,如果一个框架比另一个框架短两个点,但是较短框架的描边要粗两个点,则此设置将导致这两个框架在“变换”和“控制”面板中显示相同的高度值。

    • 当您希望面板测量能够表示对象的路径或框架(不考虑其描边粗细)时,请取消选择“尺寸包含描边粗细”。例如,两个相同高度的框架将在“变换”和“控制”面板中显示相同的高度值,无论其描边粗细是否相同。

变换对象

您可以使用工具和命令修改对象的大小或形状,以及更改对象在粘贴板上的页面方向。工具箱包含四个变换工具:“旋转”、“缩放”、“切变”和“自由变换”工具。此外,您还可以使用“选择工具”变换对象。所有变换以及对称功能都在“变换”和“控制”面板中提供,这样您就可以准确地指定变换。

变换工具(上)与变换面板(下)的比较
变换工具(上)与变换面板(下)的比较

A. 旋转选项 B. 切变选项 C. 缩放选项 

当变换对象时,请注意下列事项:

  • 变换的结果可能会有明显的不同,具体情况取决于所选的对象。例如,旋转图像时,旋转的对象取决于您是选择的图像,还是框架,亦或是框架和图像。使用“选择工具” 可变换(旋转、缩放或切变)整个路径及其内容(单击内容手形抓取工具以外的位置);使用“直接选择工具” 可以只变换路径而不影响其内容,或者只变换内容而不影响其路径。要变换内容但不影响其路径,请确保选中所有锚点。

注意:

要同时调整框架以及内容的大小,请使用“X 缩放百分比”和“Y 缩放百分比”字段,而不是 W 和 H 字段。W 和 H 字段仅更改所选框架或所选内容,而不会同时更改两者。请记住,您在缩放字段中不一定要指定百分比值。可以键入包含度量单位的尺寸,例如“6p”。

  • 变换将所有选定对象作为单个单元进行操作。例如,如果您选择多个对象并将其旋转 30°,则所有这些对象都围绕一个参考点旋转。如果您想要将每个选中的对象围绕其自身的参考点旋转 30°,则必须单独选择并旋转每个对象。

  • 在变换文字时,可以使用以下两种选择方法之一:使用选择或直接选择工具选择整个文本框架或转换为轮廓的文本,然后使用变换工具;或者,使用文字工具选择文本或者在文本框架中单击以置入一个插入点,然后在“变换”面板、“控制”面板或双击工具时出现的对话框中指定变换。在这两种情况下,变换都会影响整个文本框架。

  • 当旋转、倾斜或缩放某个组时,这些设置将应用于整个组以及组中的各个对象。例如,如果将组旋转 30°,则无论您选择组本身还是直接选择组中的某个对象,“变换”或“控制”面板中的旋转值都为 30°。

使用变换面板变换对象

使用选择工具来确定内容和框架是一起变换,还是单独变换。

  1. 选择要变换的对象。
    • 要变换框架及其内容,请使用选择工具选择框架。

    • 要变换内容而不变换其框架,请使用直接选择工具 直接选取该对象,或使用选择工具单击图像的内容手形抓取工具。

    • 要变换框架但不变换内容,请直接选择框架,然后选择所有锚点。

  2. 在“变换”面板或“控制”面板中,指定变换的参考点。

    面板中的所有值都指对象的外框。X 和 Y 值指外框上相对于标尺原点的选定参考点。

  3. 执行以下操作之一:
    • 在文本框中输入新值。
    • 选择可用弹出菜单上的值。
    • 选择面板菜单中的命令

    注意:

    要在使用“X 缩放百分比”和“Y 缩放百分比”选项时保持对象的比例,请单击面板中的约束比例图标 。如果未选中该选项,图标两边则会出现圆点(像断开的链节)。您也可以指定一个度量单位,以此指定具体尺寸而非百分比,例如指定 6p。

  4. 按 Tab 键和 Enter 键 (Windows) 或 Return 键 (Mac OS) 来应用更改。

使用“选择工具”变换对象

使用“选择工具”可以移动对象、调整对象的大小和旋转对象。

  1. 使用“选择工具”,选择一个对象。要变换框架内的图像,请单击将指针悬停在图像上方时出现的内容手形抓取工具。
  2. 执行以下操作之一:
    • 要移动对象,请在外框中的任意位置单击,然后拖动。

    • 要缩放对象,请按下 Ctrl (Windows) 或 Command (Mac OS),然后单击外框手柄直至该对象变为所需的大小。同时按下 Shift 键可以保持所选对象的比例。同时按下 Alt (Windows) 或 Option (Mac OS) 键可以从里向外缩放对象。

    • 要旋转对象,请将指针放置在外框手柄外的任意位置。当指针变为 时开始拖动,直到将选区旋转到所需的角度。

    • 要对称对象,请将外框的手柄拖过对边或手柄,直到对象对称到所需的级别。

使用自由变换工具变换对象

“自由变换”工具与它在 Adobe Photoshop 和 Adobe Illustrator 中的工作方式相同,提供了只使用一个工具即可执行任意变换的方法。在自由变换工具处于活动状态时,您可以结合使用多种变换,例如旋转和缩放。

注意:

您可以使用键盘快捷键在自由变换工具(按 E)、选择工具 (V) 和直接选择工具 (A) 之间快速切换。

  1. 使用适当的选择工具,选择要变换的一个或多个对象。
  2. 选择自由变换工具
    • 要移动对象,请在外框中的任意位置单击,然后拖动。

    • 要缩放对象,请拖动外框的任一手柄,直到对象变为所需的大小。按住 Shift 键并拖动手柄以保持选区的比例。

    • 要从外框的中心缩放对象,请按住 Alt 键并进行拖动 (Windows) 或按住 Option 键拖动 (Mac OS)。

    • 要旋转对象,请将指针放置在外框外面的任意位置。当指针变为 时开始拖动,直到将选区旋转到所需的角度。

    • 要对称对象,请将外框的手柄拖过对边或手柄,直到对象对称到所需的级别。

    • 要切变对象,请开始拖动一个手柄,然后按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。按住 Alt+Ctrl 键 (Windows) 或 Command+Option 键从对象的两侧进行切变。

旋转对象

您可以使用若干方法之一来旋转对象。

使用旋转工具旋转对象

  1. 选择要旋转的对象。要旋转框架及其内容,请使用选择工具选择框架。要旋转内容而不旋转其框架,请单击“内容手形抓取工具”或使用“直接选择工具”选中该对象。要旋转框架但不旋转内容,请直接选择框架,然后选择所有锚点。
  2. 选择旋转工具
  3. 如果要使用其他参考点进行旋转,请单击希望参考点出现的位置。
  4. 将该工具放置在远离参考点的位置,并围绕参考点拖动。要将该工具约束在 45° 倍数的方向上,请在拖动时按住 Shift 键。若要获得更精确的控制,请在距离对象参考点较远的位置拖动鼠标。

您还可以使用自由变换工具来旋转。

如果打开了智能参考线(和智能尺寸)功能,将有可见的线索告诉您对象的旋转角度是否与附近的旋转对象相同。例如,如果将页面上的一个项目旋转 24 度,那么在将另一个项目旋转到接近 24 度时,会显示一个旋转图标。

使用“选择工具”旋转对象

  1. 使用“选择工具”,将指针放置在选择手柄以外的任意位置。当指针变为 时开始拖动,直到将选区旋转到所需的角度。

使用变换或控制面板旋转对象

  1. 选择要旋转的对象。要旋转框架及其内容,请使用“选择工具” 选中该框架。要旋转内容而不旋转其框架,请单击“内容手形抓取工具”或使用“直接选择工具”选中该对象。要旋转框架但不旋转内容,请直接选择框架,然后选择所有锚点。
  2. 执行以下操作之一:
    • 要以 90° 为增量顺时针或逆时针旋转,请单击“控制”面板中的任一“旋转”按钮。

    • 要按照预设角度旋转,请在“变换”或“控制”面板的“旋转角度” 弹出菜单中选择一个角度。

    • 在“变换”或“控制”面板上的“旋转角度” 框中,键入一个正角度以按逆时针方向旋转选定对象,或者键入一个负角度以按顺时针方向旋转选定对象,然后按 Enter 键 (Windows) 或 Return 键 (Mac OS)。

    • 要创建对象副本并对副本应用新旋转,请在“变换”面板的“旋转角度”框中键入一个值,然后按住 Alt (Windows) 或 Option (Mac OS),同时按 Enter。

当旋转单个对象时,指定值仍然显示在“变换”或“控制”面板中。当旋转多个对象时,“旋转角度”重置为 0 度,即使对象已旋转也是如此。

使用旋转命令旋转对象

您可以使用“旋转”命令将对象旋转一个特定量。使用此命令还可以旋转选定对象的副本,而将原稿保留在原位。

  1. 选择要旋转的对象。要旋转框架及其内容,请使用选择工具选择框架。要旋转内容但不旋转其框架,请直接选择对象。要旋转框架但不旋转内容,请直接选择框架,然后选择所有锚点。
  2. 要打开“旋转”对话框,执行以下操作之一:
    • 选择“对象”>“变换”>“旋转”。

    • 双击旋转工具 

    • 选择旋转工具并在对象上或对象附近按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS),以选择新的参考点。

  3. 在“角度”框中,输入旋转角度(以度为单位)。输入一个负角度,对象将顺时针旋转;输入一个正角度,对象将逆时针旋转。
  4. 执行以下操作之一:
    • 要在应用前预览效果,请选择“预览”。

    • 要旋转对象,请单击“确定”。

    • 要旋转对象的副本,请单击“复制”。

移动对象

您可以通过以下方法移动对象:从一个位置剪切对象然后将其粘贴到另一个位置;输入新的水平和垂直坐标;或者拖动对象。通过拖动,您还可以移动对象的副本或者在软件应用程序之间复制对象。

智能参考线功能可方便您将对象移动到版面中的精确位置。在拖动对象时,会显示临时参考线,指明正在移动的对象与页面边缘或中心对齐,或是与其他页面项目对齐。

移动对象

为获得最佳效果,请使用选择工具移动多个对象。如果使用直接选择工具选择多个对象或路径,则拖动只会移动选定图形、路径或锚点。

  1. 选择要移动的对象。要移动框架及其中的内容,请使用“选择工具” 选中该框架。要移动框架中的内容而不移动框架,请直接选中该对象,或当鼠标悬停在图像上方时,单击内容手形抓取工具。要移动框架但不移动内容,请直接选择框架,然后选择所有锚点。
  2. 执行以下操作之一:
    • 要将对象(或其副本)粘贴到新位置,请选择“编辑”>“剪切”或“编辑”>“复制”。定位到目标跨页,然后选择“编辑”>“粘贴”。对象将出现在目标跨页的中央。
    • 要将副本粘贴到与原稿相同的位置,请选择“编辑”>“复制”。然后,选择“编辑”>“原位粘贴”。(要使副本偏离原稿,请使用箭头键轻移该副本。)

    注意:

    如果您希望对象出现在多个页面上的同一位置,则可以考虑创建一个主页,并将该对象粘贴到该主页上。

    • 要将对象移动到特定的数值位置,请在“变换”或“控制”面板中键入每个 X(水平方向)或 Y(垂直方向)位置选项的值。然后按 Enter 键 (Windows) 或 Return 键 (Mac OS)。

    • 要在一个方向上稍微移动对象,请轻按或按住某个箭头键;要按 10 倍的速度轻移对象,请在轻按箭头键的同时按住 Shift 键。

    • 要通过拖动来移动对象,将该对象拖到新位置即可。按住 Shift 键并进行拖动以约束对象在水平、垂直或对角线(45° 的倍数)方向上的移动。

    注意:

    拖动内容手形抓取工具可以在框架内移动图像。

按照精确数量移动对象

您可以使用“移动”命令,按指定数量移动对象。此命令还允许移动选定对象的副本,而将原稿保留在原位。

  1. 选择要移动的对象。要移动框架及其内容,请使用选择工具选择框架。要移动内容但不移动其框架,请直接选择对象。要移动框架但不移动内容,请直接选择框架,然后选择所有锚点。
  2. 选择“对象”>“变换”>“移动”,或者双击工具箱中的选择或直接选择工具的图标。
  3. 在“移动”对话框中,执行以下操作之一:
    • 输入希望对象移动的水平和垂直距离。输入正值,会将对象移到 x 轴的右下方;输入负值,会将对象移到左上方。

    • 要将对象移动一个精确的距离和角度,请输入要移动的距离和角度。从 x 轴开始计算您输入的角度(以度为单位)。正角度指定逆时针移动;负角度指定顺时针移动。您还可以输入 180° 到 360° 之间的值;这些值将转换为相应的负值(例如,270° 将转换为 -90°)。

  4. 执行以下操作之一:
    • 要在应用前预览效果,请选择“预览”。

    • 要移动对象,请单击“确定”。

    • 要移动对象的副本,请单击“复制”。

将对象移动到精确位置

  1. 选择要移动的对象。
  2. 如果要使用其他参考点进行移动,请单击希望参考点出现的位置。

    例如,如果要将对象移动到页面的左上角,请选择左上角参考点。

  3. 在“变换”面板上的 X 和 Y 字段中,输入希望选定对象移动到的位置坐标。

指定轻移对象时所移动的距离

  1. 选择“编辑”>“首选项”>“单位和增量”(Windows) 或“InDesign”>“首选项”>“单位和增量”(Mac OS)。
  2. 对于“光标键”,指定您希望每次轻按箭头键时选定对象所移动的距离,然后单击“确定”。

注意:

如果在移动选定对象时按住 Shift 键,选定对象移动的距离将是您在此处指定距离的 10 倍。

缩放对象与调整对象大小

在 InDesign 中,调整大小和缩放是不同的操作。调整大小只是改变对象的宽度和高度值。缩放则牵涉到使用与框架原比例 (100%) 相关的百分比值。

调整大小和缩放之间的差异不一定明显。了解这种差异的一个好方法是对应用了描边的文本框架执行调整大小和缩放操作。当使文本框架的大小加倍时,文本大小和描边粗细保持不变。当使文本框架的缩放比例加倍时,文本大小和描边粗细也将加倍。

调整框架的大小

默认情况下,如果选中框架(而不是框架内容),则无论选择工具是否处于活动状态,更改“宽度”和“高度”字段的值都只会改变框架,不会改变其内容。

缩放框架及其内容

如果用选择工具选中了框架,更改“X 缩放百分比”和“Y 缩放百分比”字段的值将会改变框架及其内容。如果已选中“自动调整”,则框架及其内容的大小都会一起调整。

调整框架内容的大小或对其进行缩放

如果只希望更改框架的内容(调整大小或进行缩放),请单击“内容手形抓取工具”或使用“直接选择工具”选中这些内容。选中以后,可根据您的喜好使用“宽度”及“高度”字段,或者缩放字段。

覆盖默认设置

如果要按百分比缩放框架或其内容,并以当前度量系统的形式返回结果,可以输入带百分号的数字来覆盖默认度量系统。例如,如果当前宽度是 12p,而您希望新宽度是当前值的 75%,可以在“宽度”字段中输入 75%。按 Enter 键后,宽度的新值会显示为 9p。

同样地,如果您要按特定增量缩放并使结果按原始值的百分比形式显示,也可以使用其他度量系统值。例如,可以用 9p 取代 100%,而 InDesign 会算出达到该宽度/高度所需的百分比。

调整对象大小

默认情况下,拖动包含内容(如导入的图形)的框架的手柄不会调整内容的大小。内容和容器框架是独立的项目,分别有各自的外框,了解这一点很重要。只需拖动导入图形的框架,即可裁剪图形或在图形外部留出空白区,具体取决于拖动方向。独立于内容修改框架提高了灵活性,但需要一些时间来习惯这种方法。

智能参考线功能可方便您参照版面中的其他项目来调整对象的大小。在调整对象大小时,会出现临时的参考线,表明对象与页面边缘或中心对齐,或者与另一个页面项目等高或等宽。

调整导入图形的大小
调整导入图形的大小

A. 使用选择工具选择的框架 B. 调整大小的框架 C. 缩放后的框架和内容 
  • 要调整框架的大小,请使用选择工具拖动任一手柄。如果在拖动时按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),将缩放框架和内容。同时按住 Shift 键将按比例缩放。

注意:

如果已选中“自动调整”,则调整框架的大小时也会调整框架内图像的大小。

  • 要调整图形框架的内容,请使用“选择工具”单击内容手形抓取工具或直接选中该图形,然后拖动任意的图形框架手柄。
  • 要将框架或其内容调整为某个精确的大小,请先选中该对象,然后在“控制”面板上的宽度 (W) 或高度 (H) 字段中输入该大小。

注意:

要在使用“控制”面板时保持对象的原始比例,请确保选中了“约束比例”图标

  • 要同时调整框架以及内容的大小,请使用“X 缩放百分比”和“Y 缩放百分比”字段,而不是 W 和 H 字段。W 和 H 字段仅更改所选框架或所选内容,而不会同时更改两者。除了指定百分比,您也可以键入包含度量单位的尺寸,例如“6p”。
  • 要将框架或其内容的大小调整为当前大小的某百分比,请选择对象并在“变换”面板的宽度或高度字段中输入百分比。
  • 要创建选定对象的副本并将新大小应用于该副本,请在“变换”面板的宽度或高度字段中键入一个值,然后在按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 的同时按 Enter 键。

注意:

调整框架或对象的大小后,您可以使用适合的选项(“对象”>“适合”)使内容适合框架或使框架适合内容。

缩放对象

缩放对象是指相对于指定参考点,在水平方向(沿 x 轴)、垂直方向(沿 y 轴)或者同时在水平和垂直方向上放大或缩小对象。

默认情况下,InDesign 会缩放描边。例如,如果您将描边为 4 点的选定对象缩放 200%,则“描边”面板指示一个 8 点描边,描边的大小明显加倍。您可以通过取消选择“变换”或“控制”面板菜单中的“缩放时调整描边粗细”,更改默认的描边行为。

使用选择工具缩放对象

  1. 要同时缩放内容和框架,请使用“选择工具”选中该对象并按下 Ctrl (Windows) 或 Command (Mac OS) 键。同时按 Shift 键可按比例调整对象大小。

使用缩放工具缩放对象

  1. 选择要缩放的对象。要缩放框架及其内容,请使用选择工具选择框架。要缩放内容而不缩放其框架,请单击“内容手形抓取工具”直接选中该对象。要缩放框架但不缩放内容,请直接选择框架,然后选择所有锚点。
  2. 选择缩放工具
  3. 将缩放工具放置在远离参考点的位置并拖动。要只缩放 x 或 y 轴,请只沿着一个轴开始拖动缩放工具。要按比例进行缩放,请在拖动缩放工具的同时按住 Shift 键。要获得更精确的控制,请在距离对象参考点较远的位置开始拖动鼠标。

    注意:

    您还可以使用自由变换工具来缩放。

使用变换面板缩放对象

要在使用“变换”面板时保持对象的原始比例,请确保选中了“约束比例”图标

  1. 选择要缩放的对象。要缩放框架及其内容,请使用选择工具选择框架。要缩放内容但不缩放其框架,请直接选择对象。要缩放框架但不缩放内容,请直接选择框架,然后选择所有锚点。
  2. 在“变换”或“控制”面板中,执行下列操作之一:
    • 在“X 缩放百分比” 或“Y 缩放百分比” 弹出菜单中选择一个预设百分比值。

    • 在“X 缩放百分比”或“Y 缩放百分比”框中键入百分比值(例如 120%)或特定距离(例如 10p),然后按 Enter 或 Return 键。

使用箭头键缩放对象

  1. 选择或直接选择对象或框架。
  2. 在“变换”面板中,单击“X 缩放百分比” 或“Y 缩放百分比” 框。
  3. 按向上箭头键或向下箭头键,可按 1% 的增量缩放对象。如果在按箭头键的同时按住 Shift 键,则可按 10% 的增量缩放对象。

如果在“常规”首选项中选中了“调整缩放百分比”,则使用此方法放大一定百分比,然后再缩小相同的百分比时,对象会恢复到原始缩放值。例如,如果将 20-mm 的圆放大 10% 又缩小 10%,该圆会恢复到 20 毫米(而不是 19.8 mm)。

使用缩放命令缩放对象

  1. 选择要缩放的对象。要缩放框架及其内容,请使用选择工具选择框架。要缩放内容但不缩放其框架,请直接选择对象。要缩放框架但不缩放内容,请直接选择框架,然后选择所有锚点。
  2. 要打开“缩放”对话框,执行以下操作之一:
    • 选择“对象”>“变换”>“缩放”。

    • 双击缩放工具 .

    • 选择缩放工具并在对象上或对象附近按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS),以选择新的参考点。

  3. 在“缩放 X”或“缩放 Y”框中键入一个百分比值。

    注意:

    要在使用“变换”面板时保持对象的原始比例,请确保选中了“约束比例”图标

  4. 执行以下操作之一:
    • 要在应用前预览效果,请选择“预览”。

    • 要缩放对象,请单击“确定”。

    • 要缩放对象的副本,请单击“复制”。

确定如何跟踪缩放

您可以确定如何在界面中跟踪缩放。如果在“常规”首选项中选择“应用于内容”首选项,则在缩放对象后,“变换”面板中的缩放值重置为 100%。如果选中“调整缩放百分比”,则缩放值保留为指定值(如 125%)。

选择多个对象时,缩放值将始终显示为 100%。但是,如果选中“调整缩放百分比”,则可以单独地选择每个对象以查看变换(如 125%)的应用效果。

  1. 选择“编辑”>“首选项”>“常规”(Windows) 或“InDesign”>“首选项”>“常规”(Mac OS)。
  2. 在“缩放时”下面,选择“应用于内容”或“调整缩放百分比”,然后单击“确定”。

注意:

如果选择了“调整缩放百分比”,在您缩放对象时,可以从“变换”或“控制”面板菜单选择“将缩放比例重新定义为 100%”来将缩放百分比重置为 100%。

缩放对象时调整描边粗细

  1. 在“变换”或“控制”面板菜单中,选中“缩放时调整描边粗细”选项。

例如,如果在启用此选项时将 4 点描边缩放为 200%,则描边粗细变为 8 点。如果关闭此选项,则对象的大小加倍,但是其描边粗细保持为 4 点。

如果启用此选项并且不按比例缩放对象,则 InDesign 对所有边应用最小描边粗细。例如,假定仅在 X 方向将描边为 4 点的选定对象缩放 200%。InDesign 将对所有边应用较小值(4 点),而不是在 X 方向应用 8 点描边、在 Y 方向应用 4 点描边。

效果的可缩放性

如果创建一个对象并应用一种效果,该效果按照对象缩放比例一致地进行缩放。将按照缩放对象时使用的相同比例缩放该效果。

在“首选项”中,选择“常规”>“应用于内容”>“包含效果”。如果希望仅缩放对象而不缩放效果,请取消选择该选项。

首选项 - 包含效果
首选项 - 包含效果

或者

“窗口”>“对象和版面”>“变换”。从弹出菜单中,选择“缩放时调整效果”以启用或禁用效果可缩放性。

调整缩放比例
调整缩放比例

它的工作方式与描边效果类似。因此,可以像缩放描边一样缩放效果。

将缩放值重置为 100%

在某些情况下,您可能希望将对象的“缩放 X”和“缩放 Y”值重置为 100%,而不调整对象的大小。例如,您可能从以前版本的 InDesign 中打开一个文档,缩放值不是 100%,或者可能在选中“调整缩放百分比”首选项设置的情况下缩放了对象。选择此命令时,所有选定框架的缩放值均重置为 100%。选择此命令不会更改对象的大小或外观。

  1. 选择缩放值不是 100% 的一个或多个对象。

    如果直接选择导入图像或对象的缩放值为 100%,则此命令会变灰。

  2. 从“变换”或“控制”面板菜单中选择“将缩放比例重新定义为 100%”。

注意:

选择此命令可能会导致变换组中的对象发生意外行为。

对称(翻转)对象

对称对象是指在指定参考点处使对象翻转到不可见轴的另一侧。(请参阅更改变换设置。)

使用水平翻转(中)和垂直翻转(下)对称的原始对象(上)
使用水平翻转(中)和垂直翻转(下)对称的原始对象(上)

如果翻转对象,则“控制”面板中间的翻转/旋转指示符 (P) 将显示为白色,而轮廓为黑色。如果没有翻转对象,则指示符为纯黑色。

  1. 选择要翻转的对象。要翻转框架及其内容,请使用选择工具选择框架。要翻转内容但不翻转其框架,请直接选择对象。要翻转框架但不翻转其内容,请直接选择框架,然后选择所有锚点。
  2. 执行以下操作之一:
    • 要将参考点作为水平轴进行对称,请选择“控制”面板中的“水平翻转”按钮。

    • 要将参考点作为垂直轴进行对称,请选择“控制”面板中的“垂直翻转”按钮。

    注意:

    您还可以通过使用选择工具或自由变换工具将对象外框的一边拖过相对的一边,或者在“变换”或“控制”面板的“X 缩放百分比”或“Y 缩放百分比”选项中键入负值,来对称对象。

切变(倾斜)对象

切变对象会将对象沿着其水平轴或垂直轴倾斜,还可以旋转对象的两个轴。切变可用于:

  • 模拟某些类型的透视,例如等角投影。

  • 倾斜文本框架。

  • 切变对象副本时创建投影。

切变对象

  1. 选择要切变的对象。要切变框架及其内容,请使用选择工具选择框架。要切变内容而不切变其框架,请单击“内容手形抓取工具”直接选择该对象。要切变框架但不缩放内容,请直接选择框架,然后选择所有锚点。
  2. 执行以下操作之一:
    • 要通过拖动切变选定对象,请选择切变工具 。然后,将切变工具放置在远离参考点的位置并拖动。按住 Shift 键并进行拖动以将切变约束在正交的垂直轴或水平轴。如果在非垂直角度开始拖动,然后按住 Shift 键,则切变将约束在该角度。


      将参考点放置在中心通过拖动切变工具切变的对象

    注意:

    如果要使用其他参考点进行切变,请单击希望参考点出现的位置。

    • 要使用预设值进行切变,请在“变换”或“控制”面板中从“切变” 弹出菜单中选择一个角度。
    • 要使用特定值进行切变,请在“变换”或“控制”面板的“切变” 框中键入一个正角度或负角度,然后按 Enter 或 Return 键。
    • 要创建对象副本并对副本应用新倾斜,请在“变换”面板的“倾斜”框中键入一个值,然后按住 Alt (Windows) 或 Option (Mac OS),同时按 Enter。

切变单个对象时,指定的值仍然显示在“变换”或“控制”面板中。切变多个对象时,“切变角度”值重置为 0 度,即使已切变对象也是如此。

注意:

您还可以使用“自由变换”工具来切变。

使用切变命令切变对象

您可以使用“切变”命令按特定量切变对象。使用此命令还可以切变选定对象的副本,而将原稿保留在原位。

  1. 选择要切变的对象。要切变框架及其内容,请使用选择工具选择框架。要切变内容而不切变其框架,请单击“内容手形抓取工具”直接选择该对象。要切变框架但不缩放内容,请直接选择框架,然后选择所有锚点。
  2. 要打开“切变”对话框,执行以下操作之一:
    • 选择“对象”>“变换”>“切变”。

    • 双击切变工具 

    • 选择“切变”工具并按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS),以选择新的参考点。

  3. 键入新的切变角度。

    切变角度是将要应用于对象的倾斜量(相对于垂直于切变轴的直线)。(切变角度是按顺时针方向从当前轴计算出来的。)

  4. 指定要沿哪个轴切变对象。您可以沿水平轴或垂直轴切变对象。
  5. 执行以下操作之一:
    • 要在应用前预览效果,请选择“预览”。

    • 要切变对象,请单击“确定”。

    • 要切变对象的副本,请单击“复制”。

重复变换

您可以重复变换,例如移动、缩放、旋转、调整大小、对称、切变和适合。您可以重复单个变换或一序列变换,还可以一次将这些变换应用于多个对象。InDesign 会记住所有的变换,直到您选择不同的对象或执行不同的任务。

注意:

并非所有变换都被记录。例如,修改路径或其点不会记录为变换。

  1. 选择一个或多个对象,然后执行要重复的所有变换。
  2. 选择要应用相同变换的一个或多个对象。
  3. 选择“对象”>“再次变换”,然后选择下列选项之一:

    再次变换

    将最后一个变换操作应用于选择项。

    逐个再次变换

    将最后一个变换操作逐个应用于每个选定对象,而不是作为一个组应用。

    再次变换序列

    将最后一个变换操作序列应用于选择项。

    逐个再次变换序列

    将最后一个变换操作序列逐个应用于每个选定对象。

清除变换

  1. 选择已变换的一个或多个对象。
  2. 从“变换”或“控制”面板菜单中选择“清除变换”。

    除非所有值均为默认值,否则清除变换将导致更改对象的外观。

    注意:

    如果缩放值重置为 100%,则清除变换不会更改该比例。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略