Editing a puppet’s structure and appearance within Character Animator is done in the Puppet panel. Changes to the puppet in here affect all puppet instances added to scenes.

To edit a puppet, do one of the following:
  • Double-click the puppet in the Project panel.
  • Double-click the puppet’s layer in the left sidebar of the Puppet panel.
  • Double-click the puppet’s track item or the track header (left side) in the Timeline panel.

The puppet opens in the Puppet panel. The panel shows the layer structure on the left (sidebar), and the appearance of the layers and any associated handles on the right. Along the bottom of the panel are commands and tools for working with layers and handles. The Properties panel also has settings for the selected layer.

The Puppet panel has many of the same controls for panning and zooming panel content and changing the background color as in the Scene panel. In addition, it has tools for selecting objects (Selection tool), panning (Hand tool), and zooming (Zoom tool).

Puppet panel controls
Puppet panel controls

Puppet mesh outline

When you select a layer in the Puppet panel, a yellow outline appears for the mesh. The yellow outline represents the mesh identified by layers with a vertical yellow line in the layers list along with the Mesh Shape and Mesh Expansion settings. The outline helps you confirm that a mesh is the shape you want and is not an unexpected shape due to a non-overlapping layer.

Puppet mesh outline
Puppet mesh outline

To hide or show the mesh outline and auto-attached handles, toggle the Show Mesh Outline and Auto Handles button ( ) in the lower-left corner of the Puppet panel.

Puppet layer duplication

You can duplicate layers and groups in the Puppet panel. To duplicate, select Edit > Duplicate menu. You can modify the duplicate layer or group without affecting the original.

Select or deselect layers

  • Click a layer in the left sidebar. The selected content is highlighted in gray.
  • To extend the selection to a range of layers, Shift-click the layer.
  • To toggle a layer selection, Cmd/Ctrl click a layer in the left sidebar or Shift-click. 
  • To select all layers, press Cmd/Ctrl+A.
  • To deselect all layers, press Shift+Cmd/Ctrl+A or click away from any layer in the left sidebar.

Hide Others in Group layers for triggers in a swap set

When you have several overlapping keyboard-triggered layers set to Hide Other's in Group, focusing on one of the layers in the Puppet panel is easier. If you turn on the eyeball for a layer, and that layer is associated with a trigger in a swap set, the eyeballs for the layers associated with the other triggers in that same swap set is turned off.

Poznámka:

Soloing of Hide Other's in Group layers cannot be done if multiple Hide Other's in Group layers are selected and you select one of their eyeballs. All selected layers are either turned on or off, like when non-Hide Other's in Group layers are selected.

To turn on all selected layers even if a Hide Other's in Group eyeball is clicked, Option/Alt-click the eyeball switch.

Hide Other's in Group is available for all layers, not just the layers with a trigger key assigned. You can use the soloing capability for other mutually exclusive sibling layers that do not have trigger keys. These could be the sibling layers in a Mouth group or that are controlled via Head Turner.

Controls panel: custom layout for puppet triggers and behavior parameters 

Use the Controls panel to get a visual interface or dashboard where you can access triggers or supported behavior parameters for a puppet. Choose the triggers and behavior parameters (numerical and angular values) that you want easy access to, and control them from a single location. These custom controls are then associated with the puppet. These controls can also be shared with others as part of an exported puppet.

The Controls panel is open by default in the Record and Stream workspaces, but you can open it using the Window > Controls menu command. The panel shows the controls associated with the selected puppet in the Project or Timeline panel, or opened puppet in the Puppet panel.

There are two modes of the control panel:

  • Layout mode: here, you can customize the contents and appearance of the controls.
Layout mode
Layout mode
  • Perform mode: use the mode to use various controls by clicking the links at the top of the panel.
Perform mode
Perform mode

Layout mode

Triggers for a puppet can be visualized as clickable buttons with the artwork for each trigger on them. They also have any key or MIDI note associated with them. You can visualize the Behavior parameters for a puppet as an adjustable slider or angle controls, and any MIDI notes associated with them. The layout is stored with the puppet, including when exporting to a .puppet file, enabling you to share trigger layouts with other people.

Following are the available controls under the Layout mode.

Add controls to the panel: select the puppet, and choose one of the following: 

  • If the panel is empty, click the Generate Controls for “puppet-name” link in the panel to create button controls based on the puppet’s triggers.
  • If triggers were recently added in the Triggers panel or you previously deleted some trigger controls, click the Refresh Controls button.This adds buttons for the additional triggers or previously deleted trigger controls.
  • When a puppet track is selected in the Timeline panel, drag the name of any numeric behavior parameter from the Properties panel into the Controls panel. You can also right-click above these parameters' names and choose Add to Controls panel.

Select or deselect multiple controls: do any of the following: 

  • Shift-click or Cmd-/Ctrl-click the controls. 
  • Drag (marquee)-select around the controls. Hold down Shift or Cmd/Ctrl to toggle the selection of marquee-selected controls. 
  • Press Cmd/Ctrl+A to select all controls.
  • Press Shift+Cmd/Ctrl+A to deselect all controls.

Rearrange controls: do any of the following

  • Drag the selected controls in the panel. The dragged control can snap to a grid layout. 
  • Option-/Alt-click the Refresh Layout button to reflow the current controls based on the current size of the panel.

To create controls for specific triggers, do either of the following:

  • Select the triggers or swap sets in the Triggers panel, then drag them into the Controls panel.
  • Right-click above a trigger or swap set, then select Add to Controls Panel from the context menu.

To assign a different key or MIDI control: select the control and tap the key or touch the MIDI control (button, slider, or knob) that you want to use. The control is the same as changing the key or MIDI note in the Triggers panel. Controls that are associated with a MIDI control appear in a green overlay in Layout mode.

To easily arm or disarm parameters without finding the controls in the Properties panel, use the Arm for Record button using the slider and knob controls for behavior parameters.

Note: The control is available only when a puppet track is selected.

Unassign the key or MIDI note/controller for a control: do either of the following:

  • Right-click the control and choose Remove Trigger Key, Remove MIDI Note, or Remove MIDI Controller (available for behavior parameter controls). 
  • Delete the contents of the MIDI Note field in the Triggers panel. 

Change the artwork on a button for a trigger associated with multiple puppet layers: right-click the button control and then a layer name.

Change the background color for the control (for improved contrast with dark artwork), right-click the control, then choose either Light or Dark. 

Change the range of values for a slider or angle parameter control: click or scrub the blue minimum (left side) and maximum (right side) values on the control. For example, if you added a Transform > Scale parameter, but don’t have to negative scaling, set the minimum value to 0. 

Remove controls: select them, then choose Edit > Delete (Delete or Backspace) or click the Delete Selected Controls button at the bottom of the panel. 

 

Custom artwork for button control

You can use custom artwork for button controls by creating it anywhere in the artwork file for a puppet. For selecting different artwork for buttons that have multiple layers assigned to its triggers, right-click a button and select the layer name at the top of the context menu.

If it affects the appearance of the puppet in the scene, turn off its eyeball.

  • To assign custom artwork to a button, drag the layer from the Puppet panel and drop it onto the button control.

Switch from Layout to Perform mode

To switch back to Perform mode, double-click away from any control in the Layout mode.
You can also assign a shortcut to quickly switch between Layout and Perform modes. Use the Window category for the Toggle Controls Panel Layout Mode command in the Keyboard Shortcut editor to assign a shortcut.

Perform mode

Click Perform to switch to Perform mode when you want to use the controls. You can click the button or press the assigned key or touch the assigned MIDI control to perform actions. 

Panning content

The contents of the Controls panel can be panned to view controls outside the viewable area.
To pan in the Controls panel, do any of the following:

  • Use the vertical or horizontal scroll bars.
  • Hold down the Option/Alt key or middle mouse button as you drag in the panel.
  • To scroll horizontally, spin the mouse wheel to scroll vertically, or hold down the Shift key as you spin the mouse wheel.

Rename behavior parameter controls

In the Controls panel, behavior parameters have controls named after their parameters. These can be renamed. Follow these steps:

  1. Switch the Controls panel to Layout mode.

  2. You can select the behavior parameter control and then press Return (macOS) or Enter (Windows), or right-click above a behavior parameter control and then choose Rename.

  3. Type in the name you wish to give and press Return/Enter or click away from the edit field.

Triggers behavior and Trigger panel

The Triggers behavior is applied by default to new puppets. It allows you to trigger artwork and setup custom-named triggers that can reference layers in different groups. These named triggers are listed in the Triggers panel, where you can assign a key to a trigger, view the list of layers controlled by a trigger, and even associate a MIDI note to trigger artwork using a connected MIDI device. 

Poznámka:

The Triggers behavior is a replacement for the Keyboard Triggers behavior.

Trigger panel
Trigger panel

There are two types of triggers: 
• Individual triggers – These hide layers by default, but show them when a key is pressed or MIDI note/controller is run, such as pressing H to show a hat on a character. 
• Swap Sets – These show only one trigger at a time, such as for different hand gestures. The set of triggers is associated with a group of layers in a puppet. Each trigger in the set has its own trigger key or MIDI note, and one of the triggers can be a default.

Clicking the name of a layer associated with a trigger reveals that layer in the Puppet panel. If you want to show a layer or group in a puppet without affecting any other layers or groups, use an individual trigger. If you want that layer or group to also hide other layers or groups (for example, pressing B to show the Blink layer in a group that also has Pupil and Eyeball layers), use a swap set.

Note: The deprecated Keyboard Triggers behavior continues to work, but if you want to use the new Triggers panel and don’t have any older Keyboard Triggers recordings that you have to keep, replace it with Triggers.

Creating and editing triggers

The Triggers panel is open by default in the Rig workspace. You can also open or close it using the Window > Triggers menu command.

Create an individual trigger that shows a puppet layer

Do any one of the following:
• Click in the trigger column (  ) for a puppet layer that doesn’t already have a trigger assigned to it (no icon in that column), then choose Create Trigger.

• Right-click the layer in the Puppet panel, then choose Create Trigger.

• Drag the layer from the Puppet panel and drop it into the Triggers panel.

Drop the layer onto a swap set to add it to that swap set. Drop it elsewhere to create an individual trigger.

• Click the Add (+) button in the Triggers panel, then choose Create Trigger to an empty trigger. Then, drag or add puppet layers to it.

Triggers with problems (key conflicts, no layers, etc) are displayed in orange. Hover your mouse over the trigger to see details. The tooltip also describes the lack of layers.

Create a Swap Set of Triggers

Do any one of the following:
• Click in the trigger column (  ) for a puppet group that doesn’t already have a swap set of triggers assigned to its layers (no icons in that column), then choose Create Swap Set. 

• Right-click a group of layers in the Puppet panel, then choose Create Swap Set.

• Click the Add (+) button in the Triggers panel, choose Create Swap Set, then drag individual triggers or puppet layers (that you want as individual triggers) into it.

A new set of triggers, each named after the selected layers, is created in the Triggers panel. If any puppet layers in the group are visible, the topmost one becomes the default trigger in the swap set. You can rename the swap set and choose not to have a default trigger.

Create triggers and swap set
Create triggers and swap set

Set default triggers

To make a specific trigger in a swap set the default, do any of the following:
• Select the trigger, then choose the Default option at the bottom of the panel.
• Click the trigger icon next to the trigger’s name.
• Double-click the trigger’s name.
The default trigger is identified with a brighter and filled-in icon and brighter name. If you don’t want any layers triggered by default, repeat the step above to toggle the Default option.

Assign a layer or group to an existing trigger

To assign a layer or group to an existing trigger, do either of the following:
• Right-click the layer or group in the Puppet panel, choose Add to Trigger, and then choose the specific trigger from the context menu.
• Drag the layer or group onto the trigger in the Triggers panel.

Configure invoke trigger settings

To change how to invoke the trigger, select the trigger in the Triggers panel, then do any of the following:

  • Enter a key in the keyboard column.
  • Click in the MIDI Note field, then either tap the key on your MIDI device or enter its MIDI note number.
  • To make the trigger latch so that you don’t have to hold the keyboard or MIDI key to keep it triggered, enable the Latch option at the bottom of the panel.
  • Adding a layer or replay to an existing trigger now selects the target trigger in the Triggers panel.

Assigning keys and MIDI notes to triggers can also be done more directly in the Layout mode of the Controls panel. For more information, see Layout mode.

Rename, rearrange, or combine a trigger or swap set

To rename a trigger or swap set, select it in the Triggers panel > Enter (on the main keyboard, not numeric keypad) and type the new name. To accept the change, press Enter or click away from the text field. Press Esc instead to cancel your edits.

To rearrange triggers and moving them within, into, or out of swap sets, select one or more triggers, and drag them in the panel. Dragging a swap set onto another set combines their triggers into a single swap set. Rearranging triggers in a swap set is also useful when you want to set the priority of triggers based on listed order.

To combine triggered layers, drag one trigger onto another trigger. The dropped trigger’s layers get reassigned to the target trigger. The dropped trigger is then deleted.

To combine the triggers from one swap set into another swap set, drag the swap set onto or into another swap set. The dropped swap set’s triggers are added to the target swap set. The target swap set’s default trigger stays the default.

 

Poznámka:

If you make a puppet group shareable, any triggers assigned to the group’s layers moves to the shared puppet. Any controls for those triggers (shown in the Controls panel) are still associated with the parent puppet, and not the shared puppet. You can generate controls for the shared puppet’s triggers.

View or reveal triggers

To view or reveal the triggers associated with a layer in a puppet, do any of the following:

• Hover over the trigger icon in the layer’s row in the Puppet panel. The list of triggers (and any trigger keys) that shows the layer appear in a tooltip.
• Click the trigger icon in the layer’s row to reveal the trigger in the Triggers panel.
• If a layer is assigned to multiple triggers, click the trigger icon with arrow in the layer’s row, then select the specific trigger to reveal in the Triggers panel.

Tip: Clicking the eyeball on for a layer (in the Puppet panel) associated with a trigger in a swap set automatically turns off eyeballs for other triggered layers in the swap set. Use Option-/Alt-click to override automatic eyeball switching.

Configure behavior of triggers when multiple triggers are invoked

To change how triggers in a swap set behave when multiple triggers are invoked at the same time, select the swap set, then set Priority to either Most Recent to favor the recently used trigger, or Listed Order to favor the topmost listed trigger in the Triggers panel. The favored trigger’s layers shows.

Remove layers

To remove layers associated with a trigger, select the trigger in the Triggers panel, then click the ‘x’ next to the layers to remove at the bottom of the panel.

Note: Removing all layers associated with a trigger does not automatically delete the trigger.

Delete a trigger or swap set

To delete a trigger or swap set, select it, then choose Edit > Delete (Delete or Backspace).

Poznámka:

Behaviors like Head Turner, Lip Sync, Motion Trigger, and Face (for eye blinks) trigger layers separate from the Triggers behavior. If you want to use those four behaviors with Trigger-triggered layers in the same puppet group, set the Hide Others in Group option to the layers not being triggered by those four behaviors. Using that option, the layer order determines priority. Otherwise, change the structure in the artwork file.

Copy triggers between puppets

Poznámka:

You can copy triggers from one puppet and paste it to another puppet with swap sets and triggers matching the same names. Copy these swap sets and triggers from the original puppet before the takes are recorded for those triggers. Otherwise, the pasted triggers won’t work.

To set up trigger compatibility between puppets, follow these steps:

  1. Select the puppet to copy the triggers from. From the Triggers panel, select the swap sets and triggers to copy.

  2. To copy the triggers, choose Edit > Copy. To move swap sets or triggers between puppets, choose Edit > Cut.

  3. Select the puppet you want to copy these swap sets or triggers to.

  4. With the Triggers panel focused, choose Edit > Paste.

The pasted swap sets and triggers appear at the bottom of the triggers list. You can move them if you want. You can now copy any recording of triggers between these two puppets.

Converting old or obsolete Keyboard Triggers to Triggers

If you have created Keyboard triggers before the October 2017 version, you can convert Keyboard Triggers to Triggers in order to take advantage of the more flexible triggering capability and use of the Controls panel. Note that existing projects and .puppet files that use Keyboard Triggers behavior continues to work.

For Triggers based puppets, use the Triggers or Controls panel to view all assigned trigger keys for a puppet.

Poznámka:

The old keyboard column in the Puppet panel no longer exists. Edit the key for an obsolete trigger in the “Keyboard Triggers (obsolete)” section of the Properties panel. You can also change the Latch and Hide Others in Group settings. The Hide Others in Group setting can still work for trigger keys used by the Triggers behavior.

To convert a puppet from Keyboard Triggers to Triggers, follow these steps:

IMPORTANT: The following procedure removes existing Keyboard Triggers recordings.

  1. Select the puppet in the Project panel.

  2. Choose Puppet > Convert Obsolete Trigger Keys.

    The Triggers behavior replaces the Keyboard Triggers behavior. The existing trigger keys are converted to equivalent triggers in the Triggers panel.

  3. (Optional) Consolidate any unessential triggers in the Triggers panel by dragging one trigger on top of another.

    If you converted a .puppet file that was imported, export the puppet to a new .puppet file to retain these changes.

Fader: Fade a group on and off via trigger

You can use keyboard triggers to control the opacity of the puppet. You can use the behavior to show or hide a specific part of a puppet by fading the opacity of that part (a group) on or off by using a trigger (example; keyboard trigger).

Setup

Add the behavior to the specific group of a puppet that you want to fade in and out. The behavior isn’t applied by default to puppets. To get best results, avoid having Fader and Transform on the same group. You can also assign a trigger key for the group. Set the key to latch if you want to toggle fading in and out by tapping the key instead of holding it down. 

Poznámka:

When a group containing overlapping layers is set to Normal blending mode, and the puppet is using Group Opacity, the layers are faded separately until the final opacity level. Workaround: Set the group’s opacity to 99.9%.

Control

Use the Duration parameter to control how fast (in seconds) opacity increases or decreases.

Editing Trigger takes

Takes recorded by starting triggers appears in the Timeline panel as trigger bars. You can easily edit the way you edit viseme bars.

You can reduce the vertical space in the Timeline panel used for take bars for triggers and visemes for a more compact user interface.

Editable trigger takes
Editable trigger takes

Listed below are the different parameters.

  • Select a trigger bar: click the middle or the edges of the bar. To select multiple bars, Shift-click, Cmd/Ctrl-click, or drag a marquee across the bars. 
  • Change the timing of a trigger bar: drag the left edge horizontally to adjust its start time, or drag its right edge for its end time. The left edge snaps to the playhead, or start, or end times for take bars. 
  • Switch to a different trigger in a swap set: right-click above the trigger bar, then choose from the other triggers in the set. 

Tip: If the playhead is parked above a trigger bar, either disarm the puppet or its Triggers behavior to see changes to a trigger. You can also scrub the playhead in time to see the change.

  • Insert a trigger take: right-click above a gap before, after, or between trigger bars, then choose from the available triggers. The new trigger bar starts at the time where you clicked. 
  • Split a trigger bar in two: select the trigger bar and then either choose Edit > Split (Cmd/Ctrl+Shift+D), which splits at the playhead, or press forward slash (/), which splits it in half. 
  • Delete trigger bars: select the trigger bars and either choose Edit > Delete (Delete or Backspace) or right-click above one of them and choose Delete.
     

To hide take bars for triggers and visemes, deselect the Show Trigger and Viseme Take Bars menu command.

Replays: Reusable and triggerable recordings

Trigger the recorded takes for a puppet, either live or for rerecording, using replays. For example, these reusable takes can be created to repeat different performances during a live stream or a specific eye gaze or arm gesture while recording. Some uses of a cycle puppet can instead be done via replay of a recorded performance. 

A replay represents specifically selected takes, and is associated with a trigger that you can assign a key or MIDI note to invoke them. Replays are also included when you export a puppet, letting you share recorded performances that others can trigger. 

Replays in Character Animator CC

Create and edit replays

To create a replay and trigger, follow these steps:

  1. Select one or more take bars in the Timeline panel.

  2. Right-click a selected take, then choose a command that creates a replay and associates it with a trigger (a new trigger, a new trigger in an existing swap set, or an existing trigger).

The created replays for a puppet appear in the Replays section in the Properties panel, and show the duration of the replays. Created replays and their triggers are, by default, named after the behavior for those takes. If there are multiple takes for a behavior in a replay, the number of takes appears in parentheses after the behavior’s name.

Created replays
Created replays

The trigger for the replay appears in the Triggers panel, like triggers that show layers of a puppet. When a trigger is selected, the Layers and Replays section in the bottom section of the panel lists the associated puppet layers and replays. Clicking the name of a replay will reveal it in the Properties panel. 

A replay contains copies of the takes used to create it, so you can delete the original takes if needed. 

Replays that have problems are shown in orange. Hover over the orange icon or name to view more information in a tooltip.

Select or deselect replays

  • To select a single replay, click it.
  • To select a range of replays, click the first replay in the range, then Shift-click the last replay in the range.
  • To select or deselect individual replays, Command-click (macOS) or Ctrl-click (Windows) the replay.
  • To select all replays, press Command+A (macOS) or Ctrl+A (Windows).
  • To deselect all replays, press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows).

Rename, reorder, delete, and add replays to a trigger

  • To rename a replay, select it in the Properties panel, either press Return (macOS) or Enter (Windows) or choose Rename from the context menu, change the name, then press Return/Enter or click away from the text field.
  • To reorder replays within the Replays list, select them, then drag a selected replay vertically. 
  • To delete replays, select them in the Properties panel, then press Delete. The original takes included in selected replays are not deleted.
  • To add replays to a trigger, select them in the Properties panel, then drag a selected replay and drop it in the Triggers panel. You can drop replays onto an existing trigger, away from a trigger to create a new trigger for each selected replay, or in a swap set to add them as triggers in the swap set.

Playing back and record replays

Replays are usually created with associated triggers (that can be invoked via key, MIDI note, or button control), but you can also use replays directly.

To play back a replay, do either of the following:

• Press the key, MIDI note, or button control (in the Controls panel) associated with the replay’s trigger.

• Click the Play button next to the replay’s name in the Properties panel.

The recorded takes in the replay playback, but the playhead doesn’t move. A small meter next to the replay’s name in the Properties panel shows the progress.

Tip: To cancel playback of a replay, move the playhead to a different time.

To record a replay, invoke the replay either before or after you start recording. Stop recording when done. 

Poznámka:

Replays are ignored when using the Record 1-frame Take and Record 2-frame Take commands. 
However, you can copy selected Replays in the properties panel and paste them in the timeline.

Using replay triggers in swap sets

Replays can be associated with any trigger, including those in a swap set. If associated with the default trigger in a swap set, those replays will play back immediately.

Stop and sustain replays

By default, replays play back the entire duration of their recorded takes, but you can control playback to occur for as long as you trigger the replay.

Poznámka:

This does not apply to takes that were created using Cmd+1, 2 or 3 that don't have edited viseme/trigger values. Those constant takes default to Stop/Sustain.

To control how a replay plays back, select it, then set the When Trigger Ends option to either of the following:

Let replay finish: The entire duration of the replay’s recorded takes plays back, regardless of how long you trigger the replay.

Stop / Sustain replay: Takes in the replay playback until you stop triggering it. If you continue triggering beyond the replay’s duration, the takes with the latest blend-out time are extended automatically. If you stop during a take that blends out, the take will blend out once trigger stops.

Puppet layer information

The layer list in the left sidebar of the Puppet panel indicates the following:

  • The letter associated with a keyboard trigger (if specified for a layer).
  • The number of behaviors applied to and number of handles in a puppet layer’s source puppet.

These details can help you determine where behaviors and handles exist in a puppet hierarchy, and the letters available to press to trigger various actions (showing or hiding layers, cycling layers, and so on).

Puppet layer information
Puppet layer information

Layer and handle match counts

When a puppet in the Project or Puppet panel is selected, a behavior’s layer or handle parameters in the Properties panel indicate the number of matches, and the specific matches (when the parameter is twirled open). 

Multiple matching values for layer and handle parameters (for example, the Views parameter for the Face behavior) show each value on a separate line in the parameter’s tool tip.

Hide or show a layer

Click the eyeball icon for the layer. Hidden layers are indicated with a dimmed eyeball, and don’t render.

Rename a layer

Select it in the left sidebar, press Enter (on the main keyboard, not numeric keypad), type the new name, then press Enter or click away from the text field to accept the change. Press Esc instead to cancel your edits. If a layer has a custom name, you can see the original/source name in a dimmer color to the right of the layer name.

Poznámka:

Unlike project items in the Project panel, layers at the same level of the hierarchy can have the same name.

Add content to a puppet

Drag either a puppet or a layer from the Project panel onto the puppet open in the Puppet panel. If no puppet is open, the dropped items are added to a new puppet.

If dropped on the left sidebar, you can control where in the hierarchy they are added; when dropped on the right side of the panel, they are always added at the top level of the puppet. The dropped items become layers, and are selected. Unlike puppet layers, layers are the “flattened” representation of its content.

Poznámka:

When a puppet is added as a layer, you can twirl the layer open to reveal the layers inside that added puppet, and modify that puppet’s layers within the context of the current puppet. Be careful when doing this as you are modifying the master definition of that added puppet.

Blending modes

Blending modes control how layers interact with the layers beneath them. Character Animator provides a set of blending modes, which you can apply to any layer or group in a puppet. You can set the opacity and experiment with the various blending modes to achieve different results.

To adjust the blending modes, follow these steps:

  1. Select the layer or group in the Puppet panel.

  2. In the Properties panel, select the Layer section and adjust the Opacity and the Blending Mode.

     

    The following descriptions use these terms:

    • The source color is the color of the layer to which the blending mode is applied.
    • The underlying color is the color of the composited layers below the source layer.
    • The result color is the output of the blending operation; the color of the composite.

    Poznámka:

    You can edit the blending modes and opacity settings for the puppets created in Photoshop or Illustrator. Character Animator does not support blending mode and opacity changes made to the Illustrator artwork files. Unsupported blending modes in the artwork file default to Normal in the Puppet panel.

    Blending Mode Description Example
    Pass Through For groups only, it allows blending mode adjustments and opacity adjustments done to the layer within the group to affect layers below the group.
    Normal To restrict blending and opacity from affecting layers other than the layers in the group, change the group’s blending mode to Normal.
    Normal No specific blending modes are applied. The result color is the source color. Normal is the default mode.
    Darken Reads the color information in each channel to identify the darker color between source color and underlying color. The darker color is the result color.
    Multiply Reads the color information in each channel and multiplies source color with underlying color. The result color is a darker color. Multiplying any color with black results in a darker color and multiplying any color with white results in no change. For example, placing multiple gels in front of a light.
    Color Burn Reads the color information in each channel and darkens the source layer to reflect the underlying color by increasing contrast. Blending with white produces no change. 
    Linear Burn Reads the color information in the channels and darkens the source color to reflect the underlying color by reducing brightness. Blending with white produces no change.
    Darker Color Darker Color is similar to Darken, but Darker Color reads composite color channel, instead of individual RGB color channels. This blending mode extracts lowest value colors from source color and underlying color to create a result color. 
    Lighten Reads color information in each channel to identify the lighter color between source color and underlying color. The lighter color is the result color.

    Screen Reads the color information in each channel and multipies opposite of source color with underlying color. The result color is a lighter color. Using the Screen mode is similar to projecting multiple photographic slides simultaneously onto a single screen. 
    Color Dodge Reads the color information in the channels and brightens the source color to reflect the underlying color by reducing contrast. If the source color is pureblack, the result color is the underlying color. 
    Linear Dodge (Add) Reads the color information in the channels and brightens the source color to reflect the underlying color by increasing brightness. Blending with black produces no change. 
    Lighter Color Lighter Color is similar to Lighten, but Lighter Color reads composite color channel, instead of individual RGB color channels. This blending mode extracts highest value colors from source color and underlying color to create a result color.

    Overlay  Multiplies if source color is darker than the underlying color, and screens if the source color is lighter than the underlying color. Produces saturated colors. Blending with 50% gray produces no change.
    Soft Light Darkens or lightens the color channel values of the underlying layer, depending on the source color. The result is similar to shining a diffused spotlight on the underlying layer. If the source color is lighter than 50% gray, the result color is lighter than the underlying color, as if dodged. If the source color is darker than 50% gray, the result color is darker than the underlying color, as if burned.
    Hard Light Color multiplies if the underlying color is darker than 50% gray, and screens if underlying color is lighter than 50% gray. The result is similar to shining a harsh spotlight on the layer.  
    Vivid Light Burns or dodges the colors by increasing or decreasing the contrast, depending on the underlying color. If the underlying color is lighter than 50% gray, the layer is lightened because the contrast is decreased. If the underlying color is darker than 50% gray, the layer is darkened because the contrast is increased.

    Linear Light Burns or dodges the colors by decreasing or increasing the brightness, depending on the underlying color. If the underlying color is lighter than 50% gray, the layer is lightened because the brightness is increased. If the underlying color is darker than 50% gray, the layer is darkened because the brightness is decreased.
    Pin Light Replaces the colors, depending on the underlying color. If the underlying color is lighter than 50% gray, pixels darker than the underlying color are replaced, and pixels lighter than the underlying color do not change. If the underlying color is darker than 50% gray, pixels lighter than the underlying color are replaced, and pixels darker than the underlying color do not change.
    Difference Looks at the color information in each color channel and subtracts the lighter colors from the darker colors. Blending with white inverts the backdrop color and blending with black results in no change.
    Exclusion
    Creates a result similar to but lower in contrast than the Difference blending mode. If the source color is white, the result color is the complement of the underlying color. If the source color is black, the result color is the underlying color.
    Subtract Subtracts the source color from the underlying color. If the source color is black, the result color is the underlying color.
    Divide Divides underlying color by source color. If the source color is white, the result color is the underlying
    color.

Reuse a group

  1. Context (right)-click the group in the layers list (left side) of the Puppet panel, then choose Make Sharable. The source group item for the layer appears and is selected in the Project panel. The menu command is disabled if the source item is already visible in the Puppet panel.
  2. Open a different puppet in the Puppet panel.

Poznámka:

If the target puppet was created by importing Photoshop or Illustrator artwork, you can turn off the “Auto-sync with Artwork” option (in the Properties panel) for the puppet to avoid losing layer modifications done in the Puppet panel due to structural content changes in the artwork. Or, create a New Empty Puppet and open it instead.

  1. Drag the revealed source item into the Puppet panel.

Change the order of a layer

To change the order of a layer, drag it vertically relative to its sibling layers within the sidebar.

Poznámka:

You cannot drag a layer outside a puppet or into another group.

Modify layer properties

To change the properties of a layer (such as position, scale, and rotation): 
  1. Select the layer in the left sidebar.
  2. In the Properties panel, adjust the following layer-specific properties:
    • X and Y (for position), X Scale and Y Scale (for size), Opacity, and Rotate (for rotation) of the layer relative to its original transform. You can also reposition a selected layer by dragging inside the gray highlighted area.
    • Warp Independently controls whether a group warps on the same rubber sheet as other layers in the puppet.
    • Attach To controls the handle to stay attached to (for example, if you have a hand group that wants to move with an arm).
    • Trigger section: Specifies the trigger key to use to show the layer or start a cycle of layers. For more information, see the Editing keyboard triggers section.
  3. To modify a warp mesh associated with the layer, adjust the following properties in the Layer Mesh section:
    • Mesh Shape controls the form of the source puppet’s warp mesh. Rectangle uses the content’s rectangular bounding box, Contour follows the outline of the content, and Auto (the default) automatically uses Contour for most cases or Rectangle if disconnected content is detected.
    • Mesh Expansion specifies the number of pixels to extend the mesh from the layer’s boundary (contoured or rectangular). Higher expansion values can reduce the possibility of curved edges appear cut, but can cause regions that warp separately (for example, a character’s legs) to warp together.
  4. If a puppet layer is selected, adjust the applied behaviors for the source (master) puppet in the Behaviors section. You can add or remove behaviors or adjust the behavior parameter values like you would if the puppet item in the Project panel was selected. For more information, see Control puppets using behavior.

Poznámka:

Because you are changing the source, all instances of that puppet in the scene and other puppets are affected.

  1. If a layer is selected, enable the Render As Vector option if you want to use a more accurate representation of the artwork.

Poznámka:

Because you are changing the source item, all instances of that layer in other puppets are affected.

Remove a layer from a puppet

Select it, then press Delete or Backspace or choose Edit > Delete.

Poznámka:

Removing a layer does not affect the original artwork on disk.

Warping inside a puppet affects its layers, whereas capabilities such as key-triggered replacements require groups. You can combine any number of layers into a group.

Using clipping masks to mask layers

A clipping mask lets you use the content of a layer to mask the layers above it. The masking is determined by the content of the bottom or base layer. The non-transparent content of the base layer clips (reveals) the content of the layers above it in the clipping mask. All other content in the clipped layers is masked out.

You can use multiple layers in a clipping mask, but they must be successive layers. The name of the base layer in the mask is underlined, and the names for the overlying layers are indented. The overlying layers display a clipping mask icon.

To create a clipping mask, follow these steps:

  1. In the Puppet panel, arrange the layers in a way that the layer with the mask is placed below the layers you want to mask.

  2. Select the layers you want to mask and choose Puppet > Create Clipping Mask (Cmd+Option+G (MAC) or Ctrl+Alt+G (Windows). Multiple selected layers can be masked if they are adjacent in the layers list and don’t include the last layer in a group.

    Poznámka:

    If a layer is inserted between layers in a clipping mask, it becomes the base layer for the layers above it and is not clipped.

    The name of the base layer in the mask is underlined in the Puppet panel and the names of the overlying layers are indented. The overlying layers also display a clipping mask icon.

    Masking layers using clipping mask
    Masking layers using clipping mask

Release layers in a clipping mask

To release clipping masks from layers, follow these steps:

  1. Select all the successive clipping mask layers (with  icons) which are above the base layer.

  2. Choose Puppet > Release clipping Mask (Cmd+Option+G (MAC) or Ctrl+Alt+G (Windows).

Poznámka:

The clipping masks you create in Photoshop artwork and import to Character Animator is converted into clipping masks in the puppet panel. The ones created using Illustrator artwork (<Clip Group>) is not converted into clipping masks in the puppet panel. But, you can create clipping masks from Illustrator sourced layers in the Puppet panel.

Group a set of layers

  1. Select the layers and choose Puppet > Group Layers (Cmd/Ctrl+G).
  2. (Recommended) Rename the new group to be more descriptive. It can be used as a separate puppet directly in the scene. It’s best to rename the “group” project item that was created, so that the new puppet layer uses the new name by default. Renaming the puppet layer directly doesn't update the source puppet item’s name.

Auto attachment of independent groups

Rigging a puppet with independent parts is streamlined with the automatic attachment of these independent groups to their parents (e.g., arms, legs, or other parts that overlap a torso or other part of a character). For newly imported artwork, position the group’s origin to where you expect it to attach. You don't have manually staple or use extra staple handles. There are also helpful visualizations in the Puppet panel to show how these independent groups attach to their parent group’s mesh.

To automatically attach independent groups to puppet’s parent group’s mesh, follow these steps:

  1. In the Puppet panel, select the independent group.

  2. In the Properties panel, under the Layer section, set Attach To to Auto.

    Auto is the default setting for newly imported artwork that doesn’t have a specific attachTo setting in the artwork file. Also, the default Attach Style setting is now Weld, except if the puppet has only one top-level independent group (e.g., a “+Character” in the artwork file), in which case it is the top-level group is set to Free.
    Tip: Hover over the Attach To drop-down list to temporarily show all the available attach points on the puppet.

  3. Adjust the position of the group so it overlaps the parent group’s mesh, then move the group’s origin handle to where you want the group to attach to the parent.

    Auto attachment of groups
    Auto attachment of groups
  4. Now, move the group’s origin handle to the position where you want the group to attach to the parent.

  5. The group automatically attaches to the parent group.

    Poznámka:

    Beta6 or older projects and .puppet files are not converted. If you have independent groups that contain Dangle handles, and the group is attached using the Free attach style, the group falls when the puppet first appears in the scene. Switch to Hinge or Weld as needed.

Release layers in a clipping mask

To release clipping masks from layers, follow these steps:

  1. Select all the successive clipping mask layers (with icons) which are above the base layer.

  2. Choose Puppet > Release clipping Mask (Cmd+Option+G (MAC) or Ctrl+Alt+G (Windows).

Poznámka:

The clipping masks you create in Photoshop artwork and import to Character Animator is converted into clipping masks in the puppet panel. The ones created using Illustrator artwork () is not converted into clipping masks in the puppet panel. But, you can create clipping masks from Illustrator sourced layers in the Puppet panel.

Layers attach style options

When you select a layer in the Puppet panel and check the Warp Independently option, the Attach To control is enabled along with the new Attach Style control. The following attach styles are available:

  • Weld: The layer cannot move, rotate, or scale around its origin.
  • Hinge: The layer can rotate, but can’t move or scale around its origin.
  • Free: The layer can move, rotate, and scale freely around its origin.

Attach style

Attach style

Layer handles

Handles, whose behaviors control to manipulate a puppet, can be created using tools in the Puppet panel.

View the handles of a puppet

Either deselect all layers (or select the top heading on the left side of the Puppet panel) or select a group layer. The handles in the open or selected group, and participating in the same warpable mesh appears as yellow circles.

Handles created in the Puppet panel have a dot in the middle of the circle; these handles can be deleted, moved, and renamed. Handles specified in the artwork file do not have a dot and cannot be moved or renamed. If the outline is solid, it can be deleted. If it's dashed, it represents an origin handle, and cannot be deleted.

Handle tags

The Puppet panel displays Handle tags to the right of the puppet and text-based tags in the Properties panel. The Handle tag is displayed to the right of the handle in large text. The small text centered below the handle is the handle name. The artwork guides named similar to the tags do not have a name by default in the Puppet panel.

Select or deselect handles

To select or deselect handles, switch to the Selection tool, then do one of the following:
  • Click the handle to select it.
  • Shift-click a handle to extend the selection.
  • Drag a selection (marquee) box around the handles. Hold down Shift while dragging to extend the selection.
  • Click away from a handle to deselect all of them.

Reposition a handle

To reposition a handle, select it, then drag it to the intended location.

Poznámka:

Read-only locations coming from the artwork file and appearing with no yellow dot in the middle of the circle cannot be moved.

To reposition the origin handle for a puppet, select the handle named after the puppet and appearing as a dashed circle by default, then drag it to the intended location. You don’t have to update the origin location in the Photoshop or Illustrator artwork file. When using Weld or Hinge attach styles for groups, you want to position the group's origin at the intended anchor or pivot location.

Note: To reset the location of the origin handle to the center of the puppet’s bounds or to its specific location in the artwork file, select the handle, then press Delete.

Rename a handle

To rename a handle, select it, press Enter (on the main keyboard, not numeric keypad), type the new name, then press Enter or click away from the text field to accept the change. Press Esc instead to cancel your edits.

Use tools in Puppet panel

To create a handle in the Puppet panel, use one of the following tools

  • Handle tool: Click at the intended location. You can change the tag of the handle, for use by a particular behavior or as an attach point for a group.
  • Stick tool: Click a layer to specify one end of the stick, then drag to the other end of the intended stick. A "Stick"-tagged stick handle is created. For example, to bend an arm or leg. Avoid crossing sticks.
  • Pin tool: Click at the place above a layer to restrict from warping. A “Fixed”-tagged handle is created.
  • Dragger tool: Click at the place above a warpable layer to control using the Dragger behavior. A “Draggable”- tagged handle is created.
  • Dangle tool: Click at the place above a warpable layer to sway using the Dangle behavior. A “Dangle”-tagged handle is created.

The Pin, Dragger, Dangle, and Stick tools are specialized tools that do what the Handle tool does, but also tag the created handles for specific purposes.

Apply tags to a handle

You can apply tags to the origin handle. For example, to allow a puppet to be dragged with the mouse or your finger on a touch screen, select the origin handle and assign the Draggable handle tag. 

To edit the tags for a layer or handle:

  1. In the Puppet panel, select the layer or handle.
  2. In the Properties panel’s Tag section, select or deselect the capabilities to associate with the selection.

Note:

  • Selected tags still require that the corresponding behaviors that use them are applied at or at a higher level in the puppet hierarchy. For example, selecting the Chest tag for a handle doesn’t do anything unless Breathe is also applied to a parent puppet.
  • Hierarchical and layer name changes in the artwork file reset any tags associated with the affected layers. However, layer content changes retain any tags changed in the Puppet panel.

When a layer is selected, you can apply both layer or handle tags, with handle tags applied to the origin handle for selected groups or in the parent puppet of a layer. When a handle is selected, only handle tags can be applied.

When viewing tags as text, applied layer tags are blue and handle tags are yellow. When viewing tags as pictures, applied tags are blue.

Poznámka:

A stick handle can be modified like other handles by giving it a Draggable handle.

Remove a handle

To remove a handle, select it, then press Delete or Backspace or choose Edit > Delete.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online