Manage projects

Learn how to access, save, and merge projects in RoboHelp.

Project Settings

To launch the Project Settings dialog, click File > Project Settings.

General

  • Title: Enter a project title. This title appears in the window bar of the output.
  • Language: Select the default project language.
  • Default Stylesheet: Select the stylesheet to be used for the project. You can however override the styles using inline and internal stylesheets.
  • Default Word Import Settings: Select the Word Settings File that the project uses when published to Microsoft Word.
  • Default FrameMaker Import Settings: Select the FrameMakerSettings File that the project uses when published to Adobe FrameMaker.
  • Do not allow inline formatting: If you enable the option, all text formatting properties are disables in the Content Properties panel of a topic in authoring mode.
  • Enable advanced HTML Help options: Enable this option to customize the TOC icons for the CHM output.

Topic Status

Add a new status for a topic. A number of statuses already exist. To add a new status, enter the name, and click the + icon.

Colors

Set colors for fonts, borders, backgrounds and so on. To add a new color, enter the name, and click the + icon.

If you've upgraded from a Classic version, you will see the colors that you'd defined earlier.

Tag Groups

Add custom tags that you want to use for creating conditional content. To add a new tag, enter the name, and click the + icon.

Font List

Add the fonts, for example, Arial, Tahoma, and so on, so that only the fonts that you've added appear in the list of fonts in Content Properties  > Font. If you misspell a font and then add it, the misspelled font will appear in the list of fonts. But if you apply the misspelled font on a text, the font will fall back to the default browser font, Times New Roman. You can also add multiple fonts as a comma-separated list.

Panels

Enable or disable the panels that you'd like to use. If you do not need a panel, disable it.

Open a project

You can access your projects in RoboHelp from the home screen or use the File menu.

Home screen

When you launch RoboHelp, the first screen that you view is the home screen. On this screen, you can access your recently edited projects under the Recent section. RoboHelp displays up to two recent projects. Simply click one of the displayed projects to open and start working with it.

You can also pin, unpin, or remove a project from the Recent section:

  • To pin a project, hover over the desired project name and click the  icon. Your pinned projects appear at the top of the Recent list. 
  • To unpin a project, simply click the  icon. 
  • To remove a project from the Recent list, hover over the desired project name and click the  icon.

File menu

Do one of the following to access your project:

  • Select File > Recent Projects, select your desired project, and click Open.
  • To open a recently edited project, select File > Recent Projects and select your desired project.
  • To open a project of RoboHelp Classic, select File > Upgrade RoboHelp Classic Project. You can then select your desired project and click Open.

Save a project

To save your work in RoboHelp, follow these steps:

  1. Select the File menu.

  2. In the drop-down list, select Save All. Alternatively, you can press Ctrl+S to save all the updated files in the project.

    It is recommended that you save your project as and when you update it so that you don't lose any content.

Close a project

Once you've edited and saved your project, follow these steps to close your project in RoboHelp:

  1. Select the File menu.

  2. Select Close Project. Alternatively, you can press Alt+Ctrl+C to close the project.

    Poznámka:

    When you close a project, all the related files are closed. The application (RoboHelp) however remains open so that you can open or create a project and work with it.

Merged projects

Using RoboHelp, you can create projects in an enterprise or a distributed setup where different documentation projects (child projects) feed into a common project (the master project). You can achieve collaborative authoring without using source-control software because multiple writers can work on their individual child projects. In the master project's Table of Contents, you can insert references to child projects (the master project does not actually contain child projects).

Insert each reference to a child project as a placeholder in the master project's Table of Contents. The location of the placeholder should be where you want the Table of Contents of the child project to appear in the output. The placeholder retains the original hierarchy of the TOC of the child project and is expanded in the output. The merging takes place after the output of the projects are generated. By using skins and templates in the master project, you can achieve a unified appearance in the merged projects.

To insert child projects, follow these steps:

  1. In your master project, click Table of Contents in the Author toolbar. The Table of Contents panel opens.

  2. In the Table of Contents panel, against the appropriate Table of Contents file, choose Options () > Edit.

    The Table of Contents editor opens as a tab and RoboHelp displays the Table of Contents toolbar at the center of the standard toolbar.

  3. In the Table of Contents editor, click the location at which you want to insert the child project's placeholder.

    Poznámka:

    If you do not select a location, the placeholder is inserted after the currently selected topic. If a folder is selected at the time of insertion, the placeholder is inserted at the end of the list of topics in the selected folder.

  4. Do one of the following:

    • In the Table of Contents toolbar, click .
    • Right-click in the Table of Contents editor and choose Insert > Child Project
  5. In the Insert Child Project dialog box, click  to select your child project (.rhpj file). Click Insert.

    A placeholder of the child project's Table of Contents is inserted. 

  6. To modify the properties of the child project placeholder, see Work with a Table of Contents' properties.

  7. Configure an output preset. In the General tab > Output Path field, specify the following location at which the output of all child projects must be generated:

    [master_project_output_folder]/mergedProjects/[child_project_name]

Child HTML Help File

You can include a CHM file in the TOC in your project so that it can be opened in your output. 

To merge Microsoft HTML Help files (CHM), follow these steps:

  1. In your master project, click Table of Contents in the Author toolbar. The Table of Contents panel opens.

  2. In the Table of Contents panel, against the appropriate Table of Contents file, choose Options () > Edit.

    The Table of Contents editor opens as a tab and RoboHelp displays the Table of Contents toolbar at the center of the standard toolbar.

  3. In the Table of Contents editor, click the location at which you want to insert the HTML file placeholder.

    Poznámka:

    If you do not select a location, the placeholder is inserted after the currently selected topic. If a folder is selected at the time of insertion, the placeholder is inserted at the end of the list of topics in the selected folder.

  4. Do one of the following:

    • In the Table of Contents toolbar, click .
    • Right-click in the Table of Contents editor and choose New > HTML Help File
  5. In the Insert HTML Help File dialog box, click  to select your .chm file. Click Insert.

    The Microsoft HTML Help File is copied into the project in the Content Explorer under assets/chm/. For example: assets/chm/xxxx.chm

  6. To modify the properties of the HTML File placeholder, see Work with a Table of Contents' properties.

  7. Configure a Microsoft HTML Help output preset. Select the same Table of Contents (TOC) 

Logo Adobe

Přihlaste se ke svému účtu.