Use este documento para obtener información acerca de CINEMA 4D y Cineware

CINEMA 4D es una popular herramienta de animación y modelado 3D de Maxon (www.maxon.net).

Una mayor integración con CINEMA 4D le permite utilizar Adobe After Effects junto con MAXON CINEMA 4D. En After Effects, puede crear un archivo CINEMA 4D (.c4d) y trabajar con animaciones, escenas y elementos 3D complejos.

Para hacer posible esta interoperabilidad, se ha integrado el motor de procesamiento de Maxon CINEMA 4D, CineRender, con Adobe After Effects. After Effects puede procesar archivos CINEMA 4D, y el usuario puede controlar algunos aspectos del procesamiento, la cámara y el contenido de las escenas capa por capa. Este flujo de trabajo optimizado elimina la necesidad de crear pasadas intermedias o archivos de secuencias de imágenes.

Maxon CINEMA 4D Lite R19

La aplicación Maxon CINEMA 4D Lite R19 se instala junto con After Effects. Esta aplicación permite crear, importar y editar archivos CINEMA 4D. Pero si tiene instalada otra edición de CINEMA 4D (por ejemplo, CINEMA 4D Prime), puede usarla en lugar de la versión que se instala con Adobe Effects. La aplicación CINEMA 4D Lite R19 permite editar, crear y trabajar con archivos CINEMA 4D nativos. Las características de la versión Lite son similares a las de CINEMA 4D Prime.

El comportamiento predeterminado utiliza la versión más reciente de la aplicación CINEMA 4D instalada.  

Consulte este tutorial para obtener más información sobre el uso de CINEMA 4D Lite con cámaras y luces de After Effects.


Efecto Cineware
Ventana de CINEMA 4D

Uso de archivos CINEMA 4D

Existen varias opciones para crear, importar y editar archivos Cinema 4D desde After Effects.

Importar archivos CINEMA 4D

Para importar archivos CINEMA 4D a After Effects, haga lo siguiente:

  1. Elija Archivo > Importar > Archivo.

  2. Seleccione al archivo CINEMA 4D y haga clic en Importar. El archivo se coloca en el panel Proyecto como elemento de material de archivo. Puede colocarlo en una composición existente o bien crear una nueva.

Nota:

Al colocar el material de archivo en una composición nueva mediante el icono de composición nueva del panel Proyecto, se creará una composición configurada según el archivo CINEMA 4D; a continuación, se creará una capa CINEMA 4D y la escena 3D se colocará en ella. En cambio, si coloca el material de archivo en una composición existente, adopta el aspecto o el tamaño de la composición.

Nota:

Antes de importar, habilite las preferencias Guardar polígonos para Melange y Guardar animaciones para Melange en las preferencias de la aplicación CINEMA 4D. Estos ajustes son especialmente útiles cuando los fotogramas CINEMA 4D dependen de fotogramas anteriores.

Editar archivos CINEMA 4D

Puede editar archivos CINEMA 4D situados en composiciones o elementos de origen CINEMA 4D en el proyecto. Los archivos se abren en la aplicación CINEMA 4D Lite R19, pero, si tiene instalada otra versión de CINEMA 4D, se utilizará esta para editarlos. Consulte Edición del material de archivo en su aplicación original.

Puede elegir la versión de CINEMA 4D que desea utilizar con Editar original. Consulte Uso de instancias distintas de CINEMA 4D en el efecto Cineware Effect.

Para obtener más información, consulte este vídeo de Jeff Sengstack: Importación y edición de archivos CINEMA 4D.

Crear archivos CINEMA 4D

  1. Puede crear un archivo de CINEMA 4D dentro de After Effects. Para ello, seleccione Archivo > Nuevo > Archivo de Maxon CINEMA 4D Capa > Nueva > Archivo de Maxon CINEMA 4D.

  2. Especifique un nombre y una ubicación para el archivo.

  3. Se abre la aplicación CINEMA 4D.

  4. Cree una escena C4D y seleccione Archivo > Guardar para guardar el archivo.

Para obtener más información, consulte este vídeo de Jeff Sengstack: Creación de archivos CINEMA 4D.

Exportar a Maxon CINEMA 4D y realizar ediciones bidireccionales usando la canalización de Live 3D

Puede exportar las composiciones con capas de forma y texto animado 3D a MAXON CINEMA 4D mediante la canalización de Live 3D de After Effects para flujo de trabajo 3D con ciclo completo.

Las capas de forma 3D se exportan como objetos polinómicos extruidos e incluyen la animación de las propiedades de capa de forma.

La opción de extrusión de texto como formas exporta las capas de texto 3D como objetos polinómicos extruidos en el archivo .c4d. Esta opción conserva la fidelidad de la capa: el formato de caracteres y párrafos y la animación de las propiedades de las capas de texto. No se puede modificar la fuente y el contenido de texto en CINEMA 4D.

La opción Conservar texto editable exporta las capas de texto 3D como objetos de texto extruidos en el archivo .c4d. En esta opción, puede personalizar la fuente y el texto en CINEMA 4D. Sin embargo, esta opción no es muy compatible con el formato de caracteres y párrafos y la animación de las propiedades de las capas de texto. Las funciones de animación de texto que no son compatibles incluyen: animadores de texto, espaciado manual, espacio entre caracteres, texto vertical, texto de párrafo y texto en trazado.

Los trazos se exportan de las capas de forma y texto 3D al archivo .c4d. Aunque el procesador 3D con trazo de rayo en After Effects no procesa los trazos de las capas de texto 3D, los trazos se exportan cuando están habilitados. Para ver los trazos de las capas de texto 3D antes de exportarlos, asegúrese de que el procesador de composición se haya establecido en Classic 3D.

Exportar a Maxon CINEMA 4D

Para exportar a MAXON Cinema 4D:

  1. Seleccione Archivo > Exportar > Exportador de Maxon CINEMA 4D y guarde el archivo C4D.

  2. En el cuadro de diálogo Exportar a Maxon CINEMA 4D, seleccione una de las opciones siguientes:

    • Extruir texto como formas: Crea un archivo .c4d con extrusión básica.
    • Conservar texto editable: exporta las capas de texto 3D como objetos de texto extruido en el archivo .c4d, lo que permite modificar la fuente y el texto en CINEMA 4D.

Nota:

  • Si es poco probable que el texto cambie después de la exportación, se recomienda elegir la opción CINEMA 4D: Extruir texto como capas en el cuadro de diálogo Exportación de texto. 
  • Al exportar, se desplazan las coordenadas de escena para el objeto nulo principal de modo que el centro de una composición de After Effects coincida con el centro de CINEMA 4D en 0,0,0. 
  • Los archivos .c4d exportados se guardan en la versión 17.0 de CINEMA 4D.

Importación del archivo .c4d y edición en Maxon CINEMA 4D

Puede importar un archivo .c4d que haya creado en la composición de After Effects para editarlo. Elija Editar > Editar original para editar el archivo .c4d en CINEMA 4D.

Al importar y añadir un archivo .c4d creado con la versión de CINEWARE 3.1 del exportador a la composición, puede ver la escena a través de una cámara de After Effects agregando primero una cámara y, a continuación, estableciendo el ajuste de la cámara en el efecto CINEWARE a la Cámara de composición centrada.

Las capas 3D de After Effects que añada a la composición se alinearán con la capa de escena de CINEMA 4D tras la exportación. Los datos de escena 3D extraídos d el archivo .c4d, tales como valores nulos, cámaras y luces, también se alinean, siempre que todos los objetos nuevos que se agreguen al archivo .c4d se agrupen en un mismo objeto principal nulo creado como en el archivo .c4d exportado.

Para abrir el archivo de CINEMA 4D exportado en After Effects y CINEMA 4D y realizar ediciones 3D avanzadas:

  1. Elija Archivo > Importar y seleccione el archivo .c4d para importarlo a la composición.

  2. Para personalizar los elementos 3D con CINEMA 4D, seleccione la capa de Cineware y elija Editar > Editar original (o presione el método abreviado de teclado Comando+E en Mac OS o Control+E en Windows). El archivo C4D se abre en CINEMA 4D, que se incluye en After Effects CC.

  3. Realice los cambios que desee y guarde el archivo. La composición de After Effects se actualiza automáticamente con todos los cambios. 

Efecto Cineware

La integración del motor CineRender, que se basa en el motor de procesamiento CINEMA 4D, permite procesar capas basadas en archivos CINEMA 4D directamente en After Effects. El efecto Cineware permite controlar los ajustes de procesamiento y ofrece cierto control sobre la relación entre calidad y velocidad del procesamiento. También puede especificar las cámaras, las pasadas o las capas C4D utilizadas para el procesamiento. El efecto Cineware se aplica automáticamente cuando en la composición se crea una capa basada en material de archivo C4D. Cada capa de CINEMA 4D tiene sus propios ajustes de procesamiento y visualización.

Para obtener más información, consulte Comprender el efecto de Cineware y motor de procesamiento.

Sincronizar capa

Al añadir varias instancias de una capa de escena de CINEMA 4D en una composición, incluida la adición de capas con varias pasadas, puede seleccionar las capas de CINEMA 4D que se sincronizarán con el resto de las capas de la composición.

Cuando se marca la opción Sincronizar capa de AE en la parte superior del panel Controles de efectos, las opciones Ajustes de procesamiento y Cámara en todas las instancias de la capa se sincronizan automáticamente, pero las capas de CINEMA 4D se definirán de forma independiente. Si la casilla está desactivada para una capa de escena de CINEMA 4D específica, ninguno de los ajustes de esa capa se sincronizan con el resto de las capas de la composición.

Live Link sincroniza las líneas de tiempo de CINEMA 4D y After Effects.

Para trabajar con Live Link, haga clic en el botón Habilitar para Live Link. La versión especificada de CINEMA 4D abre el archivo actual. Para habilitar Live Link en CINEMA 4D, elija Editar > Preferencias > Comunicación > Live Link y, a continuación, seleccione Live Link habilitado al inicio. Las líneas de tiempo se sincronizan al cambiar entre After Effects y CINEMA 4D. Cuando seleccione otra capa de c4d en After Effects, presione Habilitar para sincronizar esa capa.

Ajustes de procesamiento

Los ajustes de procesamiento de Cineware determinan cómo se procesa la escena dentro de After Effects. Estos ajustes pueden ayudar a acelerar el procesamiento mientras trabaja.

Procesador

Determina qué procesador se utilizará. Están disponibles las siguientes opciones:

  • Estándar (final): utiliza el procesador estándar que se especifica en el archivo C4D. Utilice la aplicación CINEMA 4D para editar estos ajustes.
  • Estándar (borrador): utiliza el procesador estándar pero desactiva los ajustes más lentos, por ejemplo el suavizado, para obtener una mejor interactividad.
  • Software: utiliza los ajustes necesarios para que el procesamiento sea lo más rápido posible y permite elegir los ajustes de visualización. No se mostrarán sombreadores ni pasadas múltiples. El procesador de software es útil para obtener una previsualización mientras sigue trabajando en la composición.
  • OpenGL: procesamiento acelerado por hardware para una mejor calidad y una velocidad más alta con respecto a la opción de procesamiento del software. El procesador OpenGL en CINEWARE admite el mismo nivel de calidad mejorada de OpenGL que CINEMA 4D para las propiedades Transparencia, Sombras, Efectos posteriores y Ruidos.

Nota:

Cuando se guarda el archivo .c4d en una versión de pago completa de CINEMA 4D (no CINEMA 4D Lite R19, que se incluye con After Effects) con las opciones Ajustes de procesamiento configuradas en el procesador físico o de hardware, el archivo se procesa con dichos ajustes cuando el procesador de CINEWARE se configura en Estándar (final) o Estándar (borrador).

Visualización

Esta opción solo se habilita cuando se elige el procesador Software. Las opciones disponibles son Sombreado actual, Malla metálica y Cuadro. Los modos de malla metálica y cuadro proporcionan una representación simplificada de la escena.

Sin texturas/sombreador

Active esta opción para no representar texturas ni sombreados y de ese modo acelerar el procesamiento.

Sin cálculos previos

Active esta opción para desactivar los cálculos previos para el cómputo de dinámicas de movimiento o simulaciones de partículas y de ese modo acelerar el procesamiento. No marque esta opción para el procesamiento final.

Mantener las texturas en RAM

Active esta opción para guardar las texturas en caché en la memoria RAM, de modo que no se pierda tiempo volviendo a cargar las lecturas desde el disco. Pero tenga en cuenta que si almacena en caché texturas grandes, puede que se reduzca la memoria RAM disponible.

Servidor de procesamiento

Depurar memoria: borra la memoria de un servidor de procesamiento. Durante un período de tiempo, la respuesta del servidor podría reducirse a medida que sigue almacenando las escenas que se procesan. Si se vacía la memoria que el servidor de procesamiento utiliza para las cachés internas, After Effects podrá ampliar la longitud de las previsualizaciones de escenas complejas.

Ajustes del proyecto

En el efecto Cineware, encontrará los ajustes de proyecto siguientes:

  • Cámara
  • Capas de CINEMA 4D
  • Pasada múltiple (flujo de trabajo lineal)
  • Comandos

Cámara

Elija la cámara que se utilizará para el procesamiento.

Cámara de CINEMA 4D: utiliza la cámara que se haya definido como la cámara de visualización del procesamiento en CINEMA 4D o bien, si no se ha definido ninguna, utiliza la cámara predeterminada.

Seleccionar la cámara de CINEMA 4D: utilice esta opción para elegir una cámara. Cuando esta opción esté activada, haga clic en Definir cámara.

Cámara de composición centrada: utilice esta opción para usar la cámara de After Effects. Recalcule las coordenadas deCinema 4Dpara adaptarlas a las coordenadas de After Effects. Al importar un archivo C4D existente (normalmente modelado alrededor de las coordenadas 0,0,0) para que se procese con una nueva cámara de After Effects (centrada en la composición), utilice esta opción para procesar el modelo C4D en el centro de la composición de After Effects.De lo contrario,puede que debido a la diferencia de origen, el modelo aparezca desplazado.

Cámara comp.: utilice esta opción para usar la cámara de After Effects activa. Para que esta opción funcione, debe haber agregado una cámara de After Effects. Utilice esta opción, por ejemplo, para una cámara que se ha añadido extrayéndola de un proyecto de CINEMA 4D (puesto que esas cámaras hacen referencia al sistema de coordenadas de CINEMA 4D con 0,0,0 en el centro de la ventana gráfica de CINEMA 4D). Esta opción es adecuada para cámaras añadidas a After Effects mediante el comando Capa > Nuevo > Cámara.

Definir cámara: si una escena de CINEMA 4D contiene cámaras distintas de la cámara predeterminada, haga clic en este botón y seleccione la cámara.

Definir toma: Esta opción está habilitada si el archivo .c4d contiene tomas. Puede crear varias tomas de la escena y modificar cualquier parámetro en una toma. Si el procesador actual no admite las selecciones de tomas, se utilizará la toma principal.

Capas de CINEMA 4D

Habilite y seleccione las capas de CINEMA 4D para procesarlas.

Definir capas

Haga clic en esta opción para elegir las capas. Haga clic en el botón Definir capas para elegir una o más capas. En CINEMA 4D, las capas permiten organizar varios elementos. Puede utilizar capas de CINEMA 4D para componerlas entre los elementos de la composición de After Effects.

Pasada múltiple (flujo de trabajo lineal)

Utilice la opción Pasada múltiple de Cinema 4D para especificar la pasada que se procesará. Las funciones de pasada múltiple solo están disponibles cuando se utiliza el procesador Estándar.

El uso de pasadas múltiples permite efectuar ajustes de precisión a una escena C4D componiendo juntas diferentes tipos de pasadas en After Effects, por ejemplo, ajustar solamente las sombras o los reflejos de la escena. Para que los resultados coincidan con el ajuste predeterminado del proyecto Flujo de trabajo lineal de CINEMA 4D, debe trabajarenun proyecto en el que los colores se fusionen en luz lineal (en un espacio de trabajo lineal gestionado con colores o con Mezclar colores mediante gamma 1.0 definido en el cuadro de diálogo Ajustes del proyecto).

Definir pasada múltiple

Haga clic para seleccionar qué pasada hay que representar en esta capa. Esta opción solo está disponible si está activada la opción Pasada múltiple de CINEMA 4D.

Pasadas múltiples definidas

Cuando está activado, agrega los pases añadidos explícitamente en el archivo .c4d. Puede incluir pases distintos a las capas de imagen.

Añadir capas de imagen

Utilice esta opción para crear capas de pases múltiples con los modos de fusión adecuados en función de la opción configurada en Pases múltiples definidos. Cuando la opción de pases múltiples definidos está activada, Añadir capas de imagen permite añadir únicamente los pases definidos en los ajustes de procesamiento de CINEMA 4D en lugar de añadir todos los tipos admitidos.

Nota:

Al agregar capas de imágenes, la capa seleccionada originalmente se coloca en la parte inferior de la pila de la línea de tiempo y se agrega el texto Imagen RGBA al nombre de la capa para reflejar que es del tipo pasada múltiple.

Comandos

Utilice los siguientes comandos.

Cámara comp. en CINEMA 4D

Haga clic en Combinar para agregar la cámara actual de After Effects como una cámara de C4D en el archivo C4D. Esto modifica el archivo C4D. Utilice Archivo > Volver a la versión guardada en C4D para ver la cámara de After Effects que se acaba de añadir. Este comando es especialmente útil para transferir los datos de la cámara que creó el efecto Rastreador de cámara 3D. Se añadirá AE como prefijo al nombre de la cámara.

Nota: al volver a realizar una fusión, la cámara anterior no se actualiza, sino que se crea una copia nueva.

Datos de escena de CINEMA 4D

Haga clic en Extraer para crear datos 3D, por ejemplo, cámaras, luces, sólidos o valores nulos para los objetos que tienen una etiqueta de composición externa aplicada en el proyecto CINEMA 4D.

Nota:

Habilite siempre las opciones Guardar polígonos para Melange y Guardar animaciones para Melange en las preferencias de CINEMA 4D para evitar problemas al extraer datos de escena de After Effects.

Nota:

Según la configuración de seguridad de su ordenador, es posible que aparezcan algunas advertencias sobre la comunicación TCP. Esto se debe a que After Effects y el procesador de CINEMA 4D de fondose comunicanmediante TCP, lo que cierto software de seguridad puede interpretar como comunicación peligrosa de software malicioso. Por ejemplo, Mac OS puede pedirle que confirme si desea ejecutar este software “descargado de Internet”. Confirme que desea ejecutar el software.

Si puede importar un archivo .c4d, pero no puede procesarse, compruebe si el portero (Gatekeeper) de Mac OS o el cortafuegos han bloqueado el funcionamiento del procesador de CINEMA 4D de fondo y la comunicación con After Effects. Para usuarios de Mac, defina Permitir aplicaciones descargadas desde (en la ficha General de las preferencias del sistema Seguridad y privacidad) como Cualquier sitio.

El puerto TCP que se utiliza se define en las Opciones del efecto Cineware y se incluye en el archivo de preferencias de After Effects.

Uso de instancias distintas de CINEMA 4D en el efecto CINEWARE

Ahora se puede especificar la instancia de CINEMA 4D que desea utilizar en el efecto Cineware.

Configuración de Cineware
Configuración de Cineware

Ruta de procesamiento y ruta al ejecutable de Cineware
Ruta de procesamiento y ruta de ejecución de CINEMA 4D


Seleccione Efecto Cineware > Opciones y elija una de las siguientes opciones:

  • Ruta del procesador de CINEMA 4D: elija CINEMA 4D para procesar en After Effects si tiene la versión completa de CINEMA 4D instalada.
  • Ruta al ejecutable de CINEMA 4D: elija la versión de CINEMA 4D que se usará al abrir archivos .c4d con el comando Editar original o al crear archivos de CINEMA 4D desde After Effects. El editor predeterminado es la última versión instalada de CINEMA 4D o de CINEMA 4D Lite R19.

La aplicación CINEMA 4D predeterminada se encuentra en:

  • C:\Archivos de programa\Adobe\Adobe After Effects CC\Support Files\Plug-Ins\MAXON CINEWARE AE\(CINEWARE Support)\lite\CINEMA 4D Lite.exe (Windows)
  • /Aplicaciones/Adobe After Effects CC /Plug-ins/MAXON CINEWARE AE/(CINEWARE Support)/Lite/CINEMA 4D Lite.app (Mac OS).

Nota:

Después de utilizar una versión completa de pago de CINEMA 4D como procesador, si desea volver al procesador de Cineware predeterminado, haga clic en el botón Predeterminados del cuadro de diálogo Seleccionar instalación de CINEMA 4D.

Cambiar las rutas de procesamiento

Siga los pasos siguientes para cambiar las rutas de procesamiento (por ejemplo, cambiar la aplicación de procesamiento CINEMA 4D):

  1. Opciones > Examinar para definir ruta de procesamiento

  2. Seleccione la nueva aplicación.

  3. Salga de After Effects.

  4. Inicie After Effects.

  5. Seleccione Editar > Depurar > Toda la caché de disco y memoria para que la nueva configuración surta efecto.

Nota:

Si se produce un error de conexión después de cambiar de procesador, salga de After Effects, espere 20-30 segundos y vuelva a iniciar la aplicación.

Funciones de procesamiento

Si elige Cinema 4D, versiones R14 y superiores como procesador, podrá utilizar varias funciones de procesamiento dentro del plugin Cineware de After Effects diferentes al procesador predeterminado, como el procesador Físico y Esbozo y caricatura.

Para utilizar el procesador físico, haga lo siguiente:

  1. Seleccione el procesador físico en el cuadro de diálogo Configuración de procesamiento de CINEMA 4D.

    1. En el menú Procesar, seleccione Procesar > Editar configuración de procesamiento.
    2. En el cuadro de diálogo Configuración de procesamiento, establezca Procesador: Físico en la ventana emergente.
    3. Haga clic en Físico y configure otros ajustes, como Profundidad de campo o Desenfoque de movimiento.
  2. Guarde el archivo .c4d con la configuración de procesador.

  3. El procesador especificado en CINEMA 4D lo usa el efecto Cineware cuando la opción Configuración de procesador del efecto se establece en Estándar (Final) y Estándar (Borrador).

Nota:

Puede controlar Esbozo y caricatura para objetos individuales en el gestor de objetos añadiendo Etiquetas > Etiquetas de esbozo > Estilo de esbozo (consulte la documentación de ayuda de CINEMA 4D de Maxon para obtener más información sobre Esbozo y caricatura).

Para procesar esbozos y caricaturas, haga lo siguiente:

  1. En el menú Crear de la aplicación CINEMA 4D, seleccione Crear > Material > Material de esbozo.

    1. En el cuadro de diálogo Configuración de procesamiento, establezca Procesador: Estándar en la ventana emergente.
    2. En el cuadro de diálogo Configuración de procesamiento, compruebe que los efectos posteriores Esbozo y caricatura se hayan añadido y activado.
  2. Guarde el archivo .c4d con la opción Esbozo y caricatura activada.

  3. Esbozo y caricatura lo procesa el efecto de Cineware cuando la configuración de procesamiento se establece en Estándar (Final).

Nota:

Con CINEMA, son compatibles las versiones siguientes de Cinema 4D:

  • R14.042 o posterior. Utilice el proceso de actualización en línea de CINEMA 4D para instalar la versión actual.
  • R15.037 o posterior
  • R16
  • R17
  • R19

Consulte Procesador de composición de CINEMA 4D para obtener información acerca del nuevo procesador 3D que se utiliza para la extrusión de textos y formas.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea