Si va a escribir un manual o un documento de referencia, es aconsejable que incluya una referencia cruzada que remita al lector de una parte del documento a otra. Ejemplo: Para obtener más información, consulte “Ratones de campo” en la página 249. Puede especificar si la referencia cruzada deriva de un estilo de párrafo (por ejemplo, un estilo de título) o de un anclaje de texto que haya creado. También puede determinar su formato (por ejemplo, Número de página o Párrafo completo y número de página).

Inserción de referencias cruzadas

Use el panel Referencias cruzadas para insertar referencias cruzadas en el documento. Para abrir el panel, seleccione Ventana > Texto y tablas > Referencias cruzadas.

Panel Referencias cruzadas
A. Haga clic en el indicador visual de color verde para ir al destino. B. Haga clic en el número de página para seleccionar el origen. C. Haga clic en el icono para crear una referencia cruzada. 

El texto al que se hace referencia es el texto de destino. El texto que se genera a partir del texto de destino es la referencia cruzada de origen.

Al insertar una referencia cruzada en un documento, es posible elegir entre varios formatos predeterminados, o bien puede crear su propio formato personalizado. Puede aplicar un estilo de carácter a todo el origen de referencia cruzada, o bien al texto que compone la referencia cruzada. Los formatos de referencia cruzada pueden sincronizarse a lo largo de un libro.

El texto del origen de referencia cruzada es editable y puede contener saltos de línea.

Nota:

los archivos de Adobe PDF exportados incluyen referencias cruzadas si se ha seleccionado Hipervínculo en el cuadro de diálogo Exportar PDF en InDesign. El archivo SWF exportado incluye referencias cruzadas si se ha seleccionado Incluir hipervínculos en el cuadro de diálogo Exportar SWF.

Inserción de referencias cruzadas

A. Párrafo de destino seleccionado B. Haga clic aquí para crear o editar el formato de referencias cruzadas. 
  1. Coloque el punto de inserción en el lugar que desee insertar la referencia cruzada.
  2. Realice una de las siguientes acciones para abrir el cuadro de diálogo Nueva referencia cruzada:

    • Seleccione Texto > Hipervínculos y referencias cruzadas > Insertar referencia cruzada.

    • Seleccione Ventana > Texto y tablas > Referencias cruzadas y, a continuación, elija Insertar referencia cruzada en el menú del panel.

    • Haga clic en el botón Crear nueva referencia cruzada en el panel.

  3. En el cuadro de diálogo, seleccione Párrafo o Anclaje de texto en el menú Vincular a.

    Si selecciona Párrafo, puede crear una referencia cruzada a cualquier párrafo del documento que especifique.

    Si selecciona Anclaje de texto, puede crear una referencia cruzada a cualquier texto en el que haya creado un destino de hipervínculo. (Consulte Creación de un destino de hipervínculo.) Crear un anclaje de texto resulta especialmente útil si desea usar un texto diferente al del párrafo de destino real.

  4. En Documento, seleccione el documento que contenga el destino al que desea hacer referencia. Todos los documentos abiertos guardados aparecen en el menú emergente. Si el documento que está buscando no está abierto, seleccione Explorar, localice el archivo y, a continuación, haga clic en Abrir.
  5. Haga clic en un estilo de párrafo (como Título1) del cuadro situado a la izquierda para desplegar las opciones y, a continuación, seleccione el párrafo al que desea referirse (o, en el caso de que Anclaje de texto esté seleccionado, elija el anclaje de texto).
  6. Seleccione el formato de referencia cruzada que desee utilizar en el menú Formato.

    Puede editar estos formatos de referencia cruzada o crear los suyos propios. Consulte Uso de los formatos de referencia cruzada.

  7. Especifique las opciones de apariencia de PDF para la referencia cruzada.

  8. Haga clic en OK.

Al insertar una referencia cruzada, aparece un marcador de anclaje de texto Puede ver este marcador si selecciona Texto > Mostrar caracteres ocultos. En caso de que este marcador sea desplazado o eliminado, la referencia cruzada queda sin resolver.

Uso de los formatos de referencia cruzada

Por defecto, aparecen varios formatos de referencia cruzada en el cuadro de diálogo Nueva referencia cruzada. Puede editar estos formatos, borrarlos o crear los suyos propios.

Nota:

si ha borrado o editado formatos de referencia cruzada en un documento y desea deshacerlos y volver a los formatos predeterminados, puede seleccionar Cargar formatos de referencia cruzada en el menú del panel y elegir un documento con formatos sin editar. También puede sincronizar formatos de referencia cruzada en un libro.

Creación o edición de formatos de referencia cruzada

A diferencia de otros valores, los formatos de referencia cruzada pueden editarse o eliminarse. Al editar un formato de referencia cruzada se actualizan automáticamente todas las referencias cruzadas de origen que utilicen dicho formato.

  1. Lleve a cabo una de las siguientes acciones:
    • Seleccione Definir formatos de referencia cruzada del menú del panel Referencias cruzadas.

    • Durante la creación o edición de una referencia cruzada, haga clic en el botón Crear o editar formatos de referencias cruzadas .

  2. En el cuadro de diálogo Formatos de referencia cruzada, seleccione una de las siguientes posibilidades:
    • Para editar un formato, seleccione el formato en la parte izquierda.

    • Para crear un formato, seleccione un formato que sirva de base para el nuevo formato y, a continuación, haga clic en el botón Crear formato . Esto crea un duplicado del formato seleccionado.

  3. En Nombre, especifique el nombre del formato.
  4. En el cuadro de texto Definición, añada o elimine texto según sus necesidades. Haga clic en el icono de bloque de creación  para insertar bloques de creación de un menú. Haga clic en el icono de caracteres especiales  para seleccionar guiones, espacios, comillas y otros caracteres especiales.
  5. Para aplicar un estilo de carácter a toda una referencia cruzada, seleccione Estilo de carácter para referencia cruzada y, a continuación, seleccione o cree el estilo de carácter en el menú.

    También puede utilizar el bloque de creación Estilo de carácter para aplicar un estilo de carácter al texto de la referencia cruzada.

  6. Haga clic en Guardar para guardar los cambios. Haga clic en OK cuando haya terminado.

Bloques de creación de referencias cruzadas

Bloque de creación

Descripción

Ejemplo

Número de página

Inserta el número de página.

en la página <pageNum/>

en la página 23

Número de párrafo

Inserta el número de párrafo en una referencia cruzada a una lista numerada.

Consulte <paraNum/>

Consulte 1

En este ejemplo, solo se usa “1” del párrafo, “1. Animales.”

Texto de párrafo

Inserta el texto de párrafo sin el número de párrafo en una referencia cruzada a una lista numerada.

Consulte “<paraText/>”

Consulte “Animales”

En este ejemplo, solo se usa “Animales” del párrafo, “1. Animales.”

Párrafo completo

Inserta el párrafo completo, incluidos el número de párrafo y el texto de párrafo.

Consulte “<fullPara/>”

Consulte “1. Animales”

Párrafo parcial

Permite crear una referencia cruzada a la primera parte de un párrafo, hasta el delimitador especificado, como dos puntos o guión largo.

Consulte <fullPara delim=”:” includeDelim=”false”/>

Consulte el Capítulo 7

En este ejemplo, del título “Capítulo 7: Perros y gatos” solo se utiliza “Capítulo 7”.

Especifique el delimitador (como ":" en este ejemplo) e indique si se excluye (“false” ó “0”) o se incluye (“true” ó “1”) en la referencia cruzada de origen.

Consulte Creación de referencias cruzadas a párrafos parciales.

Nombre de anclaje de texto

Inserte el nombre de anclaje de texto. Puede crear anclajes de texto escogiendo Nuevo destino de hipervínculo del menú del panel Hipervínculos.

Consulte <txtAnchrName/>

Consulte la Figura 1

Número de capítulo

Inserta el número de capítulo.

en el capítulo <chapNum/>

en el capítulo 3

Nombre de archivo

Inserta el nombre de archivo del documento de destino.

en <fileName/>

en newsletter.indd

Estilo de carácter

Aplica un estilo de carácter al texto de una referencia cruzada.

Consulte <cs name=”bold”><fullPara/></cs> en la página <pageNum>.

Consulte Animales en la página 23.

Especifique el nombre de estilo de carácter e incluya el texto al que desee aplicar el estilo de carácter entre las etiquetas <cs name=””> y </cs>.

Consulte Aplicación de estilos de carácter en una referencia cruzada.

Creación de referencias cruzadas a párrafos parciales

Puede diseñar formatos de referencia cruzada para incluir solo la primera parte de un párrafo. Por ejemplo, si el documento cuenta con títulos del estilo “Capítulo 7—De Granada a Barcelona”, puede crear una referencia cruzada que remita únicamente a “Capítulo 7”.

Referencia cruzada a un párrafo parcial

A. El origen de referencia cruzada termina con un guión largo (^_) B. “false” excluye el guión largo del origen 

Al insertar el bloque de creación de párrafo parcial, debe realizar dos cosas. En primer lugar, especifique el delimitador entre comillas. El delimitador es el carácter que marca el final del párrafo. Los delimitadores más comunes son dos puntos (Capítulo 7: Granada), puntos (Capítulo 7. Granada), y guiones (Capítulo 7—Granada). Para insertar caracteres especiales como guión largo (^_), espacio largo (^m) o símbolos de viñeta (^8), seleccione una de las opciones del menú que aparece al hacer clic en el icono de caracteres especiales.

En segundo lugar, indique si el limitador queda excluido (Capítulo 7) o incluido (Capítulo 7 —). Utilice includeDelim=”false” para excluir el delimitador, o bien includeDelim=”true” para incluirlo. En lugar de “false” y “true” puede utilizar “0” y “1” respectivamente.

Aplicación de estilos de carácter en una referencia cruzada

Si desea hacer hincapié en alguna parte del texto de una referencia cruzada, puede utilizar el bloque de creación Estilo de carácter. Este bloque de creación se compone de dos etiquetas. La etiqueta <cs name=”stylename”> indica el estilo que se aplica, mientras que la etiqueta </cs> marca el final del estilo de carácter. Cualquier texto o bloque de creación enmarcado entre estas etiquetas adquiere el formato del estilo especificado por éstas.

Aplicación de un estilo de carácter a una sección de la referencia cruzada

A. Esta etiqueta aplica un estilo de carácter llamado "Rojo".  B. Esta etiqueta marca el final del formato del estilo de carácter. C. El estilo de carácter llamado "Negrita" se aplica al resto del origen de referencia cruzada. 
  1. Cree los estilos de carácter que desee usar.
  2. En el cuadro de diálogo Formatos de referencia cruzada, cree o edite el formato que desee aplicar.
  3. En Definición, seleccione el texto y los bloques de creación a los que desee aplicar el estilo de carácter.
  4. Seleccione el estilo de carácter en el menú que aparece a la derecha de la lista de definiciones.
  5. Escriba entre comillas el nombre del estilo de carácter tal y como aparece en el panel Estilos de carácter.

    Los nombres de estilos distinguen entre mayúsculas y minúsculas. En caso de que el estilo de carácter pertenezca a un grupo, introduzca el nombre del grupo seguido de dos puntos antes del estilo de carácter como, por ejemplo, Grupo de estilos 1: Rojo.

  6. Haga clic en Guardar para guardar el formato y, a continuación, haga clic en OK.

Cargar (importar) formatos de referencia cruzada

Al cargar formatos de referencia cruzada procedentes de otro documento, los formatos de entrada sustituyen a cualquier otro formato que tenga el mismo nombre.

En InCopy, solo es posible importar formatos de referencia cruzada en documentos independientes. No es posible importar formatos desde un documento InCopy a un documento InDesign. En caso de que, al registrar el artículo, el formato nuevo o modificado en InCopy presente algún tipo de problema con un formato del documento InDesign, el formato de InDesign tiene prioridad.

  1. Seleccione Cargar formatos de referencia cruzada en el menú del panel Referencias cruzadas.

  2. Haga doble clic en el documento de que contiene los formatos de referencia cruzada que desea importar.

También puede compartir formatos de referencia cruzada en los documentos sincronizando un libro.

Eliminación de formatos de referencia cruzada

No es posible borrar un formato de referencia cruzada que haya sido aplicado a alguna referencia cruzada del documento.

  1. En el cuadro de diálogo Formatos de referencia cruzada, seleccione el formato que desee borrar.
  2. Haga clic en el botón Eliminar formato .

Administración de referencias cruzadas

Al insertar una referencia cruzada, el panel Referencias cruzadas indica el estado de la referencia cruzada. Por ejemplo, los iconos indican si el texto de destino aparece en la mesa de trabajo , una página maestra , una capa oculta , en texto desbordado o en texto oculto . Las referencias cruzadas que enlazan con dichas áreas de destino quedan sin resolver. El panel permite además saber si el párrafo de destino ha sido editado (también llamado no actualizado) o si no está disponible . El texto de destino no estará disponible en caso de que no sea posible encontrar el texto de destino o el archivo que contiene el texto de destino. Coloque el puntero del ratón sobre cualquier icono para ver una pequeña descripción.

En InCopy, puede administrar las referencias cruzadas únicamente si se ha extraído el artículo para su edición.

Actualización de referencias cruzadas

Un icono de actualización indica que el texto de destino de referencia cruzada ha cambiado o que el texto de dicha referencia cruzada ha sido editado. Puede editar fácilmente la referencia cruzada. Si el destino se mueve a una página diferente, la referencia cruzada se actualiza automáticamente.

Cuando se actualiza una referencia cruzada, se elimina cualquier cambio de formato que haya realizado en el texto de origen.

Al imprimir o al mostrar un documento, se le informará si las referencias cruzadas están sin resolver o desactualizadas.

Nota:

También puede utilizar el panel Comprobación preliminar para recibir notificaciones cuando las referencias cruzadas estén desactualizadas o sin resolver. Al definir un perfil, seleccione Referencias cruzadas en la sección Texto. Consulte Definición de perfiles de comprobación preliminar.

  1. Seleccione una o más referencias cruzadas desactualizadas. Para actualizar todas las referencias cruzadas, asegúrese de que no hay ninguna seleccionada.
  2. Lleve a cabo una de las siguientes acciones:
    • Haga clic en el botón Actualizar referencias cruzadas  del panel Referencias cruzadas.

    • Seleccione Actualizar referencias cruzadas en el menú del panel Referencias cruzadas.

    • Seleccione Texto > Hipervínculos y referencias cruzadas > Actualizar referencia cruzada.

Para actualizar todas las referencias cruzadas de un libro, seleccione Actualizar todas las referencias cruzadas en el menú del panel de libro. Recibirá una notificación en caso de que alguna referencia cruzada quede sin resolver.

Si el texto de destino se ha movido a un documento diferente o si se cambia el nombre del documento que contiene el texto de destino, puede volver a vincular la referencia cruzada. Al volver a vincular, se elimina cualquier cambio realizado sobre la referencia cruzada de origen.

  1. En el panel Referencias cruzadas, seleccione la referencia cruzada que desea volver a vincular.

  2. Seleccione Volver a vincular referencia cruzada en el menú del panel.

  3. Localice el documento en el que aparece el texto de destino y, a continuación, haga clic en Abrir.

Si aparece cualquier otro texto de destino en ese documento, puede volver a vincular referencias cruzadas adicionales.

Edición de referencias cruzadas

Edite la referencia cruzada si desea cambiar la apariencia de la referencia cruzada de origen o especificar un formato diferente. Si edita una referencia cruzada que contiene un enlace a un documento diferente, el documento se abre de manera automática.

  1. Lleve a cabo una de las siguientes acciones:
    • Seleccione Texto > Hipervínculos y referencias cruzadas > Opciones de referencia cruzada.

    • En el panel Referencia cruzadas, haga doble clic en la referencia cruzada que desee editar.

    • Seleccione la referencia cruzada y elija Opciones de referencias cruzadas en el menú del panel Referencias cruzadas.

  2. Edite la referencia cruzada y haga clic en OK.

Eliminación de referencias cruzadas

Al borrar una referencia cruzada, la referencia cruzada de origen se convierte en texto.

  1. En el panel Referencias cruzadas, seleccione las referencias cruzadas que desea eliminar.

  2. Haga clic en el icono Eliminar o seleccione Eliminar referencia cruzada en el menú del panel.

  3. Haga clic en Sí para confirmar.

Para eliminar por completo una referencia cruzada, también puede seleccionar el origen de referencia cruzada y eliminarlo.

Edición del texto de origen de referencia cruzada

Puede editar el texto de origen de una referencia cruzada. La ventaja de editar texto de referencia cruzada reside en que puede cambiar el tracking o el espacio entre palabras según le convenga para encajar el texto, así como para realizar otros cambios. La desventaja consiste en que si actualiza o vuelve a vincular la referencia cruzada, se eliminan todos los cambios de formato local.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea