Problème lors de la création d'une connexion à la base de données : Code d'erreur HTTP 404 Fichier non trouvé (Dreamweaver Developer Toolbox)

Dernière mise à jour le 27 avr. 2021

Problème

Lorsque j'essaie de créer une nouvelle connexion à la base de données Dreamweaver, je reçois un message d'erreur indiquant : Code d'erreur HTTP 404 Fichier non trouvé

Cause

Plusieurs causes peuvent expliquer ce problème :

Le serveur de test n'est pas configuré correctement dans la définition du site Dreamweaver. Dreamweaver tente de charger certains fichiers sur le serveur de test dans le dossier que vous avez indiqué dans la définition du site, puis il essaie de les appeler avec un appel HTTP en utilisant l'URL de base que vous avez fournie. Si les chemins d'accès ne sont pas configurés correctement, vous recevrez cette erreur.
Le serveur web n'est pas en marche sur la machine du serveur de test.
Le serveur proxy tel qu'il est configuré dans le navigateur, est utilisé même pour les adresses locales comme localhost, le serveur de test auquel vous voulez vous connecter.
Votre navigateur est configuré sur « Travailler hors ligne ».

Solution

Vous pouvez essayer plusieurs solutions :

Accédez à la définition de votre site depuis Dreamweaver et vérifiez à nouveau tous les chemins d'accès choisis (dossiers et URL).
Vérifiez le statut du serveur web. Vous pouvez même le redémarrer pour être sûr.
Vous devriez modifier les configurations de votre serveur proxy dans le navigateur pour contourner les adresses locales comme localhost.