ReadMe for Macromedia FreeHand 7 Updater

Version 7.0.2 for Windows 95 and Windows NT

May 1997

==========================================

The FreeHand 7.0.2 Updater fixes a number of problems with FreeHand 7; adds new Xtras for exporting Acrobat PDF documents, Flash graphics, and GIF images; and improves Photoshop 4.0 compatibility.

Table of Contents

=================

Installation Instructions

Updates

Improved Xtras for Acrobat PDF Import and Export

New Flash Export Xtra

Improved Xtra for GIF Image Export

Improved Photoshop 4.0 Compatibility

Installation Instructions

=========================

Apply this updater to an installed FreeHand 7.

NOTE: An earlier updater for FreeHand 7, version 7.0a, has been distributed as-is from Macromedia Technical Support. If the FreeHand 7.0a beta updater for Windows has already been applied, reinstall FreeHand 7 from the original CD-ROM before installing the 7.0.2 updater.

  1. If FreeHand is running, choose File > Exit.
  2. Copy the updater file into the same folder as the FH7.exe application file (default is Program Files\Macromedia\FH7 folder).
  3. Double-click to launch the Fh702up.exe updater file.
  4. Follow the directions on the screen.
  5. When the update is finished, start FreeHand and choose Help> About FreeHand. FreeHand 7.0.2 displays in the dialog box.

On some computers, the new GIF export options are not available after applying the 7.0.2 updater. To fix this problem, exit FreeHand, delete the file named Fh7.mch (located in Program Files\Macromedia\Fh7 folder), and restart FreeHand.

Updates

=======

  • Gradients in EPS files overprint correctly when printed from QuarkXPress or Adobe PageMaker.
  • A problem with printing duplicate spot color plates is fixed.
  • A problem with copying and pasting spot colors with tints to a new FreeHand document is corrected.
  • When text pasted into a FreeHand document was edited, the edits were incorrectly applied to the Clipboard copy of the text. This problem is fixed.
  • PANTONE ProSim colors now print correctly on Canon printers using a Fiery level 2 raster image processor.
  • FreeHand 4/5/5.5 files containing blends with contents pasted inside are now correctly saved in FreeHand 7.
  • Displaying and printing LRG images with dots per centimeter units has been corrected.
  • RGB colors now convert correctly to CMYK when Color Management is turned off.
  • Exporting bitmaps such as BMP, GIF, JPEG, PNG, TIFF, or Targa at certain resolutions caused banding in the resulting image. This problem is corrected.
  • A failed export did not allow the FreeHand document to be saved in the same folder. This problem is fixed.
  • Under specific circumstances in Windows 95, FreeHand 7 caused the printer driver to be uninstalled after printing. This problem is corrected.
  • A system memory problem occurred when the combined use of the Text Toolbar, 24-bit color display properties, and a high-color desktop scheme resulted in uncompleted commands, errors, and sometimes a crash. This problem is fixed.
  • Exporting large bitmaps resulted in an incorrect "out of memory" error message. This problem is corrected.
  • FreeHand printed an extra page on the Hewlett-Packard 4/4M printer, and a PostScript error occurred. This problem is fixed.
  • Subselecting one object behind another object within a group or within a paste inside, using the right mouse button while holding down the Control-Alt keys, now works properly.
  • With FreeHand running, a new file could not be opened either by double-clicking it or dragging it to a FreeHand shortcut on the desktop. This problem is corrected.

Improved Xtras for Acrobat PDF Import and Export

================================================

Updated PDF import and export Xtras provide better results when exporting FreeHand illustrations as PDF documents and importing them back into FreeHand.

The updater installs two new Xtras, called PDFimprt.x32 and PDFexprt.x32, in the Program Files\Macromedia\FH7\Usenglsh\Xtras folder. These files replace the original Xtras.

Improvements

------------

Prior to this update, grouped objects became ungrouped and individual text blocks became multiple text blocks when importing PDFs back into FreeHand. All layering information is now retained when importing a PDF that was created in either FreeHand 7 or Illustrator. Also, files with Tiled fills now export to PDF faster and result in smaller PDF files.

FreeHand can now save more formatting information for groups, layers, and text blocks. By default, the option to include the additional information in the PDF file is turned off.

To include extra formatting in a PDF export:

  1. Choose File > Export.
  2. Click the Options button in the PDF Export dialog box.
  3. Check the Include text formatting option.

Adding more formatting information increases the PDF file size. To exclude this information from the exported PDF file, uncheck the Include text formatting option. Doing so does not affect how the PDF appears when opened in an application other than FreeHand 7 or Illustrator.

Restrictions

------------

Due to limitations with the Adobe PDF file format, there are some restrictions on the formatting retained when importing and exporting PDF files.

  • The option to include the formatting information is only available when importing PDFs created by either FreeHand 7 or Illustrator.
  • FreeHand does not support the Acrobat 3.0 format containing compression. Before importing into FreeHand, PDFs created with Acrobat Distiller 3.0 should either be created in Acrobat 2.1 format or created in Acrobat 3.0 format with all compression options unchecked.

New Flash(TM) Export Xtra

=========================

The Flash Export Xtra exports FreeHand 7 documents to the Flash SWF file format, which can be imported into Flash 2 or viewed with the Shockwave Flash 2 player in either Netscape Navigator or Microsoft Internet Explorer.

The updater installs a new Xtra called Flash.x32 in the Program Files\Macromedia\FH7\Usenglsh\Xtras folder.

Options

-------

To export a FreeHand file in the Flash image format, choose Xtras> Create > Flash Image in FreeHand 7. Click the Options button to display settings for image compression and the number of pages to export.

Image compression

Bitmap images convert to JPEG format on export. Users control the image quality and amount of compression of color JPEG files. Options range from None (high quality, low compression) to Maximum (low quality, high compression).

Pages (Default: All)

When exporting multiple-page documents, FreeHand creates a separate SWF file for each page. Each image is the same size as the page, so exporting a document with different page sizes results in the Flash images of different sizes.

Restrictions

------------

Text

Text is converted to paths on export. Including a large amount of text dramatically increases the size of the resulting SWF file. Of all of FreeHand's text effects, only inline graphics exports to the Flash format. To preview text as it will appear in Flash, we recommend converting text to paths before exporting.

Linked text containers

Linked text containers do not export to the Flash format. We recommend selecting all linked text containers on a page, and then cutting and pasting all the text into one container. The text will export.

URLs

The URL Editor Xtra in FreeHand 7 applies URLs to objects. When exported, the objects become links when displayed in a web browser with Shockwave Flash. Objects lose their links if the image is opened in Flash to be edited.

Colors

All colors are converted to RGB equivalents. Using "web-safe" colors--216 colors that are common to both Macintosh and Windows--in your FreeHand documents ensures consistent color. Grayscale, colorized grayscale, CMYK, and 1-bit images are ignored on export. Indexed 256 color images are converted to RGB on export.

Color Management

FreeHand's Color Management affects colors when exported to the Flash 2 format. For true RGB values on export to Flash 2, choose File > Preferences > Color and set the Monitor simulates preference to None.

Fills and strokes

PostScript and Pattern fills and strokes are converted to Basic fills and strokes. Custom fills, Custom strokes, and Textured fills are not supported in Flash.

Clipping paths and Tiled fills

Flash does not support clipping paths. The contents of a clipping path are exported, but the objects are no longer clipped. Tiled fills, a special type of clipping path, are converted to Basic fills. The tile is discarded.

Other

Grouping, layering information, caps and joins, Encapsulated PostScript (EPS) files, halftones, and styles are ignored.

NOTE: Shockwave FreeHand supports many of the features for viewing FreeHand files that Flash does not support. For the exact representation of a FreeHand document on the web, use the Shockwave FreeHand plug-in available on the FreeHand 7 CD-ROM or on Macromedia's web site at www.macromedia.com.

Improved Xtra for GIF Image Export

===================================

Use the new GIF Import and GIF Export Xtras for more control over the characteristics and size of exported GIF images. These two Xtras replace the older GIF Import Export Xtra.

The updater installs two new Xtras, GIFimprt.x32 and GIFexprt.x32, in the Program Files\Macromedia\FH7\Usenglsh\Xtras folder.

To export a GIF image:

  1. Choose File > Export.
  2. From the Format pop-up, choose GIF.
  3. Click Setup.
  4. In the Bitmap Export Defaults dialog box, click More.
  5. Select any of the available GIF options and click OK.
  6. Click OK.
  7. Type a name for the file, select the destination, and click Export.

NOTE: If the GIF Options dialog box does not display when you click the More button in step 4 (above), exit FreeHand, delete the file named Fh7.mch (located in Program Files\Macromedia\Fh7 folder), and restart FreeHand.

Options

-------

The new GIF Export Xtra adds several new options when exporting GIF images: control over dithering, optional palette settings, and user control of GIF transparency. Make changes to GIF export options in the GIF Options dialog box.

Dither--By default, exported GIF images are dithered so that they better match the colors used in the original object. Uncheck this box to turn off dithering. Undithered GIF files are smaller, but the colors may look different if the original colors are not available in the palette used for export.

Tip: Use dithering when exporting objects containing more than 256 colors, complex blends or gradients, or photographic images.

Palette--Use the Palette pop-up to select the specific set of colors included in the exported GIF image. Using a specific palette:

  • Lowers GIF file size by eliminating unused colors.
  • Prevents color conflicts when creating graphics for use on a web page or in another online medium.

The Palette pop-up choices are:

Exact Palette--When selected, FreeHand creates and includes a color palette for the exported GIF consisting only of the colors used in the selected object.

Web--The Web palette is the standard 216-color palette used by web browsers. This palette includes the 216 colors that are common to both Macintosh and Windows, and are often called web-safe colors. Web palette is the default if the exported image has more than 256 colors.

64 colors, 32 Colors, 16 Colors--These are preset color palettes to quickly export smaller GIFs by constraining the number of colors to a minimum.

NOTE: If the original colors differ from the colors in the preset palettes, FreeHand approximates the colors, sometimes producing inconsistent results.

3-3-2--This palette was the one used by the original FreeHand GIF Import Export Xtra.

Other--FreeHand can export GIFs using Photoshop or xRes palette files. Place the palette file into the Program Files\Common Files\Macromedia\Palettes folder. Then select the installed palette from the Palette pop-up in the GIF Options dialog box to apply it when exporting. Choose Other to browse to a palette file in any folder.

Palette display

The Palette display shows all the colors used in the palette selected in the Palette pop-up. X boxes indicate unused color spaces in the palette. Select any one of the color chips to set the Index of the transparent color for the exported GIF.

Transparency and the Index color

Create a transparent GIF by checking Transparent Background in the GIF Options dialog box. Use the Index color to define which color is transparent in the exported GIF. The Index color appears highlighted in the Palette display, and its Index number in the palette is shown in the Index field. Select a different Index color by clicking any color in the Palette display, or by entering a number into the Index field.

File size of GIF Images

To create smaller GIF files when exporting from FreeHand, use a reduced color palette (such as Exact Palette, 16 colors, 32 colors, or 64 colors) or turn off dithering. Turning off dithering causes the greatest reduction in file size, especially if the exported object is composed primarily of large, flat areas of color as opposed to photographs or 3D models.

Improved Photoshop 4.0 Compatibility

====================================

This update takes advantage of Photoshop 4.0's ability to rasterize any EPS file instead of just Illustrator EPS files, which helps maintain color fidelity between Photoshop and FreeHand. The following have been improved in this update:

  • All of FreeHand 7's Illustrator formats, including Photoshop EPS, now open properly and without error in Photoshop 3.x and Photoshop 4.0.
  • Text no longer causes errors when copied and pasted to Photoshop 4.0.

Exporting objects with RGB colors to Photoshop 4.0

--------------------------------------------------

When exporting an object with RGB colors, export it as a Photoshop 4 RGB EPS. This format best preserves color information when opened and rasterized in Photoshop 4.0. If the object contains any CMYK colors, they are converted to RGB on export. xRes 3 can also use Photoshop 4 RGB EPS.

NOTE: Photoshop 4 RGB EPS files contain RGB colors only, and they are best suited for screen-based media. Printing four-color separations of a Photoshop 4 RGB EPS separates all colors onto the cyan, magenta, and yellow plates only.

Exporting objects with CMYK colors to Photoshop

-----------------------------------------------

When exporting an object with CMYK colors to Photoshop 4.0, export as a Macintosh EPS (Macintosh) or EPS with TIFF preview (Windows).

When exporting an object with CMYK colors to Photoshop 3.x, export as a Photoshop EPS.

Preparing to copy and paste

--------------------------------------------

Export RGB-colored objects to Photoshop 4.0 from FreeHand using copy and paste. RGB color values are preserved when transferring objects in this manner. For best results, set the preference to RGB as follows. A Yes setting converts colors to RGB; a No setting converts colors to CMYK.

  1. Quit FreeHand.
  2. Open the FHprefs.txt preferences file, located in Program Files\Macromedia\FH7, in Notepad or another text editor.
  3. Find the Photoshop4RGBPaste preference.
  4. Change the Photoshop4RGBPaste preference from No to Yes.
  5. Save the file.

Copyright (c) 1997 Macromedia. All rights reserved. FreeHand, Flash, Xtra, and Shockwave are registered trademarks of Macromedia, Inc. All other trademarks are property of their respective owners.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy