在 Dreamweaver 中使用「操作記錄」面板來重播及自動執行步驟。根據操作記錄步驟建立、使用和儲存命令。

註解:

Dreamweaver CC 2017 和更新版本中已不再支援「操作記錄」面板。

工作自動化

「操作記錄」面板會在您完成工作時,記錄您所採取的步驟。您可以從「操作記錄」面板中重播步驟,或建立自動執行步驟的新命令,將經常執行的工作自動化。

某些滑鼠動作 (例如在「文件」視窗中按一下進行選取) 無法重播或儲存。當您進行此類動作時,「操作記錄」面板中會顯示一個黑色行 (此行在您執行另一個動作之後才會變得明顯)。為了避免這種情況發生,在「文件」視窗內移動插入點時,請使用方向鍵而不要使用滑鼠。

有些其他步驟也是無法重複的,例如將頁面元素拖曳到頁面上的其他位置。當您執行此類步驟時,「操作記錄」面板中會顯示包含紅色小 X 的圖示。

儲存的命令會永久保存 (除非您刪除它們),但是錄製的命令則會在您結束 Adobe Dreamweaver 時捨棄,而複製的一系列步驟也會在您複製其他項目時捨棄。

使用操作記錄面板

自建立或開啟文件後,「操作記錄」面板 (「視窗 > 操作記錄」) 便會顯示您在現行文件中所執行的步驟清單 (而非在其他頁框、其他「文件」視窗或「網站」面板中所執行的步驟)。使用「操作記錄」面板可以一次還原多個步驟,並將工作自動化。

操作記錄面板
操作記錄面板

A. 滑動軸 (指標) B. 步驟 C. 重播按鈕 D. 複製步驟按鈕 E. 另存新檔命令按鈕 

在「操作記錄」面板中,滑動軸或縮圖一開始會指向您執行過的上一個步驟。

註解:

您無法重新排列「操作記錄」面板中步驟的順序。不要將「操作記錄」面板想像成任意的命令集合;而要想成是檢視所執行步驟的一種方法,並且是以您執行它們時的順序來檢視。

還原最後一個步驟

  1. 請執行下列其中一項作業:
    • 選取「編輯>還原」。

    • 將「操作記錄」面板滑動軸拖曳到清單中的上一個步驟。

    註解:

    若要自動捲動到某個特別步驟,您必須按一下到步驟的左邊;按一下步驟本身的動作就會選取該步驟。在還原操作記錄中,選取某個步驟與返回該步驟是不同的。

一次還原多個步驟

  1. 拖曳滑動軸以指向任一個步驟,或沿著滑動軸的路徑,按一下該步驟的左邊。

    滑動軸會自動捲動至該步驟,並在捲動時還原那些步驟。

    註解:

    就像還原單一步驟一樣,如果您還原一系列的步驟,再於文件中執行某個新步驟,將無法再重做那些已還原的步驟;它們會從「操作記錄」面板中消失。

設定操作記錄面板會保留及顯示的步驟數目

對於大部分的用戶來說,預設的步驟數目已能夠符合他們的需求。步驟的數目越多,「操作記錄」面板所需的記憶體也越多,這樣將會影響效能並使電腦明顯變慢。

  1. 選取「編輯 > 偏好設定」(Windows) 或「Dreamweaver > 偏好設定」(Macintosh)。
  2. 從左邊的「分類」清單中選取「一般設定」。
  3. 為「操作記錄步驟的上限」輸入一個數目。

    當「操作記錄」面板達到這個步驟數目上限時,會將最早的步驟捨棄。

清除目前文件的操作記錄清單:

  1. 在「操作記錄」面板的快顯選單中,選取「清除操作記錄」。

    這個命令也會清除目前文件的所有還原資訊;在選擇「清除操作記錄」之後,您便無法還原已清除的步驟。「清除操作記錄」不會還原步驟;它只會將這些步驟的記錄從記憶體中移除。

重複步驟

使用「操作記錄」面板可重複您執行的最後一個步驟、重複一系列相鄰的步驟,或重複一系列不相鄰的步驟。請直接從「操作記錄」面板中重播這些步驟。

重複一個步驟

  1. 請執行下列其中一項作業:
    • 選取「編輯>重做」。

    • 在「操作記錄」面板中,選取一個步驟並按一下「重新執行」按鈕。此步驟會重新執行,在「操作記錄」面板中也會出現一個複本。

重複一系列步驟

  1. 在「操作記錄」面板中選取步驟:
    • 若要選取相鄰的步驟,請從一個步驟拖曳到另一個步驟 (請勿拖曳滑動軸;只需從一個步驟的文字標籤拖曳到另一個步驟的文字標籤),或是選取第一個步驟,並且 Shift+按一下最後一個步驟。

    • 若要選取不相鄰的步驟,請先選取一個步驟,然後 Control+按一下 (Windows) 或 Command+按一下 (Macintosh) 以選取或取消選取其他步驟。

      所播放的步驟就是選取 (標示) 的步驟,並不一定是目前滑動軸所指向的步驟。

    註解:

    雖然您可以選取包含黑色行 (表示無法記錄的步驟) 的一系列步驟,但是當您重播這些步驟時,便會略過該步驟。 

  2. 按一下「重新執行」。

    步驟會依序重新執行,而且在「操作記錄」面板中會出現一個標記「重新執行步驟」的新步驟。

選取或延伸選取範圍

  1. 按方向鍵的同時,請按住 Shift 鍵。

    註解:

    當您在執行稍後要重複的工作時,如果出現黑色的滑鼠動作指標行,您可以還原至該步驟之前的步驟,然後嘗試另一個方法,例如使用方向鍵。

將操作記錄面板中的步驟套用至物件

您可以從「操作記錄」面板將一組步驟套用至「文件」視窗中的任何物件。

如果您選取多個物件,然後從「操作記錄」面板中將步驟套用至這些物件,則這些物件會被視為單一的選取範圍,而且 Dreamweaver 會嘗試將步驟套用至此組合的選取範圍;不過,您也可以一次只將一組步驟套用到單一物件。

若要將步驟套用至物件組中的每個物件,您必須讓該系列中的最後一個步驟選取物件組中的下一個物件。第二個程序將示範在特定情況下的這項原則:設定一系列影像的垂直和水平間距。

將步驟套用至另一個物件

  1. 選取物件。
  2. 在「操作記錄」面板中選取相關步驟,然後再按一下「重播」。

將步驟套用至多個物件

  1. 從每行包含小型影像 (如圖形項目符號或圖示)、後接文字的文件開始著手。

    目標是將影像與文字分開,並與它們上方及下方的其他影像分開。

    每行包含小型影像
    每行包含小型影像

  2. 開啟「屬性」檢視窗 (如果尚未開啟的話,請選取「視窗 > 屬性」)。
  3. 選取第一個影像。
  4. 在「屬性」檢視窗中,請於「垂直距離」和「水平距離」方塊中輸入數字,以設定影像的間距。
  5. 再按一下影像,讓「文件」視窗呈作用中狀態,但是不移動插入點。
  6. 按向左鍵將插入點移到影像的左邊。
  7. 按向下鍵,將插入點向下移動一行,停留在該系列中第二個影像左邊的位置。
  8. 按 Shift+向右鍵,選取第二個影像。

    註解:

    不要用按一下的方式來選取影像,否則您將無法重播所有步驟。

  9. 在「操作記錄」面板中,選取對應到變更影像間距和選取下一個影像的步驟。按一下「重新執行」,即可重新執行那些步驟。
    按一下「重播」即可重播步驟
    按一下「重播」即可重播步驟

    目前影像的間距就會變更,並選取下一個影像。

    目前影像的間距變更
    目前影像的間距變更

  10. 繼續按一下「重新執行」,直到所有影像間距都正確為止。

在文件間複製和貼上步驟

每個開啟的文件都有自己的步驟操作記錄。您可以從某個文件複製步驟,再將它們貼到另一個文件中。

關閉文件會清除它的操作記錄。如果您知道稍後將需要使用某個文件中的步驟,請在關閉該文件之前,先複製或儲存那些步驟。

  1. 在包含所要重複使用之步驟的文件中,選取「操作記錄」面板中的這些步驟。
  2. 按一下「操作記錄」面板中的「複製步驟」

    註解:

    「操作記錄」面板中的「複製步驟」按鈕與「編輯」選單中的「複製」命令是不同的。雖然您的確是使用「編輯>貼上」來貼上步驟,但是卻無法使用「編輯>複製」來複製步驟。

    在複製包括「複製」或「貼上」命令的步驟時必須特別小心:

    • 如果其中一個步驟是「複製」命令,請勿使用「複製步驟」;您可能無法依照想要的方式來貼上此類步驟。

    • 如果步驟包括「貼上」命令,則您無法貼上這些步驟,除非在「貼上」命令之前也包括「複製」命令。

  3. 開啟另一個文件。
  4. 將插入點放在所要的位置,或選取要套用這些步驟的物件。
  5. 選取「編輯>貼上」。

    當步驟貼到文件的「操作記錄」面板中時,便會播放這些步驟。「操作記錄」面板會將它們顯示為一個步驟,叫做「貼上步驟」。

    如果您將步驟貼到文字編輯器,或是「程式碼」檢視或「程式碼」檢視窗中,則它們會顯示為 JavaScript 程式碼。這對於學習如何撰寫自己的 Script 是很好用的。

從操作記錄步驟中建立和使用命令

將一組操作記錄步驟儲存成具名的命令,然後它就會變成「命令」選單中可用的命令。如果您可能再使用某一組步驟,特別是在下次啟動 Dreamweaver 時,請建立並儲存新的命令。

建立命令

  1. 在「操作記錄」面板中選取一個步驟或一組步驟。
  2. 按一下「儲存成命令檔」按鈕,或是從「操作記錄」面板的快顯選單中選取「儲存成命令檔」。
  3. 輸入命令的名稱,並按一下「確定」。

    命令便會出現在「命令」選單中。

    註解:

    此命令會在您的 Dreamweaver/Configuration/Commands 資料夾中儲存成 JavaScript 檔 (有時會儲存成 HTML 檔)。如果您在多用戶的作業系統上使用 Dreamweaver,則該檔案會儲存在特定用戶的 Commands 資料夾中。

使用儲存的命令

  1. 選取要套用命令的物件,或將插入點放在所要套用命令的位置。
  2. 從「命令」選單中選取命令。

編輯命令名稱

  1. 選取「命令>編輯命令清單」。
  2. 選取要重新命名的命令,並為它輸入新名稱,然後按一下「關閉」。

從命令選單中刪除名稱

  1. 選取「命令>編輯命令清單」。
  2. 選取命令。
  3. 按一下「刪除」,然後按一下「關閉」。

錄製和儲存命令

請錄製暫時的命令以供短期使用,或是錄製並儲存命令以供稍後使用。Dreamweaver 一次只會保留一個錄製的命令;只要您開始錄製新的命令,舊的命令便會消失,除非您在錄製新命令之前先儲存舊的命令。

暫時錄製一系列步驟

  1. 選取「命令>開始錄製」,或按 Control+Shift+X 鍵 (Windows) 或 Command+Shift+X 鍵 (Macintosh)。

    指標便會變更,指示您正在錄製命令。

  2. 錄製完成時,請選取「命令>停止錄製」,或按 Control+Shift+X 鍵 (Windows) 或 Command+Shift+X 鍵 (Macintosh)。

播放錄製的命令

  1. 選取「命令 > 執行預先錄製的命令」。

儲存錄製的命令

  1. 選取「命令>執行預先錄製的命令」。
  2. 選取顯示在「操作記錄」面板的步驟清單中的「執行命令」步驟,然後按一下「儲存成命令檔」按鈕。
  3. 輸入命令的名稱,並按一下「確定」。

    命令便會出現在「命令」選單中。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策