Sync Settings in Premiere Pro

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
    3. Features in Beta
      1. New import & export in Premiere Pro (Beta)
      2. FAQ | New import and export in Premiere Pro (Beta)
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Creating projects
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. Working with Panels
    3. Windows touch and gesture controls
    4. Use Premiere Pro in a dual-monitor setup
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transferring and importing files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Editing, repairing and improving audio using Essential Sound panel
      5. Monitor clip volume and pan using Audio Clip Mixer
      6. Audio balancing and panning
      7. Advanced Audio - Submixes, downmixing, and routing
      8. Audio effects and transitions
      9. Working with audio transitions
      10. Apply effects to audio
      11. Measure audio using the Loudness Radar effect
      12. Recording audio mixes
      13. Editing audio in the timeline
      14. Audio channel mapping in Premiere Pro
      15. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Create titles and motion graphics
      2. Applying text gradients in Premiere Pro
      3. Using Motion Graphics templates for titles
      4. Replace images or videos in Motion Graphics templates
      5. Use data-driven Motion Graphics templates
      6. Best Practices: Faster graphics workflows
      7. Add Responsive Design features to your graphics
      8. Working with captions
      9. Speech to Text
      10. Speech to Text in Premiere Pro | FAQ
      11. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  11. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  12. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Get creative with color using Lumetri looks
    3. Adjust color using RBG and Hue Saturation Curves
    4. Correct and match colors between shots
    5. Using HSL Secondary controls in the Lumetri Color panel
    6. Create vignettes
    7. Looks and LUTs
    8. Lumetri scopes
    9. Display Color Management
    10. HDR for broadcasters
    11. Enable DirectX HDR support
  13. Exporting media
    1. Workflow and overview for exporting
    2. Quick export
    3. Exporting for the Web and mobile devices
    4. Export a still image
    5. Exporting projects for other applications
    6. Exporting OMF files for Pro Tools
    7. Export to Panasonic P2 format
    8. Exporting to DVD or Blu-ray Disc
    9. Best Practices: Export faster
  14. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  15. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Using Productions
    8. How clips work across projects in a Production
    9. Consolidate, transcode, and archive projects
    10. Managing metadata
    11. Best Practices
      1. Best Practices: Working with Productions
      2. Best Practices: Learning from broadcast production
      3. Best Practices: Working with native formats
  16. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Green and pink video in Premiere Pro or Premiere Rush
      2. How do I manage the Media Cache in Premiere Pro?
      3. Fix errors when rendering or exporting
      4. Troubleshoot issues related to playback and performance in Premiere Pro
  17. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

 

Learn how to quickly sync files and folders, custom Premiere Pro preferences, keyboard shortcuts, and presets between your desktop and Creative Cloud.

Note:

Sync Settings in video applications

Effective with the December 10 2018 release (Premiere Pro 13.0.2), the Sync Settings architecture has been updated. This means some changes to the workflow for Premiere Pro, After Effects, and Media Encoder:

  • The option to clear Sync Settings via Creative Cloud is no longer available (previously accessed through Manage Creative Cloud Account). 
  • Sync Settings are available in current and recent versions of Premiere Pro:
    • Select Sync Settings from the Start screen on macOS and Windows.
    • Within the application on Windows you can also select File > Sync Settings. On macOS select the Premiere Pro menu and then either Sync Settings (if there are currently no synced settings) or your Creative Cloud account email (if you have existing synced settings).
  • Sync Settings are no longer available in Premiere Pro CC 2015 (9.0.2) or older. To use Sync Settings, please update to a more recent version.

For information on sync settings in After Effects and Media Encoder, see:

When you work with Adobe® Premiere® Pro on multiple machines, managing and syncing preferences, presets, and libraries between them can be time-consuming, complex, and error-prone.

The new Sync Settings feature lets you sync your general preferences, keyboard shortcuts, presets, and libraries to the Creative Cloud. For example, if you use more than one computer, the Sync Settings feature helps keep settings synchronized across machines.

You can also download and use settings on a computer that contains a copy of the software licensed to a different user. This feature lets multiple users work with their own personal settings on the same computer. For example, freelance editors working during different shifts in a post-production facility.

You can sync using your Adobe Creative Cloud account. The settings get uploaded to your Creative Cloud account and then get downloaded and applied on the other computer. After the settings are applied on the other computer, initiate the sync manually. This does not happen automatically, and it cannot be scheduled.

Sync Settings using Adobe Creative Cloud

Initiating Sync

On first launch, you can initiate the sync by selecting Sync Settings from the Start screen. Or you can select File > [your Adobe ID] > Sync Settings Now (Windows) or Premiere Pro > [your Adobe ID] > Sync Settings Now (macOS).

The Adobe ID associated with the product's license is used to identify the user. If you haven't already created and uploaded settings for this application, the local settings are uploaded to the cloud by default.

Note:

Before initiating sync, ensure that you have upgraded the Creative Cloud desktop application to the latest version and you are logged in with your Adobe ID.

Edit collaborators
Edit collaborators

Sync settings from a different account

You can choose to sync the settings from a different Adobe ID instead of the Adobe ID associated with the product license used on the computer you're working on.

To use a different Adobe ID to sync the settings, select Use Settings From a Different Account from the Start screen. Or select File > [your Adobe ID] > Use Settings From a Different Account.

Enter the Adobe ID and password. The settings for that Creative Cloud account are downloaded and applied, and the user name appears in the Start Screen.

Managing Sync

Clear Settings

You can clear all settings and revert to default settings. Select Edit > [your Adobe ID] > Clear Settings.

Note:

If you select Clear Settings while a project is open, Premiere Pro saves and closes the current project to proceed.

Specify Sync preferences, and manage sync conflicts

Setting Sync preferences
Setting Sync preferences

The Preference dialog box lets you specify the sync setting options. For example, you can choose to have only keyboard shortcuts stored in the Creative Cloud, and not sync the other preferences and settings on a computer.

The Preference dialog box also lets you choose what to do when a sync conflict occurs.

Sync settings

To specify what gets synchronized, Select File > [your Adobe ID] > Manage Sync Settings. Or open Sync Settings in the Preferences dialog box (Edit > Preferences > Sync Settings).

Note:

To sync your settings successfully, change the settings only from within the application. The sync settings feature does not sync files manually placed in the preferences folder location.

Select the options to sync preferences and settings. Synchronizable preferences are not dependent on computer or hardware settings.

  • Preferences/Settings
  • Workspace Layouts
  • Keyboard Shortcuts
Note:

Keyboard shortcuts created for Windows only sync with a Windows computer. Mac OS keyboard shortcuts only sync with a Mac OS computer.

When Syncing

When you initiate a sync, the modification date between the local settings and the settings stored in the Creative Cloud is compared. If modification dates do not match, a sync conflict is detected.

You can specify what action to take when a sync conflict occurs by selecting from the following:

  • Ask My Preference
  • Always Upload Settings
  • Always Download Settings

When you select Ask My Preference, the Sync Settings dialog opens, prompting you to upload or download your settings.

Sync settings
Sync settings

Upload Settings: Syncs settings from your computer to Creative Cloud.

Download Settings: Syncs settings from Creative Cloud to your computer, overwriting the local version with the Creative Cloud version of settings.

Automatically clear settings on application quit

Select this preference option to clear the sync settings every time you quit Premiere Pro. On next launch, the default settings are used.

Auto-save projects to Creative Cloud

Your Adobe Creative Cloud account comes with online storage that makes your files available to you anywhere and on any device or computer.

Premiere Pro lets you auto-save your projects directly to your Creative Cloud-based storage, letting you save backups of your projects to a secure and accessible storage environment.

Choose Auto Save in the Preferences dialog, and select Save Backup Project To Creative Cloud.

When Premiere Pro auto-saves a project, a directory named "auto-save" is created in your Creative Cloud online storage. All the backed-up projects are stored in the "auto-save" directory.

You can access your backed-up projects from the Files tab of your Creative Cloud desktop application. Or you can access the files from your Creative Cloud account on the Web.

Migrate Sync Settings  

Each major version of Premiere Pro has its own copy of settings files. For example, Premiere Pro CC 7.x uses a "7.0" directory to store the settings file while the 2014 version of Premiere Pro CC uses a "8.0" directory.

When you upgrade to the latest version from Premiere Pro CC 7.x, your sync settings are automatically migrated to the new version.

Select Sync Settings or Use Settings From A Different Account from the Start screen or the File > Sync Settings menu. All the settings files from the "7.0" directory are automatically copied to the "8.0" directory.

Important notes:

  • The "8.0" directory is created on the Creative Cloud server only after you sync settings for the first time. When you sync settings for the first time, you can notice a delay in syncing because all the settings from the “7.0’ directory are copied to the “8.0” directory.
  • Before you customize any local settings like adding new keyboard shortcuts or workspaces, sync your settings at least once on one of your computers. Doing so ensures that you don’t lose any changes to your settings during auto-migration of settings from the previous version.
Adobe logo

Sign in to your account