Get to know the RoboHelp workspace

Learn about the key workspace elements of Adobe RoboHelp (2020 release).

Packed with tons of powerful features, Adobe RoboHelp offers you a thoughtfully designed, clean, and easy-to-use workspace. Quickly create content with all the elements you need, build efficiency with single-sourcing and content reusability, and publish your project in a desired output type. You can also collaborate with multiple authors in a project.

The menu bar provides access to the File, Edit, View, Insert, Collaborate, and Help menus.

File menu Create, open, save, and close a project. You can also find options to import Word document and Captivate video, upgrade RoboHelp Classic project, configure project settings, and exit project.

Edit menu Cut, copy, paste, undo, and redo content. You can also find options to select all, copy and clear formatting, and edit application preferences.

View menu Find options to view Properties panel, starter screen, condition tags, variables, and view topics by title. You can also view options to Toggle Full Screen and change the application theme.

Insert menu Insert an image, video file, YouTube url, bookmark, variable, snippet, and many more. This a contextual menu option.

Collaborate menu You can find options to add and open connections to share your project for collaboration in a multi-author system.

Help menu You can find options to access Help resources, manage your account, sign out from RoboHelp, update your application, and view the RoboHelp About dialog box.

Menu bar
Menu bar

RoboHelp stores application-related settings on your local computer. To configure application-related settings, go to the Edit menu and select the Preferences to change the Application Settings.

For more information, see Set application preferences.

Tha Author, Output, and Review views are three different workspaces and can be accessed through respective tabs in the standard toolbar. The Author view is used to write, modify, and format the content for topics that the users see in the output. In addition to writing content, you can also work with Index, Glossary, Table of Contents. etc. in topics and master pages.

Author view
Author view

In Output View, there are various components to set up your Output formats e.g., Skins, Map Files, Variable Sets, Dynamic Content Filters, etc. To configure and use these components, create and use various Web-based and Print-based Output Presets. Output presets are easy-to-configure; you can use the many settings to generate and publish multiple output formats.

Publish view
Publish view

In the Review tab, you can share content with other authors, Subject Matter Experts (SMEs), and others. You can also share content individually or to a group, so that each individual can see comments and edits made by others.

For more information, see Reviews in RoboHelp.

Review tab
Review tab

The left toolbar helps you to easily manage your project by accessing various components of your project, such as Contents, Table of Contents, Condition Tags, Variables, Snippets, Reports, and more.

Left toolbar
Left toolbar

When you click a project component on the Author toolbar, the project component panel opens and allows you to manage that component. You can find the following project components in the Author toolbar:

  • Contents panel This panel lists the topics in a project and provides options to add, rename, and edit topic properties. You can also create folders and subfolders to organize the topics. To know more about how to work with topics, see Work with topics and folders.
  • Table of Contents panel This includes the hierarchy of the folders, subfolders, and topics in a project. You can reorder the folders and organize your content in a strategic manner for easy user navigation in your output. You can edit, rename, and delete a Table of Contents. To know more, see Create, edit, and format a Table of Contents.
  • Index panel This panel lists the index in your project. You can add, rename, edit, and delete an index. To know more, see Create and manage an index.
  • Glossary panel Lists the glossary terms in your project. You can add, edit, rename, or delete a glossary item. To know more, see Create and manage a glossary.
  • Condition Tags panel This panel lists the assigned condition tags in your project. You can add, edit, and delete a conditional tag. To know more, see Create and apply condition tags.
  • Variables panel This panel displays all the variables that are assigned values in your project. You can add, edit, or delete a variable. To know more, see Create and use variables for easy updates.
  • Snippets panel This panel displays the snippets in your project. You can create, edit, or delete snippets. To know more, see Work with snippets.
  • Master Pages panel This panel displays the master pages in your project. You can create, edit, duplicate, delete, import, or export master pages. To know more, see Work with master pages.
  • Browse Sequences panel This panel displays the browse sequences in your project. You can create, edit, rename, or delete browse sequences. To know more, see Create and manage browse sequences.
  • Reports panel Includes options to generate reports such as Topic List, Project Status, Variables, Condition Tags, Broken links, and more. You can edit, download, and print a desired report. To know more about reports, see Generate reports.

Double-click a topic in the Contents panel to open a topic. You can then edit and format content in your topic. To know more about topics, see Work with topics and folders.

While authoring a topic in a project, the panel displayed on the right side of the screen is the Properties panel. This panel contains the following tabs:

  • Content properties panel: You can find options to edit font, alignment, border, layout, and background. To know more, see Format your content.
Use the tabs in the Properties panel to edit content properties.
Contet properties panel

  • Topic properties panel: You can find options to edit topic properties. To know more, see Topic properties.
Topic properties panel
Topic properties panel

  • Styles panel: You can find options to list various types of styles such as paragraph style, character style, hyperlink style, and more. On this panel, you can:
    • List styles by name: On the Styles panel, toggle between listing the available styles by name or preview.
    • Filter styles by category: Select from the drop-down to filter and list styles by categories like Headings, Paragraphs, Lists, Tables, and so on. This is convenient if you want to see all the heading styles.
Styles panel
Styles panel

  • Spell check panel: You can run the spell checker in the current topic, all topics, or all the project files. You can also navigate to the preferences and set the dictionary and stop words. For more information, see Spell checks in RoboHelp.
Spell check panel
Spell check panel

The Standard toolbar appears below the menu bar and includes three toolsets:

  • The first toolset is a set of tabs and icons at the left side of the standard toolbar. This includes Author and Output tabs, and Save All, Undo, Redo, Find Files, and Find and Replace icons. 
  • The second toolset is the set of icons at the center of the standard toolbar. This contains various options to quickly format content such as inserting bulleted and numbered lists, images, multimedia, and more. To know more, see Format your content.
  • The last toolset is the set of icons at the right side of the standard toolbar. This contains various view options such as Author, Source, and Preview. It also includes Quick Generate. The Quick Generate dialog box allows you to select and configure an output preset of your choice and generate your output. To know more about generating output, see Generate output.
The three toolsets in the Standard toolbar.
The three toolsets in the Standard toolbar.

There are many dialog boxes that you will come across while working with RoboHelp. The most commonly used are:

  • Special Character Dialog The Special Character dialog offers hundreds of characters that you can insert into your content. To know more, see Work with special characters.
  • Hyperlink Dialog The Hyperlink dialog helps to create a navigation link. When an end user clicks the hyperlink in the output, the location specified in the hyperlink opens. To know more, see Open, Edit and Remove Hyperlinks
  • Image Dialog  RoboHelp supports standard image formats such as GIF, JPEG, BMP, MRB, WMF, PNG, etc. To know more, see Work with images and multimedia.
הערה:

You can easily resize the dialog boxes by clicking the edge and dragging the mouse to the desired size. 

הערה:

You can also drag-and-drop the dialog boxes around in topics. The next time you re-open the dialog box, its last position is retained to the place before you closed the dialog box.

The context menu gives people access to additional functionality related to the components in the Author, Output, and Review tabs. When you right-click or hover over the  icon on any of the components in the content panel, a context menu with a nested list opens and immediately displays the relevant commands. From the list, you can select from several options to take action on the content associated with that particular component.

Context menu
Context menu

The RoboHelp menu bar provides various navigational controls in the authoring area. For example, zoom controls, rulers, and so on.

Zoom in and out

  • To zoom a topic, Click the “View” menu in the menu bar and select Zoom. Then select the desired percentage between 25% to 500% from the Zoom sub-menu.
  • To set the document zoom to 100%, Click the Zoom sub-menu and select “100%”. Alternatively, press CTRL+0.
            Note: If you have zoomed in or out in your topic, you can press CTRL+0 on your keyboard to return the view to 100%.
  • To increase or decrease the magnification, Select Zoom In or Zoom Out from the View menu. Alternatively, press CTRL+= (that's a plus sign) to increase the zoom level and to zoom out again, press CTRL+- (that's a minus sign).
           Note: You can also hold the CTRL key on your keyboard and scroll the mouse wheel to zoom in and out.

Rulers

Rulers provide a quick way to control and set margins for paragraphs, images, tables, text, and other elements in your topic and appear horizontally at the top of the editor. To turn the display of the ruler on and off, select View > Show > Rulers

  • Measurement units By default, the Measurement unit for the ruler is set to Inch (in). To change the unit of measure, such as  Centimeter (cm), Pica (pc), Point (pt), and Pixel (px),  right-click the ruler and choose a new unit from the context menu that appears.
    Note: These settings control the units of measurement used throughout RoboHelp.
  • Change margins Margins are indicated on the rulers by grey and white areas. The grey areas at either end of the ruler represent the parent area, while the white areas represent your authoring area. You can quickly adjust the margin inside the white area by sliding the little inverted triangle on the ruler.
לוגו של Adobe

כניסה לחשבון