Guida utente Annulla

Scaricamento e caricamento dei file da e verso il server

  1. Guida utente di Dreamweaver
  2. Introduzione
    1. Nozioni di base sul design responsive
    2. Novità di Dreamweaver
    3. Sviluppo Web con Dreamweaver - Panoramica
    4. Dreamweaver / Domande frequenti
    5. Scelte rapide da tastiera
    6. Requisiti di sistema di Dreamweaver
    7. Riepilogo delle funzioni
  3. Dreamweaver e Creative Cloud
    1. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    2. Creative Cloud Libraries in Dreamweaver
    3. Utilizzare i file Photoshop in Dreamweaver
    4. Operazioni con Adobe Animate e Dreamweaver
    5. Estrarre file SVG ottimizzati per il Web da Libraries
  4. Aree di lavoro e viste di Dreamweaver
    1. Area di lavoro di Dreamweaver
    2. Ottimizzare l'area di lavoro di Dreamweaver per lo sviluppo visivo
    3. Eseguire ricerche nei file in base al nome file o al contenuto | Mac OS
  5. Configurare i siti
    1. Siti di Dreamweaver
    2. Configurare una versione locale del sito
    3. Collegamento a un server di pubblicazione
    4. Configurare un server di prova
    5. Importare ed esportare le impostazioni di un sito Dreamweaver
    6. Passaggio di siti Web esistenti da un server remoto alla cartella principale del sito locale
    7. Funzioni di accessibilità in Dreamweaver
    8. Impostazioni avanzate
    9. Impostazione delle preferenze del sito per il trasferimento dei file
    10. Specificare le Impostazioni del server proxy in Dreamweaver
    11. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    12. Utilizzo di Git in Dreamweaver
  6. Gestire i file
    1. Creare e aprire file
    2. Gestire file e cartelle
    3. Scaricamento e caricamento dei file da e verso il server
    4. Depositare e ritirare i file
    5. Sincronizzare i file
    6. Confrontare file per verificare le differenze
    7. Applicare la maschera file a file e cartelle del sito Dreamweaver
    8. Attivare le Design Notes per i siti di Dreamweaver
    9. Impedire un potenziale attacco exploit del Gatekeeper
  7. Layout e progettazione
    1. Usare i riferimenti visivi per il layout
    2. Informazioni sull'utilizzo di CSS per creare il layout della pagina
    3. Progettazione di siti Web reattivi con Bootstrap
    4. Creazione e utilizzo di media query in Dreamweaver
    5. Presentare il contenuto mediante le tabelle
    6. Colori
    7. Responsive design con i layout a griglia fluida
    8. Extract in Dreamweaver
  8. CSS
    1. Nozioni sui fogli di stile CSS
    2. Creazione del layout delle pagine con CSS Designer
    3. Utilizzare i preprocessori CSS in Dreamweaver
    4. Impostare le preferenze di stile CSS in Dreamweaver
    5. Spostare le regole CSS in Dreamweaver
    6. Convertire CSS in linea in una regola CSS in Dreamweaver
    7. Utilizzare i tag div
    8. Applicare sfumature allo sfondo
    9. Creare e modificare effetti di transizione CSS3 in Dreamweaver
    10. Formattazione del codice
  9. Contenuto e risorse delle pagine
    1. Impostare le proprietà di pagina
    2. Impostare le proprietà dei collegamenti CSS e le proprietà dei collegamenti CSS
    3. Lavorare con il testo
    4. Ricercare e sostituire testo, tag e attributi
    5. Pannello DOM
    6. Modifica nella vista Dal vivo
    7. Codifica dei documenti in Dreamweaver
    8. Selezionare e visualizzare gli elementi nella finestra del documento
    9. Definire le proprietà del testo nella finestra di ispezione Proprietà
    10. Eseguire il controllo ortografico di una pagina Web
    11. Utilizzo dei filetti orizzontali in Dreamweaver
    12. Aggiungere e modificare le combinazioni di caratteri in Dreamweaver
    13. Operazioni con le risorse
    14. Inserire e aggiornare le date in Dreamweaver
    15. Creare e gestire le risorse preferite in Dreamweaver
    16. Inserire e modificare le immagini in Dreamweaver
    17. Aggiungere oggetti multimediali
    18. Aggiunta di video in Dreamweaver
    19. Inserire video HTML5
    20. Inserire file SWF
    21. Aggiungere effetti audio
    22. Inserire l'audio HTML5 in Dreamweaver
    23. Operazioni con le voci di libreria
    24. Utilizzare testo in arabo e in ebraico in Dreamweaver
  10. Collegamenti e navigazione
    1. Informazioni sui collegamenti e sulla navigazione
    2. Collegamenti
    3. Mappe immagine
    4. Risoluzione dei problemi di collegamenti
  11. Widget ed effetti jQuery
    1. Utilizzare i widget jQuery UI e Mobile in Dreamweaver
    2. Usare effetti jQuery in Dreamweaver
  12. Programmazione dei siti Web
    1. Programmazione in Dreamweaver
    2. Ambiente di codifica in Dreamweaver
    3. Impostare le preferenze di codifica
    4. Personalizzare la colorazione del codice
    5. Scrivere e modificare codice
    6. Suggerimenti sul codice e completamento del codice
    7. Comprimere ed espandere codice
    8. Riutilizzo del codice con gli snippet
    9. Comando Lint
    10. Ottimizzare il codice
    11. Modificare il codice nella vista Progettazione.
    12. Utilizzo del contenuto dell'intestazione delle pagine
    13. Inserimento di server-side include in Dreamweaver
    14. Uso delle librerie di tag in Dreamweaver
    15. Importazione di tag personalizzati in Dreamweaver
    16. Utilizzare i comportamenti JavaScript (istruzioni generali)
    17. Applicare comportamenti JavaScript incorporati
    18. Informazioni su XML e XSLT
    19. Eseguire trasformazioni XSL server-side in Dreamweaver
    20. Esecuzione di trasformazioni XSL client-side in Dreamweaver
    21. Aggiungere entità di carattere per XSLT in Dreamweaver
    22. Formattazione del codice
  13. Flussi di lavoro di interazione con altri prodotti
    1. Installazione e uso delle estensioni in Dreamweaver
    2. Aggiornamenti in app in Dreamweaver
    3. Inserire documenti Microsoft Office in Dreamweaver (solo Windows)
    4. Operazioni con Fireworks e Dreamweaver
    5. Modificare il contenuto nei siti Dreamweaver mediante Contribute
    6. Integrazione tra Dreamweaver e Business Catalyst
    7. Creare campagne e-mail personalizzate
  14. Modelli
    1. Informazioni sui modelli di Dreamweaver
    2. Riconoscere i modelli e i documenti basati sui modelli
    3. Creare un modello di Dreamweaver
    4. Creare aree modificabili nei modelli
    5. Creare aree e tabelle ripetute nei modelli in Dreamweaver
    6. Usare le aree opzionali nei modelli
    7. Definire attributi di tag modificabili in Dreamweaver
    8. Creare modelli nidificati in Dreamweaver
    9. Modificare, aggiornare ed eliminare modelli
    10. Esportare e importare contenuti xml in Dreamweaver
    11. Applicare o rimuovere un modello da un documento esistente
    12. Modificare il contenuto nei modelli di Dreamweaver
    13. Regole di sintassi per i tag di modello in Dreamweaver
    14. Impostare le preferenze di evidenziazione per le aree dei modelli
    15. Vantaggi dell'uso dei modelli in Dreamweaver
  15. Dispositivi mobili e multischermo
    1. Creare media query
    2. Cambiamento dell'orientamento della pagina per i dispositivi mobili
    3. Creare web app per dispositivi mobili utilizzando Dreamweaver
  16. Siti, pagine e moduli Web dinamici
    1. Applicazioni Web
    2. Configurare il computer per lo sviluppo di applicazioni
    3. Risoluzione dei problemi relativi alle connessioni di database
    4. Rimozione di script di connessione in Dreamweaver
    5. Progettare pagine dinamiche
    6. Panoramica sulle origini di contenuto dinamico
    7. Definire le origini di contenuto dinamico
    8. Aggiungere contenuto dinamico alle pagine
    9. Modifica del contenuto dinamico in Dreamweaver
    10. Visualizzare i record di database
    11. Fornire dati dal vivo e risoluzione dei problemi in Dreamweaver
    12. Aggiungere comportamenti server personalizzati in Dreamweaver
    13. Creazione di moduli con Dreamweaver
    14. Usare moduli per raccogliere informazioni dagli utenti
    15. Creare e attivare i moduli ColdFusion in Dreamweaver
    16. Creare moduli Web
    17. Supporto HTML5 avanzato per gli elementi modulo
    18. Sviluppare un modulo con Dreamweaver
  17. Sviluppo visivo delle applicazioni
    1. Creare pagine principali e di dettaglio in Dreamweaver
    2. Creare pagine di ricerca e di risultati
    3. Creare una pagina di inserimento record
    4. Costruire una pagine di aggiornamento record in Dreamweaver
    5. Costruzione di pagine di eliminazione record in Dreamweaver
    6. Utilizzare comandi ASP per modificare un database in Dreamweaver
    7. Creare una pagina di registrazione
    8. Creare una pagina di login
    9. Creare una pagina accessibile solo agli utenti autorizzati
    10. Protezione delle cartelle in ColdFusion utilizzando Dreamweaver
    11. Utilizzo di componenti ColdFusion in Dreamweaver
  18. Verifica, anteprima e pubblicazione dei siti Web
    1. Anteprima delle pagine
    2. Visualizzare in anteprima pagine web di Dreamweaver su più dispositivi
    3. Verificare il sito Dreamweaver

 

Scaricamento e caricamento dei file da e verso il server, e gestione dei trasferimenti di file tramite Dreamweaver.

Se lavorate in team, utilizzate il sistema di deposito/ritiro per trasferire i file tra i siti locali e remoti. Se invece siete l'unica persona che lavora sul sito remoto, potete utilizzare i comandi Scarica e Carica per trasferire i file senza depositarli o ritirarli.

Per ulteriori informazioni sul deposito e sul ritiro di file, consultate Depositare e ritirare i file.

Quando trasferite un documento tra una cartella locale e una remota mediante il pannello File, potete trasferire anche i file dipendenti del documento, ovvero le immagini, i fogli di stile esterni e altri file associati al documento che vengono caricati nel browser insieme al documento stesso.

Nota:

solitamente, è consigliabile scaricare i file dipendenti quando ritirate un nuovo file, ma se le ultime versioni dei file dipendenti si trovano già sul disco locale, non è necessario scaricarli di nuovo. Questo vale anche quando caricate e depositate i file: l'operazione non è necessaria se sul sito remoto sono già presenti copie aggiornate.

Le voci di libreria vengono considerate come file dipendenti.

Alcuni server generano errori quando vengono caricate voci di libreria. Tuttavia, potete mascherare questi file per impedirne il trasferimento.

Informazioni sui trasferimenti di file in background

Potete eseguire altre attività, che non coinvolgono il server, durante le operazioni di caricamento o scaricamento dei file. Il trasferimento di file in background funziona con tutti i protocolli supportati da Dreamweaver: FTP, SFTP, LAN, WebDAV e RDS.

Le attività che non coinvolgono il server comprendono operazioni comuni come la digitazione di testi, la modifica di fogli di stile esterni, la generazione di rapporti per il sito e la creazione di nuovi siti.

Le attività che coinvolgono il server e che Dreamweaver non è in grado di eseguire durante i trasferimenti di file includono:

  • Caricare, scaricare, depositare e ritirare i file

  • Annullare il ritiro

  • Creare una connessione di database

  • Associare dati dinamici

  • Anteprima di dati nella vista Dal vivo

  • Inserire un servizio Web

  • Eliminare file o cartelle remoti

  • Anteprima in un browser su un server di prova

  • Salvare un file su un server remoto

  • Inserire un'immagine da un server remoto

  • Aprire un file da un server remoto

  • Caricare automaticamente i file in fase di salvataggio

  • Trascinare i file su un sito remoto

  • Tagliare, copiare o incollare file su un sito remoto

  • Aggiornare la vista remota

Per impostazione predefinita, la finestra di dialogo Attività file in background è aperta durante il trasferimento dei file. Potete ridurre a icona la finestra di dialogo facendo clic sul pulsante Riduci a icona nell'angolo superiore destro. Se chiudete la finestra di dialogo durante i trasferimenti dei file, l'operazione viene annullata.

Scaricare file da un server remoto

I file possono essere copiati dal sito remoto a quello locale in uno dei modi seguenti:

Dreamweaver crea un registro dell'attività relativa ai file durante il trasferimento che può essere visualizzato e salvato.

Nota:

Non è possibile disattivare il trasferimento dei file in background. Se nella finestra di dialogo Attività file in background è aperto il registro di dettaglio, potete chiuderlo per migliorare le prestazioni.

Anche tutte le attività di trasferimento via FTP dei file vengono registrate da Dreamweaver. In caso di errori durante il trasferimento di un file mediante FTP, il registro FTP del sito può facilitare l'individuazione del problema.

Scaricare file da un server remoto mediante il pannello File

  1. Nel pannello File (Finestra > File), selezionate i file da scaricare.

    Di solito questa selezione avviene nella vista remota, ma potete anche selezionare i file corrispondenti nella vista locale. Se è attiva la vista remota, i file selezionati vengono copiati da Dreamweaver nel sito locale, mentre se è attiva la vista locale, le versioni remote dei file locali selezionati vengono copiate da Dreamweaver nel sito locale.

    Nota:

    per scaricare solo i file la cui versione remota è più recente di quella locale, utilizzate l'opzione Sincronizza.

  2. Per scaricare il file, effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Scarica nella barra degli strumenti del pannello File.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file nel pannello File, quindi selezionate Scarica dal menu di scelta rapida.

  3. Fate clic su Sì nella finestra di dialogo File dipendenti per scaricare anche i file dipendenti; se disponete già di copie locali dei file dipendenti, fate clic su No. L'impostazione predefinita prevede che i file dipendenti non vengano scaricati. Per impostare questa opzione, selezionate Modifica > Preferenze > Sito.

    Dreamweaver scarica i file selezionati, nel modo seguente:

    • Se utilizzate il sistema di deposito/ritiro, lo scaricamento genera una copia locale di sola lettura del file e il file rimane disponibile sul sito remoto o sul server di prova per il ritiro da parte di altri utenti.

    • Se non utilizzate il sistema di deposito/ritiro, durante l'operazione di scaricamento di un file viene trasferita una copia con proprietà di lettura e scrittura.

    Nota:

    se lavorate in team, ovvero se più persone lavorano sugli stessi file, non è consigliabile disattivare l'opzione Abilita deposito e ritiro file. Se altri utenti stanno utilizzando il sistema di deposito/ritiro sul sito, è opportuno utilizzare lo stesso sistema.

    Per interrompere il trasferimento in qualsiasi momento, fate clic sul pulsante Annulla nella finestra di dialogo Attività file in background.  

Scaricare file da un server remoto mediante la finestra del documento

  1. Assicuratevi che il documento sia attivo nella finestra del documento.
  2. Per scaricare il file, effettuate una delle seguenti operazioni:
    • Seleziona Sito > Scarica.

    • Fate clic sull'icona Gestione file nella barra degli strumenti della finestra del documento, quindi selezionate Scarica dal menu.

    Nota:

    se il file corrente non fa parte del sito corrente nel pannello File, Dreamweaver tenta di determinare il sito di appartenenza del file corrente. Se il file corrente appartiene a un solo sito locale, il sito viene aperto da Dreamweaver e viene eseguita l'operazione di scaricamento.

Visualizzare il registro FTP

  1. Fate clic sul menu Opzioni nell'angolo superiore destro del pannello File.
  2. Selezionate Visualizza > Registro FTP del sito.
Nota:

nel pannello File espanso, potete fare clic sul pulsante Registro FTP per visualizzare il registro.

Caricare file su un server remoto

Potete caricare file dal sito locale al sito remoto, solitamente senza modificarne lo stato di ritiro.

Due sono le situazioni più comuni nelle quali utilizzate il comando Carica al posto di Deposita:

  • Non lavorate in team e quindi non utilizzate il sistema di deposito/ritiro.
  • Desiderate caricare sul server la versione corrente di un file che avete intenzione di continuare a modificare.
Nota:

se caricate un file precedentemente assente dal sito remoto e utilizzate il sistema di deposito/ritiro, il file viene copiato sul sito remoto e quindi ritirato per consentire di continuare le operazioni di modifica.

Potete utilizzare il pannello File o la finestra del documento per caricare file. Dreamweaver crea un registro dell'attività relativa ai file durante il trasferimento che può essere visualizzato e salvato.

Nota:

Non è possibile disattivare il trasferimento dei file in background. Se nella finestra di dialogo Attività file in background è aperto il registro di dettaglio, potete chiuderlo per migliorare le prestazioni.  

Anche tutte le attività di trasferimento via FTP dei file vengono registrate da Dreamweaver. In caso di errori durante il trasferimento di un file mediante FTP, il registro FTP del sito può facilitare l'individuazione del problema.

Per un'esercitazione sul caricamento di file su un server remoto, consultate www.adobe.com/go/vid0163_it.

Per un'esercitazione sulla risoluzione di problemi di pubblicazione, consultate www.adobe.com/go/vid0164_it.

Caricare file su un server remoto o su un server di prova mediante il pannello File

  1. Nel pannello File (Finestra > File), selezionate i file da caricare.

    Di solito questa selezione avviene nella vista locale, ma potete anche selezionare i file corrispondenti nella vista remota.

    Nota:

    potete caricare solo i file la cui versione locale è più recente di quella remota.

  2. Per caricare il file sul server remoto, effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Carica nella barra degli strumenti del pannello File.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file nel pannello File, quindi selezionate Carica dal menu di scelta rapida.

  3. Se il file non è stato salvato, viene visualizzata una finestra di dialogo (se questa preferenza è stata impostata nella categoria Sito della finestra di dialogo Preferenze) che consente di salvare il file prima di caricarlo sul server remoto. Fate clic su Sì per salvare il file o fate clic su No per caricare sul server remoto la versione precedentemente salvata.
    Nota:

    se non salvate il file, tutte le eventuali modifiche apportate dopo l'ultimo salvataggio non vengono caricate sul server remoto. Tuttavia, il file rimane aperto per consentire il salvataggio delle modifiche una volta caricato il file sul server.

  4. Fate clic su Sì per caricare i file dipendenti insieme ai file selezionati, oppure fate clic su No per non caricare tali file. L'impostazione predefinita prevede che i file dipendenti non vengano caricati. Per impostare questa opzione, selezionate Modifica > Preferenze > Sito.
    Nota:

    solitamente, è consigliabile caricare i file dipendenti quando si deposita un nuovo file, ma se le ultime versioni dei file dipendenti si trovano già sul server remoto, non è necessario caricarli di nuovo.

    Per interrompere il trasferimento in qualsiasi momento, fate clic sul pulsante Annulla nella finestra di dialogo Attività file in background.

Caricare file su un server remoto mediante la finestra del documento

  1. Assicuratevi che il documento sia attivo nella finestra del documento.
  2. Per caricare il file, effettuate una delle seguenti operazioni:
    • Selezionate Sito > Carica.

    • Fate clic sull'icona Gestione file nella barra degli strumenti della finestra del documento, quindi selezionate Carica dal menu.

    Nota:

    se il file corrente non fa parte del sito corrente nel pannello File, Dreamweaver tenta di determinare il sito di appartenenza del file corrente. Se il file corrente appartiene a un solo sito locale, il sito viene aperto da Dreamweaver e viene eseguita l'operazione di caricamento.

Visualizzare il registro FTP

  1. Fate clic sul menu Opzioni nell'angolo superiore destro del pannello File.
  2. Selezionate Visualizza > Registro FTP del sito.
Nota:

nel pannello File espanso, potete fare clic sul pulsante Registro FTP per visualizzare il registro.

Gestire i trasferimenti di file

Potete visualizzare lo stato delle operazioni di trasferimento dei file, nonché un elenco dei file trasferiti e dei relativi risultati (trasferimento riuscito, ignorato o non riuscito). Potete inoltre salvare un registro relativo alle attività dei file.

Nota:

Dreamweaver consente di eseguire altre attività, che non coinvolgono il server, durante le operazioni di trasferimento di file da o verso un server.

Annullare un trasferimento di file

  1. Fate clic sul pulsante Annulla nella finestra di dialogo Attività file in background. Se la finestra di dialogo non è visibile, fate clic sul pulsante Attività file nella parte inferiore del pannello File.

Visualizzare la finestra di dialogo Attività file in background durante i trasferimenti

Fate clic sul pulsante Attività file o Registro nella parte inferiore del pannello File.

Visualizzare i dettagli dell'ultimo trasferimento di file

  1. Fate clic sul pulsante Registro nella parte inferiore del pannello File per aprire la finestra di dialogo Attività file in background.
  2. Fate clic sulla freccia di espansione Dettagli.

Salvare un registro dell'ultimo trasferimento di file

  1. Fate clic sul pulsante Registro nella parte inferiore del pannello File per aprire la finestra di dialogo Attività file in background.
  2. Fate clic sul pulsante Salva registro e salvare le informazioni come file di testo.

    Potete esaminare l'attività relativa al file aprendo il file di registro in Dreamweaver o in qualsiasi editor di testo.

Logo Adobe

Accedi al tuo account