Esercitazione video: oggetti avanzati collegati

Esercitazione video: oggetti avanzati collegati
Infinite Skills

Nozioni di base sugli oggetti avanzati

Gli oggetti avanzati sono livelli che contengono dati appartenenti a immagini raster o vettoriali, ad esempio file di Photoshop o Illustrator. Gli oggetti avanzati conservano tutte le caratteristiche originali del contenuto sorgente di un’immagine, permettendovi di apportare modifiche non distruttive al livello.

In Photoshop CC e CS6 è possibile incorporare i contenuti di un’immagine in un documento Photoshop. In Photoshop CC è inoltre possibile creare oggetti avanzati collegati i cui contenuti fanno riferimento a file immagine esterni. I contenuti di un oggetto avanzato collegato vengono aggiornati quando il file immagine sorgente subisce delle modifiche.

Gli oggetti avanzati collegati sono diversi dalle istanze duplicate di un oggetto avanzato in un documento Photoshop. Con gli oggetti avanzati collegati è possibile utilizzare uno stesso file sorgente e condividerlo tra più documenti Photoshop, funzione molto utile per i Web designer.

Vantaggi degli oggetti avanzati

Con gli oggetti avanzati potete:

  • Applicare trasformazioni non distruttive. Potete ridimensionare, ruotare, distorcere, deformare, trasformare in prospettiva o alterare un livello senza perdere i dati o la qualità originale dell’immagine, in quanto le trasformazioni non influiscono sui dati originali.

  • Usare i dati vettoriali, come la grafica vettoriale di Illustrator, che altrimenti sarebbero rasterizzati in Photoshop.

  • Applicare filtri non distruttivi. Potete modificare in qualunque momento i filtri che avete applicato agli oggetti avanzati.

  • Modificando un oggetto avanzato, vengono aggiornate automaticamente tutte le istanze di tale oggetto.

  • Applicare una maschera di livello collegata o non collegata al livello di oggetti avanzati.

  • Provate diverse soluzioni con immagini segnaposto a bassa risoluzione, da sostituire in un secondo tempo con le relative versioni finali.

Per effettuare operazioni che alterano i dati dei pixel (come colorare, schermare, bruciare o clonare) direttamente su un livello Oggetto avanzato, occorre prima convertirlo in un livello normale in modo da rasterizzarlo. Per effettuare operazioni che alterano i dati dei pixel, potete modificare il contenuto di un oggetto avanzato, clonare un nuovo livello sopra il livello Oggetto avanzato, modificare i duplicati dell’oggetto avanzato o creare un nuovo livello.

Nota:

Quando viene modificato un oggetto avanzato al quale è applicato un filtro avanzato, Photoshop disattiva gli effetti filtro durante la trasformazione. Gli effetti filtro vengono applicati nuovamente dopo la trasformazione. Consultate Applicare i filtri avanzati.

Vantaggi degli oggetti avanzati in Photoshop
Livello normale e oggetto avanzato nel pannello Livelli. L’icona in basso a destra nella miniatura indica un oggetto avanzato.

Un oggetto avanzato nel pannello Livelli in Photoshop
(Photoshop CC) Un oggetto avanzato collegato nel pannello Livelli

Creare gli oggetti avanzati incorporati

Potete creare gli oggetti avanzati incorporati in diversi modi: usando il comando Apri come oggetto avanzato, inserendo un file (CS6) o un file incorporato (CC, CS6), incollando i dati da Illustrator o convertendo uno o più livelli di Photoshop in un oggetto avanzato.

  1. Effettuate una delle seguenti operazioni:
    • (CC) Scegliete File > Inserisci incorporato per importare i file come oggetti avanzati in un documento di Photoshop aperto.
    • Scegliete File > Apri come oggetto avanzato, selezionate un file e fate clic su Apri.
    • (CS6) Scegliete File > Inserisci per importare i file come oggetti avanzati in un documento di Photoshop aperto.

    Nota:

    Sebbene sia possibile inserire anche file JPEG, è preferibile inserire file PSD, TIFF o PSB in quanto questi formati consentono di aggiungere livelli e modificare i pixel, quindi di salvare di nuovo senza alcuna perdita di dati. Per salvare invece un file JPEG modificato è necessario unire i nuovi livelli in un livello unico e ricomprimere l’immagine, provocando un deterioramento della qualità dell’immagine.

    • Per convertire un livello selezionato in oggetto avanzato, scegliete Livello > Oggetti avanzati > Converti in oggetto avanzato.
    • In Bridge, scegliete File > Inserisci > In Photoshop per importare un file come oggetto avanzato in un documento di Photoshop aperto.

    Nota:

    Un modo semplice per lavorare con i dati da fotocamera in formato raw consiste nell’aprire tali dati come oggetti avanzati. Per regolare le impostazioni Camera Raw, potete fare doppio clic sul livello Oggetto avanzato che contiene il file in formato raw in qualsiasi momento.

    Guardate il video su come aprire un’immagine come oggetto avanzato.

    • Selezionate uno o più livelli e scegliete Livello > Oggetti avanzati > Converti in oggetto avanzato. Gli oggetti vengono raggruppati in un unico oggetto avanzato.

    • Trascinate i livelli o gli oggetti PDF o di Adobe Illustrator in un documento di Photoshop.

    • Incollate la grafica da Illustrator al documento di Photoshop e scegliete Oggetto avanzato nella finestra di dialogo Incolla. Per la massima flessibilità, attivate sia PDF che AICB (trasparenza non supportata) nella sezione Gestione file e Appunti della finestra di dialogo Preferenze di Adobe Illustrator.

Creare oggetti avanzati collegati | Photoshop CC

Nota:

La funzione Oggetto avanzato collegato è disponibile nella versione 14.2 di Photoshop (Photoshop CC | Gennaio 2014) e nelle versioni successive.

In Photoshop CC potete creare degli oggetti avanzati collegati. I contenuti di un oggetto avanzato collegato vengono aggiornati quando il file immagine sorgente subisce delle modifiche. Gli oggetti avanzati collegati sono utili quando team di più utenti lavorano su uno stesso progetto oppure per riutilizzare le stesse risorse in pogetti diversi.

Per creare un oggetto avanzato collegato, effettuate le seguenti operazioni:

  1. Scegliete File > Inserisci collegato.
  2. Selezionate un file, quindi fate clic su Inserisci.

L’oggetto avanzato collegato viene creato e visualizzato nel pannello Livelli con un’icona di collegamento ().

Nota:

Potete anche creare un oggetto avanzato collegato in un documento aperto trascinando e rilasciando il file appropriato mentre tenete premuto il tasto seguente:

(Windows) Alt
(Mac OS) Opzione

Per cambiare questo comportamento predefinito, disattivate l’opzione Preferenze > Generali > Crea sempre elementi avanzati durante l’inserimento.

Riduzione delle dimensioni dei file grazie agli oggetti avanzati collegati

Poiché gli oggetti avanzati collegati restano dipendenti da un file esterno e il file sorgente non viene incorporato nel documento contenitore, spesso consentono di ridurre sensibilmente le dimensioni dei file. Tuttavia, anche se il file originale non viene memorizzato nel documento contenitore, con gli oggetti avanzati collegati viene comunque salvata una versione a livello unico e ridimensionata dei dati di immagine del file originale. In alcuni casi, le dimensioni di questi dati possono risultare molto maggiori di quelle del file originale, producendo quindi un effetto opposto.

Aggiornare gli oggetti avanzati collegati

Se viene modificato un file sorgente esterno a cui si fa riferimento in un documento Photoshop aperto, l’oggetto avanzato collegato corrispondente viene automaticamente aggiornato. Se invece si apre un documento Photoshop contenente oggetti avanzati collegati non sincronizzati, questi possono essere aggiornati:

  • Fate clic con il pulsante destro del mouse su un oggetto avanzato collegato e scegliete Aggiorna contenuto modificato.
  • Scegliete Livello > Oggetti avanzati > Aggiorna contenuto modificato.

Gli oggetti avanzati collegati le cui immagini sorgente hanno subito modifiche sono evidenziati nel pannello Livelli:

Oggetti avanzati collegati non sincronizzati, evidenziati nel pannello Livelli di Photoshop
Oggetti avanzati collegati non sincronizzati, evidenziati nel pannello Livelli

Nota:

Per aggiornare tutti gli oggetti avanzati collegati nel documento Photoshop corrente, scegliete Livello > Oggetti avanzati > Aggiorna tutti i contenuti modificati.

Oggetti avanzati collegati con file sorgente esterni mancanti, nel pannello Livelli di Photoshop
Oggetti avanzati collegati con file sorgente esterni mancanti, nel pannello Livelli.

Nota:

Durante il rilevamento delle modifiche apportate agli oggetti avanzati collegati o l’aggiornamento di un oggetto avanzato collegato, Photoshop elabora unicamente il file collegato immediato, senza aggiornare i collegamenti nidificati negli oggetti avanzati.

Risolvere un collegamento interrotto di un oggetto avanzato

Qualora una sorgente esterna mancante provochi l’interruzione del collegamento di un oggetto avanzato, effettuate le seguenti operazioni:

  1. Fate clic con il pulsante destro sull’icona del livello dell’oggetto avanzato e selezionate Risolvi collegamento interrotto.
  2. Accedete alla nuova posizione dell’oggetto mancante.
  3. Fate clic su Inserisci.

Visualizzare le proprietà di un oggetto avanzato collegato

Con un oggetto avanzato collegato selezionato nel pannello Livelli, scegliete Finestra > Proprietà.

Vengono visualizzate le proprietà seguenti:

  • Il percorso del file sorgente esterno dell’oggetto avanzato collegato
  • Le dimensioni e le coordinate di posizione (X, Y) dell’oggetto avanzato collegato

Nel pannello Proprietà potete eseguire direttamente le seguenti operazioni:

  • Modificare il contenuto del file di immagine esterno. Se necessario, Photoshop apre un’applicazione esterna in grado di gestire il file di immagine sorgente. Ad esempio, se il file di immagine esterno è in formato .ai, Photoshop apre Adobe Illustrator.
  • Incorporare l’oggetto avanzato collegato nel documento corrente.

Incorporare gli oggetti avanzati collegati

Effettuate una delle seguenti operazioni:

  • Fate clic con il pulsante destro del mouse su un livello Oggetto avanzato collegato nel pannello Livelli e scegliete Incorpora collegato.
  • Scegliete Livello > Oggetti avanzati > Incorpora collegato.
  • Nel pannello Proprietà, selezionate Incorpora.

Nota:

Scegliete Livello > Oggetti avanzati > Incorpora tutti i collegati per incorporare tutti gli oggetti avanzati collegati nel documento Photoshop.

Creare un pacchetto con gli oggetti avanzati collegati

Potete creare un pacchetto con gli oggetti avanzati collegati presenti in un documento Photoshop, in modo tale da salvare i relativi file sorgente in una cartella del computer. Una copia del documento Photoshop viene salvata nella cartella insieme ai file sorgente.

  1. Scegliete File > Pacchetto.
  2. Selezionate la posizione in cui salvare i file sorgente e una copia del documento Photoshop.

Nel pacchetto vengono salvati anche eventuali oggetti avanzati collegati di tipo audio o video presenti nel documento.

Nota:

Prima di creare un pacchetto con oggetti avanzati collegati, dovete salvare il file in cui sono contenuti.

Come Photoshop individua i file collegati

Photoshop cerca sempre i file collegati nell’ultima posizione relativa nota. Se non è presente in tale posizione, il file collegato viene cercato:

  • nell’ultima posizione assoluta nota
  • utilizzando un alias salvato (solo su Mac OS)
  • nella stessa cartella del documento contenitore

Questo tipo di comportamento permette di spostare, copiare e condividere file e cartelle di progetto con un minimo rischio di incontrare collegamenti interrotti.

Nota:

La finestra di dialogo Risolvi font mancanti visualizza sempre l’ultimo percorso assoluto noto dei file sorgente mancanti.

Convertire un oggetto avanzato incorporato in oggetto avanzato collegato

È possibile convertire un oggetto avanzato incorporato in oggetto avanzato collegato. Le trasformazioni, i filtri e altri effetti applicati all’oggetto avanzato incorporato vengono mantenuti anche dopo la conversione.

Effettuate una delle seguenti operazioni:

  1. Selezionate un livello di oggetto avanzato incorporato nel documento Photoshop.
  2. Scegliete Livello > Oggetto avanzato > Converti in collegato.
  3. Selezionate la posizione in cui volete salvare il file sorgente sul computer. Inserite un nome per il file, inclusa un’estensione supportata. Ad esempio, link_file.jpg.

Filtrare il pannello Livelli in base agli oggetti avanzati | Photoshop CC

  1. Nel pannello Livelli, selezionate Oggetti avanzati dal menu a comparsa del filtro.
Livelli filtrati in base agli oggetti avanzati in Photoshop
Livelli filtrati in base agli oggetti avanzati

  1. Fate clic su una delle icone seguenti:
  •     Filtra gli oggetti avanzati collegati aggiornati
  •     Filtra gli oggetti avanzati collegati non sincronizzati
  •     Filtra gli oggetti avanzati collegati mancanti
  •     Filtra gli oggetti avanzati incorporati

Nota:

Potete usare l’icona di attivazione/disattivazione () per disattivare il filtro dei livelli.

Duplicare un oggetto avanzato incorporato

  1. Nel pannello Livelli selezionate un livello Oggetto avanzato ed effettuate una delle seguenti operazioni:
    • Per creare un oggetto avanzato duplicato che sia collegato all’originale, scegliete Livello > Nuovo > Crea livello copiato, oppure trascinate il livello Oggetto avanzato sull’icona Crea un nuovo livello, nella parte inferiore del pannello Livelli. Eventuali modifiche apportate all’originale saranno riprodotte sulla copia e viceversa.

    • Per creare un oggetto avanzato duplicato che non sia collegato all’originale, scegliete Livello > Oggetti avanzati > Nuovo oggetto avanzato tramite Copia. Eventuali modifiche apportate all’originale non saranno riprodotte sulla copia.

    Nel pannello Livelli viene visualizzato un nuovo oggetto avanzato con lo stesso nome dell’originale e con il suffisso “copia”.

Modificare il contenuto di un oggetto avanzato

Quando modificate un oggetto avanzato, il contenuto sorgente viene aperto in Photoshop (se si tratta di dati raster o di un file camera raw) o nell’applicazione predefinita per il formato inserito (ad esempio, Adobe Illustrator or Adobe Acrobat). Quando salvate le modifiche nel contenuto sorgente, tali modifiche si ripercuotono su tutte le istanze collegate dell’oggetto avanzato nel documento di Photoshop.

  1. Selezionate l’oggetto avanzato nel pannello Livelli ed effettuate una delle seguenti operazioni:
    • Scegliete Livello > Oggetti avanzati > Modifica contenuto.
    • Fate doppio clic sull’icona degli oggetti avanzati nel pannello Livelli.
    • Nel pannello Proprietà, selezionate Modifica contenuto.
  2. Per chiudere la finestra di dialogo, fate clic su OK.
  3. Apportate le modifiche necessarie al file del contenuto sorgente, quindi scegliete File > Salva.

    Photoshop aggiorna l’oggetto avanzato per riflettere le modifiche apportate. Se le modifiche non sono visibili, accertatevi che il documento contenente l’oggetto avanzato sia attivo.

Sostituire il contenuto di un oggetto avanzato

Potete sostituire i dati immagine per un oggetto avanzato o per più istanze collegate. Questa funzione permette di aggiornare rapidamente una soluzione visiva o di sostituire le immagini segnaposto a bassa risoluzione con le relative versioni finali.

Nota:

Quando sostituite un oggetto avanzato, eventuali ridimensionamenti, alterazioni o effetti che sono stati applicati al primo oggetto avanzato vengono mantenuti.

  1. Selezionate l’oggetto avanzato, quindi scegliete Livello > Oggetti avanzati > Sostituisci contenuto.
  2. Selezionate il file da usare e fate clic su Inserisci.
  3. Fate clic su OK.

    Il nuovo contenuto viene inserito nell’oggetto avanzato.

Riconvertire in livello un oggetto avanzato collegato o incorporato

Convertendo un oggetto avanzato in un livello normale, il contenuto viene rasterizzato in base alle dimensioni correnti. Convertite un oggetto avanzato in un livello normale soltanto se non avete più bisogno di modificare i dati dell’oggetto avanzato. Le trasformazioni, le alterazioni e i filtri applicati a un oggetto avanzato non possono più subire modifiche dopo che l’oggetto avanzato viene rasterizzato.

  • Selezionate l’oggetto avanzato, quindi scegliete Livello > Oggetti avanzati > Rasterizza.

Nota:

Se volete ricreare l’oggetto avanzato, selezionate nuovamente i livelli originali e ricominciate da capo. Il nuovo oggetto avanzato non conserverà le trasformazioni che sono state applicate all’oggetto avanzato originale.

Esportare il contenuto di un oggetto avanzato incorporato

  1. Selezionate l’oggetto avanzato nel pannello Livelli, quindi scegliete Livello > Oggetti avanzati > Esporta contenuto.
  2. Scegliete una destinazione per il contenuto dell’oggetto avanzato e fate clic su Salva.

    Photoshop esporta l’oggetto avanzato nel formato originale con cui è stato inserito (JPEG, AI, TIF, PDF o altro). Se l’oggetto avanzato è stato creato dai livelli, viene esportato nel formato PSB.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online