Risolvi i problemi di avvio delle app video Adobe su macOS Sonoma

Se hai eseguito l’aggiornamento a macOS Sonoma (versione 14) e le tue app video non si avviano, scopri come risolvere il problema.

Problema

Le app video Adobe non si avviano su macOS Sonoma (versione 14) e viene visualizzato il seguente messaggio di errore:

Adobe Premiere Pro 2024 è danneggiato e non può essere aperto. Dovresti spostarlo nel Cestino.

Il messaggio di errore mostra che Adobe Premiere Pro 2023 è danneggiato e non può essere aperto. Dovresti spostarlo nel Cestino.
Messaggio di errore ricevuto su macOS Sonoma (versione 14).

Nota:

Questo problema riguarda tutte le versioni delle applicazioni Adobe e non è correlato al nuovo aggiornamento della versione 2024, pertanto il downgrade alle versioni 2023 non sarà la soluzione. Benché sia più probabile che gli utenti di Sonoma visualizzino l’errore, questo potrebbe presentarsi anche se utilizzi una versione precedente di macOS.

Causa

Il problema si verifica a causa della Tecnologia di sicurezza Gatekeeper di Apple. Per garantirne l’autenticità, Apple richiede che tutte le app siano firmate dallo sviluppatore. Tutte le modifiche apportate al contenuto del pacchetto dell’applicazione in seguito alla firma dello sviluppatore attivano un avviso di sicurezza inviato da Apple. Questo è positivo, poiché impedisce la distribuzione di malware che dirottano un’applicazione a scopi dannosi. Gatekeeper fa parte di macOS da diversi anni, tuttavia Apple ha migliorato le misure di sicurezza in macOS Sonoma, motivo per il quale questo errore risulta più frequente su Sonoma. Nelle versioni precedenti di macOS è ancora possibile visualizzare questo errore.

Alcuni sviluppatori di plug-in ed estensioni di terze parti installano componenti come predefiniti e altre impostazioni nel nostro pacchetto di applicazioni, attivando il meccanismo di sicurezza di Apple e impedendo l’avvio dell’app. 

L’esecuzione del programma di disinstallazione di Adobe lascerà sul disco un frammento di app con questi componenti di terze parti, poiché Adobe disinstallerà solo i file inseriti dal programma di installazione originale. Quando provi a eseguire una nuova reinstallazione, i file incriminati rimangono e il problema persiste anche dopo la reinstallazione. 

Soluzione alternativa

installa l’app senza componenti di terze parti

  1. Disinstalla l’app seguendo queste istruzioni.

  2. Controlla che la cartella dell’applicazione e tutto il suo contenuto siano eliminati in questo modo: /Applicazioni/Adobe Premiere Pro 2024.

  3. Reinstalla l’applicazione dall’app desktop Creative Cloud come di consueto. Scopri come scaricare le app Creative Cloud qui. 

  4. Non installare software illeciti di terze parti. 

Utilizza l’app con componenti di terze parti

L’impossibilità di utilizzare alcuni strumenti di terze parti non è l'ideale. Si consiglia di contattare lo sviluppatore di terze parti per chiedergli di aggiornare il proprio programma di installazione per evitare di inserire i componenti nel pacchetto dell’applicazione. Stiamo inoltre lavorando con gli sviluppatori di terze parti per informarli di questo problema.  Se devi utilizzare strumenti di terze parti per il tuo flusso di lavoro, applica la seguente soluzione alternativa. 

Avviso

Per verificare che il malware sia stato inserito in un’app Adobe sul dispositivo, segui le istruzioni elencate di seguito per consentirne l’esecuzione. Esercita la dovuta diligenza e installa applicazioni e utilità solo da sviluppatori affidabili e rispettabili.

  1. Apri l’app.

  2. Quando viene visualizzato il messaggio di errore "Adobe Premiere Pro 2024 è danneggiato e non può essere aperto. Dovresti spostarlo nel Cestino.", vai a Impostazioni di sistema > Privacy e sicurezza.

  3. Verifica la presenza di un avviso relativo all’app Adobe in questione e seleziona Apri comunque.

Seleziona l’avviso che indica Apri comunque in Privacy e sicurezza per aprire il file danneggiato.
Un avviso nella sezione Privacy e sicurezza del dispositivo macOS segnala che l’app è stata bloccata.

Ottieni supporto in modo più facile e veloce

Nuovo utente?