メニューのカスタマイズ

非表示およびカラー設定メニューコマンドを使用すると、メニューの混乱を防ぎ、よく使用するコマンドを強調できます。メニューコマンドを非表示にしても、単に対応するメニューコマンドが表示されなくなるだけで、機能が無効になるわけではありません。メニュー下部の「すべてのメニュー項目を表示」コマンドを選択すれば、非表示にしたコマンドをいつでも表示できます。また、ウィンドウワークスペースメニュー項目をすべて表示を選択すると、選択しているワークスペースのメニューがすべて表示されます。メニューをカスタマイズし、保存するワークスペースに含めることができます。

カスタマイズできるメニューは、メインメニュー、コンテキストメニュー、およびパネルメニューです。コンテキストメニューは、領域を右クリック(Windows)または Control キーを押しながらクリック(Mac OS)すると表示されます。パネルメニューは、パネル右上のアイコンをクリックすると表示されます。

注意:

「テキスト編集」など、別のワークスペースを選択すると、一部のメニューコマンドは表示されません。 メニューコマンドを表示するには、メニュー下部の「すべてのメニュー項目を表示」を選択するか、「詳細」などのワークスペースを選択します。

カスタムメニューセットの作成

  1. 編集メニューを選択します。

    デフォルトのメニューセットは編集できません。

  2. 別名で保存」をクリックし、メニューセット名を入力し、「OK」をクリックします。
  3. カテゴリーメニューから、アプリケーションメニューまたはコンテキスト&パネルメニューのいずれかを選択して、カスタマイズするメニューを決定します。
  4. メニューカテゴリーの左にある矢印をクリックして、サブカテゴリーまたはメニューコマンドを表示します。カスタマイズするコマンドごとに、「表示 / 非表示」の目のアイコンをクリックして、そのコマンドを表示または非表示にします。メニューからカラーを選択するには、「カラー」の「なし」をクリックします。
  5. 「保存」をクリックし、次に「OK」をクリックします。

カスタムメニューセットの選択

  1. 編集メニューを選択します。

  2. セットポップアップメニューからメニューセットを選択し、「OK」をクリックします。

カスタムメニューセットの編集または削除

  1. 編集メニューを選択します。

  2. セットポップアップメニューからメニューセットを選択し、次のいずれかの操作をおこないます。
    • メニューセットを編集する場合は、メニューコマンドの表示 / 非表示またはカラーを変更し、「保存」をクリックしてから「OK」をクリックします。

    • メニューセットを削除するには、「削除」をクリックし、「はい」をクリックします。メニューセットを編集後、保存せずに閉じようとした場合は、現在のメニューセットを保存するよう促すメッセージが表示されます。メニューセットを保存するには「はい」をクリックします。変更を破棄するには「いいえ」をクリックします。

非表示のメニュー項目の表示

  • ウィンドウワークスペースメニュー項目をすべて表示を選択します。 すると、選択しているワークスペースのメニューがすべて表示されるようになります。メニューを非表示に戻すには、ワークスペースをリセットします。
  • 非表示にしたコマンドがあるメニューの下部の「すべてのメニュー項目を表示」を選択します。

注意:

Ctrl キー(Windows)または Command キー(Mac OS)を押したままメニュー名をクリックすると、メニューのカスタマイズによって非表示にしたメニューコマンドが一時的に表示されます。

見つからないメニューコマンド

メニューコマンドが見つからない場合、それが非表示になっている可能性があります。「詳細」以外のワークスペースを選択すると、一部のメニューコマンドが表示されません。また、自分自身か別のユーザーが「メニュー」コマンドを使用したためにメニューが非表示になったとも考えられます。

探しているコマンドが見つからない場合、次のいずれかの方法を試してください。

  • メニュー下部の「すべてのメニュー項目を表示」を選択します。

  • ウィンドウワークスペースメニュー項目をすべて表示を選択します。

  • ウィンドウワークスペースを選択し、別のワークスペースを選択します(「詳細」を選択すると、すべてのメニュー項目が表示されます)。

  • 編集メニューを選択してメニューコマンドをさがし、非表示になっていないことを確認します。

上記の操作をおこなってもメニューコマンドが見つからない場合には、環境設定を元に戻してみます。

キーボードショートカットセットの使用

ツールヒントを使用するとショートカットに関する簡単なリファレンスを確認することができます。また、InDesign にはショートカット編集機能が用意されており、全ショートカットの表示、ショートカットリストの作成、ユーザーショートカットの作成および編集をおこなうことができます。ショートカット編集では、デフォルトのショートカットセットに含まれているコマンド以外にも、ショートカットキーの設定が可能なすべてのコマンドがリスト表示され、作業に適したショートカットを作成することができます。

キーボードショートカットは、段落スタイルや文字スタイル(段落スタイルと文字スタイルの追加を参照)またはスクリプトと関連付けることもできます。

使用するショートカットセットの変更

  1. すべてのドキュメントについてショートカットセットをアクティブにする場合は、ドキュメントを開いていないことを確認します。
  2. 編集キーボードショートカットを選択します。

  3. 「セット」メニューからショートカットセットを選択します。例えば、「QuarkXPress® 4.0J 用」を選択します。
  4. 「OK」をクリックします。

ショートカットの表示

  1. 編集キーボードショートカットを選択します。

  2. セットポップアップメニューからショートカットセットを選択します。
  3. 「機能エリア」から表示するコマンドを含むエリアを選択します。
  4. 「コマンド」から表示するコマンドを選択します。「現在のショートカット」セクションにショートカットが表示されます。

印刷用ショートカットのリストの作成

  1. 編集キーボードショートカットを選択します。

  2. 「セット」の場合は、ショートカットセットを選択します。
  3. セットを表示」をクリックします。

選択したセットの、使用中および未定義のすべてのショートカットの一覧のテキストファイルが開きます。

新しいショートカットセットの作成

  1. 編集キーボードショートカットを選択します。

  2. 新規セット」をクリックします。

  3. 新しいショートカットセットの名前を入力し、元とするセットポップアップメニューから基準にするセットを選択します。「OK」をクリックします。

ショートカットの作成または再定義

  1. 編集キーボードショートカットを選択します。

  2. 「セット」の場合は、ショートカットセットを選択するか、「新規セット」をクリックして新しいショートカットセットを作成します。

    注意:

    デフォルトまたは QuarkXPress のショートカットセットは編集できません。代わりに、これらのセットを元にした新しいセットを作成して編集します。

  3. 「機能エリア」で、定義または再定義するコマンドを含むエリアを選択します。
  4. コマンドリストから定義または再定義するコマンドを選択します。
  5. 「新規ショートカット」ボックスをクリックして、新しいショートカット用のキーを押します。キーの組み合わせが他のコマンド用に使用されている場合は、「現在の割り当て」にそのコマンドが表示されます。この場合は、オリジナルのショートカットを変更するか、別の新しいショートカットを指定するかを選択できます。

    注意:

    テキストの入力と区別がつかなくなるので、メニューコマンドには、文字キーが 1 つだけのショートカットを割り当てないでください。挿入点がアクティブになっているときにキーを1 つだけ使用してショートカットを入力すると、キーの文字がテキストに挿入される代わりに、InDesign でそのキーボードショートカットがアクティブになります。

  6. 「内容」リストで、ショートカットキーを機能させたい内容を選択します。設定したショートカットは、「内容」リストで選択されている部分でだけ機能します。例えば、「内容」で表を選択し、「セルを結合」コマンドに Ctrl+G キーを割り当て、同じショートカットキーを「内容」からテキストを選択して「特殊文字を挿入」などのコマンドに割り当てることもできます。

    注意:

    ドキュメントの状態に関係なく、ショートカットを使いたい場合は、「デフォルト」でショートカットを割り当ててください。表やテキストなど、違う状況で割り当てたショートカットは、「デフォルト」で割り当てたショートカットより優先されます。

  7. 次のいずれかの操作をおこないます。
    • ショートカットがない場合は、「割り当て」をクリックして新しいショートカットを作成します。

    • 「割り当て」をクリックして、別のショートカットをコマンドに追加します。メニューコマンドには複数のショートカットを割り当てることができます。

  8. ダイアログボックスを閉じるには、「OK」をクリックします。ダイアログボックスを開いたまま、さらにショートカットを入力する場合は「保存」をクリックします。

キーボードショートカットセットのコピー

キーボードショートカットセット(*.indk)は、2 か所に保存されます。アプリケーションに組み込みのショートカットは、メインアプリケーションフォルダーの Presets フォルダーに保存されます。ユーザーが作成したショートカットは、次の場所の InDesign Shortcut Sets フォルダーに保存されます。

Windows XP

Documents and Settings¥[ユーザー名]¥Application Data¥Adobe¥InDesign¥[バージョン]¥[言語]¥InDesign Shortcut Sets

Windows Vista、Windows 7、Windows 10

ユーザー¥[ユーザー名]¥AppData¥Roaming¥Adobe¥InDesign¥[バージョン]¥[言語]¥InDesign Shortcut Sets

Mac OS

ユーザー/[ユーザー名]/ライブラリ/Preferences/Adobe InDesign/[バージョン]/[言語]/InDesign Shortcut Sets

作成したキーボードショートカットセットをコンピューター間でコピーする場合は、*.indk ファイルをコピー先のコンピューターの同じ場所にコピーします。

ショートカットセットは、カスタムの場所からアプリケーションフォルダーに移動することもできます。移動したカスタムショートカットは、コンピューターを共有するすべてのユーザーが使用できます。ただし、移動元と移動先に同じ名前のセットがないことを確認して移動してください。アプリケーションのショートカットセットとカスタムのセットは異なる名前にします。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー