Solucionar errores de impresión y de exportación como PDF en InDesign

Descubra cómo solucionar errores al imprimir PDF o exportar como PDF a través de InDesign.

Soluciones previas de problemas

Pruebe las soluciones en el orden indicado a continuación para conocer la naturaleza del problema. Es posible que su problema se resuelva en esta fase del procedimiento sin que tenga que continuar con la guía avanzada de resolución de problemas.

Solución

Explicación

Reiniciar el ordenador

El error no se repite: es probable que tenga su origen en un problema temporal en la comunicación, en la falta de recursos del sistema u otros factores del entorno. 

El error se repite al imprimir o exportar después de reiniciar: siga las soluciones que se indican en la pestaña sobre problemas relacionados con el sistema.

Reiniciar la impresora

El error no se repite: es probable que estuviera ocasionado por un problema con la memoria de la impresora.

Crear un documento de muestra

Si puede imprimir o exportar un documento nuevo, pero no el original, siga las soluciones que se indican en la pestaña sobre problemas relacionados con el documento.

Imprimir o exportar con una aplicación distinta

Si puede imprimir en otra aplicación (como WordPad o TextEdit) o exportar y guardar como PDF mediante otra aplicación (como Illustrator o Photoshop) y le surgen errores, siga las soluciones que se indican en la pestaña sobre problemas relacionados con la aplicación.

Imprimir en una impresora diferente

Si hay otra impresora disponible, úsela para imprimir el documento. Si esto funciona, compruebe que la impresora original está encendida y en línea. Desenchufe los cables de la impresora y vuelva a conectarlos y lleve a cabo una prueba de impresión para ver si se produce un fallo mecánico o los cables están dañados. Si el problema continúa, siga las soluciones que se indican en la pestaña sobre problemas relacionados con el sistema.

Recurrir a un método diferente para crear el archivo PDF

Si el problema aparece:

  • Al exportar como PDF de InDesign a Acrobat Standard, Pro o Pro Extended, pruebe a usar la impresora de Adobe PDF (si utiliza macOS 10.6 o una versión posterior con Acrobat 9, consulte Compatibilidad con Guardar como PDF de Adobe).
  • Al utilizar la función de impresión para crear el archivo PDF, elija Archivo > Exportar a PDF.

Seleccione el problema en las siguientes pestañas y siga con las soluciones.

Si el error se produce al imprimir o exportar un nuevo documento, es posible que la configuración de impresión o exportación del documento sea incorrecta o que hayan resultado dañados una fuente u objeto usados en el documento o la estructura del documento. Pruebe una o varias de las siguientes soluciones.

Según la impresora que utilice, la ubicación de los ajustes puede variar y puede ser diferente de lo que figura en los siguientes procedimientos. Consulte la documentación de la impresora.

Solución 1: Exporte como IDML (InDesign CS4 y posteriores) o INX (InDesign CS3 y anteriores).

Es probable que el documento se haya dañado debido a que se ha convertido incorrectamente de versiones anteriores de documentos de InDesign o QuarkXpress. 

Sugerencia: Los datos problemáticos pueden eliminarse con la exportación como formato InDesign Markup Language (IDML) o InDesign Interchange (INX).

Solución 2: (Solo impresoras PostScript) Active el control de errores de PostScript.

Windows

macOS

  1. Elija Archivo > Imprimir.

  2. Haga clic en el botón Configurar.

  3. Si aparece el siguiente cuadro de diálogo, haga clic en OK: “Si es posible, configure los ajustes de impresión en la forma deseada en el cuadro de diálogo Imprimir de InDesign para evitar conflictos de impresión”.

  4. Haga clic con el botón derecho en la impresora y elija Propiedades.

  5. En la pestaña General, haga clic en Preferencias de impresión.

  6. Haga clic en Avanzadas.

  7. Expanda Opciones de documento y luego Opciones PostScript. Si en Enviar controlador de errores de PostScript no se elige la opción , haga clic en él y seleccione  en el menú emergente.

  1. Elija Archivo > Imprimir.

  2. Seleccione la impresora.

  3. Seleccione Control de errores en el menú que está debajo de Ajustes preestablecidos.

  4. Seleccione Imprimir informe detallado y después haga clic en Imprimir.

Si el problema se debe a un error de PostScript, el administrador de errores de PostScript imprimirá una página con información sobre el error. Consulte Solución de errores de PostScript.

Solución 3: Excluya gráficos del documento.

Cuando vaya a imprimir

Cuando vaya a exportar como PDF

  1. Elija Archivo > Imprimir.

  2. Haga clic en Gráficos y seleccione Ninguno en el menú Enviar datos.

  3. Haga clic en Imprimir.

  1. Elija Archivo > Exportar y seleccione Adobe PDF (Imprimir) como formato o Guardar como texto.

  2. Elija una ubicación y haga clic en Guardar.

  3. Haga clic en Avanzadas y, a continuación, seleccione las tres casillas Omitir para OPIEPS, PDF y Mapa de bits.

  4. Cambie el estándar de PDF a Ninguno para permitir la exclusión de imágenes.

  5. Haga clic en Exportar.

Si el documento se imprime o exporta correctamente, es posible que haya uno o más elementos gráficos dañados en la página. Siga estos pasos para continuar:

  1. Elimine una cantidad determinada de gráficos y pruebe a imprimir. Repita el proceso hasta que descarte los gráficos que causan el error.

  2. Una vez que identifique los gráficos que producen el error sistemáticamente, elimínelos y reemplácelos. Es posible que sea necesario volver a exportar un gráfico a través de la aplicación en la que se creó.

Si consigue imprimir correctamente sin los gráficos, es posible que la memoria de la impresora no sea la adecuada. Entre los posibles indicios del problema, están la sustitución de fuentes, la ausencia de gráficos o impresiones incompletas. Siga estos pasos para continuar:

  1. Imprima utilizando un intervalo de páginas.

  2. Imprima con un número reducido de gráficos.

  3. Imprima con una resolución inferior.

Si el documento contiene solo elementos gráficos, le saldrá una página en blanco al imprimir solamente si se ha activado la opción de imprimir páginas en blanco en InDesign. Seleccione Imprimir páginas en blanco en la sección General del cuadro de diálogo Imprimir.

Solución 4: Excluya o minimice fuentes.

Cuando vaya a imprimir

Cuando vaya a exportar como PDF

  1. Elija Archivo > Imprimir.

  2. Haga clic en Gráficos.

  3. En la sección Fuentes, elija Ninguna en el menú Descargar.

  4. Haga clic en Imprimir.

No puede excluir fuentes al exportar, pero puede reducir la cantidad de fuentes utilizadas.

  1. Elija TextoBuscar fuente.

  2. En la lista Fuentes en documento, mantenga pulsada la tecla Mayús y elija la primera fuente y la última fuente para seleccionar todas las fuentes de la lista.

  3. En la lista Reemplazar por familia de fuentes, seleccione una fuente que sepa que funciona en otros documentos como, por ejemplo, Arial o Verdana.

  4. Haga clic en Cambiar todo.

  5. Haga clic en Listo.

  6. Elija Archivo > Exportar y seleccione Adobe PDF (Imprimir) como formato.

  7. Elija una ubicación y haga clic en Guardar.

  8. Haga clic en Exportar.

Cree una copia del documento y luego pruebe con una fuente cada vez para detectar la fuente corrupta o dañada. Puede reemplazar las fuentes corruptas si las vuelve a descargar en el sitio del fabricante.

Solución 5: Compruebe si hay vínculos que no son válidos.

Para ver el estado de los vínculos, seleccione Ventana > Vínculos. Anule o vuelva a crear los vínculos de los archivos cuyo nombre esté precedido de un signo de interrogación u otro símbolo. Para obtener más información sobre los vínculos en InDesign, consulte Administrar vínculos de gráficos.

Solución 6: Desactive los ajustes de configuración.

Deshabilite tantos ajustes como sea posible. Si al desactivar estos ajustes se resuelve el problema, vuelva a habilitarlos en grupos para averiguar cuál causa el problema.

La disponibilidad de estos ajustes dependerá de la impresora que utilice.

Elija Archivo > Imprimir para abrir el cuadro de diálogo Imprimir. Luego, cambie los ajustes en el panel correspondiente:

Panel General

  • Configure el número de copias en 1.
  • Seleccione Páginas para desactivar Pliegos.
  • Anule la selección de Imprimir páginas maestras, Imprimir objetos no imprimibles, e Imprimir guías visibles y cuadrículas base.
  • Configure Imprimir capas en Capas visibles, imprimibles.

Panel de configuración

  • Configure el tamaño de papel en Definido por controlador.
  • Configure la anchura y altura de escala en 100%.
  • Desactive Miniaturas y Mosaico.

Panel Marcas y sangrado

  • Desactive Marcas, Sangrado y Anotaciones.

Panel Salida

  • Configure el color en No cambiar compuesto.
  • Desactive Reventado, Texto en negro y Simular sobreimpresión.
  • En el Administrador de tinta, desactive Alias de tinta.

Panel Gráficos

  • Configure el envío de imágenes como Ninguno o Todo.
  • Configure la descarga de fuentes como Ninguno o Todo.
  • Configure PostScript en Nivel 2.
  • Configure el formato de datos en ASCII.

Panel Gestión de color

  • En Administración de color, elija Dejar que la impresora PostScript determine los colores.
  • Active Conservar números de CMYK.

Panel Páginas (fuera del cuadro de diálogo Imprimir)

Seleccione todas las páginas, haga clic con el botón derecho y elija Atributos de página > Acoplar pliegos > Ninguno (ignorar transparencia).

Solución 7: Solucione problemas de los plug-ins.

Quite los plug-ins de terceros desde la carpeta Plugins de InDesign y reinicie la aplicación. Si el problema se repite, vuelva a colocar los plug-ins en la carpeta Plugins de InDesign. Si el problema desaparece, identifique los plug-ins problemáticos:

  1. Seleccione Ayuda > Configurar plug-ins (Windows)InDesign > Configurar plug-ins (macOS).

  2. Seleccione Todos los plug-ins como Conjunto y luego anule todas las selecciones de la sección Mostrar excepto Terceros. Cree una lista con estos plug-ins.

  3. Salga de InDesign y saque estos plug-ins de la carpeta Plugins.

    • Windows: /Archivos de programa/Adobe/Adobe InDesign [versión]/Plug-Ins
    • macOS: /Aplicaciones/Adobe InDesign [versión]/Plug-Ins
  4. Reinicie InDesign, trate de reproducir el problema y realice los siguientes pasos:

    • Si el problema no vuelve a producirse, repita los pasos 3 y 4, volviendo a añadir algunos plug-ins de terceros a la carpeta de plug-ins.
    • Si el problema se repite, contacte con el desarrollador del último plug-in que ha movido para solicitar una actualización.

Para obtener más información, consulte Solución de problemas de plug-ins de terceros de InDesign.

Solución 8: Imprima o exporte a través de una cuenta de usuario nueva.

En ocasiones, las cuentas de usuario pueden dañarse e impedir que una aplicación lea o escriba en ciertos archivos y carpetas. Cree una cuenta de usuario (sin eliminar la original), inicie sesión en la cuenta nueva y vuelva a intentar imprimir o exportar el documento.

Windows

macOS

Elija Inicio > Panel de control > Cuentas de usuario.

Elija el menú Apple > Preferencias del Sistema > Usuarios y Grupos.

Solución 9: Determine si el documento está dañado.

Si recibe un error al imprimir cualquier documento de InDesign, pruebe una o varias de las siguientes tareas para identificar la causa del problema de la propia aplicación.

Solución 1: Vuelva a crear las preferencias de InDesign

Cuando InDesign funciona de forma irregular, los problemas se solucionan a menudo eliminando y volviendo a crear preferencias.

Existen dos maneras de volver a crear las preferencias:

Automáticamente

Con este método se eliminan rápidamente los archivos de preferencias actuales y después se vuelve a generar un nuevo conjunto de archivos de preferencias predeterminadas. Sin embargo, se pierden todos los ajustes personalizados ya existentes.

Manualmente

Si no desea perder su configuración personalizada, cambie el nombre de los archivos de preferencias actuales antes de volver a generar un nuevo conjunto de archivos de preferencias predeterminadas. De esta forma, si con las nuevas preferencias no se resuelve el problema de impresión o exportación, dispone de una copia de seguridad de sus archivos de preferencias originales (incluidos los ajustes de configuración personalizados) que puede utilizar para reemplazar los nuevos archivos de preferencias.

Volver a crear los archivos de preferencias de InDesign automáticamente

 Al volver a crear los archivos de preferencias de InDesign, se eliminan datos de preferencias anteriores, incluido cualquier ajuste personalizado. Si no desea perder su configuración personalizada, vuelva a crear los archivos de preferencias de forma manual.

  1. Salga de InDesign.

  2. Vuelva a iniciar InDesign y, en cuanto se inicie, mantenga pulsadas las teclas requeridas según el sistema operativo:

    • macOS: Control+Opción+Comando+Mayús
    • Windows: Control+Alt+Mayús
  3. En el cuadro de diálogo donde se le pregunta si desea eliminar los archivos de preferencias de InDesign, haga clic en . InDesign se inicia con preferencias predeterminadas generadas de nuevo.

Volver a crear archivos de preferencias de InDesign manualmente

Cambie el nombre de los dos archivos de preferencias (por ejemplo, cambie “InDesign SavedData” a “Copia de seguridad de InDesign SavedData” e “InDesign defaults” a “Copia de seguridad de InDesign defaults”). Los archivos de preferencias se encuentran en:

macOS

InDesign Defaults
Usuarios/[usuario]/Librería/Preferencias/Adobe InDesign/Version [versión]/[idioma]/InDesign Defaults

 

InDesign SavedData:

Usuarios/[usuario]/Librería/Caches/Adobe InDesign/Version [versión]/[idioma]/InDesign SavedData

Windows XP

InDesign Defaults:
/Documents and Settings/[usuario]/Application Data/Adobe/InDesign/Version [versión]/InDesign Defaults

Oculta de manera predeterminada. Conozca cómo mostrar archivos ocultos.

InDesign SavedData:
/Documents and Settings/[usuario]/Local Settings/Application Data/Adobe/InDesign/Version [número de versión]/Caches/InDesign SavedData

Windows 7 y 8

InDesign Defaults:

C:\Usuarios\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[idioma]\InDesign Defaults

Oculta de manera predeterminada. Conozca cómo mostrar archivos ocultos.

InDesign SavedData:

/Usuarios/[usuario]/AppData/Local/Adobe/InDesign/Version[versión]/[idioma]/Caches/InDesign SavedData

Reinicie InDesign. InDesign crea un nuevo conjunto de archivos de preferencias predeterminadas.

Si se sigue produciendo el problema de impresión o exportación, puede restaurar las preferencias originales restaurando el nombre original de los archivos de preferencias antiguos: InDesign SavedData e InDesign Defaults.

Solución 2: (Solo Windows) Compruebe que el controlador de la impresora está actualizado.

Instale el controlador más reciente para la impresora:

Solución 3: (Solo Windows, impresora PostScript) Optimice PostScript para agilizar las operaciones.

  1. Elija Archivo > Imprimir.

  2. Haga clic en Configuración, seleccione una impresora, haga clic en Preferencias y luego en Avanzadas.

  3. Expanda Opciones de documento y luego Opciones PostScript.

  4. Elija Opción de salida de PostScript.

  5. En el menú emergente, seleccione Optimizar para velocidad y haga clic en OK.

  6. Haga clic en Aceptar y luego en Imprimir.

Solución 4: Desactive la función de protección de página de la impresora.

Consulte la documentación de la impresora para obtener instrucciones sobre cómo desactivar esta función.

Solución 6: Guárdelo como PDF en una unidad de disco duro local.

Si el problema se produce al exportar como PDF a una ubicación de red, pruebe a guardar como PDF en un disco duro local.

La inestabilidad de redes o los problemas con los permisos pueden provocar problemas al exportar a volúmenes de red montados. Si puede exportar un archivo a una unidad local, pero no a una ubicación de red, pida al departamento de TI que investigue el problema.

Si tiene problemas al imprimir en una impresora PostScript, pruebe una o más de las tareas siguientes. Intente imprimir después de cada una de ellas.

Solución 1: Utilizar un controlador de impresora actualizado.

Descargue la versión más reciente del controlador de la impresora PostScript para macOS o Windows.

 Si utiliza una impresora de red, puede que esté usando un controlador de impresora que es compatible con el sistema operativo del servidor de la impresora pero no con su sistema operativo. Para instalar un controlador de impresora que sea compatible con su sistema operativo, configure de nuevo la impresora de red con el Asistente para agregar impresoras.

Solución 2: Utilice un archivo PPD actualizado.

Un archivo de Descripción de impresora PostScript (PPD) describe las posibilidades de una impresora PostScript en cuanto a márgenes, color y resolución. Un archivo PPD incorrecto u obsoleto puede aumentar el tiempo de impresión. Configure su impresora con el archivo PPD recomendado por el fabricante de la impresora.

Para obtener un archivo PPD, póngase en contacto con el fabricante de la impresora o descárguelo desde el sitio web de Adobe.

Solución 3: (Solo Windows) Configure la impresora para que genere un código de PostScript optimizado.

Para Windows 7:

  1. Elija Inicio > Dispositivos e impresoras.

  2. Haga clic con el botón derecho del ratón y elija Preferencias de impresión > Avanzadas.

  3. Expanda las opciones de documento y luego las de PostScript.

  4. Elija Optimizar para portabilidad en el menú de opción de salida PostScript.

Solución 4: Deje más espacio libre en disco.

Asegúrese de que haya una cantidad de espacio libre suficiente en el disco duro. Intente mantener libre al menos el 10 % del espacio del disco duro. Para crear más espacio, busque y elimine archivos temporales (.tmp) en el equipo y borre la memoria caché utilizada por el navegador web. Para obtener información acerca de la eliminación de la memoria caché del disco, consulte la documentación del navegador.

Solución 5: Imprima con una impresora local.

Si imprime en una impresora de red, pruebe a imprimir el archivo en un equipo que esté conectado directamente a una impresora local. Si el archivo se imprime correctamente, es posible que el origen del problema esté relacionado con la red. Póngase en contacto con el administrador de redes para obtener asistencia.

Solución 6: (Solo Windows) Instale un controlador de impresora compatible con su sistema operativo.

Si utiliza una impresora de red, instale un controlador de impresora que sea compatible con su sistema operativo. Los servidores de impresora no siempre incluyen controladores para los sistemas operativos en los equipos cliente. Podría estar usando un controlador de impresora que sea adecuado para el sistema operativo del servidor de impresión pero no para el sistema operativo del ordenador.

Para Windows 7:

  1. Elija Inicio > Dispositivos e impresoras.

  2. Haga clic en Añadir una impresora.

  3. Seleccione Añadir una impresora local.

  4. Elija Crear un nuevo puerto > Puerto local > Siguiente.

  5. Introduzca el nombre del puerto (por ejemplo, \\[nombre de servidor de impresora]\[nombre de impresora]) y haga clic en Aceptar.

  6. Siga las instrucciones que aparecen en pantalla para instalar un controlador que coincida con la marca y el modelo de su impresora de red.

Si tiene problemas al imprimir en una impresora no PostScript, pruebe una o más de las tareas siguientes. Intente imprimir después de cada una de ellas.

 Para algunas de estas soluciones es necesario cambiar las propiedades del controlador de impresora. Las ubicaciones de las propiedades específicas cambian en función de la impresora y del controlador de la impresora. Póngase en contacto con el fabricante de la impresora o consulte la documentación de la misma para obtener más información.

Solución 1: Imprima como mapa de bits.

  1. Elija Archivo > Imprimir.

  2. Asegúrese de que la impresora seleccionada no sea PostScript y seleccione el panel de opciones Avanzadas.

  3. Marque la casilla Imprimir como mapa de bits y seleccione la resolución apropiada para su impresora.

Solución 2: Compruebe que la impresora tenga memoria suficiente.

Para imprimir a 300 ppp, la impresora debería tener al menos 2 MB de RAM disponible. Para imprimir a 600 ppp, la impresora debería tener al menos entre 4 y 6 MB de RAM. Para obtener más información sobre cómo determinar la memoria disponible de la impresora, consulte la documentación de la impresora.

Solución 3: Utilice el modo PostScript de la impresora, si está disponible.

Para obtener más información, consulte la documentación de la impresora.

Solución 4: (Solo Windows) Cambie al modo de controlador SVGA estándar.

Cambie al modo de controlador SVGA estándar para determinar si el controlador de vídeo de terceros está ocasionando el problema. Si el error no se produce al utilizar el controlador SVGA estándar, póngase en contacto con el fabricante de la tarjeta de vídeo para obtener un controlador actualizado. Si ya utiliza una versión actualizada, pruebe con otra resolución de vídeo (por ejemplo, 1024 x 768 en lugar de una más alta).

Si no puede imprimir o exportar como PDF desde ninguna aplicación, póngase en contacto con el soporte técnico de Apple o Microsoft, o con el fabricante de la impresora. Compruebe siempre la conexión física entre la impresora y el ordenador antes de llamar, ya que es posible que el problema se solucione volviendo a conectar un cable suelto.

Tenga también en cuenta lo que haya cambiado en el sistema recientemente, ya que podría estar afectando al proceso de impresión. Por ejemplo, ¿ha llevado a cabo alguna de estas acciones en el sistema?

  • Ha actualizado el hardware o ha añadido o quitado componentes de hardware
  • Ha añadido, actualizado o eliminado software
  • Ha instalado o eliminado fuentes
  • Se ha conectado a una red
  • Ha limpiado o borrado archivos del disco duro
  • Ha detectado errores de sistema aleatorios o errores en otras aplicaciones

A menudo, un cambio en el sistema influye directamente en la aparición de un problema de impresión. Mantenga un registro de los cambios realizados en el sistema como recurso para solucionar problemas de impresión y de otro tipo.

Recursos relacionados

Póngase en contacto con nosotros

Nos encantaría conocer su opinión. Comparta sus ideas con la Comunidad de Adobe InDesign

 Adobe

Obtén ayuda de forma más rápida y sencilla

¿Nuevo usuario?

Adobe MAX 2024

Adobe MAX
La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX

La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX 2024

Adobe MAX
La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX

La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea