إضافة نص

يمكنك إضافة نص بالكتابة، اللصق، أو الإدراج من ملف آخر. بصفة عامة، تستخدم أساليب معالجة النصوص القياسية لمعالجة النص في InCopy. حدد أداة Type في شريط الأدوات، ثم استخدم الأساليب الموصوفة فيما يلي. هذه الطرق تعمل بنفس الطريقة في طرق عرض Galley وStory وLayout، سواءً كان المحتوى مرتبط بـ Adobe InDesign® أم لا.

كتابة

انقر فوق نقطة الإدخال حيث تريد أن تقوم بإضافة النص، وأبدأ الكتابة.

التحديد

قم بالنقر المزدوج أو السحب أو النقر الثلاثي لتحديد حروف منفردة أو كلمات أو سطور أو فقرات (طبقاً لإعدادات التفضيلات). أو انقر أي مكان في المحتوى واختر Edit > Select All.

اللصق

انسخ أو قص النص، انقر في المكان الذي تريد، واختر تحرير > لصق. إذا كنت تريد إزالة تنسيق النص الملصق، اختر تحرير > لصق بدون التنسيق. إذا رغبت في إضافة أو إزالة المسافات حسب الضرورة، حدد ضبط المسافة آلياً عند قص ولصق الكلمات في قسم الكتابة من شاشة التفضيلات.

يمكنك أيضًا استخدام Edit > Paste Without Grid Format للصق النص في شبكة إطار كث يحتفظ النص الذي تم لصقه بحجمه وحجم الخط والمسافات بين الأحرف وإعدادات النص المنسوخ.

الحذف

حدد النص الذي تريد حذفه، واختر Edit > Clear.

يمكنك أيضاً إدراج نص مباشرة من وثيقة نص آخر.

استيراد الملفات

يمكنك استيراد النص من مجموعات InCopy نصية أخرى، وMicrosoft® Word وMicrosoft Excel، وأي تطبيق يمكن تصدير نص منه بتنسيق Rich Text Format أو تنسيق نص فقط. كل تنسيقات الملفات التي يمكن استيرادها مسرودة بالأسفل في مربع حوار InCopy Place (في قائمة نوع الملفات في Windows®، وفي القائمة اليمنى في Mac OS).

تنسيق المستندات والأنماط

يمكنك إدراج ملفات بتنسيق أو بدون. إذا قمت بإدراج ملفات مع التنسيق، يقوم InCopy بإدراج أغلب خصائص التنسيق للفقرات والحروف من الملفات النصية ولكن يتجاهل معظم المعلومات الخاصة بتخطيط الصفحة كإعدادات الهوامش والأعمدة (يمكنك ضبط هذه الإعدادات من خلال InDesign). بصفة عامة، يقوم InCopy بإدراج كل معلومات التنسيقات المحددة بتطبيقات معالجة الكلمات ما عدا معلومات خصائص برنامج معالجة الكلمات غير المتاحة في InCopy.

إذا كان InCopy يتمتع بمرشح للتطبيق، يمكنك أن تحدد أي الأنماط يتم إدراجها، وأي التنسيقات سيتم استخدامها إذا كان هناك تعارض في الاسم.

ملاحظة:

يتحكم InDesign في الأنماط في مجموعات نص InCopy المرتبطة. عندما تقوم بوضع مجموعة نص InCopy في InDesign، فإن أي أنماط مدرجة في وثيقة InCopy يتم تخطيها في InDesign إذا كانت تتعارض مع أسماء النمط.

حفظ الملفات للاستيراد

إذا كان التطبيق الخاص بك لمعالجة الكلمات يمكنه حفظ الملفات بتنسيق ملفات أو أكثر، حاول استخدام التنسيق القادر على الحفاظ على معظم التنسيق-إما تنسيق الملف الأصلي أو تنسيق تبادلي مثل Rich Text Format (RTF).

يمكنك إدراج ملفات تم إنشائها في الإصدرات الحديثة من Microsoft Word. إذا كنت تقوم بوضع ملف من تطبيق معالجة كلمات مختلف أو من Word 95 في Windows أو ما سبقه، مثل Word 6، قم بفتح الملف في التطبيق الأصلي واحفظه بتنسيق Word متوافق أو بتنسيق RTF، والذي يحافظ على معظم التنسيق.

وضع (استيراد) النص

للكميات الكبيرة من النص، فإن أمر وضع يكون أكثر طريقة مفيدة لإدراج المحتوى. يدعم InCopy العديد من التنسيقات الخاصة بتطبيقات معالجة الكلمات والجداول الإلكترونية والملفات النصية. تعتمد الدرجة التي يتم بها الاحتفاظ بالتنسيق الأصلي على مرشح الإدراج لنوع الملف والخيارات التي تختارها وأنت تقوم بوضع الملف. يمكنك أيضاً فتح ملفات Word، نص، وRTF مباشرة في InCopy.

  1. باستخدام أداة Type ، انقر حيث تريد أن يظهر النص.
  2. اختر File > Place.
  3. في مربع الحوار Place، حدد Show Import Options إذا أردت عرض مربع حوار يحتوي على خيارات الاستيراد لنوع الملف الذي تضعه.
  4. حدد ملف النص الذي تريد وضعه، ثم انقر Open. (إذا تم الضغط على Shift مع النقر فوق Open، يظهر مربع الحوار Import Options حتى لو لم يتم تحديد Show Import Options.)
  5. قم بتنفيذ أي من الإجراءات التالية:
    • إذا عرض مربع حوار ما خيارات للاستيراد لنوع الملف الذي تقوم بوضعه، حدد أي خيارات تريدها، وانقر فوق OK.

    • إذا كانت الوثيقة التي تقوم بإدراجها تحتوي على خطوط غير متوفرة على نظامك، تظهر شاشة لتخبرك باستبدال الخطوط. إذا فضلت أن تحدد خطوط بديلة، انقر البحث عن خط واختر البدائل.

ملاحظة:

إذا كان النص الذي تقوم بإدراجه في وثيقتك يحتوي على تمييزات ذات لون وردي أو لون أخضر أو أي لون أخر من ألوان التمييز، فإنه من المحتمل أنه هناك خيار أو أكثر من خيارات تفضيلات التكوين نشطة. افتح القسم الخاص بالتكوين في مربع حوار Preferences وراجع خيارات التمييز التي تم تنشيطها. على سبيل المثال، إذا كان النص الموضوع منسقاً بخطوط غير متوفرة في InCopy، فإن النص يتم تمييزه باللون الوردي.

خيارات الاستيراد

عندما تقوم باستيراد ملفات Word وExcel ونص بعلامات تمييز، يمكنك تحديد كيفية استيراد الملفات.

خيارات استيراد Microsoft Word وRTF

إذا حددت Show Import Options عند تضمين ملف Word أو ملف RTF، فيمكنك الاختيار من هذه الخيارات:

Table Of Contents Text

يتم استيراد جدول المحتويات كجزء من النص في المجموعة النصية. يتم استيراد هذه المدخلات كنص عادي فقط.

Index Text

يتم استيراد الفهرس كجزء من النص في المجموعة النصية. يتم استيراد هذه المدخلات كنص عادي فقط.

Footnotes

يتم استيراد حواشي Word سفلية. يتم الاحتفاظ بالحواشي السفلية والمراجع، ولكن تتم إعادة ترقيمها بناءً على إعدادات الحواشي السفلية في المستند. إذا لم يتم استيراد الحواشي السفلية من Word بشكل صحيح، فحاول حفظ مستند Word بتنسيق RTF وقم واستيراد ملف RTF.

Endnotes

يستورد التعليقات الختامية كجزء من النص في نهاية المجموعة النصية.

Use Typographer’s Quotes

للتأكد من أن النص الذي تم استيراده يحتوي على علامات تنصيص يسرى ويمنى (“ ”) وأيضًا علامة تنصيص مفردة (’) بدلاً من علامات التنصيص المستقيمة (" ") وعلامات التنصيص المفردة (').

Remove Styles And Formatting From Text And Tables

تتم إزالة التنسيقات، مثل مظهر الكتابة ولون الكتابة ونمط الكتابة من النص المستورد متضمنًا النص الموجود داخل الجداول. لا يتم استيراد أنماط الفقرات أو الرسومات داخل السطر إذا كان هذا الخيار محددًا.

Preserve Local Overrides

عند قيامك باختيار إزالة الأنماط وتنسيقات من النص والجداول، يمكنك تحديد خيار Preserve Local Overrides للحفاظ على تنسيق الحروف، مثل الأسود والمائل، التي يتم تطبيقه كجزء من الفقرة. قم بإلغاء تحديد هذا الخيار لإزالة كل التنسيقات.

Convert Tables To

عندما تختار إزالة الأنماط وتنسيقات النص والجدول، يمكنك تحويل الجداول إلى الجداول الأساسية أو الجداول غير المنسقة أو نصًا غير منسق مفصول بعلامات جدولة.

إذا كنت تريد استيراد نص غير منسق وجداول منسقة، فقم باستيراد النص بدون تنسيق ثم الصق الجداول من Word في InCopy.

Preserve Styles And Formatting From Text And Tables

الاحتفاظ بتنسيقات مستند Word في مستند InDesign أو InCopy. يمكنك استخدام الخيارات الأخرى في قسم Formatting لتحديد كيفية الاحتفاظ بالأنماط والتنسيق.

Manual Page Breaks

يحدد كيفية تنسيق فواصل الصفحات الموجودة في ملف Word عند إدراجها في InDesign أو InCopy. حدد Preserve Page Breaks لاستخدام نفس فواصل الصفحات المستخدمة في Word أو حدد Convert To Column Breaks أو No Breaks.

Import Inline Graphics

يحتفظ بالرسومات على السطر من مستند Word في InCopy.

Import Unused Styles

استيراد كل الأنماط من مستند Word، حتى إذا كانت الأنماط غير مطبقة على نص.

Convert Bullets & Numbers To Text

يتم استيراد نقاط التعداد والأرقام كحروف حقيقية، مع الحفاظ على مظهر الفقرة. ومع ذلك، في القوائم المرقمة، لا يتم تحديث الأرقام تلقائيًا عند تغيير عناصر القائمة.

Track Changes

يؤدي تحديد هذا الخيار إلى ظهور علامات تتبع التغييرات من مستند Word في مستند InCopy. في InDesign، قم بعرض تتبع التغييرات في Story Editor.

Import Styles Automatically

استيراد الأنماط من مستند Word إلى مستند InDesign أو InCopy. إذا ظهر مثلث أصفر بجوار Style Name Conflicts، عندئذ يكون هناك أنماط فقرة أو حرف من مستند Word له نفس اسم نمط InCopy.

لتحديد كيفية حل تعارضات اسم النمط، حدد خيارًا من قائمة Paragraph Style Conflicts وقائمة Character Style Conflicts. يؤدي تحديد الخيار Use InCopy Style Definition إلى تنسيق نص النمط الذي تم استيراده بناءً على نمط InCopy. إن اختيار Redefine InCopy Style يسبب تنسيق نمط النص الذي تم استيراده بناءً على نمط Word، وتغيير تنسيق نص InCopy باستخدام نمط Word. يؤدي تحديد خيار Auto Rename إلى إعادة تسمية أنماط Word التي تم استيرادها. على سبيل المثال، إذا كان كل من Word وInCopy يحتويان على نمط يسمى Subheading، فستتم إعادة تسمية نمط Word الذي تم استيراده إلى Subheading_wrd_1 عندما يكون خيار Auto Rename محددًا.

ملاحظة:

يحول InCopy أنماط الحرف والفقرة وليست أنماط قائمة التعداد النقطي أو الرقمي.  

Customize Style Import

قم باستخدام مربع حوار Style Mapping لتحديد أي من أنماط InCopy يلزم استخدامه لكل نمط Word في المستند الذي تم استيراده.

Save Preset

حفظ خيارات استيراد Word الحالية للاستخدام المستقبلي. حدد خيارات الاستيراد ثم انقر فوق Save Preset واكتب اسم الإعداد المسبق ثم انقر فوق OK. في المرة التالية التي تقوم فيها باستيراد نمط Word، يمكنك تحديد الإعداد المسبق الذي قمت بإنشائه من القائمة Preset. انقر فوق Set As Default إذا كنت تريد استخدام الإعداد المسبق المحدد في الوضع الافتراضي عند إجراء أي عملية استيراد لمستندات Word فيما بعد.

خيارات استيراد ملف نصي

إذا حددت Show Import Options عند تضمين ملف نصي، يمكنك الاختيار من هذه الخيارات:

Character Set

سوف تقوم بتحديد نسق الحروف تبعًا للغة الكمبيوتر مثل نسق ANSI أو Unicode UTF8 أو Windows CE المستخدم عند إنشاء الملف النصي. التحديد الافتراضي هو مجموعة الحروف المرادفة للغة الافتراضية وبيئة عمل InCopy أو InDesign.

سوف تقوم مجموعة حروف لغة الكمبيوتر مثل ANSI أو Unicode UTF8 أو Shift JIS أو Chinese Big 5 التي تم استخدامها عند إنشاء الملف النصي. التحديد الافتراضي هو مجموعة الحروف المرادفة للغة الافتراضية وبيئة عمل InCopy أو InDesign.

Platform

يحدد ما إذا كان الملف قد تم إنشاؤه على بيئة تشغيل Windows (PC) أو Mac OS (Macintosh).

Set Dictionary To

يحدد القاموس المراد استخدامه مع النص الذي تم استيراده.

Extra Carriage Returns

يحدد كيفية استيراد انكسارات الفقرات الزائدة. اختر Remove At End Of Every Line أو Remove Between Paragraphs.

Replace

يستبدل عددًا محددًا من المسافات بجدولة.

Use Typographer’s Quotes

للتأكد من أن النص الذي تم استيراده يحتوي على علامات تنصيص يسرى ويمنى (“ ”) وأيضًا علامة تنصيص مفردة (’) بدلاً من علامات التنصيص المستقيمة (" ") وعلامات التنصيص المفردة (').

خيارات استيراد Microsoft Excel

يمكنك اختيار من بين تلك الخيارات عند استيراد ملف Excel:

Sheet

لتحديد ورقة العمل التي تريد استيرادها.

View

لتحديد كيفية استيراد أي طرق عرض مخصصة أو طرق عرض شخصية أو يمكنك تجاهل طرق العرض.

Cell Range

لتحديد حدود مدى الخلايا باستخدام حرف (:) لتحديد المدى (مثل A1:G15). إذا كان هناك أي نطاقات محددة داخل ورقة العمل فإن أسماء النطاقات سوف تظهر في قائمة Cell Range.

Import Hidden Cells Not Saved In View

يشمل أي خلية تم تنسقيها بحيث تكون مختفية في ورقة عمل Excel.

Table

يحدد كيفية عرض بيانات ورقة العمل في المستند.

Formatted Table

يحاول InCopy الحفاظ على نفس التنسيق المستخدم في Excel، بالرغم أنه لا قد لا يمكن الاحتفاظ بتنسيق النص ضمن كل خلية. إذا كان جدول البيانات مرتبطًا وليس مضمنًا، فإن تحديث الرابط سيتخطى أي تنسيق مطبق على الجدول في InCopy.

Unformatted Table

يتم استيراد الجدول بدون أي تنسيق من الجدول الإلكتروني. عندما يكون هذا الخيار محددًا، يمكنك تطبيق نمط الجدول على الجدول الذي تم استيراده. إذا قمت بتنسيق النص باستخدام أنماط الفقرة والحرف، سيتم الحفاظ على التنسيق حتى وأن قمت بتحديث الرابط إلى الجدول الإلكتروني.

Unformatted Tabbed Text

يتم استيراد الجدول كنص مفصول بحرف جدولة، والذي يمكنك عندئذ تحويله إلى جدول في InDesign أو InCopy.

Formatted Only Once

يحافظ InDesign على نفس التنسيق المستخدم في Excel أثناء الاستيراد المبدئي. إذا كانت الجداول الإلكترونية مرتبطة وليست مدمجة، فإن تغييرات التنسيق التي تمت على الجداول الإلكترونية يتم تجاهلها في الجدول المرتبطة عندما تقوم بتحديث الرابط. هذا الخيار غير متاح في InCopy.

Table Style

تطبيق نمط جدول تحدده على المستند الذي تم استيراده. يكون هذا الخيار متاحًا فقط في حالة وجود جدول غير منسق محدد.

Cell Alignment

يحدد محاذاة الخلايا للمستند الذي تم استيراده.

Include Inline Graphics

يحتفظ بالرسومات على السطر من مستند Excel في InCopy.

Number Of Decimal Places To Include

يحدد عدد الخانات العشرية في أرقام جدول البيانات.

Use Typographer’s Quotes

للتأكد من أن النص الذي تم استيراده يحتوي على علامات تنصيص يسرى ويمنى (“ ”) وأيضًا علامة تنصيص مفردة (’) بدلاً من علامات التنصيص المستقيمة (" ") وعلامات التنصيص المفردة (').

خيارات استيراد نص ذو علامات تمييز

يمكنك استيراد (أو تصدير) ملف نصي قادر على الاستفادة من إمكانيات تنسيق InCopy باستخدام تنسيق نص بعلامات تمييز. ملفات النص ذات علامات التمييز هي ملفات نصية تحتوي على معلومات تصف التنسيق الذي تريد أن يطبقه InCopy. يمكن أن يصف النص الذي تم عمل علامات له بشكل صحيح كل شيء يمكن أن يظهر في مجموعة InCopy النصية، بما في ذلك خصائص كل مستويات الفقرة، وخصائص على مستوى الحرف، والحروف الخاصة.

لمزيد من المعلومات حول تحديد العلامات، اطلع على "ملف PDF ذو النص المميز" في www.adobe.com/go/learn_id_taggedtext_cs5_ae (PDF).

تتوفر الخيارات التالية عندما تقوم باستيراد نص مميز و تحديد Show Import Options في مربع حوار Place.

Use Typographer’s Quotes

للتأكد من أن النص الذي تم استيراده يحتوي على علامات تنصيص يسرى ويمنى (“ ”) وأيضًا علامة تنصيص مفردة (’) بدلاً من علامات التنصيص المستقيمة (" ") وعلامات التنصيص المفردة (').

Remove Text Formatting

تتم إزالة التنسيقات، مثل مظهر الكتابة ولون الكتابة ونمط الكتابة من النص الذي تم استيراده.

Resolve Text Style Conflicts Using

لتحديد نمط الحرف أو نمط الفقرة الذي سيتم تطبيقه إذا حدث أي تعارض بين النمط المعرف في النص ذو علامات التمييز والنمط المعرف بمستند InDesign. حدد Publication Definition لاستخدام تعريفات الأنماط الموجودة بالفعل في مستند InDesign. حدد الخيار Tagged File Definition لاستخدام الأنماط المعرفة في النص المميز.

Show List Of Problem Tags Before Place

يقوم بعرض قائمة بعلامات التمييز غير المتعارف عليها. إذا ظهرت القائمة فإنه يمكنك إلغاء عملية الاستيراد أو الاستمرار فيها. إذا قمت بالاستمرار ربما لن يظهر الملف المدرج بالشكل المتوقع.

استيراد مستندات Buzzword

Buzzword هو محرر نصي يستند إلى الويب ويتيح للمستخدمين إنشاء ملفات نصية وتخزينها على خادم ويب. في InCopy CS5، يمكن استيراد نصوص من مستندات Buzzword وتصديرها إليها.

عند استيراد مستند Buzzword، يتم إنشاء رابط يستند إلى عنوان URL إلى مستند Buzzword في الخادم. عند تحديث مستند Buzzword خارج InCopy، يمكنك استخدام لوحة Links لتحديث الإصدار الذي تم استيراده في InCopy. إلا أن ذلك سيؤدي إلى إزالة أي تغييرات تمت في نص Buzzword الذي أعددته في InCopy.

ملاحظة:

يتوفر تطبيق Buzzword على الموقع Acrobat.com باللغات الإنجليزية والفرنسية والألمانية فقط.

  1. اختر File > Place From Buzzword.

  2. إذا لم تكن قد سجلت الدخول بالفعل إلى CS Live، انقر فوق Sign In، حدد عنوان بريدك الإلكتروني وكلمة السر، ثم انقر فوق Sign In.

    بعد تسجيل الدخول، يعرض مربع حوار Place Buzzword Documents قائمة بمستندات Buzzword التي يمكن استيرادها.

  3. حدد المستندات المطلوب استيرادها أو قم بلصق عنوان URL الخاص بوثيقة Buzzword داخل حقل لصق عنوان URL.

  4. حدد أيًا من الخيارات التالية ثم انقر فوق OK.

    Show Import Options

    إذا حددت هذا الاختيار، فسيظهر مربع حوار Buzzword Import Options قبل وضع الملف.

    Replace Selected Item

    حدد هذا الخيار لاستبدال الكائن المحدد حاليًا في المستند.

    Link To Document

    حدد هذا الخيار لإنشاء رابط بين وثيقة Buzzword والنص المضمن. إذا تم إنشاء رابط وتحديث وثيقة Buzzword، فستشير اللوحة Links إلى حدوث تعديل على الملف. في حالة تحديث الرابط، يتم تحديث النص الموجود في InCopy. غير أنه يتم فقد التغييرات التي تم إجراؤها على التنسيق بهذا النص في InCopy.

    تطبيق التنسيق الشبكي

    إعادة تنسيق نص تم استيراده وفقًا لسمات الشبكة.

  5. إذا حددت Show Import Options، حدد الإعدادات في مربع الحوار Buzzword Import Options.

    يتضمن هذا الحوار أغلب الخيارات الموجودة في مربع حوار RTF Import Options. راجع خيارات الاستيراد لـ Microsoft Word وRTF. لا يحتوي Buzzword حاليًا على ميزة الأنماط، لذا لا يمكن استخدام أي من خيارات الأنماط في هذا الوقت.

  6. استخدم مؤشر النص المحمل في النقر أو السحب لإنشاء إطار نص.

كتابة نص آسيوي باستخدام مدخل خط داخلي

  1. اختر Edit > Preferences > Advanced Type (في Windows) أو InCopy > Preferences > Advanced Type (في Mac OS).
  2. قم بتحديد خيار استخدام مدخل خط داخلي للنصوص غير اللاتينية ثم انقر فوق OK.

يمكنك استخدام طريقة إدخال النظام إذا كانت متاحة، لإضافة حروف 2-بايت و4-بايت. حيث أن هذه الطريقة مفيدة لإدخال الحروف الآسيوية.

يمكنك استخدام أي برنامج إدخال خاص بإدخال النص الآسيوي مباشرة في إطارات النص.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت