Undo, history, and events

  1. Adobe Premiere Pro User Guide
  2. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Premiere Pro system requirements
    5. Keyboard shortcuts in Premiere Pro
    6. Accessibility in Premiere Pro
  3. Creating projects
    1. Creating projects
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  4. Workspaces and workflows
    1. Workspaces
    2. Working with Panels
    3. Windows touch and gesture controls
  5. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transferring and importing files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  6. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Rendering and previewing sequences
      7. Working with markers
      8. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Editing, repairing, and improving audio using Essential Sound panel
      5. Monitor clip volume and pan using Audio Clip Mixer
      6. Audio balancing and panning
      7. Advanced Audio - Submixes, downmixing, and routing
      8. Audio effects and transitions
      9. Working with audio transitions
      10. Apply effects to audio
      11. Measure audio using the Loudness Radar effect
      12. Recording audio mixes
      13. Editing audio in the timeline
      14. Audio channel mapping in Premiere Pro
      15. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  7. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stablilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  8. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Create titles and motion graphics
      2. Applying text gradients in Premiere Pro
      3. Using Motion Graphics templates for titles
      4. Replace images or videos in Motion Graphics templates
      5. Use data-driven Motion Graphics templates
      6. Best Practices: Faster graphics workflows
      7. Add Responsive Design features to your graphics
      8. Working with captions
      9. Speech to Text
      10. Speech to Text in Premiere Pro | FAQ
      11. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  9. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  10. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Get creative with color using Lumetri looks
    3. Adjust color using RBG and Hue Saturation Curves
    4. Correct and match colors between shots
    5. Using HSL Secondary controls in the Lumetri Color panel
    6. Create vignettes
    7. Lumetri scopes
    8. Display Color Management
    9. HDR for broadcasters
    10. Enable DirectX HDR support
  11. Exporting media
    1. Workflow and overview for exporting
    2. Quick export
    3. Exporting for the Web and mobile devices
    4. Export a still image
    5. Exporting projects for other applications
    6. Exporting OMF files for Pro Tools
    7. Export to Panasonic P2 format
    8. Exporting to DVD or Blu-ray Disc
    9. Best Practices: Export faster
  12. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  13. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Using Productions
    8. How clips work across projects in a Production
    9. Consolidate, transcode, and archive projects
    10. Managing metadata
    11. Best Practices
      1. Best Practices: Working with Productions
      2. Best Practices: Learning from broadcast production
      3. Best Practices: Working with native formats
  14. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Green and pink video in Premiere Pro or Premiere Rush
      2. How do I manage the Media Cache in Premiere Pro?
      3. Fix errors when rendering or exporting
      4. Troubleshoot issues related to playback and performance in Premiere Pro
  15. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

Undo command

In case you change your mind or make a mistake, Premiere Pro provides several ways to undo your work. You can undo only those actions that alter the video program; for example, you can undo an edit, but you cannot undo scrolling in a window.

  1. Do one of the following:

    • To undo the most recent change, choose Edit > Undo. (You can sequentially undo as many as 32 recent changes made to the project in any Premiere Pro panel.)

    • To jump to a specific state of the project since the project was opened, select an item in the History panel.

    • To undo all changes made since the last time you saved the project, choose File > Revert.

    • To undo changes made before the last time you saved a project, try opening a previous version of your project in the Premiere Auto-Save folder, and then choose File > Save As to store the project in a location outside the Premiere Auto-Save folder. The number of previous versions saved depends on the Auto Save preference settings.

    • To stop a change that Premiere Pro is processing (for example, when you see a progress bar), press Esc.

    • To close a dialog box without applying changes, click Cancel.

    • To set all values in an applied effect back to the default values, click the Reset button for the effect in the Effect Controls panel.

History panel

Use the History panel to jump to any state of the project created during the current working session. Each time you apply a change to some part of the project, the new state of that project is added to the panel. You can modify the project from the state you select. History states aren’t available for actions within the Capture panel.

The following guidelines can help you with the History panel:

  • Program-wide changes, such as changes to panels, windows, and preferences, are not changes to the project itself and so are not added to the History panel.

  • After you close and reopen the project, the previous states are no longer available in the History panel.

  • The oldest state is at the top of the list, and the most recent one is at the bottom.

  • Each state is listed with the name of the tool or command used to change the project as well as an icon representing the tool or command. Some actions generate a state for each panel affected by the action, such as the Titler. Actions you perform in such a panel are treated as a single state in the History panel.

  • Selecting a state dims those below it, to indicate which changes are removed if you work from the project at that state.

  • Selecting a state and then changing the project removes all subsequent states.

  1. Do any of the following:
    • To select a state, click the name of the state in the History panel.

    • To navigate in the History panel, drag the panel’s slider or scroll bar; or choose Step Forward or Step Backward from the panel menu.

    • To delete a project state, select the state. Then choose Delete from the panel menu or click the Delete icon and click OK.

    • To clear all states from the History panel, choose Clear History from the panel menu.

Events panel

The Events panel lists warnings, error messages, and other information you can use to identify and troubleshoot problems, particularly those associated with plug-ins and other components from third-party developers.

An alert icon , , on the status bar notifies you of an error. Double-clicking the icon opens the Events panel, and clearing the associated item from the Events panel removes the icon from the status bar.

  1. Do either of the following:
    • Double-click the alert icon in the status bar.

    • Choose Window > Events.

  2. Do any of the following:
    • To learn more about an item in the list, select it and click Details.

    • To clear the events list, click Clear All.

Event notification

In addition to the alert icon in the Events panel, a notification pop-up window appears in the lower right corner of the user interface.

The notification appears for a few seconds, and the background color of the notification indicates the type of event. For example, error notifications have a Red background, warning notifications have a Yellow background, and informational notifications have a Blue background.

The notification pop-up window appears by default. If you want to turn it off, deselect Show Event Indicator under the General category in the Preferences dialog.

Adobe logo

Sign in to your account