Working with the Layers panel in Muse

Muse includes a Layers panel that you can use to structure your page elements and organize your site designs. In this article, you'll learn about the Layers panel and find strategies to make your projects easier to update.

Understanding layers

By default, each page of a Muse site contains at least one named layer. Using multiple layers, you can create and edit specific areas or kinds of content on the page without affecting other areas or accidentally changing other content. For example, you can use layers to display main page content and sidebar information in the same web design. Or you can place content that rarely updates in one layer, while keeping content that you'll update frequently on a different layer of the same page.

Think of layers as transparent sheets that are stacked on top of each other. If a layer doesn’t have objects on it, you can see through it to any objects that exist on the layers behind it.

Review the Layers panel and take a moment to consider how the stacking order works.

Layers panel in Adobe Muse
The Layers panel in Adobe Muse.

In the example above, Layer 1 has a text field that displays 1, Layer 2 has a text field that displays 2, and Layer 3 has a text field that displays 3.

Any elements placed on Layer 3 (the top layer) will display above the elements in Layer 2 and Layer 1. This behavior is similar to the stacking order that occurs when you select an object and choose Arrange > Bring to Front. Except when you place elements on specific layers, they are organized in a way that allows you to control the stacking order of groups of elements.

To change the stacking order, you can select a layer and drag it, to reposition it in the order of the Layers panel. In this example, Layer 1 has been dragged to the top of the Layers panel and Layer 3 has been repositioned to the bottom of the stack.

Rearrange the layers in Adobe Muse
Rearrange the order of the layers to change which element is on top.

Each layer can contain multiple elements, and the stacking order of the elements in each layer also dictates whether items display above or below other items on the page.

Layers give you unprecedented control over the arrangement of page elements in your Muse site projects.

Using layers in Muse sites

Even if you've previously worked with Layer panels in other tools, such as image editors, it's important to consider how layers work in Muse:

Expand and collapse layers. Each layer has a triangle to the left of the layer name. When collapsed, you can click the triangle to expand the contents of the layer and see the list of objects and their stacking order on that layer for the active page. Groups, widgets, and certain widget parts also have triangles that can be clicked to expand the set, to display their contained objects. You can re-order these objects, lock and unlock them, and add or remove them from groups. Layers that do not contain objects on the current page do not display a triangle because they are already expanded.

Objects on master pages appear at the bottom of each layer. Master items can appear in front of document page objects if the master page objects are placed on a higher layer, but by default they are located on the bottom of the stacking order.

Layers involve all pages of a site, including masters. For example, if you hide Layer 1 while editing the Home page of your document, the content on Layer 1 is hidden on all pages until you choose to show it again.

Reviewing the Layers Panel

The Layers panel is very powerful and includes many helpful features that can help you work more efficiently. Take a moment to familiarize yourself with the key features:

  • Create new layers
  • Set layer options
  • Add objects to layers
  • Select, move, and copy objects on layers
  • Paste objects into different layers
  • Duplicate a layer
  • Change the order of layers
  • Show or hide layers and objects
  • Lock or unlock layers
  • Delete layers
  • Merge layers in a document

These features are described in more detail in the sections below. The key elements of the Layers panel are highlighted below.

The itemized features in the Layers panel.

A. Target layer B. Delete layer C. New layer D. Search E. Help about layers F. Locked layer G. Hidden layer H. Visible layer 

Create new layers

You can add layers at any time by clicking the New Layer button at the bottom of the Layers panel. The number of layers a document can have is limited only by the amount of RAM available to Muse. The new layers you create will always appear at the top of the Layers panel, but you can drag them to reposition them.

Follow these steps to create a new layer:

  1. Click the Layers tab to make the Layers panel active, or choose Window > Layers to open the Layers panel if it is closed.
  2. Click the New Layer button at the bottom of the Layers panel.

Note: If you'd like to create a new layer and also open the Layer Options dialog box, press Alt/Option as you click the New Layer button.

Set layer options

You can update the attributes of layers in the Layers panel, to change the color coding associated with that layer, show or hide layers, show or hide guides, and lock layers to prevent them from being accidentally selected and edited. Follow these steps to update the layer options:

  1. Right-click or double-click an existing layer. (Or press Alt/Option while clicking the New Layer button).
  2. In the Layer Options dialog box that appears, specify the layer options, and then click OK.
Layer options dialog box
Update the settings in the Layer Options dialog box.

You can update the following settings:

  • Layer name: Enter a descriptive name for the layer, to help organize your page content.
  • Color: Assign a color to identify the objects that exist on that layer. Assigning a color to a layer makes it easier to distinguish the layers of different selected objects. When selected on the page, each object displays the color of its layer in its bounding box, shape selection handles, text frames, and image frame edges. The layer color does not appear when objects are deselected.
  • Show Layer: Select this option to make a layer visible. Selecting this option invokes the same behavior as clicking the eye icon to make the layer visible in the Layers panel.
  • Lock Layer: Select this option to prevent changes to any objects on the layer.

Add objects to layers

Any new object is placed on the target layer, the layer with a bold label displaying the triangle in the top right corner of the layer in the Layers panel. Target a specific layer by clicking it.

You can add objects to the target layer by doing any one of the following:

  • Creating new objects with the Text tool or Rectangle tools.
  • Importing, placing, or pasting text or graphics.
  • Selecting objects on other layers, and then moving them to the new layer.

You cannot draw or place a new object on a hidden or locked layer. When you select a drawing tool or the Type tool, or place a file when the target layer is hidden or locked, the pointer displays the crossed-out pencil icon when it is positioned over the page in Design view. Either show or unlock the target layer, or target a visible, unlocked layer.

If you choose Edit > Paste when the target layer is hidden or locked, an alert message appears, giving you the choice of showing or unlocking the target layer.

When you click a layer in the Layers panel to target it, a triangle appears at the top right on the layer you clicked, the layer label becomes bold, and the layer also highlights to indicate that it is targeted.

Select, move, and copy objects on layers

By default, you can select any object on any layer. In the Layers panel, colored squares on the far right mark layers that contain selected objects. A small square indicates that at least one object is selected on that layer and a large square indicates that all objects on that layer are currently selected. The layer’s selection color helps you identify an object’s layer. To prevent selecting objects on a specific layer, lock (or hide) the layer.

  • To select individual objects on a layer, click the triangle icon to the left of the layer name to expand the layer, and select the target element in the list. You can also drag the target object to a different location without selecting it.
  • To select all objects on a specific layer, click the square to the right of the layer name.
  • To move or copy objects to another layer, use the Selection tool to select one or more objects on a page or master page. In the Layers panel, drag the colored square on the right side of the layer list to move the selected objects to the other layer.

Paste objects into different layers

The Paste Remembers Layers option affects how objects pasted from other locations interact with existing layers.

If the “Paste Remembers Layers” option is enabled, objects cut or copied from different layers retain their layer assignments when pasted to a new page or position. If you paste an object to a page that doesn’t have the same layers as the page from which is was copied, Muse adds the object's layer name to the Layers panel in the second document, and pastes the object on its corresponding layer.

If the Paste Remembers Layers option is not selected, objects cut or copied from different layers are pasted together on the current target layer.

  1. Make sure that Paste Remembers Layers is deselected in the Layers context menu that appears when you right-click anywhere in the panel.
  2. Select objects and choose Edit > Copy or Edit > Cut.
  3. In the Layers panel, click a different layer to target it.
  4. Choose Edit > Paste.

Duplicate a layer

When you duplicate a layer, you copy its contents and settings. The duplicate layer then appears above the original layer in the Layers panel.

In the Layers panel, do one of the following:

  • Select the layer name and choose Duplicate Layer in the Layers context menu that appears when you right click (context click) on a layer (or selected layers).
  • Drag a layer name and drop it on the New Layer button.

Change the order of layers

Change the stacking order of layers in your document by rearranging the layers on the Layers panel. Rearranging layers changes the order of layers on every page in the site, not just the current page in Design view.

You can also change the stacking order of objects within a layer by repositioning objects within the layer.

In the Layers panel, drag a layer up or down in the list. You can also drag multiple selected layers.

Show or hide layers and objects

You can hide or display any layer at any time, and you can hide or display objects on a layer. Hidden layers and objects can’t be edited, and don’t appear on screen in Design view, Preview, Publish, or after exporting sites. Hiding layers can be useful when you want to do any of the following:

  • Hide objects when you design sites using responsive layout. You can optionally hide objects while you design your page for various devices in a single canvas. For example, you can choose to hide a traditional menu and instead opt for an accordian while laying out a site for mobiles. To learn how to hide objects in responsive layout, see Hide objects in a responsive layout.
  • Hide parts of a document that are not meant to appear in the final document.
  • Hide alternate versions of a document.
  • Simplify the display of a document, to make it easier to edit other parts of the document.
  • Prevent a layer from exporting.
  • Speed up screen redraw when a layer contains high-resolution graphics.

Note: Hidden layers or hidden page items do not export. However, the page still appears in design view as if the items are present. For example, a hidden text frame would still push items below it down the page. This prevents the page from shifting content as you hide/show layers.

Hide or show layers by doing one of the following options:

  • To hide or show one layer at a time, in the Layers panel, click the square at the far left of a layer name to hide or show the eye icon for that layer.
  • To show or hide individual objects in a layer, click the twirl down disclosure triangle to the left of the layer name to view all objects in a layer, and then click the eye icon to show or hide the object.

Lock or unlock layers

Locking is useful for preventing accidental changes to a layer. A locked layer displays a crossed-out pencil icon in the Layers panel. Objects on locked layers cannot be selected or edited directly; however, if objects on locked layers have attributes that can be edited indirectly, they will change. For example, if you edit a tint swatch, objects on locked layers using that tint swatch will reflect the change.

You can also use the Layers panel to lock or unlock objects in a layer. To unlock and lock layers, do the following:

  • To lock or unlock one layer at a time, in the Layers panel, click a square in the second column from the left to show (lock) or hide (unlock) the layer.

Delete layers

Remember that each layer is site-wide—it appears on every page of a site. Before deleting a layer, consider hiding all other layers first, and then review each page of the site to verify that it is safe to delete the remaining objects. When you are sure you want to delete a layer, do the following:

  • To delete a layer, drag a layer from the Layers panel to the Delete icon at the bottom right of the layers panel or right-click and choose Delete Layer from the context menu.
  • To delete multiple layers, press and hold Control/Command while you click the layers to select them. Then, drag the layers from the Layers panel to the Delete icon or right-click and choose Delete Layers from the context menu.
  • To delete an object on a layer, select the object in the Layers panel, and then click the Delete icon.

Merge layers in a document

You can reduce the number of layers in a site without deleting any objects by merging layers. When you merge layers, objects from all selected layers are moved to the target layer. Of the layers you merge, only the target layer remains in the document; the other selected layers are deleted. You can also flatten a site by merging all layers.

Note: If you merge layers containing a mix of page objects and master page items, the master items move to the back of the resulting merged layer.

  1. In the Layers panel, select any combination of layers. Be sure to include the layer you want to target as the merged layer. If you’re flattening the site to a single layer, select all layers in the panel.
  2. Right-click on the Layers panel, and then choose Merge Layers in the context menu.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy