Videozelfstudie: Gekoppelde slimme objecten

Videozelfstudie: Gekoppelde slimme objecten
Infinite Skills

Inzicht in slimme objecten

Slimme objecten zijn lagen met afbeeldingsgegevens uit raster- of vectorafbeeldingen, zoals Photoshop- of Illustrator-bestanden. In slimme objecten blijven de broninhoud en alle oorspronkelijke kenmerken van een afbeelding behouden, zodat u niet-destructieve bewerkingen kunt uitvoeren op de laag.

In Photoshop CC en CS6 kunt u de inhoud van een afbeelding insluiten in een Photoshop-document. In Photoshop CC kunt u ook gekoppelde slimme objecten maken waarvan de inhoud verwijst naar externe afbeeldingsbestanden. De inhoud van een gekoppeld slim object wordt bijgewerkt wanneer het bronbestand ervan wordt gewijzigd.

Gekoppelde slimme objecten zijn niet hetzelfde als gedupliceerde instanties van een slim object in een Photoshop-document. Met gekoppelde slimme objecten kunt u een gedeeld bronbestand gebruiken in meerdere Photoshop-documenten: een vertrouwd en welkom concept voor webontwerpers.

Voordelen van slimme objecten

Met slimme objecten kunt u:

  • Transformaties uitvoeren zonder de oorspronkelijke gegevens te wijzigen. U kunt een laag schalen, roteren, schuintrekken, vervormen, verdraaien of het perspectief van een laag transformeren zonder verlies van oorspronkelijke afbeeldingsgegevens of kwaliteit, want de transformaties hebben geen invloed op de oorspronkelijke gegevens.

  • Werken met vectorgegevens, zoals vectorillustraties uit Illustrator, die anders in pixels zouden worden omgezet in Photoshop.

  • Niet-destructieve filters toepassen. U kunt filters die op slimme objecten zijn toegepast op ieder gewenst moment bewerken.

  • Eén slim object bewerken en alle gekoppelde varianten automatisch bijwerken.

  • Een laagmasker toepassen dat is gekoppeld aan de laag met het slimme object of dat hiervan is ontkoppeld.

  • Experimenteer met ontwerpen met plaatsaanduidingen in lage resolutie die u later vervangt door de definitieve versie.

U kunt geen bewerkingen rechtstreeks op een laag met een slim object uitvoeren waarbij pixelgegevens worden gewijzigd, zoals tekenen, tegenhouden, doordrukken of klonen. Dergelijke lagen dient u eerst om te zetten in een standaardlaag die in pixels wordt omgezet. Als u bewerkingen wilt uitvoeren waarbij pixelgegevens worden gewijzigd, kunt u de inhoud van een slim object bewerken, een nieuwe laag boven de laag met het slimme object klonen, duplicaten van het slimme object bewerken of een nieuwe laag maken.

Opmerking:

Wanneer u een slim object transformeert waarop een slim filter is toegepast, worden de filtereffecten uitgeschakeld terwijl de transformatie wordt uitgevoerd. De filtereffecten worden dan weer toegepast wanneer de transformatie is voltooid. Zie Slimme filters toepassen.

Gewone lagen en slimme objecten in het deelvenster Lagen. Pictogram geeft slim object aan.
Gewone laag en slim object in het deelvenster Lagen. Het pictogram in de rechteronderhoek van de miniatuur geeft een slim object aan.

(Photoshop CC) Een gekoppeld slim object in het deelvenster Lagen
(Photoshop CC) Een gekoppeld slim object in het deelvenster Lagen

Ingesloten slimme objecten maken

U kunt op verschillende manieren ingesloten slimme objecten maken: met de opdracht Openen als slim object, door een bestand te plaatsen (CS6), door een ingesloten bestand te plaatsen (CC, CS6), door gegevens te plakken uit Illustrator of door een of meer Photoshop-lagen om te zetten in slimme objecten.

  • Ga als volgt te werk:
    • (CC) Kies Bestand > Ingesloten plaatsen om bestanden als slimme objecten te importeren in een geopend Photoshop-document.
    • Kies Bestand > Openen als slim object, selecteer een bestand en klik op Openen.
    • (CS6) Kies Bestand > Plaatsen om bestanden als slimme objecten te importeren in een geopend Photoshop-document.

    Opmerking:

    U kunt JPEG-bestanden plaatsen, maar het is beter om PSD-, TIFF- of PSB-bestanden te plaatsen, omdat u dan lagen kunt toevoegen, pixels kunt wijzigen en het bestand weer kunt opslaan zonder gegevensverlies. (Wanneer u een gewijzigd JPEG-bestand wilt opslaan, moet u de nieuwe lagen samenvoegen tot één laag en de afbeelding opnieuw comprimeren, hetgeen tot kwaliteitsverlies leidt.)

    • Kies Laag > Slim object > Omzetten in slim object om een geselecteerde laag om te zetten in een slim object.
    • Kies in Bridge Bestand > Plaatsen > In Photoshop om een bestand als een slim object te importeren in een geopend Photoshop-document.

    Opmerking:

    U kunt ook heel gemakkelijk werken met Camera Raw-bestanden door deze te openen als slimme objecten. U kunt op ieder gewenst moment dubbelklikken op de slimme-objectlaag die het Raw-bestand bevat om de Camera Raw-instellingen aan te passen.

    Bekijk de video Een afbeelding openen als een slim object om te zien hoe u dit kunt doen.

    • Selecteer een of meerdere lagen en kies Laag > Slimme objecten > Omzetten in slim object. De lagen worden gebundeld in één slim object.

    • Sleep de PDF- of Adobe Illustrator-lagen of -objecten naar een Photoshop-document.

    • Plak illustraties uit Illustrator in een Photoshop-document en kies Slim object in het dialoogvenster Plakken. Voor extra flexibiliteit schakelt u zowel de opties PDF als AICB (transparantie wordt niet ondersteund) in in het gedeelte Bestandsbeheer en Klembord van het dialoogvenster Voorkeuren in Adobe Illustrator.

Gekoppelde slimme objecten maken | Photoshop CC

Opmerking:

De functie Gekoppeld slim object is beschikbaar in Photoshop versie 14.2 (Photoshop CC | januari 2014) en later.

U kunt in Photoshop CC gekoppelde slimme objecten maken. De inhoud van gekoppelde slimme objecten wordt bijgewerkt wanneer het bronbestand wordt gewijzigd. Gekoppelde slimme objecten zijn vooral handig als u in een team werkt of als middelen opnieuw worden gebruikt in verschillende ontwerpen.

Voer de volgende stappen uit om een gekoppeld slim object te maken:

  1. Kies Bestand > Gekoppelde plaatsen.
  2. Selecteer een geschikt bestand en klik op Plaatsen.

Het gekoppelde slimme object wordt gemaakt en in het deelvenster Lagen aangeduid met een koppelingspictogram ().

Opmerking:

U kunt ook een gekoppeld slim object in een geopend document maken door het desbetreffende bestand te slepen en neer te zetten terwijl u de volgende toets ingedrukt houdt:

(Windows) Alt-toets
(Mac OS) Option-toets

Schakel Voorkeuren > Algemeen > Altijd slimme objecten maken bij het plaatsen uit als u deze standaardwerkwijze wilt wijzigen.

Kleinere bestanden door gebruik van gekoppelde slimme objecten

Omdat gekoppelde slimme objecten afhankelijk blijven van een extern bestand en er geen bronbestand in het document wordt ingesloten, leidt dit dikwijls tot aanzienlijk kleinere bestanden. Hoewel het oorspronkelijke bestand bij gebruik van gekoppelde slimme objecten niet in het document wordt opgeslagen, wordt er wel een gecomprimeerde en geschaalde versie van de afbeeldingsgegevens uit het oorspronkelijke bestand opgeslagen. In sommige gevallen zijn deze gegevens bij elkaar veel groter dan het oorspronkelijke bestand, in welk geval de besparing op de bestandsgrootte te verwaarlozen lijkt.

Gekoppelde slimme objecten bijwerken

Als een extern bronbestand wordt gewijzigd terwijl een Photoshop-document dat naar dit bestand verwijst, is geopend, wordt het desbetreffende gekoppelde slimme object automatisch bijgewerkt. Als u echter een Photoshop-document opent dat niet-gesynchroniseerde gekoppelde slimme objecten bevat, kunt u de slimme objecten bijwerken:

  • Klik met de rechtermuisknop op een laag met een gekoppeld slim object en selecteer Gewijzigde inhoud bijwerken.
  • Selecteer Laag > Slimme objecten > Gewijzigde inhoud bijwerken.

Gekoppelde slimme objecten waarvan de bronafbeelding is gewijzigd, worden gemarkeerd weergegeven in het deelvenster Lagen:

Niet-gesynchroniseerde gekoppelde slimme objecten gemarkeerd in het deelvenster Lagen
Niet-gesynchroniseerde gekoppelde slimme objecten worden gemarkeerd in het deelvenster Lagen.

Opmerking:

U kunt alle gekoppelde slimme objecten in het actieve Photoshop-document bijwerken door Laag > Slimme objecten > Alle gewijzigde inhoud bijwerken te kiezen.

Gekoppelde slimme objecten met ontbrekende externe bronbestanden gemarkeerd in het deelvenster Lagen
Gekoppelde slimme objecten met ontbrekende externe bronbestanden worden gemarkeerd in het deelvenster Lagen.

Opmerking:

Tijdens de detectie van wijzigingen in gekoppelde slimme objecten of het bijwerken van een gekoppeld slim object, kijkt Photoshop alleen naar het direct gekoppelde bestand. Koppelingen in slimme objecten zelf worden niet bijgewerkt.

Een verbroken koppeling van een slim object oplossen

Voer de volgende stappen uit als u een gekoppeld slim object met een ontbrekende externe bron wilt oplossen:

  1. Klik met de rechtermuisknop op het laagpictogram van het gekoppelde slimme object en kies Verbroken koppeling oplossen.
  2. Ga naar de nieuwe locatie van het ontbrekende object.
  3. Klik op Plaatsen.

Eigenschappen van het gekoppelde slimme object weergeven

Zorg dat in het deelvenster Lagen een laag met een gekoppeld bestand is geselecteerd en kies Venster > Eigenschappen.

De volgende eigenschappen worden weergegeven:

  • Het pad naar het externe bronbestand voor het gekoppelde slimme object
  • De grootte en plaatsbepalingscoördinaten (X, Y) van het gekoppelde slimme object

U kunt rechtstreeks vanuit het deelvenster Eigenschappen de volgende acties uitvoeren:

  • De inhoud van het externe afbeeldingsbestand bewerken. Indien nodig wordt in Photoshop een externe toepassing geopend waarin het bronbestand van de afbeelding kan worden verwerkt. Photoshop zal bijvoorbeeld Adobe Illustrator openen als het bronbestand een .ai-bestand is.
  • Het gekoppelde slimme object in het huidige document insluiten.

Gekoppelde slimme objecten insluiten

Voer een van de volgende handelingen uit:

  • Klik met de rechtermuisknop op een laag met een gekoppeld slim object in het deelvenster Lagen en selecteer Gekoppelde insluiten.
  • Selecteer Laag > Slimme objecten > Gekoppelde insluiten.
  • Klik in het deelvenster Eigenschappen op Insluiten.

Opmerking:

Selecteer Laag > Slimme objecten > Alle gekoppelde insluiten om alle gekoppelde slimme objecten in te sluiten in het Photoshop-document.

Gekoppelde slimme objecten verpakken

U kunt de gekoppelde slimme objecten verpakken in een Photoshop-document, zodat bronbestanden van de objecten in een map op uw computer worden opgeslagen. Samen met de bronbestanden wordt ook een kopie van het Photoshop-document in de map opgeslagen.

  1. Kies Bestand > Pakket.
  2. Selecteer de locatie waar u de bronbestanden en een kopie van het Photoshop-document wilt opslaan.

Daarnaast worden ook eventuele gekoppelde slimme audio- en video-objecten in het document verpakt.

Opmerking:

U moet een bestand opslaan voordat u de gekoppelde slimme objecten in dat bestand verpakt.

Hoe Photoshop gekoppelde bestanden vindt

Photoshop zoekt gekoppelde bestanden altijd op de laatst bekende relatieve locatie. Als het gekoppelde bestand op die locatie niet wordt gevonden, wordt als volgt naar het bestand gezocht:

  • Op de laatst bekende absolute locatie
  • Met behulp van een opgeslagen alias (alleen Mac OS)
  • In dezelfde map als het containerdocument

Door deze werkwijze kunt u projectmappen en -bestanden verplaatsen, kopiëren en delen zonder een al te groot risico dat koppelingen worden verbroken.

Opmerking:

In het dialoogvenster Ontbrekende middelen oplossen wordt altijd het laatst bekende absolute pad van ontbrekende bronbestanden weergegeven.

Een ingesloten slim object omzetten in een gekoppeld slim object

U kunt een ingesloten slim object omzetten in een gekoppeld slim object. Transformaties, filters en andere effecten die op het ingesloten slimme object zijn toegepast, blijven tijdens het omzetten behouden.

Ga als volgt te werk:

  1. Selecteer de laag van een ingesloten slim object in het Photoshop-document.
  2. Selecteer Laag > Slim object > Omzetten in gekoppeld.
  3. Selecteer de locatie op uw computer waar u het bronbestand wilt opslaan. Voer een naam voor het bestand in, met een ondersteunde extensie. Typ bijvoorbeeld link_file.jpg.

Het deelvenster Lagen filteren op slimme objecten | Photoshop CC

  1. Selecteer in het deelvenster Lagen de optie Slim object in het pop-upmenu met filters.
Lagen filteren op slimme objecten
Lagen filteren op slimme objecten

  1. Klik op een van de volgende pictogrammen:
  •     Filter voor bijgewerkte gekoppelde slimme objecten
  •     Filter voor niet-gesynchroniseerde gekoppelde slimme objecten
  •     Filter voor ontbrekende gekoppelde slimme objecten
  •     Filter voor ingesloten slimme objecten

Opmerking:

U kunt de schakeloptie () gebruiken om laagfiltering uit te schakelen.

Een ingesloten slim object dupliceren

  • Selecteer een laag met een slim object in het deelvenster Lagen en voer een van de volgende handelingen uit:
    • Als u een duplicaat van een slim object wilt maken en dat wilt koppelen aan het origineel, kiest u Laag > Nieuw > Laag via kopiëren of sleept u de laag met het slimme object naar het pictogram Een nieuwe laag maken onder aan het deelvenster Lagen. Bewerkingen aan het origineel worden dan ook doorgevoerd in de kopie en andersom.

    • Als u een duplicaat van een slim object wilt maken en dat niet wilt koppelen aan het origineel, kiest u Laag > Slimme objecten > Nieuw slim object via kopiëren. Wijzigingen aan het origineel hebben dan geen effect op de kopie.

    Er verschijnt een nieuw slim object in het deelvenster Lagen met dezelfde naam als het origineel en "kopie" als suffix.

De inhoud van een slim object bewerken

Wanneer u een slim object bewerkt, wordt de broninhoud geopend in Photoshop (als de inhoud rastergegevens of een Camera Raw-bestand is) of in de toepassing die de geplaatste indeling standaard verwerkt, zoals Adobe Illustrator of Adobe Acrobat. Wanneer u de wijzigingen in de broninhoud opslaat, worden de bewerkingen weergegeven in alle gekoppelde exemplaren van het slimme object in het Photoshop-document.

  1. Selecteer het slimme object in het deelvenster Lagen en voer een van de volgende handelingen uit:
    • Kies Laag > Slimme objecten > Inhoud bewerken.
    • Dubbelklik in het deelvenster Lagen op de miniatuur van het slimme object.
    • Klik in het deelvenster Eigenschappen op Inhoud bewerken.
  2. Klik op OK om het dialoogvenster te sluiten.
  3. Bewerk de inhoud van het bronbestand en kies Bestand > Opslaan.

    Photoshop werkt het slimme object bij om de aangebrachte wijzigingen te weerspiegelen. (Als u de wijzigingen niet ziet, activeert u het Photoshop-document met het slimme object.)

De inhoud van een slim object vervangen

U kunt de afbeeldingsgegevens in één slim object of in meerdere gekoppelde instanties vervangen. Met deze functie kunt u snel een visueel ontwerp bijwerken of plaatsaanduidingen in lage resolutie vervangen door definitieve versies.

Opmerking:

Wanneer u een slim object vervangt, blijven de schalingen, verdraaiingen of effecten die u op het eerste object hebt uitgevoerd gewoon behouden.

  1. Selecteer het slimme object en kies Laag > Slimme objecten > Inhoud vervangen.
  2. Ga naar het bestand dat u wilt gebruiken en klik op Plaatsen.
  3. Klik op OK.

    De nieuwe inhoud wordt in het slimme object geplaatst.

Een ingesloten of gekoppeld slim object omzetten in een laag

Als u een slim object omzet in een normale laag, wordt de inhoud met de huidige afmetingen omgezet in pixels. Zet een slim object alleen om in een standaardlaag als u de slimme-objectgegevens niet meer wilt bewerken. U kunt transformaties, verdraaiingen en filters die u op een slim object het toegepast niet meer bewerken als u het slimme object hebt omgezet in pixels.

  • Selecteer het slimme object en kies Laag > Slimme objecten > Lagen omzetten in pixels.  

Opmerking:

Als u het slimme object opnieuw wilt maken, selecteert u de oorspronkelijke lagen van het object opnieuw en begint u weer van voren af aan. De transformaties die op het originele slimme object zijn toegepast, blijven niet behouden in het nieuwe slimme object.

De inhoud van een ingesloten slim object exporteren

  1. Selecteer het slimme object in het deelvenster Lagen en kies Laag > Slimme objecten > Inhoud exporteren.
  2. Kies een locatie voor de inhoud van het slimme object en klik op Opslaan.

    Photoshop exporteert het slimme object in de indeling waarin het oorspronkelijk is geplaatst (.JPEG, .AI, .TIF, .PDF of een andere indeling). Als het slimme object op basis van lagen is gemaakt, wordt het geëxporteerd in de PSB-indeling.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid