Kombinere objekter

Lær hvordan du kombinerer objekter i Illustrator.

Du kan kombinere vektorobjekter for å lage former på forskjellige måter i Illustrator. Banene eller formene som opprettes, varierer avhengig av hvilken metode du bruker til å sette sammen objektene.

Metoder for å kombinere objekter

Pathfinder-effekter

Med Pathfinder-effekter kan du kombinere flere objekter ved hjelp av samhandlingsmoduser. Når du bruker Pathfinder-effekter, kan du ikke redigere interaksjonen mellom objekter. Se Kombinere objekter ved hjelp av Pathfinder-effekter.

Sammensatte former

Med sammensatte former kan du kombinere flere objekter og angi hvordan du vil at hvert objekt skal samhandle med de andre objektene. Sammensatte former er mer allsidige enn sammensatte baner fordi de gir fire typer interaksjoner: legge til, trekke fra, snitte og utelate. De underliggende objektene endres ikke, så du kan markere hvert objekt i en sammensatt form for å redigere det eller endre samhandlingsmodusen. Se Kombinere objekter ved hjelp av sammensatte former.

Sammensatte baner

Med sammensatte baner kan du bruke et objekt til å skjære hull i et annet objekt. Du kan for eksempel lage en smultringform av to kjedede sirkler. Når du oppretter en sammensatt bane, fungerer banene som grupperte objekter. Du kan markere og endre objektene enkeltvis ved hjelp av segmentmarkøren eller gruppemarkøren, eller du kan markere og redigere den kombinerte banen. Se Kombinere objekter ved hjelp av sammensatte baner.

Merk:

Du kan også legge til et objekt ved hjelp av flekkpenselen. Når du bruker denne penselen, legges baner du maler, til i tilstøtende baner som bruker identiske fyllattributter. Se Tegne og slå sammen baner med Flekk-penselen og Bygge nye former med formverktøyet.

Kombinere objekter ved hjelp av Pathfinder-effekter

Navigere i Pathfinder-panelet

Du bruker Pathfinder-panelet (Vindu > Pathfinder) til å kombinere objekter til nye former.

Adobe Illustrator-frakobling

Prøv det i appen
Kombiner objekter i noen få enkle trinn.

Oversikt over Pathfinder-panelet
Pathfinder-panel

Bruk den øverste raden med knapper i panelet til å lage baner eller sammensatte baner. Hvis du vil lage sammensatte former, bruker du knappene i de radene mens du trykker på Alt- eller Tilvalg-tasten. 

Velg mellom følgende formmodi:

Legg til i formområde

Legger til området for komponenten i den underliggende geometrien.

Trekk fra formområde

Kutter ut komponentområdet fra den underliggende geometrien.

Snitt formområder

Bruker komponentens område til å beskjære den underliggende geometrien på samme måte som en maske.

Utelat områder med overlappende former

Bruker komponentens område til å invertere den underliggende geometrien, og gjøre fylte områder om til hull og omvendt.

Bruk den nederste raden med knapper i panelet, kalt Pathfinder-effekter, til å lage endelige formkombinasjoner ved første klikk. (Se Bruke Pathfinder-effekter.)

Pathfinder-effekter
Formmodi

A. Alle komponenter i Legg til-modus B. Trekk fra-modus brukt på firkanter C. Snitt-modus brukt på kvadrater D. Utelat-modus brukt på firkanter 

Angi alternativer for Pathfinder

Angi Pathfinder-valg på Pathfinder-panelmenyen eller ved å dobbeltklikke på en Pathfinder-effekt i Utseende-panelet.

Presisjon

Påvirker hvor nøyaktig Pathfinder-effektene beregner banen til et objekt. Jo mer nøyaktig beregningen er, jo mer nøyaktig er tegningen og jo mer tid er nødvendig for å generere den resulterende bane.

Fjern overflødige punkter

Fjerner unødvendige punkter når du klikker en Pathfinder-knapp.

Del og disposisjon fjerner umalt kunstverk

Sletter alle ufylte objekter i den merkede grafikken når du klikker Del- eller Kontur-knappen.

Bruke Pathfinder-effekter

Med Pathfinder-effekter kan du lage nye former av overlappende objekter. Bruk Pathfinder-effekter ved hjelp av Effekter-menyen eller Pathfinder-panelet.

  • Pathfinder-effekter i Effekter-menyen kan bare brukes på grupper, lag og tekstobjekter. Når du har tatt i bruk effekten, kan du likevel markere og redigere de opprinnelige objektene. Du kan også bruke Utseende-panelet til å endre eller fjerne effekten. Se Bruke en Pathfinder-effekt ved hjelp av Effekter-menyen.

  • Pathfinder-effekter i Pathfinder-panelet kan brukes på alle kombinasjoner av objekter, grupper og lag. Den endelige formkombinasjonen opprettes når du klikker en Pathfinder-knapp. Deretter kan du ikke redigere de opprinnelige objektene. Hvis effekten resulterer i flere objekter, grupperes de automatisk sammen. Se Bruke en Pathfinder-effekt ved hjelp av Pathfinder-panelet.

Bruke en Pathfinder-effekt ved hjelp av Effekter-menyen

  1. Gjør ett av følgende:
    • Grupper objektene du vil bruke, og velg gruppen.

      -eller-

    • Flytt objektene du vil bruke, til et eget lag, og angi laget.

  2. Velg Effekt > Pathfinder, og velg en Pathfinder-effekt.
    Merk:

    Hvis du raskt vil bruke samme Pathfinder-effekt igjen, velger du Effekt > Bruk [effekt].

Bruke en Pathfinder-effekt ved hjelp av Pathfinder-panelet

  1. Marker objektene du vil bruke effekten på.

    Hvis du vil bruke en Pathfinder-effekt på en gruppe eller et lag, angir du gruppen eller laget.

  2. Klikk på en Pathfinder-knapp (på den nederste raden) i Pathfinder-panelet, eller Alt-klikk (Windows) eller Tilvalg-klikk (Mac OS) en formmodus-knapp (på den øverste raden).

Sammendrag av Pathfinder-effekter

Legg til

Sporer omrisset av alle objektene som om de var ett sammenslått objekt. Den resulterende formen tar opp malingsattributtene til det øverste objektet.

Snitt

Sporer omrisset av området som overlappes av alle objektene.

Ekskluder

Sporer alle ikke-overlappende områder av objektene og gjør overlappende områder gjennomsiktige. Når et likt antall objekter overlapper hverandre, blir overlappingen gjennomsiktig. Når et ulikt antall objekter overlapper hverandre, blir overlappingen fylt.

Trekk fra

Trekker de fremste objektene fra det bakerste objektet. Du kan bruke denne kommandoen til å slette illustrasjonsområder ved å justere stablerekkefølgen.

Minus bakerste

Trekker objektene bakerst fra det forreste objektet. Du kan bruke denne kommandoen til å slette illustrasjonsområder ved å justere stablerekkefølgen.

Del

Deler opp et kunstverk i de komponentfylte sidene (en ansikt er et område som er udelt av et linjesegment).

Merknad: Når du bruker Del-knappen i Pathfinder-panelet, kan du bruke segmentmarkøren eller gruppemarkøren til å manipulere de resulterende sidene uavhengig av hverandre. Du kan også velge å slette eller beholde objekter som ikke er fylt, når du bruker kommandoen Del.

Skjær til

Fjerner den delen av et fylt objekt som er skjult. Fjerner alle strøk og slår ikke sammen objekter med samme farge.

Slå sammen

Fjerner den delen av et fylt objekt som er skjult. Fjerner alle strøk og slår sammen alle sammenhengende eller overlappende objekter som er fylt med samme farge.

Beskjær

Grafikken deles inn i de komponentfylte sidene, og alle delene av grafikken som faller utenfor grensen til det øverste objektet, slettes. Det fjerner også eventuelle strøk.

Omriss

Deler et objekt inn i sine komponentlinjesegmenter, eller kanter. Denne kommandoen er nyttig når du skal klargjøre grafikk som trenger en overlapping for overtrykking av objekter. Se Opprette en overlapping.

Merknad: Når du bruker Outline-knappen i Pathfinder-panelet, kan du bruke segmentmarkøren eller gruppemarkøren til å manipulere hver enkelt kant uavhengig av hverandre. Du kan også velge å slette eller beholde objekter som ikke er fylt, når du bruker kommandoen Kontur.

Hard fargeblanding

Kombinerer farger ved å velge den høyeste verdien for hver av fargekomponentene. Hvis for eksempel Farge 1 er 20 % cyan, 66 % magenta, 40 % gul og 0 % svart og Farge 2 er 40 % cyan, 20 % magenta, 30 % gul og 10 % svart, blir den harde fargen 40 % cyan, 66 % magenta, 40 % gul og 10 % svart.

Myk miks

Gjør de underliggende fargene synlige gjennom de overlappende grafikkene, og deler deretter bildet inn i de enkelte komponentene. Du kan angi ønsket prosentandel av synlighet i de overlappende fargene.

Overlapping

Kompenserer for potensielle brudd mellom farger i grafikk ved å opprette et lite overlappingsområde (en såkalt overlapping) mellom to tilstøtende farger.

Kombinere objekter ved hjelp av sammensatte former

A sammensatt form er redigerbar kunst som består av to eller flere objekter, hvert tilordnet en formmodus. Sammensatte former gjør det enkelt å lage komplekse former fordi du kan manipulere formmodus, stablerekkefølge, form, plassering og utseende nøyaktig for hver bane som er inkludert.

Sammensatte former fungerer som grupperte objekter og vises som <compound shape=""> elementer i Lag-panelet. Du kan bruke Lag-panelet til å vise, velge og endre innholdet i en sammensatt form, for eksempel for å endre stablerekkefølgen for komponentene. Du kan også bruke segmentmarkøren eller gruppemarkøren til å markere komponenter i en sammensatt form.

Når du oppretter en sammensatt form, får den malings- og gjennomsiktighetsattributtene til den øverste komponenten i modusen Legg til, Snitt eller Utelat. Deretter kan du endre attributtene for maling, stil eller gjennomsiktighet for den sammensatte formen. Illustrator forenkler denne prosessen ved å automatisk angi hele den sammensatte formen når du merker noen del av den, med mindre du eksplisitt angir en komponent i Lag-panelet.

Sammensatte former
Arbeide med sammensatte former

A. Opprinnelige objekter B. Sammensatt form opprettet C. Individuelle formmodi brukt på hver komponent D. Stilen som er brukt på hele den sammensatte formen 

Lage en sammensatt form

  1. Marker alle objektene du vil ha med i den sammensatte formen.

    Du kan inkludere baner, sammensatte baner, grupper, andre sammensatte former, blandinger, tekst, konvolutter og fordreininger i en sammensatt form. Alle åpne baner du velger, lukkes automatisk.

  2. Gjør ett av følgende:
    • Alt-klikk (Windows) eller Tilvalg-klikk (Mac OS) en av formmodusene i Pathfinder-panelet. Hver komponent i den sammensatte formen tilordnes formmodusen du velger.

      -eller-

    • Velg Lag sammensatt form på Pathfinder-panelmenyen. Hver komponent i den sammensatte formen tilordnes som standard modusen Legg til.

  3. Endre formmodusen for en komponent ved å velge den med segmentmarkøren eller lagpanelet og klikke på en formmodusknapp.

    Merk: Du trenger aldri å endre modus for den bakerste komponenten, fordi den modusen er ikke relevant for den sammensatte formen.

    Merk:

    For å opprettholde maksimal ytelse, kan du lage komplekse sammensatte former ved å kjede andre sammensatte former (inneholder opptil 10 komponenter hver) i stedet for å bruke mange individuelle komponenter.

Endre en sammensatt form

  1. Bruk segmentmarkøren eller lagpanelet til å velge en enkeltkomponent i den sammensatte formen.
  2. Se etter den uthevede formmodusknappen i Pathfinder-panelet for å finne ut hvilken modus som brukes på den valgte komponenten.
    Merk:

    Hvis du har valgt to eller flere komponenter som bruker forskjellige modi, vises spørsmålstegn på knappene for formmodus.

  3. Velg en annen formmodus i Pathfinder-panelet.

Frigi og utvid en sammensatt form

Når du frigjør en sammensatt form, deles den tilbake i separate objekter. Når du utvider en sammensatt form, bevares formen på det sammensatte objektet, men du kan ikke lenger markere de enkelte komponentene.

  1. Merk den sammensatte formen med markeringsverktøyet eller lagpanelet.
  2. Gjør ett av følgende:
    • Velg Utvid i Pathfinder-panelet.

      -eller-

    • Velg Utvid sammensatt form på Pathfinder-panelmenyen.

      Den sammensatte formen omdannes til en <path> eller <compound path=""> element i Lag-panelet, avhengig av hvilken formmodus det brukte.

      -eller-

    • Velg Frigi sammensatt form på Pathfinder-panelmenyen.

Flytte sammensatte former mellom Illustrator og Photoshop

Formlagene og maskeringsbanene for lag (vektormasker) i Adobe Photoshop er typer sammensatte former. Du kan importere formlag og maskerende lagbaner til Illustrator som sammensatte former, og fortsette å manipulere dem. I tillegg kan du eksportere sammensatte former til Photoshop. Ha følgende i tankene når du bruker sammensatte former med Photoshop:

  • Bare sammensatte former som ligger på øverste nivå i laghierarkiet, eksporteres til Photoshop som formlag.

  • En sammensatt form som er malt med et strøk ved hjelp av et annet hjørne enn avrundet, eller med en tykkelse i punkter som ikke er et heltall, rastreres når den eksporteres til PSD-filformatet.

Kombinere objekter ved hjelp av sammensatte baner

A sammensatt bane inneholder to eller flere baner som er malt slik at det vises hull der baner overlapper hverandre. Når du definerer objekter som en sammensatt bane, får alle objektene i den sammensatte banen male- og stilattributtene som er brukt på det bakerste objektet, i stablerekkefølgen.

Sammensatte baner fungerer som grupperte objekter og vises som <compound path=""> elementer i Lag-panelet. Bruk segmentmarkøren eller gruppemarkøren til å markere en del av en sammensatt bane. Du kan manipulere formen på enkeltkomponenter i en sammensatt bane, men du kan ikke endre utseendeattributter, grafikkstiler eller effekter for enkeltkomponenter, og du kan ikke manipulere komponenter enkeltvis i lagpanelet.

Merk:

Hvis du vil ha mer fleksibilitet når du oppretter sammensatte baner, kan du lage en sammensatt form og deretter utvide den.

Klippe ut et hull i et objekt ved hjelp av en sammensatt bane

  1. Marker objektet som skal brukes som et hull, og plasser det slik at det overlapper objektet som skal klippes. Gjenta dette for andre objekter du vil bruke som hull.
  2. Marker alle objektene du vil ha med i den sammensatte banen.
  3. Velg Objekt > Sammensatt bane > Opprett.

Bruke fyllregler på sammensatte baner

Du kan angi om en sammensatt bane er en viklingsbane som ikke er null, eller en partall-oddetall-bane.

Ikke-null viklingsfyllregel

Bruker matematiske ligninger til å fastslå om et punkt er utenfor eller innenfor en form. Illustrator bruker viklingsregelen som ikke er null som standardregel.

Fyllregel lik oddetall

Bruker matematiske ligninger til å fastslå om et punkt er utenfor eller innenfor en form. Denne regelen er den mest forutsigbare regelen fordi annenhver region innenfor en like-odde sammensatt bane er et hull, uavhengig av baneretning. Noen applikasjoner, for eksempel Adobe Photoshop, bruker like/odde-regelen som standard, slik at sammensatte baner som importeres fra disse applikasjonene, bruker like/odde-regelen.

Baner som krysser hverandre selv er stier som krysser seg selv. Du kan velge om disse banene skal være ikke-null-buktninger eller partall-oddetall, avhengig av hvordan du vil at de skal se ut.

Sammensatte baner
Bane som krysser seg selv med Bruk ikke-null viklingsfyllingsregel (venstre) sammenlignet med Bruk like/odde fyllingsregel (høyre)

Når du oppretter en sammensatt bane som ikke er null, kan du angi om overlappende baner skal vises med hull eller om de skal fylles, ved å klikke på knappen Reverser baneretning i Attributter-panelet.

Fire sirkelbaner
Fyllregler

A. Fire sirkelbaner B. Sirkulære baner er merket, konvertert til sammensatt bane C. Reverser baneretning brukt på den innerste banen 

Endre fyllregelen for en sammensatt bane

  1. Velg den sammensatte banen ved hjelp av markeringsverktøyet eller lagpanelet.
  2. Klikk på knappen Bruk ikke-null viklingsfyllregel i Attributter-panelet  eller knappen Bruk like/ulike fyllregler  .

Endre et hull i en sammensatt bane til et fylt område

  1. Kontroller at den sammensatte banen bruker regelen for viklingsfyll som ikke er null.
  2. Bruk segmentmarkøren til å markere den delen av den sammensatte banen som du vil reversere. Ikke marker hele den sammensatte banen.

  3. Klikk knappen Reverser baneretning av i Attributter-panelet  eller knappen Reverser baneretning på  .

Tilbakestille en sammensatt bane til de opprinnelige komponentene

  1. Velg den sammensatte banen ved hjelp av markeringsverktøyet eller lagpanelet.
  2. VELG OBJEKT > SAMMENSATT BANE > FRIGI.

 Adobe

Få hjelp raskere og enklere

Ny bruker?