User Guide Cancel

Create and edit panoramic images

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop on the iPad
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
    29. Auto adjustment commands in Photoshop on the iPad
    30. Smudge areas in your images with Photoshop on the iPad
    31. Saturate or desaturate your images using Sponge tool
    32. Content aware fill for iPad
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
    19. Generate Image
    20. Generate Background
    21. Reference Image
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
    3. Generate image with descriptive text prompts
    4. Generate background with descriptive text prompts
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Blur Gallery
    2. Filter basics
    3. Filter effects reference
    4. Add Lighting Effects
    5. Use the Adaptive Wide Angle filter
    6. Use the Oil Paint filter
    7. Use the Liquify filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

  Discontinuation of 3D features in Photoshop

Photoshop’s 3D features will be removed in future updates. Users working with 3D are encouraged to explore Adobe’s new Substance 3D collection, which represents the next generation of 3D tools from Adobe. Additional details on the discontinuation of Photoshop’s 3D features can be found here: Photoshop 3D | Common questions on discontinued 3D features.

Create panoramic images with Photomerge

About Photomerge

The Photomerge™ command combines several photographs into one continuous image. For example, you can take five overlapping photographs of a city skyline, and then merge them into a panorama. The Photomerge command can assemble photos that are tiled horizontally as well as vertically.

Source images (top), and completed Photomerge composition (bottom)

Take pictures for Photomerge

Your source photographs play a large role in panoramic compositions. To avoid problems, follow these guidelines when taking pictures for use with Photomerge:

Overlap images sufficiently

Images should overlap by approximately 40%. If the overlap is less, Photomerge may not be able to automatically assemble the panorama. However, keep in mind that the images shouldn't overlap too much. If images overlap by 70% or more, Photomerge may not be able to blend the images. Try to keep the individual photos at least somewhat distinct from each other.

Use one focal length

If you use a zoom lens, don't change the focal length (zoom in or out) while taking your pictures.

Keep the camera level

Although Photomerge can process slight rotations between pictures, a tilt of more than a few degrees can result in errors when the panorama is assembled. Using a tripod with a rotating head helps maintain camera alignment and viewpoint.

Stay in the same position

Try not to change your position as you take a series of photographs, so that the pictures are from the same viewpoint. Using the optical viewfinder with the camera held close to the eye helps keep the viewpoint consistent. Or try using a tripod to keep the camera in the same place.

Avoid using distortion lenses

Distortion lenses can interfere with Photomerge. However, the Auto option adjusts for images taken with fish-eye lenses.

Maintain the same exposure

Avoid using the flash in some pictures and not in others. The blending features in Photomerge helps smooth out different exposures, but extreme differences make alignment difficult. Some digital cameras change exposure settings automatically as you take pictures, so you may need to check your camera settings to be sure that all the images have the same exposure.

Create a Photomerge composition

  1. Choose File > Automate > Photomerge.

  2. Under Source Files in the Photomerge dialog box, choose one of the following from the Use menu:

    Files

    Generates the Photomerge composition using individual files.

    Folders

    Uses all the images stored in a folder to create the Photomerge composition.

  3. Specify which images to use by doing one of the following:
    • To select image files or a folder of images, click the Browse button and navigate to the files or folder.

    • To use the images currently open in Photoshop, click Add Open Files.

    • To remove images from the Source File list, select the file and click the Remove button.

  4. Select a Layout option:

    Auto

    Photoshop analyzes the source images and applies either a Perspective, Cylindrical, and Spherical layout, depending on which produces a better photomerge.

    Perspective

    Creates a consistent composition by designating one of the source images (by default, the middle image) as the reference image. The other images are then transformed (repositioned, stretched or skewed as necessary) so that overlapping content across layers is matched.

    Cylindrical

    Reduces the "bow‑tie" distortion that can occur with the Perspective layout by displaying individual images as on an unfolded cylinder. Overlapping content across files is still matched. The reference image is placed at the center. Best suited for creating wide panoramas.

    Applying Cylindrical Mapping

    Spherical

    Aligns and transforms the images as if they were for mapping the inside of a sphere, which simulates the experience of viewing a 360-degree panorama. If you have taken a set of images that cover 360 degrees, use this for 360 degree panoramas. You might also use Spherical to produce nice panoramic results with other file sets.

    Collage

    Aligns the layers and matches overlapping content and transforms (rotate or scale) any of the source layers.

    Reposition

    Aligns the layers and matches overlapping content, but does not transform (stretch or skew) any of the source layers.

  5. Select any of the following options:

    Blend Images Together

    Finds the optimal borders between the images and creates seams based on those borders, and color matches the images. With Blend Images Together turned off, a simple rectangular blend is performed. This may be preferable if you intend to retouch the blending masks by hand.

    Vignette Removal

    Removes and performs exposure compensation in images that have darkened edges caused by lens flaws or improper lens shading.

    Geometric Distortion Correction

    Compensates for barrel, pincushion, or fisheye distortion.

    Content Aware Fill Transparent Areas

    Seamlessly fill the transparent areas with similar image content nearby.

  6. Click OK.

Photoshop creates one multi‑layer image from the source images, adding layer masks as needed to create optimal blending where the images overlap. You can edit the layer masks or add adjustment layers to further fine-tune the different areas of the panorama.

Note:

To replace empty areas around image borders, use a content-aware fill. (See Use Content-aware, pattern, or history fills.)

Create 360-degree panoramas

Devices such as the Ricoh Theta V and Insta360One let you capture full 360 panoramic images in a single take. Alternatively, you can combine Photomerge with 3D features to create a 360-degree panorama. First, you stitch together the images to create a panorama; then you use the Spherical Panorama command to wrap the panorama so it's continuous.

Be sure to photograph a full circle of images with sufficient overlap. Photographing with a pano head on a tripod helps produce better results.

  1. Choose File > Automate > Photomerge.
  2. In the Photomerge dialog box, add the images you want to use.

    Do not include images that cover the top (zenith) or bottom (nadir) of the scene. You'll add these images later.

  3. Select Spherical for the Layout.
    Note:

    If you photographed with a fisheye lens, select the Auto layout and Geometric Distortion Correction. If Photoshop cannot automatically identify your lens, download the free Adobe Lens Profile Creator from the Adobe website.

  4. (Optional) Select Vignette Removal or Geometric Distortion for the Lens Correction.
  5. (Optional) Select Content Aware Fill Transparent Areas to avoid transparent pixels on the edges of the panoramic image.

  6. Click OK.

  7. Choose 3D > New Shape From Layer > Spherical Panorama.
  8. (Optional) Manually add the top and bottom images into the sphere. You could also paint out any remaining transparent pixels in the 3D spherical panorama layer.

Edit panoramas

Introduced in the October 2017 release of Photoshop CC.

You can edit equirectangular spherical panoramas in Photoshop. With the panorama asset imported and its layer selected, invoke the panoramic viewer by choosing 3D > Spherical Panorama > New Panorama Layer From Selected Layer. Alternatively, directly load a spherical panorama from your system into the viewer by selecting 3D > Spherical Panorama > Import Panorama.

Once you've opened a panorama in the viewer, you can perform a variety of operations on it.

Rotate the camera view around

Photoshop lets you adjust the camera view for your panoramic image.

  1. Select the Move tool.
  2. Click and drag in the view to look around inside the panoramic image.
Rotate the camera view using the Move tool in Photoshop

Adjust the field of view

The Properties Panel in Photoshop displays the camera properties. Here, you can adjust the field of view of the camera in mm (as in a 35mm camera) or degrees.

You can also click and drag the Axis widget controls available in the lower-left corner of the document window in Photoshop to rotate the camera without switching back to the Move tool.

Adjust the field of view using the Axis widget controls

Paint on the panorama

You can use the painting and adjustment tools available in Photoshop such as the Healing Brush and the Spot Healing Brush to edit the panorama. Filters work only on the visible portion of the panorama. Accordingly, it is recommended that you isolate the image outside the 3D view to apply the filters to your panoramic image.

The workflow given below uses the Spot Healing Brush tool as an example.

  1. Choose File > Open and select the name of the file you want to open.

  2. Choose 3D > Spherical Panorama > New Panorama Layer From Selected Layer.

  3. Select the Spot Healing Brush tool. Ensure that Projection is selected as the Paint System in the Properties panel.

  4. Click the area you want to fix, or click and drag to smooth over imperfections in a larger area. For details, see Retouch with the Spot Healing Brush tool.

    Note:

    • To improve the quality and performance while painting your panoramic image, create a new layer above the panoramic layer. After editing this layer, choose the Merge Down option from the Layers panel menu or press CtrlCommand+E.
    • To apply filters to the entire panorama, double-click the layer titled Spherical Map in the Layers panel, edit as desired, and then save the file. The image automatically gets updated in the spherical layout.
  5. To export the image, choose 3D > Spherical Panorama > Export Panorama.


 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online