Otwieranie wspólnej zawartości

Tylko użytkownicy InCopy mogą otwierać pliki przydziałów (.inca). Jeżeli użytkownik InCopy otworzy plik InDesign, który zawiera przydziały, to będzie miał dostęp do całej zawartości zarządzanej, niezależnie od przydziałów.

  1. Wykonaj jedną z poniższych czynności.
    • W programie InCopy wybierz polecenie Plik > Otwórz, zaznacz plik przydziału (.icma lub .inca) i kliknij Otwórz.

    • W programie InDesign lub InCopy wybierz polecenie Plik > Otwórz, zaznacz plik InDesign (.indd), który zawiera przydzieloną zawartość, a następnie kliknij Otwórz.

    • Otwórz pakiet przydziału. Zobacz Otrzymywanie pakietów (InCopy).

Nazwy przydziałów i ich zawartość pojawią się w panelu Przydziały.

Pobieranie zawartości do edycji

Po pobraniu pliku do edycji, w systemie plików tworzony jest ukryty plik blokady (.idlk). Gdy użytkownik pobierze zawartość, ma wyłączność na zmianę jego zawartości, a inni nie mogą wprowadzać żadnych zmian. Pobierać można tylko zawartość InCopy. Nie można pobierać dokumentów InDesign z informacjami o układzie.

Gdy próbujesz zamknąć dokument InDesign zawierający przynajmniej jeden plik zawartości InCopy, pobrany przez ciebie do edycji, wyświetlany jest komunikat przypominający o konieczności odłożenia całej zawartości. Jeżeli zamknie się dokument bez odkładania plików zawartości, pozostaną one pobrane przy następnym otwarciu tego dokumentu InDesign. Zapisanie dokumentu InDesign powoduje automatyczne zapisanie wszystkich edytowalnych plików zawartości InCopy.

Pobierz zawartość do edycji (InDesign)

  1. Wykonaj jedną z poniższych czynności:
    • Zaznacz w układzie ramki tekstowe lub graficzne, które mają być edytowane, a następnie wybierz polecenie Edycja > InCopy > Pobierz.

    • Otwórz panel Przydziały, zaznacz pliki i wybierz polecenie Pobierz z menu panelu.

Po pobraniu dostępnej zawartości za pomocą programu InDesign, w ramce InDesign pojawi się ikona Edycja . W programie InCopy pojawia się ikona Używany  na ramce InCopy i w panelu Przydziały, jeśli pliki przydziału są przechowywane na lokalnym serwerze.

Pobieranie zawartości InCopy

  1. Wykonaj jedną z poniższych czynności:
    • Jeżeli zawartość do pobrania jest częścią przydziału, wybierz polecenie Plik > Otwórz i zaznacz plik przydziału (.icma lub .inca).

    • Jeżeli zawartość ta została wyeksportowana do osobnych plików, wybierz polecenie Plik > Otwórz i zaznacz plik InCopy (.icml lub .incx). W celu obejrzenia układu, tak aby można było dopasować zawartość, wybierz dokument InDesign.

  2. Wykonaj jedną z poniższych czynności:
    • Wybierz polecenie Plik > Pobierz do edycji, aby pobrać do edycji pojedynczy plik zawartości InCopy.

    • Aby pobrać całą zawartość przydziału na raz, zaznacz przydział w panelu Przydziały, a następnie wybierz polecenie Pobierz z menu panelu.

    • Aby pobrać poszczególne pozycje z przydziału, otwórz listę przydziałów w panelu Przydziały, zaznacz przynajmniej jedną pozycję i wybierz polecenie Pobierz z menu panelu.

    Obok takich pozycji w panelu Przydziały pojawi się ikona Edycja , co wskazuje, że zawartość ta została pobrana do wyłącznej edycji.

  3. Jeżeli program poprosi o uaktualnienie zawartości zgodnie ze zmianami, kliknij OK.

Po pobraniu dostępnej zawartości za pomocą programu InCopy, na ramce tekstowej InCopy i w panelu Przydziały wyświetlana jest ikona Edycja . W programie InDesign na ramce InDesign pojawia się ikona Używany .

Otwieranie plików zarządzanych (InCopy)

Do szybkich prac edycyjnych i pisania wygodniej jest otworzyć plik z zawartością zarządzaną (.icml lub .incx) bezpośrednio w InCopy i pracować w widoku wątku. Pojedynczych plików zarządzanych nie trzeba pobierać do edycji; program InCopy robi to automatycznie. Po zapisaniu i zamknięciu pliku, InCopy automatycznie odkłada go. Po otwarciu pojedynczego pliku, polecenia Zapisz zmieniają postać.

Uaktualnianie plików przydziałów (InDesign)

Zmiany w przydziałach można zapisywać ręcznie albo podczas zamykania bieżącego dokumentu. Uaktualnienie pliku przydziału to jedyna metoda, pozwalająca udostępnić użytkownikom InCopy zmieniony układ.

  1. Wykonaj jedną z poniższych czynności:
    • Aby uaktualnić wybrane przydziały, zaznacz je w panelu Przydziały i wybierz polecenie Uaktualnij zaznaczone przydziały z menu tego panelu.

    • Aby uaktualnić wszystkie nieaktualne przydziały w bieżącym dokumencie, wybierz polecenie Uaktualnij nieaktualne przydziały z menu panelu Przydziały. Tylko nieaktualne przydziały są aktualizowane.

    • Aby uaktualnić wszystkie przydziały w bieżącym dokumencie, wybierz polecenie Uaktualnij wszystkie przydziały z menu panelu Przydziały.

Uwaga:

Jeżeli podczas uaktualniania dany przydział jest otwarty przez kogoś w InCopy, to obok nazwy przydziału w panelu Przydziały w programie InCopy pojawi się ikona Nieaktualny .

Uaktualnianie zawartości

Warto obserwować, czy w panelu Przydziały nie pojawiły się ikony Nieaktualny, a jeżeli tak, to odpowiednio uaktualniać zawartość. Pozwoli to zapewnić zawsze pracę z najnowszą wersją zawartości. Uaktualnienie pliku przydziału InCopy i jego zawartości lub uaktualnienie osobnych plików zawartości powoduje skopiowanie danych z najnowszej wersji w systemie plików. Dzięki temu wersja w komputerze użytkownika jest zgodna z wersją w systemie plików. W celu uaktualnienia nie trzeba odkładać ani pobierać wątków, nie uzyskuje się też możliwości edycji. Uaktualnienie może jednak doprowadzić do problemów, jeżeli inny użytkownik usunął naszą blokadę.

Uwaga:

Uaktualnianie zawartości nie uaktualnia jej w pakietach przydziału, które nie zostały zwrócone.

Typowy obieg pracy podczas uaktualniania:

  1. Użytkownik InCopy otwiera plik przydziału lub pobiera oddzielny plik zawartości, a następnie edytuje tę zawartość.

  2. Użytkownik InCopy zapisuje plik zawartości, co powoduje uaktualnienie kopii w systemie plików, a następnie pracuje dalej.

  3. Użytkownik InDesign widzi ikonę Nieaktualny , pojawiającą się obok zaznaczonej zawartości w panelach Łącza i Przydziały, a także ikonę Używany , Zawartość tekstowa nieaktualna  bądź Zawartość graficzna nieaktualna  na odpowiedniej ramce.

    Panel Przydziały z ikonami Używany i Nieaktualny (po lewej). Nieaktualna zawartość w układzie (po prawej)
  4. Użytkownik InDesign uaktualnia zawartość.

Uaktualnianie zawartości podczas otwierania dokumentu zarządzanego (InDesign)

  1. Wybierz polecenie Plik > Otwórz i odszukaj plik, który ma zostać otwarty. Naciśnij przycisk Otwórz.
  2. Gdy program wyświetli pytanie o uaktualnienie dokumentu zmodyfikowaną zawartością z systemu plików, kliknij Tak.
  3. Wykonaj jedną z poniższych czynności:
    • Aby InDesign uaktualnił łącza, kliknij Napraw łącza automatycznie.

    • Aby ręcznie uaktualnić łącza, naciśnij przycisk Nie naprawiaj. Potem otwórz panel Łącza, zaznacz plik, który ma zostać uaktualniony i wybierz polecenie Uaktualnij łącze z menu tego panelu.

Uaktualnianie zawartości podczas pracy (InDesign)

  1. Wykonaj jedną z poniższych czynności:
    • Zaznacz ramki tekstowe lub graficzne w układzie i wybierz polecenie Edycja > InCopy > Uaktualnij zawartość.

    • Zaznacz ramki tekstowe lub graficzne w panelu Łącza i naciśnij przycisk Uaktualnij łącze  albo wybierz polecenie Uaktualnij łącze z menu panelu Przydziały.

Uaktualnianie zawartości podczas pracy (InCopy)

  1. Wykonaj jedną z poniższych czynności:
    • Kliknij punkt wstawiania w ramce tekstowej, aby ją zaznaczyć, a następnie wybierz polecenie Plik > Uaktualnij zawartość.

    • Zaznacz zawartość w panelu Przydziały, a następnie kliknij przycisk Uaktualnij zawartość  lub wybierz Uaktualnij zawartość z menu panelu Przydziały.

Zawartość możesz także uaktualnić używając panelu Łącza.

Niezamierzone uaktualnienie pracy

W większości przypadków polecenia uaktualniania dla pobranej zawartości są nieaktywne, ponieważ jej treść jest zawsze aktualna. Może jednak dojść do niepożądanej sytuacji, gdy inny użytkownik usunie blokadę na pobranej zawartości, przeciągając plik blokady (.idlk) do Kosza, a następnie zmodyfikuje tę zawartość. W takim przypadku, polecenia aktualizacji zostają włączone, nawet jeśli zawartość jest pobrana przez ciebie do edycji, pozwalając dwóm osobom na edycję zawartości w tym samym czasie. Uaktualnianie zawartości powoduje utratę pracy. Aby uzyskać najlepsze wyniki, nie należy usuwać plików blokad.

Uaktualnianie układu InDesign

Użytkownicy InDesign mogą modyfikować układ (np. zmieniając rozmiar lub położenie ramek tekstowych danego wątku) oraz zapisywać te zmiany, w czasie gdy użytkownicy InCopy modyfikują tekst znajdujący się w tych ramkach. W obiegu pracy ze współużytkowanym serwerem, sposób powiadamiania użytkowników InCopy o zmianach układu zależy od tego, czy otworzyli oni plik przydziału, czy pobrali oddzielne pliki zawartości, otwierając jednocześnie połączony plik InDesign.

Należy pamiętać o następujących wskazówkach:

  • Jeżeli użytkownik InDesign zmieni układ ramek w przydziale, to musi uaktualnić przydział, aby udostępnić te zmiany użytkownikom InCopy. InDesign nie uaktualnia automatycznie plików przydziałów podczas zapisywania dokumentu.

  • Gdy użytkownik InDesign uaktualni już przydział przechowywany na współużytkowanym serwerze, to w programie InCopy obok nazwy tego przydziału w panelu Przydziały pojawi się ikona Nieaktualny . Użytkownik InCopy musi uaktualnić projekt, aby zobaczyć bieżący układ.

  • Jeżeli użytkownik InDesign zmieni układ wyeksportowanej zawartości, która nie wchodzi w skład przydziału, ikona Nieaktualny pojawi się obok nazwy dokumentu InDesign w panelu Przydziały. Również pasek tytułowy dokumentu będzie informował o tym, że układ jest nieaktualny. Użytkownicy InCopy mogą uaktualnić aktywny w danym momencie dokument InDesign najnowszymi zmianami układu i stylów.

Jest to przydatne przy dopasowywaniu zawartości, ponieważ w widoku Układ i Wierszownik są wtedy widoczne najświeższe zmiany w wyglądzie i łamaniu wierszy.

  1. Wykonaj jedną z poniższych czynności:
    • Jeżeli otwarty jest plik przydziału, a w panelu Przydziały obok nazwy tego przydziału pojawiła się ikona Nieaktualny , naciśnij przycisk Uaktualnij projekt  albo wybierz polecenie Plik > Uaktualnij projekt. Polecenia tego nie można cofnąć.

    • Jeżeli nie posługuje się plikami przydziału, ale otworzyłeś przynajmniej jeden dokument InDesign, wybierz ten, który ma się stać aktywny, a następnie wybierz polecenie Plik > Uaktualnij projekt.

Odkładanie zawartości

Po odłożeniu zarządzanego pliku zawartości, jest on zapisywany we wspólnym miejscu w systemie plików. Stamtąd mogą go pobrać do edycji inni użytkownicy. Wyeksportowanie ramki tekstowej lub graficznej z programu InDesign automatycznie powoduje jej odłożenie.

Chociaż pliki odłożone są dostępne do edycji, nie można ich edytować, dopóki się takiego pliku nie pobierze (wyjątek stanowi edycja zawartości w trybie autonomicznym w programie InCopy). Odłożenie zawartości jest równoznaczne z zrzeczeniem się wyłączności na edycję, nie powoduje jednak zamknięcia pliku. Zawartość pozostaje otwarta na ekranie, ale ma status „tylko do odczytu”.

Wtyczki LiveEdit Workflow nie tworzą wielu wersji plików. Po uaktualnieniu w InCopy lub w InDesign poprzednie wersje pliku są nadpisywane.

Jeśli pracujesz nad pakietem przydziału, zwróć lub przekaż pakiet przydziału po odłożeniu go.

Odkładanie zarządzanej zawartości po edycji (InDesign)

  1. Wykonaj jedną z poniższych czynności:
    • Zaznacz zawartość w układzie i wybierz polecenie Edycja > InCopy > Odłóż.

    • W panelu Przydziały, zaznacz zawartość i wybierz polecenie Odłóż z menu panelu.

Odkładanie zarządzanej zawartości po edycji (InCopy)

  1. Wykonaj jedną z poniższych czynności:
    • Zaznacz zawartość w widoku Układ i wybierz polecenie Plik > Odłóż.

    • W panelu Przydziały, zaznacz zawartość i wybierz polecenie Odłóż z menu panelu.

    Uwaga:

    Przed odłożeniem zawartości możesz cofnąć ostatnie zmiany.

    Uwaga:

    Odłożenie pliku spowoduje pojawienie się ikony Dostępny, widocznej na ramce tekstowej lub graficznej w układzie InDesign, w widoku Układ w programie InCopy, w panelu Przydziały, a także na pasku wątku (InCopy).

Zapisywanie zmian (InDesign)

Podczas z pracy z pobraną zawartością można zapisywać zmiany, uaktualniając kopię przechowywaną w systemie plików.

  1. Wykonaj jedną z poniższych czynności:
    • Aby zapisać wybrane elementy zawartości bez zapisywania zmian w dokumencie InDesign ani w przyłączonych do niego plikach, wybierz polecenie Edycja > InCopy > Zapisz zawartość.

    • Aby zapisać każdy pobrany przez siebie plik zawartości, wybierz polecenie Plik > Zapisz. Ta metoda zapisywania nie powoduje automatycznego uaktualnienia plików przydziałów ani plików zawartości pobranych w InCopy. Jednak pliki pobrane w InCopy zostaną oznaczone ikoną Nieaktualny  w panelu Przydziały.

    • Aby zapisać dokument InDesign pod nową nazwą, z łączami do istniejących plików InCopy, wybierz polecenie Plik > Zapisz jako. Ta operacja spowoduje, że program stwierdzi brak przydziałów w pliku InDesign, ale tylko do momentu, w którym nie zostaną one aktualizowane.

    • Aby zapisać kopię aktywnego dokumentu, wybierz polecenie Plik > Zapisz kopię. Kopię można zapisać pod nową nazwą i w innym miejscu, zachowując połączenia z istniejącymi plikami InCopy.

Zapisywanie zmian (InCopy)

  1. Wykonaj jedną z poniższych czynności:
    • Aby zapisać plik InCopy pod tą samą nazwą i w tym samym miejscu w systemie plików, wybierz polecenie Plik > Zapisz zawartość. Plik pozostaje pobrany do edycji dla tego samego użytkownika.

    • Aby zapisać plik InCopy pod nową nazwą, wybierz polecenie Plik > Zapisz zawartość jako. Nowo utworzony plik zawartości nie podlega zarządzaniu w obiegu pracy. Polecenie Zapisz zawartość jako jest dostępne tylko wtedy, gdy plik zawartości InCopy (.icml lub .incx) został otwarty bezpośrednio.

    • Aby zapisać kopię aktywnego pliku zawartości InCopy, wybierz polecenie Plik > Zapisz kopię zawartości. Można ją zapisać pod nową nazwą i w innym miejscu. Zapisana w ten sposób kopia nie podlega zarządzaniu w przepływie pracy. Polecenie Zapisz kopię zawartości jest dostępne tylko wtedy, gdy plik zawartości InCopy (.icml lub .incx) został otwarty bezpośrednio.

    • Aby zapisać wszystkie otwarte i pobrane pliki zawartości InCopy, wybierz polecenie Plik > Zapisz całą zawartość. Pliki są zapisywane w tym samym miejscu, jakie zajmowały. Polecenie Zapisz całą zawartość jest dostępne tylko wtedy, gdy otwarto przydział lub plik InDesign.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online