Descubra o que fazer se a colagem de uma arte-final ficar lenta ou se houverem dados inesperados nos seus arquivos do Illustrator.

Problema

Ao colar arte-final em arquivos do Illustrator, ou entre os arquivos, a ação é muito mais lenta do que o esperado ou aparecem objetos globais inesperados no documento de destino (por exemplo: amostras, símbolos e pincéis).

Soluções

Tente uma ou mais das seguintes soluções, dependendo de qual versão do Illustrator estiver usando.

Escolha a sua versão do Illustrator:

Corrija os nomes de objeto globais de plug-in inválidos (Mac e Windows; CS6 e CC)

  1. Certifique-se de estar utilizando a versão mais recente do Illustrator. Escolha Ajuda > Atualizações ou atualize o Illustrator usando o aplicativo de desktop da Creative Cloud.

  2. Baixe o arquivo ZIP anexado e extraia o script contido nele (arquivo JSX).

    Download

  3. Inicie o Illustrator e execute o script: Selecione menu Arquivo > Scripts > Outros Scripts ou arraste o script no Illustrator. A seguinte mensagem é exibida: “a preferência fixBadPluginGlobalObjectNames foi ATIVADA”.

  4. Execute novamente o script se essa mensagem for exibida: “a preferência fixBadPluginGlobalObjectNames foi DESATIVADA”.

  5. Feche e reinicie o Illustrator e, em seguida, abra o arquivo do Illustrator afetado para verificar se ele foi corrigido.

Soluções para CS5 e anteriores

Resolver o problema para o Illustrator CS5 e versões anteriores requer uma das duas soluções a seguir. Se a primeira alternativa não resolver, tente a segunda.

Solução 1 (CS5 e anterior): Ativar o modo de recuperação de conteúdo 

  1. Saia do Illustrator.

  2. Localize o arquivo de preferências do Adobe Illustrator. Por exemplo, os arquivos de preferências para o Illustrator CS5 estão localizados aqui:

    • Mac OS: /[usuário]/Biblioteca/Preferências/Configurações do Adobe Illustrator CS5/[idioma]/
    • Windows 7/vista: Usuários/[usuários] /AppData/Roaming/Adobe/Configurações do Adobe Illustrator CS5/[idioma]/AIPrefs
    • Windows XP: Documents and Settings/[usuário]/Dados de Aplicativos/Adobe/Configurações do Adobe Illustrator CS5/ AIPrefs

    Observação:

    No Windows, os arquivos do aplicativo e do AppData ficam ocultos por padrão. Se precisar de ajuda para exibir arquivos ocultos, consulte Mostrar arquivos ocultos.

  3. Abra o arquivo de preferências, em um editor de texto comum, como o TextWrangler (Mac OS) ou o Bloco de notas (Windows). (Também é possível usar um aplicativo de processamento de texto mais tradicional. Mas, se o fizer, salve o arquivo como texto simples, sem permitir uma extensão .txt oculta.)

  4. No arquivo de preferências, localize a seção que se pareça com esta:

    /aiFileFormat {

    /PDFCompatibility 1

    /enableATEReadRecovery 0

    /enableContentRecovery 0

    /enableATEWriteRecovery 0

    /clipboardPSLevel 3

    }

  5. Altere o valor enableContentRecovery de 0 para 1. Se a seção /aFileFormat não tiver uma linha enableContentRecovery, adicione uma. Após editar, terá esta aparência:

    /enableContentRecovery 1

  6. Salve o arquivo de preferências sem permitir uma alteração de nome ou extensão.

Solução 2 (CS5 e anterior): Edite o arquivo recuperado 

  1. Inicie o Illustrator.
  2. Para abrir o documento, escolha Arquivo > Abrir ou pressione Comando + O.

    Não abra o documento clicando duas vezes nele, usando a lista de Arquivos Recentes ou arrastando o arquivo para o ícone de aplicativo do Illustrator.  

  3. Na caixa de diálogo de navegação de arquivos, selecione o arquivo que deseja reparar.

  4. Pressione Comando+Option+Shift(Mac OS) ou Ctrl+Alt+Shift(Windows), em seguida clique em Abrir Na caixa de diálogo Abrir.

  5. Feche a janela vazia que se abre, sem salvá-la.

  6. No Finder (Mac OS) ou no Windows Explorer (Windows), no mesmo diretório que contém o arquivo original, localize uma cópia do arquivo precedida por um sublinhado. Por exemplo, se abriu "BrokenFile.ai", você verá um novo arquivo denominado "_BrokenFile.ai".

  7. Abra o arquivo com o sublinhado em um editor de texto simples como o TextWrangler (Mac OS) ou UltraEdit (Windows). (Usuários do Windows devem poder usar o WordPad ou o Bloco de notas). Se o arquivo quebrado for grande, pode demorar um pouco abrir. Se o seu editor de texto tiver um limite máximo para o tamanho de arquivos que podem ser abertos, use um aplicativo diferente.

  8. No arquivo com o sublinhado, procure cada ocorrência dessa:

    %AI8_BeginPluginObject

  9. Verifique a seguinte linha para ver se corresponde a uma destas sequências:
    (Adobe Calligraphic Brush Tool)
    (Adobe Scatter Brush Tool)
    (Adobe ArtOnPath Brush Tool)
    (Adobe Pattern Brush Tool)

  10. Se a linha não coincidir com uma das quatro sequências de caracteres exatamente (inclusive maiúsculas e minúsculas), selecione todo o texto dentro do comando %AI8_BeginPluginObject e no primeiro comentário %AI8_EndPluginObjetc subsequente. Em seguida exclua os próprios comentários e a seleção.

  11. Repita as etapas 9 e 10 para cada ocorrência do comentário %AI8_BeginPluginObject no arquivo.

  12. Salve o arquivo.
  13. Abra o arquivo no Illustrator.
  14. Exclua todos os símbolos e pincéis. Ou, se você suspeitar que o arquivo contenha símbolos necessárias ou traçados de pincel, execute a ação Excluir Itens Não Utilizados do Painel (escolha Ações > Excluir Itens Não Utilizados do Painel, em seguida, clique em Reproduzir Seleção Atual).  

  15. Salve o arquivo com um novo nome (por exemplo, “Arquivo Consertado.ai”).

  16. (Importante) Feche o arquivo.

  17. Abra novamente o arquivo no Illustrator. Verifique se o arquivo foi corrigido selecionando qualquer objeto e copiando-o e colando-o em um novo arquivo em branco.

Informações adicionais

Conteúdos inesperados são causados por problemas das versões anteriores do Illustrator que foram corrigidos na versão atual. Se estiver trabalhando com um documento salvo em uma versão anterior do Illustrator, abrir o arquivo na versão atual pode não corrigir o problema.

Objetos globais inesperados podem aparecer em seus respectivos painéis, ou não. As tentativas de excluir os objetos globais inesperados podem falhar ou podem fazer com que o Illustrator se torne instável e pare de repente.

Se você salvar o documento, o tamanho do documento mostra um aumento significativo devido à quantidade de objetos globais adicionados ao documento. Estes dados inválidos podem existir em um documento muito antes de serem notados, de modo que abrir o documento em versões anteriores nem sempre corrige o problema. Os dados inválidos podem estender-se quando você copia a arte-final de um documento para outro.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online