Способы повторного использования графики и текста

В InDesign есть несколько способов изменения назначения графических объектов и текста.

Сниппеты

Сниппет — это файл, содержащий в себе объекты и описывающий их взаимное расположение на странице или развороте (см. Использование сниппетов).

Библиотеки объектов

Библиотека объектов является удобным местом для хранения таких элементов, как логотипы, вставки, врезы и других повторяющихся элементов (см. Использование библиотек объектов).

Шаблоны

Шаблон — это документ, содержащий текст-местозаполнитель и графические объекты (см. раздел Использование шаблонов документов).

Использование сниппетов

Сниппет — это файл, содержащий в себе объекты и описывающий их взаимное расположение на странице или развороте. Он позволяет повторно использовать и быстро позиционировать объекты страницы. Создайте сниппет, сохранив объекты в файле сниппета, имеющем расширение .IDMS (предыдущие версии InDesign используют расширение .INDS). Когда файл сниппета помещается в документ InDesign, можно задать, где должны быть расположены объекты: в своих исходных позициях или в месте щелчка. Сниппеты могут быть сохранены в библиотеке объектов и программе Adobe Bridge, а также на жестком диске.

Содержимое сниппета при помещении в документ сохраняет взаимосвязи между слоями. Если он содержит определения ресурсов, имеющиеся также и в документе, в который выполняется копирование, то используются ресурсы, содержащиеся в документе.

Сниппеты, созданные в программе InDesign CS5, могут быть открыты в программе InDesign CS4, но их невозможно открыть в предыдущих версиях программы InDesign.

Создание сниппетов

  1. Выполните одно из следующих действий:
    • При помощи инструмента «Выделение» выделите один или несколько объектов, а затем выберите меню «Файл» > «Экспорт». В поле «Тип файла» (Windows) или «Формат» (Mac OS) диалогового окна «Сохранить как» выберите «Шаблон InDesign CS4» и нажмите кнопку «Сохранить». Введите имя файла и нажмите кнопку «Сохранить».

    • При помощи инструмента «Выделение» выделите один или несколько объектов, а затем перетащите их на рабочий стол. При этом будет создан файл сниппета. Переименуйте файл.

    • Выберите один или несколько объектов, затем перетащите их на панель Mini Bridge. При этом будет создан файл сниппета. Переименуйте файл.

    • Перетащите элемент из палитры «Структура» на рабочий стол.

Добавление сниппетов в документ

  1. Выберите меню «Файл» > «Поместить».
  2. Выберите один или несколько файлов сниппетов (*.IDMS или *.INDS).
  3. Щелкните курсором загруженного сниппета в том месте, где должен быть размещен левый верхний угол сниппета.

    Если точка ввода размещена в текстовом фрейме, сниппет помещается в текст как привязанный объект.

    Все объекты после помещения сниппета остаются выделенными. Изменить положение всех объектов можно перетаскиванием.

  4. Если загружено более одного сниппета, выполните прокрутку и щелкните курсором загруженного сниппета, чтобы поместить в документ следующий сниппет.

Примечание.

Можно перетащить файл сниппета с рабочего стола в документ InDesign и щелкнуть в том месте, где должен быть размещен его левый верхний угол.

Выбор метода помещения сниппетов

Объекты сниппета могут быть размещены не в месте щелчка, а в их исходных позициях. Например, текстовый фрейм, на момент включения в сниппет находившийся в середине страницы, может отображаться точно в том же месте при помещении в качестве сниппета.

  1. В разделе установок «Обработка файлов» выберите параметр «Исходное положение» в меню «Положение», чтобы в сниппетах сохранялись исходные положения объектов. Выберите «Положение курсора» в меню «Положение», чтобы сниппеты помещались на странице в месте щелчка.

Примечание.

Настройку параметра позиционирования можно также временно изменить, удерживая нажатой клавишу Alt (Windows) или Option (Mac). Например, если был выбран параметр «Позиционировать в положении курсора», но необходимо поместить объекты сниппета в их исходных положениях, в момент щелчка курсором загруженного сниппета на странице удерживайте нажатой клавишу Alt или Option.

Использование библиотек объектов

Библиотеки объектов помогают упорядочить наиболее часто используемые графические объекты, текст, страницы, а также направляющие, сетки, рисованные фигуры и сгруппированные изображения. Можно создать много библиотек: для разных типов объектов, для разных проектов или заказчиков и т.п.

Во время сеанса работы можно открыть столько библиотек, сколько поместится в памяти компьютера. Библиотеки объектов могут быть распределены по разным серверам, различным платформам, однако библиотека в один момент времени может быть открыта только одним пользователем. Если библиотека включает текстовые файлы, убедитесь, что на всех системах, где она используется, имеются нужные шрифты.

При добавлении в библиотеку объектов страничного элемента (например, графического объекта) InDesign сохраняет все импортированные и примененные атрибуты. Например, если при добавлении из документа InDesign графический объект добавляется в библиотеку, то это будет точная копия оригинала, включая информацию о связи, что позволяет обновлять графический объект при его изменении.

Если объект удален из документа InDesign, его миниатюра будет по-прежнему отображаться на палитре «Библиотека», и вся информация о связи также останется без изменений. Если исходный объект перемещен или удален, при помещении объекта в документ рядом с его именем на палитре «Связи» появится значок отсутствующей связи.

В каждой библиотеке объектов элементы можно идентифицировать и найти по названию, дате добавления в библиотеку или по ключевым словам. Можно также просто просмотреть библиотеку объектов, отсортировав элементы в ней или выделяя их подмножества. Например, можно скрыть все элементы, кроме EPS-файлов.

Библиотека объектов на палитре «Библиотека»
Библиотека объектов на палитре «Библиотека»

A. Миниатюра и имя объекта B. Кнопка «Информация об элементе библиотеки» C. Кнопка «Показать подмножество библиотек» D. Кнопка «Новый элемент библиотеки» E. Кнопка «Удалить элемент из библиотеки» 

При добавлении элемента в библиотеку объектов InDesign сохраняет все атрибуты страницы, текста и изображения и поддерживает взаимосвязи между библиотечными объектами и другими элементами страницы следующим образом.

  • Элементы, сгруппированные в документе InDesign при перетаскивании на палитру «Библиотека», остаются сгруппированными и при перетаскивании в обратном направлении.

  • Сохраняется форматирование текста.

  • Стили абзацев, шрифта и объектов, которые имеют те же имена, что и в целевом документе, преобразуются к его стилям; те, которые имеют отличные имена, добавляются в документ.

  • Исходные слои объекта сохраняются, если установлен параметр «Вставить скопированные слои» в меню палитры «Слои».

Создание библиотеки объектов

Библиотека объектов представляет собой именованный файл на диске. При создании библиотеки необходимо указать, где этот файл будет сохранен. При открытии библиотеки она отображается в виде панели, сгруппированной с другими панелями. Имя файла библиотеки объектов отображается во вкладке палитры. При закрытии библиотеки она удаляется из текущего сеанса, однако файл при этом не удаляется.

В библиотеку можно добавлять и удалять из нее объекты, выделенные страничные элементы и целые страницы. Можно также добавлять и перемещать объекты из одной библиотеки в другую.

  1. Выберите меню «Файл» > «Новый» > «Библиотека».
  2. В диалоговом окне «CC Libraries» вы можете выбрать продолжение работы с библиотеками объектов InDesign или использование сервиса CC Libraries для систематизации и поиска всех дизайнерских ресурсов, а также применения их в своих проектах. Дополнительные сведения представлены в разделе Библиотеки Creative Cloud Libraries — удобная синхронизация, обмен и совместная работа.

  3. Укажите имя и расположение библиотеки и нажмите кнопку «Сохранить». Указанное имя становится заголовком вкладки палитры библиотеки.

Открытие существующей библиотеки

  1. Выполните одно из следующих действий:
    • Если в текущем сеансе библиотека уже открыта (и не была закрыта), выберите файл библиотеки в меню «Окно».

    • Если библиотека не открыта, выберите меню «Файл» > «Открыть» и выберите одну или несколько библиотек. В Windows файлы библиотек имеют расширение INDL. InDesign в момент открытия преобразует библиотеки предыдущих версий программы в новый формат. Пользователю предлагается сохранить эти библиотеки с новыми именами.

Закрытие библиотеки

  1. Щелкните вкладку библиотеки, которую нужно закрыть.
  2. Выполните одно из следующих действий:
    • Выберите в меню палитры «Библиотека» команду «Закрыть библиотеку».

    • Выберите имя файла библиотеки в меню «Окно».

Удаление библиотеки

  1. В Проводнике (Windows) или программе Finder (Mac OS) перетащите файл библиотеки в Корзину (Windows) или Trash (Mac OS). В Windows файлы библиотек имеют расширение INDL.

Добавление объекта или страницы в библиотеку

  1. Выполните одно из следующих действий:
    • Перетащите один или несколько объектов из окна документа в активную палитру «Библиотека».

    • Выделите один или несколько объектов в окне документа и нажмите кнопку «Новый элемент библиотеки» на палитре «Библиотека».

    • Выделите один или несколько объектов в окне документа и выберите в меню палитры «Библиотека объектов» пункт «Добавить элемент».

    • Выберите в меню палитры «Библиотека» пункт «Добавить элементы страницы [номер] индивидуально», чтобы все объекты были добавлены в виде отдельных библиотечных объектов.

    • Выберите в меню палитры «Библиотека» пункт «Добавить элементы страницы [номер]», чтобы все объекты были добавлены в виде одного библиотечного объекта.

    • Перетащите элемент из палитры «Структура» в активную палитру «Библиотека объектов».

Примечание.

Если при этом удерживать нажатой кнопку Alt (Windows) или Option (Mac OS), то при добавлении объекта в библиотеку появляется диалоговое окно «Информация об элементе».

Добавление объекта из библиотеки в документ

  1. Выполните одно из следующих действий:
    • Перетащите объект из палитры «Библиотека» в окно документа.

    • На палитре «Библиотека» выделите объект и выберите пункт «Поместить элемент(ы)» в меню палитры «Библиотека». Этот метод помещает объект в его исходные координаты по горизонтали и по вертикали.

    • Перетащите XML-элемент в родительский элемент на палитре «Структура» или на страницу.

Работа с объектами библиотеки

Работа с библиотечными объектами производится на палитре «Библиотека».

Обновление библиотечного объекта новым элементом

  1. В окне документа выделите элемент, который необходимо добавить на палитру «Библиотека».
  2. На палитре «Библиотека» выделите объект, который необходимо заменить, и выберите пункт «Обновить элемент библиотеки» в меню панели «Библиотека».

Копирование и перемещение объекта из одной библиотеки в другую

  1. Переместите из палитры «Библиотека» вкладку первой палитры библиотеки, чтобы обе библиотеки были видны на экране одновременно.
  2. Выполните одно из следующих действий:
    • Чтобы скопировать объект из одной библиотеки в другую, перетащите элемент из палитры одной библиотеки на палитру другой библиотеки.

    • Чтобы переместить объект из одной библиотеки в другую, при перетаскивании удерживайте нажатой клавишу Alt (Windows) или Option (Mac OS).

Удаление объекта из библиотеки

  1. На палитре «Библиотека» выделите объект и выполните одно из следующих действий.
    • Нажмите кнопку «Удалить элемент из библиотеки».

    • Перетащите элемент на кнопку «Удалить элемент из библиотеки».

    • Выберите в меню палитры «Библиотека» пункт «Удалить элемент(ы)».

Изменение вида библиотеки объектов

Библиотека объектов отображает объекты в виде миниатюр или в виде текстового списка. Миниатюры можно отсортировать по имени, возрасту или типу объекта. Просмотр в виде списка и параметры сортировки лучше всего подходят в том случае, если объекты каталогизированы.

  1. Выполните одно из следующих действий:
    • Чтобы объекты отображались в виде миниатюр, выберите в меню палитры »Библиотека» режим «Просмотр в виде миниатюр» или «Просмотр в режиме больших миниатюр».

    • Чтобы объекты отображались в виде текстового списка, выберите в меню палитры «Библиотека» режим «Просмотр в виде списка».

    • Чтобы отсортировать объекты в нужном порядке, выберите пункт «Сортировать элементы» в меню палитры «Библиотека», а затем метод сортировки.

Просмотр всех объектов

  1. Выберите в меню палитры «Библиотека» команду «Показать все».

Просмотр, добавление и редактирование информации о библиотеке

В больших библиотеках объектов, содержащих множество элементов, информация о библиотеке может отражать имена, типы и текстовые описания объектов.

  1. На палитре «Библиотека» выполните одно из следующих действий:
    • Дважды щелкните объект.

    • Выделите объект и нажмите кнопку «Информация об элементе библиотеки».

    • Выделите объект и выберите пункт «Информация об элементе» в меню палитры «Библиотека».

  2. Просмотрите или измените имя элемента, тип объекта или описание, а затем нажмите кнопку «ОК».

Поиск объектов в библиотеке

При поиске объекта все объекты, кроме результатов поиска, будут скрыты от просмотра. Функцию поиска можно использовать для отображения или скрытия определенных категорий объектов. Например, можно отобразить только элементы, которые содержат в своем имени слово «звезда».

  1. Выберите в меню палитры «Библиотека» пункт «Показать подмножество» или нажмите кнопку «Показать подмножество библиотеки».
  2. Выполните одно из следующих действий:
    • Для поиска среди всех объектов библиотеки выберите «Поиск по всей библиотеке».

    • Чтобы искать только среди объектов, присутствующих в списке (в результатах предыдущего поиска), выберите «Поиск среди показанных элементов».

  3. Выберите категорию в первом меню раздела параметров.
  4. Во втором меню укажите, следует ли включить или исключить элементы типа, выбранного в первом меню.
  5. Справа от второго меню введите искомое слово или фразу.
  6. Чтобы добавить критерий поиска, нажмите «Добавить критерий» (это можно сделать до пяти раз), после чего будет добавлен новый критерий поиска. Чтобы удалить критерий поиска, нажмите «Убрать критерий».
  7. Чтобы отображать только объекты, которые соответствуют всем критериям поиска, выберите параметр «Соответствие по всем». Чтобы отобразить объекты, которые соответствуют хотя бы одному из критериев, выберите «Соответствие хотя бы по одному».
  8. Чтобы начать поиск, нажмите кнопку «ОК».

Примечание.

Чтобы снова отобразить все объекты, выберите в меню палитры «Библиотека» пункт «Показать все».

Перенос ресурсов объектов библиотеки в CC Libraries

Сервис Creative Cloud Libraries позволяет систематизировать и просматривать все дизайнерские ресурсы, а также использовать их в своих проектах. В InDesign вы можете использовать библиотеки сервиса CC Libraries вместо библиотек объектов.

Примечание.

InDesign продолжает осуществлять поддержку библиотек объектов.

InDesign позволяет переносить ресурсы библиотек объектов в сервис CC Libraries.

  1. Для переноса всех ресурсов из текущей библиотеки откройте палитру библиотек объектов и нажмите кнопку «Перенести».

    Или выберите несколько ресурсов, нажмите на них правой кнопкой мыши, затем выберите параметр переноса выбранных ресурсов.

  2. В диалоговом окне «Перенос ресурсов» выберите функцию переноса ресурсов в новую или уже существующую библиотеку Creative Cloud.

Дополнительные сведения о библиотеках CC Libraries представлены в разделе Библиотеки Creative Cloud Libraries — удобная синхронизация, обмен и совместная работа.

Библиотеки Creative Cloud Libraries — удобная синхронизация, обмен и совместная работа
Библиотеки Creative Cloud Libraries — удобная синхронизация, обмен и совместная работа
Библиотеки Creative Cloud Libraries — удобная синхронизация, обмен и совместная работа

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет