انقر نقرًا مزدوجًا داخل لوحة المشروع أو استخدم ملف > استيراد > ملف لتصفح واستيراد ملف SVG.
تعلّم كيفية استيراد ملفات SVG كطبقات أشكال أصلية قابلة للتحرير وجاهزة للتحريك في Animate دون الحاجة إلى أي تحويل.
تتيح لك النسخة الأحدث من After Effects استيراد الملف كمقطع أو كتركيبة.
اسحب وأسقط ملف SVG المستورد في لوحة الجدول الزمني.
حدد الطبقة لاستخدام قسم محتويات الطبقة في لوحة الخصائص لعرض بنية SVG.
يمكنك أيضًا تحديد السهم بجانب الطبقة لفتحها، ثم توسيع قسم المحتويات.ستشاهد جميع العناصر الفردية وخصائصها، مثل المسار، التعبئة، والتحويل.
يمكنك استخدام هذه الخصائص للتحريك مثل أي طبقة شكل أخرى.على سبيل المثال:
- حرك المسار لإنشاء تأثيرات التشكل
- غير لون التعبئة عبر الزمن للحصول على انتقالات ديناميكية
- استخدم خصائص التحويل لتغيير الحجم أو التدوير أو نقل العناصر بشكل مستقل
إذا كانت الطبقات تحتوي على تعبئة وحدود متدرجة، يمكنك استخدام خصائص التحجيم والتدوير لتحريك التدرج اللوني.
يوفر استيراد SVG في After Effects مرونة وتحكمًا أفضل في كيفية استيراد ملفات SVG في مشروعك.مع النسخة الأحدث، عند استيراد ملف SVG، يمكنك اختيار إحضاره كمقطع أو كتركيبة.
|
استيراد كـ لقطات |
استيراد كـ تركيبة |
|---|---|
|
يستورد ملف SVG كطبقة متجهة واحدة قابلة للتنقيط باستمرار. |
يستورد ملف SVG كتركيبة مكونة من طبقات الشكل القابلة للتعديل. |
|
يحافظ على اتصال مع ملف SVG الخارجي. |
كل عنصر يُحوّل إلى الشكل القابل للتعديل الخاص به. |
|
مناسب للرسومات المتجهة الأحادية الطبقة عندما لا تحتاج لتقسيم العمل الفني إلى أجزاء. |
مناسب لتحرير المسارات والأشكال وتفاصيل مستوى الطبقة عندما تحتاج لتحريك عناصر منفردة. |
يمكنك التحكم في أسلوب الاستيراد المستخدم افتراضيًا عند استيراد ملفات SVG من خلال ضبط خيار سحب عناصر ملفات متعددة كـ ضمن تفضيلات استيراد.
- macOS: After Effects > الإعدادات > استيراد > سحب عناصر ملفات متعددة كـ
- Windows: تعديل > التفضيلات > استيراد > سحب عناصر ملفات متعددة كـ
انقر نقرًا مزدوجًا داخل لوحة مشروع أو استخدم ملف > استيراد > ملف لتصفح واستيراد ملف SVG.
استخدم القائمة المنسدلة استيراد كـ في صندوق حوار استيراد ملف لتحديد أحد الخيارات التالية:
- لقطات
- تركيبة - الاحتفاظ بأحجام الطبقة
اختيار لقطات يستورد الملف كطبقة واحدة مسطحة بدون إمكانية الوصول للعناصر المنفردة، مما يجعله مناسبًا للاستخدام الثابت أو عندما لا يكون التحريك مطلوبًا.تحديد تركيبة – الاحتفاظ بأحجام الطبقة ينشئ تركيبة جديدة حيث تُستورد كل طبقة مصدر بشكل منفصل، بحجم محتواها الفعلي، مما يجعل نقاط الارتساء أوضح والتحويلات أسهل للتحريك.
macOS
Windows
حدد الخيارات التالية إن أمكن:
- إنشاء تركيبة: ينشئ تركيبة جديدة باستخدام الإعدادات الافتراضية ويضع ملف SVG المستورد تلقائيًا، إما كـلقطات أو كـتركيبة مع طبقات الشكل، في الجدول الزمني، مما يوفر عليك إنشاء تركيبة يدويًا وسحب ملف SVG إليها.
- تسلسل الرسومات المتجهة القابلة للقياس: يستورد عدة ملفات SVG مرقمة ويتعامل معها كتسلسل صور متجهة إطار بجانب إطار.
استخدم قسم محتويات الطبقة في لوحة الخصائص أو قسم المحتويات الخاص بالطبقة في الجدول الزمني لعرض العناصر الفردية وخصائصها والعمل عليها إذا كنت قد استوردت ملف SVG كتركيب. إذا تم استيراده كلقطات، فسيتصرف كطبقة عادية ويمكن ضبطه باستخدام خصائص تحويل القياسية.
كما هو الحال مع ملفات Illustrator، إذا تم استيراد الملف المتجه كلقطات، يمكنك تحديد الطبقة في الجدول الزمني، ثم النقر بزر الماوس الأيمن وتحديد إنشاء > إنشاء أشكال ونص من طبقة متجهة لتحويله إلى طبقات قابلة للتحرير، ما يتيح لك تحريك المسارات الفردية والحدود والتعبئات. في أحدث إصدار Beta من After Effects، يتحول النص الموجود في الملف المصدر إلى طبقات نص قابلة للتحرير مع الحفاظ على الخط والحجم والتعبئة والموضع والأنماط والحدود وإعدادات الخط المتغير.
عندما تستورد SVG كلقطات، يحتفظ After Effects برابط مباشر إلى الملف الأصلي، لذلك يتم تحديث أي تغييرات تجريها على ملف SVG هذا خارج التطبيق تلقائيًا داخل مشروعك.
استخدم ميزات Beta الجديدة
أصبح النص القابل للتحرير من ملفات Illustrator متاحًا الآن للاختبار وإرسال الملاحظات. جرّبه الآن في After Effects (beta).
في أحدث إصدار Beta من After Effects، عند استيراد طبقة Illustrator كلقطات، يتحول أي نص في الملف المصدر إلى طبقة نص قابلة للتحرير خاصة به بدلًا من تسويته في حدود شكل.هذا يعني أن الخط والحجم والتعبئة والموضع والأنماط (مثل الغامق والمائل) والحدود وإعدادات الخط المتغير كلها تُنقل، بحيث يمكنك متابعة تحرير النص مباشرةً في After Effects بدلًا من إعادة إنشائه من البداية أو الرجوع إلى Illustrator لإجراء التغييرات.
حدد ملف > استيراد > ملف، ثم حدد ملف Illustrator الذي تريد استيراده.
في مربع الحوار استيراد الملف، تأكد من ضبط استيراد كـ على لقطات عند تحديد الملف المراد استيراده.
في مربع حوار الاستيراد، تأكد من ضبط نوع الاستيراد على لقطات وحدد خيارات الطبقة بناءً على ما تريد استيراده من ملف Illustrator.
اسحب الملف المستورد إلى لوحة الجدول الزمني.
انقر بزر الماوس الأيمن على طبقة Illustrator وحدد إنشاء > إنشاء أشكال ونص من طبقة متجهة، أو استخدم طبقة > إنشاء > إنشاء أشكال ونص من طبقة متجهة.
يتحول النص إلى طبقة نص قابلة للتحرير تطابق إلى حد كبير الخط والحجم والتعبئة والموضع في الملف الأصلي. بعد ذلك، يمكنك تحرير النص وضبطه مباشرةً في After Effects.
يظل النص الذي يحتوي على حدود فقط يتحول إلى مسارات بدلًا من طبقة نص قابلة للتحرير.
لا يزال المحتوى المتجه غير النصي يتحول إلى طبقات شكل كما في السابق، وإذا كان ملف Illustrator يحتوي على الاثنين معًا، فستحصل على مزيج من طبقات النص وطبقات الشكل.
انضم إلى النقاش في مجتمع After Effects (Beta) الخاص بنا حول دعم النص القابل للتحرير من ملفات Illustrator.
يمكن الآن لصق محتوى SVG الموجود في الحافظة في After Effects باستخدام تعديل > لصق. يتم استيراد المحتوى كطبقات أشكال أصلية قابلة للتحرير وجاهزة للتحريك، دون الحاجة لخطوة استيراد وسطية.
نسخ المحتوى من Illustrator
افتح عملك الفني في Adobe Illustrator.
تأكد من تحديد تفضيل تضمين كود SVG .
- macOS: حدد Illustrator > الإعدادات > التعامل مع الحافظة وحدد تضمين كود SVG.
- Windows: حدد تعديل > التفضيلات > التعامل مع الحافظة وحدد تضمين كود SVG.
حدد العمل الفني الذي تريد نسخه.
حوّل أي نص SVG إلى منحنيات قبل النسخ، حيث أن نص SVG غير مدعوم عند اللصق.
حدد تعديل > نسخ.
انتقل إلى After Effects وقم بأحد الإجراءات التالية حسب حالة المشروع:
- إذا لم يكن هناك مشروع مفتوح، حدد تعديل > لصق لإنشاء مشروع جديد مع تركيبة تحتوي على محتوى SVG كطبقة شكل.
- إذا كان المشروع مفتوحاً ولكن لم يتم تحديد تركيبة، حدد تعديل > لصق لإنشاء تركيبة جديدة في المشروع الحالي تحتوي على المحتوى الملصق.
إذا كانت التركيبة محددة في After Effects، حدد تعديل > لصق لإضافة محتوى SVG كطبقة شكل جديدة في تلك التركيبة.
لصق SVG من التطبيقات الأخرى
يمكن لصق محتوى SVG المنسوخ من أي تطبيق يكتب SVG إلى حافظة النظام باستخدام نفس سير عمل تعديل > لصق. يعتمد الدعم على ما إذا كان التطبيق المصدر يضع بيانات SVG صالحة على الحافظة.
إنشاء رسوم متحركة ثلاثية الأبعاد مذهلة في After Effects
قم بتحريك الشخصيات والرسوم التوضيحية، وأضف الحركة إلى النص، والمزيد.