Security updates available for Adobe Flash Player

Release date: May 13, 2014

Vulnerability identifier: APSB14-14

Priority: See table below

CVE number: CVE-2014-0510, CVE-2014-0516, CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520

Platform: All Platforms

Summary

Adobe has released security updates for Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh and Adobe Flash Player 11.2.202.356 and earlier versions for Linux. These updates address vulnerabilities that could potentially allow an attacker to take control of the affected system. Adobe recommends users update their product installations to the latest versions:

  • Users of Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh should update to Adobe Flash Player 13.0.0.214.
  • Users of Adobe Flash Player 11.2.202.356 and earlier versions for Linux should update to Adobe Flash Player 11.2.202.359.
  • Adobe Flash Player 13.0.0.206 installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 13.0.0.214 for Windows, Macintosh and Linux.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.0.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 11 will automatically be updated to the latest Internet Explorer 11 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.1.
  • Users of the Adobe AIR 13.0.0.83 SDK and earlier versions should update to the Adobe AIR 13.0.0.111 SDK.
  • Users of the Adobe AIR 13.0.0.83 SDK & Compiler and earlier versions should update to the Adobe AIR 13.0.0.111 SDK & Compiler.

Affected software versions

  • Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh
  • Adobe Flash Player 11.2.202.356 and earlier versions for Linux
  • Adobe AIR 13.0.0.83 SDK and earlier versions
  • Adobe AIR 13.0.0.83 SDK & Compiler and earlier versions

To verify the version of Adobe Flash Player installed on your system, access the About Flash Player page, or right-click on content running in Flash Player and select "About Adobe (or Macromedia) Flash Player" from the menu. If you use multiple browsers, perform the check for each browser you have installed on your system.

To verify the version of Adobe AIR installed on your system, follow the instructions in the Adobe AIR TechNote.

Solution

Adobe recommends users update their software installations by following the instructions below:

  • Adobe recommends users of Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh update to the newest version 13.0.0.214 by downloading it from the Adobe Flash Player Download Center, or via the update mechanism within the product when prompted.
  • Adobe recommends users of Adobe Flash Player 11.2.202.356 and earlier versions for Linux update to Adobe Flash Player 11.2.202.359 by downloading it from the Adobe Flash Player Download Center.
  • Adobe Flash Player 13.0.0.206 installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 13.0.0.214 for Windows, Macintosh and Linux.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.0.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 11 will automatically be updated to the latest Internet Explorer 11 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.1.
  • Users of the Adobe AIR 13.0.0.83 SDK should update to the Adobe AIR 13.0.0.111 SDK.
  • Users of the Adobe AIR 13.0.0.83 SDK & Compiler and earlier versions should update to the Adobe AIR 13.0.0.111 SDK & Compiler.

* Beginning May 13, 2014, Adobe Flash Player 13 for Mac and Windows replaces version 11.7 as the extended support version. Adobe recommends users upgrade to version 13 in order to continue to receive security updates.  See this blog post for further details. http://blogs.adobe.com/flashplayer/2014/03/upcoming-changes-to-flash-players-extended-support-release.html

Priority and severity ratings

Adobe categorizes these updates with the following priority ratings and recommends users update their installation to the newest version:

Product Updated version Platform Priority rating
Adobe Flash Player 13.0.0.214
Windows and Macintosh
1
  13.0.0.214 Internet Explorer 10 for Windows 8.0 1
  13.0.0.214
Internet Explorer 11 for Windows 8.1 1
  13.0.0.214
Chrome for Windows, Macintosh and Linux 1
  11.2.202.359 Linux 3
Adobe AIR SDK and Compiler 13.0.0.111 Windows and Macintosh 3
Adobe AIR SDK 13.0.0.111 Windows and Macintosh 3

These updates address a critical vulnerability in the software.

Details

Adobe has released security updates for Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh and Adobe Flash Player 11.2.202.356 and earlier versions for Linux. These updates address vulnerabilities that could potentially allow an attacker to take control of the affected system. Adobe recommends users update their product installations to the latest versions:

  • Users of Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh should update to Adobe Flash Player 13.0.0.214
  • Users of Adobe Flash Player 11.2.202.356 and earlier versions for Linux should update to Adobe Flash Player 11.2.202.359.
  • Adobe Flash Player 13.0.0.206 installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 13.0.0.214 for Windows, Macintosh and Linux.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.0.
  • Adobe Flash Player 13.0.0.206 installed with Internet Explorer 11 will automatically be updated to the latest Internet Explorer 11 version, which will include Adobe Flash Player 13.0.0.214 for Windows 8.1.
  • Users of the Adobe AIR 13.0.0.83 SDK and earlier versions should update to the Adobe AIR 13.0.0.111 SDK.
  • Users of the Adobe AIR 13.0.0.83 SDK & Compiler and earlier versions should update to the Adobe AIR 13.0.0.111 SDK & Compiler.

These updates resolve a use-after-free vulnerability that could result in arbitrary code execution (CVE-2014-0510).

These updates resolve a vulnerability that could be used to bypass the same origin policy (CVE-2014-0516).

These updates resolve security bypass vulnerabilities (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520).

Affected Software     Recommended Player Update Availability
Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh   13.0.0.214 Flash Player Download Center
Flash Player 13.0.0.206 and earlier versions (network distribution)   13.0.0.214
Flash Player Licensing
Flash Player 11.2.202.356 and earlier for Linux   11.2.202.359 Flash Player Download Center
Flash Player 13.0.0.206 and earlier for Chrome (Windows, Macintosh and Linux)   13.0.0.214
Google Chrome Releases
Flash Player 13.0.0.206 and earlier in Internet Explorer 10 for Windows 8.0   13.0.0.214
Microsoft Security Advisory
Flash Player 13.0.0.206 and earlier in Internet Explorer 11 for Windows 8.1   13.0.0.214
Microsoft Security Advisory
AIR 13.0.0.83 SDK & Compiler   13.0.0.111 AIR SDK Download
AIR 13.0.0.83 SDK   13.0.0.111 AIR SDK Download

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:

  • Keen Team and Team 509 working with HP’s Zero Day Initiative (CVE-2014-0510)
  • Masato Kinugawa (CVE-2014-0516)
  • James Forshaw of Contextis (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)