Príručka používateľa Zrušiť

Live shapes

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Learn faster with the Illustrator Discover panel
      3. Create documents
      4. Toolbar
      5. Default keyboard shortcuts
      6. Customize keyboard shortcuts
      7. Introduction to artboards
      8. Manage artboards
      9. Customize the workspace
      10. Properties panel
      11. Set preferences
      12. Touch Workspace
      13. Microsoft Surface Dial support in Illustrator
      14. Undo edits and manage design history
      15. Rotate view
      16. Rulers, grids, and guides
      17. Accessibility in Illustrator
      18. Safe Mode
      19. View artwork
      20. Use the Touch Bar with Illustrator
      21. Files and templates
    3. Tools in Illustrator
      1. Tools at a glance
      2. Select tools
        1. Selection
        2. Direct Selection
        3. Group Selection
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. Navigate tools
        1. Hand
        2. Rotate View
        3. Zoom
      4. Paint tools
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. Text tools
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. Draw tools
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. Anchor Point
        5. Curvature
        6. Line Segment
        7. Rectangle
        8. Rounded Rectangle
        9. Ellipse
        10. Polygon
        11. Star
        12. Paintbrush
        13. Blob Brush
        14. Pencil
        15. Shaper
        16. Slice
      7. Modify tools
        1. Rotate
        2. Reflect
        3. Scale
        4. Shear
        5. Width
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
    4. Quick actions
      1. Retro text
      2. Neon glow text
      3. Old school text
      4. Recolor
      5. Convert sketch to vector
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Share documents for review
      4. Upgrade cloud storage for Adobe Illustrator
      5. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D objects and materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Map artwork over 3D objects
      4. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Copy and duplicate objects
      8. Rotate and reflect objects
      9. Intertwine objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Add text and work with type objects
      2. Create bulleted and numbered lists
      3. Manage text area
      4. Fonts and typography
      5. Format type
      6. Import and export text
      7. Format paragraphs
      8. Special characters
      9. Create type on a path
      10. Character and paragraph styles
      11. Tabs
      12. Text and type
      13. Find missing fonts (Typekit workflow)
      14. Update text from Illustrator 10
      15. Arabic and Hebrew type
      16. Fonts | FAQ and troubleshooting tips
      17. Create 3D text effect
      18. Creative typography designs
      19. Scale and rotate type
      20. Line and character spacing
      21. Hyphenation and line breaks
      22. Text enhancements
      23. Spelling and language dictionaries
      24. Format Asian characters
      25. Composers for Asian scripts
      26. Create text designs with blend objects
      27. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Place multiple files
      2. Manage linked and embedded files
      3. Links information
      4. Unembed images
      5. Import artwork from Photoshop
      6. Import bitmap images
      7. Import Adobe PDF files
      8. Import EPS, DCS, and AutoCAD files
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash issues
    2. Recover files after crash
    3. File issues
    4. Supported file formats
    5. GPU device driver issues
    6. Wacom device issues
    7. DLL file issues
    8. Memory issues
    9. Preferences file issues
    10. Font issues
    11. Printer issues
    12. Share crash report with Adobe
    13. Improve Illustrator performance

Learn how to create and work with live shapes in Illustrator.

Use the powerful Shape tools to quickly craft vector shapes. Most shapes are live, which means you can dynamically adjust them, without switching the tool, using the on-shape control widgets or the controls available in the Transform panel.

Live shapes

Create and modify live shapes

  1. Draw a live shape using one of the following tools:

    • Rectangle tool ()
    • Rounded Rectangle tool ()
    • Ellipse tool ()
    • Polygon tool ()
    • Shaper tool ()
    • Line Segment tool ()
    Poznámka:
    • To view the bounding box when you select an object, ensure that the setting is set to display the bounding box (View > Show Bounding Box).
    • To view the on-screen control widgets when you select any shape, select any live shape drawing tool and ensure that the setting is set to Show Shape Widgets () in the Control panel.
  2. Use the following on-shape control widgets to modify live shapes:

    Scale live shapes

    Rotate live shapes

    To scale a live shape, drag any of the eight bounding box handles.

    To rotate, move the cursor away from a corner until you see the Rotate icon (), and then drag.

    Move live shapes

    Create pie shapes

    To move the live shape, use the center point widget to drag it to the desired area.

    For an ellipse, drag one of the pie widgets to create a pie shape.

    Add or remove sides from polygons

    Change the corner radius of live shapes

    To change the number of the sides of a polygon, drag its side widget.

    Drag any corner widget to change the corner radius of the live shape.

    Poznámka:
    • When you drag the corners widgets to the maximum possible limit, the preview of the rounded corners is displayed in red.
    • To cycle through corner styles, such as Round, Inverted Round, and Chamfer, Alt-click (Windows) or Option-click (macOS) the corner widget or press Up and Down arrow keys while dragging the widget.
    • To access a Corners menu to customize the appearance and rounding attributes, double-click the widget using the Direct Selection tool. For details, see Work with Live Corners.
    • To edit a corner individually, use the Direct Selection tool and click the anchor point of the corner to modify.
  3. You can modify the shapes using the Control panel, the Properties panel, or the Transform panel (Window > Transform). For details, see Live shapes properties.

    Poznámka:
    • You can open the Transform panel by double-clicking any corner widget.
    • To specify if the Transform panel appears or not when you create a live shape, use the Show on Shape Creation option in the Transform panel menu.
    • Irrespective of which tool is selected, when shapes of the same type are selected, editing properties in the Transform panel will modify the selected artwork.

Specify live shape options

To view or edit the properties of live shapes, do one of the following:

  • Open the Transform panel by double-clicking any corner widget or choosing Window > Transform.
  • In the Transform section of the Properties panel (Window > Properties), click the More Options () button.
Specify live shape options
Specify live shape options

A. Transform panel B. Properties panel 

Rectangle/Rounded Rectangle

Live shape properties | Rectangle and Rounded Rectangle

  • Width/Height: Specifies the height or width of the rectangle. The corners are maintained, and the radii do not change.
  • Rectangle Angle: Rotate the rectangle, using the Scale/Rotate widget.
  • Corner Type: Specifies the Corner type of any of the corners of the rectangle.
  • Corner Radii: Use the stepper control or type in an absolute value in the Transform panel, for each of the corners of the rectangle.
  • Constrain Width And Height Proportions: Use the Scale Corner checkbox to ensure that corner radii increase or decrease in direct proportion to the object's transformation.

Ellipse

Live shape properties | Ellipse

  • Width/Height: Specifies the width and height of the ellipse. When equal, the ellipse is a circle.
  • Ellipse Angle: Specifies the angle at which the Ellipse is placed on the canvas.
  • Pie Start/Pie End Angle: Use the Pie widget (to the right of a newly-drawn Ellipse shape) to present the shape as a pie chart representation.
  • Constrain Pie Angle: Specifies if the difference in the Pie Start and Pie End Angles must be maintained when modifying their values using the Transform panel.
  • Invert Pie: Specifies when the Pie Start and Pie End Angles must be swapped. Use this to generate a 'slice' graphical representation.

Polygon

Live shape properties | Polygon

  • Polygon Side Count: Specifies the number of sides the polygon will have. 
    • Using the on-screen widget , you can change this to between 3 and 11. 
    • Use the slider to modify the value between 3 and 20. 
    • If you want a value between 3 and 1000, type the value manually.
  • Polygon Angle: Specifies the angle at which the polygon will be drawn or placed relative to the canvas.
  • Corner Type: Specifies the type of corner you want for the polygon (Round, Inverted Round, or Chamfer).
  • Polygon Radius: Specifies the exact radius of the polygon drawn. Use the on-screen widget   to modify the radius.
  • Polygon Side Length: Specifies the length of each side of the polygon.
  • Corner Radius: Specifies the radii of the corners of the polygon.
  • Make Sides Equal: While modifying a polygon, if the live shape becomes disproportionate or loses symmetry, use the Make Sides Equal button to balance the sides of the polygon.

Line

Live shape properties | Line

  • Line Length: Specifies the length of the line drawn.
  • Line Angle: Specifies the angle at which the line is drawn, relative to the canvas.

Hide bounding boxes and control widgets

While using the Shape tool, you may choose to hide or show the bounding box. Do one of the following:

  • To toggle between the two options, press (Windows) Shift+Ctrl+B, or (macOS) Shift+Cmd+B.
  • Choose View > Hide Bounding Box, or View > Show Bounding Box.

You may also choose to hide or show the on-screen control widgets by selecting any live shape drawing tool and clicking the Hide/Show Shape Widgets button () in the Control panel.

You can enable the Real-Time Drawing and Editing feature to enhance the live appearance of objects when you work on them. To enable this feature:

[Windows] Choose Edit > Preferences > Performance > Real-Time Drawing and Editing.

[macOS] Choose Illustrator > Preferences > Performance > Real-Time Drawing and Editing.

Select live shapes

Layers panel

Live shapes are displayed as a different object type in the Layers panel. For example, when you draw a Live Rectangle, the layer is named <Rectangle>, in the Layers panel. This helps in identifying the available live shapes, for purposes of selection and modification.

Live Rectangle and Ellipse in the Layers panel
Example: Live Rectangle and Ellipse in the Layers panel. Similarly, other live shapes are marked in the Layers panel.

Select menu

To select all the available Live Shapes in your document, choose Select > Same > Shape.

Convert shapes

Convert paths to live shapes

  • When you open a document saved in an older version of Illustrator, the shapes in that document are not automatically editable as live shapes. To convert a path into a live shape, select it, and then click Object > Shape > Convert to Shape.

Convert live shapes to paths

  • To convert a live shape into a path, select the live shape, and then click Object > Shape > Expand Shape.

What's next?

We've got you started on how to create and modify live shapes. Take a step forward and learn how to transform objectswork with Live Corners, and draw simple lines and shapes in Illustrator.

Got a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We'd love to hear from you.

Logo Adobe

Prihláste sa do svojho účtu