Príručka používateľa Zrušiť

Copy, insert graphics

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Work with Style Packs
      3. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Work with InDesign Cloud documents
    2. InDesign cloud documents | Common questions
    3. Share and collaborate        
    4. Share for Review
    5. Review a shared InDesign document
    6. Manage feedback 
  6. Publish
    1. Place, export, and publish
      1. Publish Online
      2. Copy, insert graphics
      3. Export content for EPUB
      4. Adobe PDF options
      5. Export content to HTML
      6. Export to Adobe PDF
      7. Export to JPEG format
      8. Export HTML
      9. DPS and AEM Mobile overview
      10. Supported File Formats
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  8. Troubleshooting
    1. Fixed issues
    2. Crash on launch
    3. Preference folder read-only issue
    4. Troubleshoot file issues
    5. Unable to export PDF
    6. InDesign document recovery

Learn how to Copy and Insert different file formats.

Do you want to learn how to work with various file formats in InDesign? Do you want to copy text or artwork from Illustrator to InDesign? Or Place Photoshop or Acrobat files?

You can copy and paste artwork, text, or objects from other Adobe applications like Illustrator, Photoshop, or Acrobat. You can also insert graphic formats like EPS, BMP, PNG, and so on into your InDesign document. Read on to learn how to copy or import files into InDesign.

Copy text from Illustrator

Copy and paste text from Illustrator to InDesign without any loss of effects or format.

Copy paste text from Illustrator to InDesign
Copy paste text from Illustrator to InDesign

Before you proceed, ensure that you have the latest version of Illustrator (version 27.0) and InDesign (version 18.0).

You can now copy text from Illustrator, paste it into InDesign and keep it live. You can also choose to paste it with formatting or without formatting.

  1. Go to EditPreferences > Clipboard Handling.

  2. Select any of the following options:

    • All Information (Index Markers, Swatches, Styles, etc.): Select this to Paste with formatting   by default.
    • Text only: Select this to Paste text only   by default.
  3. Select OK.

Paste options in clipboard handling
Paste options in clipboard handling

You can also toggle between the paste formatting options with the paste nudge. Copy text from Illustrator, any text editor or webpage, and you can see a paste nudge as follows:

  1. Go to Edit > Preferences > Clipboard Handling.

  2. Check Show Paste Options.

    If you've selected All Information (Index Markers, Swatches, Styles, etc.), you'll see the Paste with formatting   as default in the nudge. Select the nudge to choose Paste text only  .

    If you've selected Text only, you'll see the Paste text only   as default in the nudge. Select the nudge to choose Paste with formatting   .

If you copy text into an existing text frame, the paste nudge appears at the end of the last line.

You can also copy-paste or drag Illustrator graphics to select and edit paths within the graphic. When you drag graphics from Illustrator, it works like the Place command, and the images appear in the Links panel, but you cannot set import options. You can also drag multiple files simultaneously.

Select a graphic from Adobe Illustrator, Adobe Bridge, Explorer (Windows), the Finder (macOS), or your desktop, and drag it into InDesign. Ensure that the image is in a supported file format.

Insert other Adobe files

The Place option can insert graphics (place images or import pictures). It provides the highest level of support for the resolution, file formats, multipage PDF and INDD files, and color.

Do you want to import a PSD, layered PDF, AI, or INDD file into your InDesign document? Follow these steps to Place layered files and control the layer visibility:

  1. Go to File > Place.

  2. Check Show Import Options and select the layered Adobe file you want to import.

  3. In the Place dialog, you can select or update the following options:

    Show Preview

    Preview the page before you place it. If placing a multi-page PDF, click the arrows, or type a page number under the image to preview a specific page.

    General

    Pages

    Specify the pages you want to place from the following options:

    • Previewed Page
    • All
    • Range

    For Illustrator files, you can specify the artboard to place.

    Crop toBounding Box (Visible Layers Only)

    Places the page’s bounding box, or the minimum area that encloses the objects on the page, including page marks for visible layers only.

    Crop toBounding Box (All Layers)

    Places the bounding box of the entire layer area of the file, even if layers are hidden.

    Crop toArt

    Places the PDF only in the area defined by a rectangle that the author created as a placeable artwork (for example, clip art).

    Crop toCrop

    Places the PDF only in the area that is displayed or printed by Adobe Acrobat.

    Crop toTrim

    Identifies the place where the final produced page is physically cut in the production process, if trim marks are present.

    Crop toBleed

    If a bleed area is present, places only the area that represents where all page content should be clipped. This information is useful if the page is being output in a production environment. The printed page may include page marks that fall outside the bleed area.

    Crop toMedia

    Places the area that represents the physical paper size of the original PDF document (for example, the dimensions of an A4 sheet of paper), including page marks.

    Transparent Background

    Select this option to reveal text or graphics that fall beneath the PDF page in the InDesign layout. Deselect this option to place the PDF page with an opaque white background.

    Layers

    Show Layers

    Follow any of these options to work with layers:

    • All the visible layers have an eye with the layer name.
    • Select the eye icon to hide a layer.
    • Alt + select (Windows) or Option + select (macOS) the eye icon to hide all the other layers.
    • Drag through the eye column to change the visibility of layers.

    Update Link Options

    Select any of the following options:

    • Use Photoshop’s/PDF’s Layer Visibility: Matches the layer visibility settings to those of the linked file when you update the link.
    • Keep Layer Visibility Overrides: Maintains the layer visibility settings as they were when the file was originally placed.

    (Photoshop PSD files only) If the image contains layer comps, choose the layer comp you want to display from the Layer Comp pop‑up menu.

  4. Select OK.

Insert any graphic

You can insert any supported graphic file to your InDesign document. Read on to learn how:

  1. Go to File > Place.

  2. Browse and select an image.

  3. Check the following options per your preference:

    • Show Import Options to set format-specific options.
    • Create Static Captions to add a caption based on the image metadata. See Generate a caption from an image.
    • Replace Selected Item to replace an existing image.
  4. Select Open.

  5. Add or adjust Image Import Options and select OK.

  6. Follow any of these options to place the image:

    • Select or drag to create a frame with the image.
    • Select a frame to place the image into the frame.
    • To place all the specified pages of a multipage file (such as a PDF or INDD file) at the same time, one overlapping another, hold down Alt (Windows) or Option (macOS), and click the loaded graphics icon where you want the pages to appear.
  7. To place the next graphic or the next page of a multipage PDF, click the loaded graphics icon in the layout where desired.

    You can also scroll to a different location or change pages without losing the loaded graphics icon.

Insert multiple graphics

You can add multiple images to your InDesign document. Follow these steps to import more than one item at a time:

  1. Go to File > Place.

  2. Ctrl + select (Windows) or Command + select (macOS) the images you want to add.

    You can select graphics, text files, InDesign files, and any supported file format.

  3. Check Show Import Options.

    A thumbnail image of the first graphic appears with the loaded images icon and the number of graphics selected for import. The names of the images appear in the Links panel with LP (Loaded in Place cursor) beside the name of the foremost image.

    Poznámka:

    You can cycle through the loaded graphics with right or left arrows. Click Esc to unload the foremost graphic from the loaded graphics icon without placing it in InDesign.

  4. Select Open.

  5. Add or adjust Image Import Options for each image and select OK.

  6. Follow any of these options to import multiple images:

    • Select to import into a new frame.
    • Drag to create a frame of a certain size and import the graphic into it.
    • Select inside a frame to import an image into an existing frame. Hold down Alt (Windows) or Option (macOS) when you select to replace the contents of an existing frame.
    • Drag to import all the loaded graphics in a grid, and press the arrow keys to determine the number of rows and columns. Use the Up and Down Arrows to change the number of rows and the Left and Right Arrows to change the number of columns. Release the mouse button to place the grid of images.
    • Go to File > Place while the graphics icon is displayed, and you can add more graphics to the selection.

The graphic import options vary depending on the type of image being imported. Read on to learn about the import options for specific file formats.

Insert EPS graphics

When you place an EPS graphic (or a file saved with Illustrator 8.0 or earlier) and select Show Import Options in the Place dialog box, you see a dialog box containing these options:

  1. Go to File > Place.

  2. Browse and select the EPS File you want to import.

  3. Check Show Import Options.

  4. Select Open.

  5. Adjust the following options as per your preference:

    Read Embedded OPI Image Links

    Reads links from OPI comments for images included (or nested) in the graphic.

    Apply Photoshop Clipping Path

    A placed EPS file includes a clipping path even if this option is unchecked. However, if you uncheck this option, you may see a different bounding box size.

    Proxy Generation

    Creates a low-resolution bitmap representation of an image when drawing the file to the screen.

    Use TIFF and PICT Preview

    Select this option to generate the proxy image of the existing preview. If a preview does not exist, InDesign generates a proxy by rasterizing the EPS to an offscreen bitmap.

    Rasterize The PostScript

    Select this option to ignore the embedded preview. This option is typically slower but provides the highest-quality results.

  6. Select OK.

Insert PSD, TIFF, GIF, JPEG, or BMP images

You can apply color-management options to individual imported graphics. You can also import a clipping path or an alpha channel saved with a Photoshop image to select it directly and modify its path without changing the graphics frame.

Read on to learn about the Import Options for PSD, TIFF, GIF, JPEG, or BMP files.

  1. Go to File > Place.

  2. Browse and select the image you want to import.

  3. Check Show Import Options.

  4. Select Open.

  5. Adjust the following options as per your preference:

    Apply Photoshop Clipping Path

    If this option isn’t available, the image wasn’t saved with a clipping path, or the file format doesn’t support clipping paths. If the bitmap image doesn’t have a clipping path, you can create one in InDesign.

    Alpha channel

    Select an alpha channel to import the area of the image saved as an alpha channel in Photoshop. You can see this option if an image contains at least one alpha channel.

    Profile

    If Use Document Default is selected, leave this option unchanged. Otherwise, choose a color source profile that matches the gamut of the device or software used to create the graphic. This profile enables InDesign to properly translate its color to the output device's gamut.

    Rendering Intent

    Select one of the following methods to scale the color range of the graphic to the output device.

    • Perceptual (Images): Accurately represents colors in photographs.
    • Saturation (Graphics): They don’t reproduce photographs well for solid color areas.
    • Relative Colorimetric: They don’t reproduce photographs well for solid color areas.
    • Absolute Colorimetric: For areas of solid color, they don’t reproduce photographs well.

    Rendering Intent options aren’t available for bitmap, grayscale, and index-color mode images.

  6. Select OK.

Insert PNG images

When you place a PNG image and select Show Import Options in the Place dialog box, you see a dialog box with three sections of import settings. Two sections contain the same options available for other bitmap image formats. The other section, PNG Settings, contains the following settings:

  1. Go to File > Place.

  2. Browse and select the PNG image you want to import.

  3. Check Show Import Options.

  4. Select Open.

  5. Adjust the following options as per your preference:

    Use Transparency and Information

    This option is enabled by default when a PNG graphic includes transparency. If an imported PNG file contains transparency, the graphic interacts only where the background is transparent.

    White Background

    Select this option to have white background when applying transparency information. This is the default option if a PNG graphic does not contain a file-defined background color. However, it's only enabled if Use Transparency Information is activated.

    File Defined Background Color

    Displays the image's background color if a PNG graphic was saved with a non-white background color, and Use Transparency Information is selected.

    Apply Gamma Correction

    Check and adjust a PNG graphic's gamma (mid-tone) values as you place it. This option lets you match image gamma to the print or display gamma. Uncheck this option to place the image without any gamma correction. This option is selected by default if the PNG graphic was saved with a gamma value.

    Gamma Value

    This option, available only if Apply Gamma Correction is selected, displays the gamma value saved with the graphic. To change the value, type a positive number from 0.01 to 3.0.

  6. Select OK.

Create contact sheets

A contact sheet is a grid of thumbnail images, often used for pre-press analysis. In previous versions of Adobe Bridge (CS2 and CS3), you can create a contact sheet for InDesign pages with Create InDesign Contact Sheet option. Now, you can use the Adobe Output Module in Adobe Bridge (CS4 and later) to create a PDF contact sheet.

You can also place multiple images in a grid to create a simple contact sheet.

  1. Go to File > Place.

  2. Ctrl + select (Windows) or Command + select (macOS) to select multiple images.

  3. Step text
  4. Start dragging, and press the arrow keys to determine the number of rows and columns. Use the Up Arrow key and Down Arrow key to change the number of rows and the Left and Right Arrow keys to change the number of columns.

    To change the spacing between frames, press Page Up or Page Down or hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

    To change the spacing between frames, hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

  5. Release the mouse button to place the grid of images.

Tips and tricks

  • When you copy and paste or drag a graphic, you may lose some attributes, depending on the operating system's limitations, the range of data types the other application makes available for transfer, and the InDesign Clipboard preferences.
  • InDesign preserves all the imported or applied graphic attributes when you copy and paste or drag between two InDesign documents or within a single document.
  • In Windows, if you try to drag an item from an application that does not support drag-and-drop, the pointer displays the Prohibited icon.
  • To cancel dragging a graphic, drop the graphic onto any panel title bar or document title bar.
  • When you import more than one single file into the same document, all instances share the proxy setting of the first instance of the imported file.
  • If the image you place may appear to have a low resolution, change your image display settings, see Control graphics’ display performance.
  • If you place or drag a graphic from a removable media, such as a CD‑ROM, the link breaks when you remove that media from your system.
  • When you place a graphic created in Illustrator 9.0 or later with Show Import Options, the options are identical to those for PDFs. When you place an Illustrator 5.5–8.x graphic, the options are identical to those for EPS files.
  • If displaying thumbnails in the loaded graphics icon slows down your system, go to Edit > Preferences > Interface and uncheck Show Thumbnails On Place.

Related resources

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

Logo Adobe

Prihláste sa do svojho účtu