Dreamweaver çalışma alanı, kullanılabilir olan farklı görünümler ve çalışma alanları ile Dreamweaver'daki tüm farklı paneller ve araç çubukları hakkında daha fazla bilgi edinin.

Dreamweaver'ı kullanıma alma

Dreamweaver'ı yükledikten sonra uygulamayı ilk defa çalıştırdığınızda, ekranda Dreamweaver çalışma alanınızı ihtiyaçlarınıza göre kişiselleştirmenize yardımcı olan üç soru soran bir Hızlı Başlatma menüsü görünür.

Bu üç soruya verdiğiniz yanıtlara göre Dreamweaver, Geliştirici çalışma alanında (minimum kod odaklı mizanpaj) veya Standart çalışma alanında (görsel araçlar ve siz kod yazdıkça uygulama içi önizleme ile bölünmüş bir mizanpaj) açılır. 

Çalışma alanını seçtikten sonra size en uygun renk temasını seçin. Böylece çalışmaya başlayabilirsiniz.

Not:

Düzenle > Tercihler iletişim kutusunu kullanarak dilediğiniz zaman bu çalışma alanı tercihlerini değiştirebilirsiniz.

Geliştirilmiş Giriş ekranı

Dreamweaver uygulamasındaki Giriş ekranı son kullandığınız dosyalara, dosya türlerine ve başlangıç şablonlarına hızlı erişim sağlar.

Başlangıç çalışma alanı, abonelik durumunuza bağlı olarak aynı zamanda ihtiyaçlarınıza uygun içerikleri de görüntüleyebilir.

Dreamweaver, başlangıçta veya herhangi bir belge açık değilken Giriş ekranını görüntüler.

Dreamweaver'da başlangıç çalışma alanı
Dreamweaver'da başlangıç çalışma alanı

Dreamweaver Başlangıç deneyiminde seçenekler

Öğrenin

Dreamweaver eğitimlerine bu ekrandan anında erişmek için Öğrenin'i tıklatın.

Hızlı Başlatma

Görüntülenen dosya türlerinden birini tıklatarak Dreamweaver'da belgeler oluşturmaya başlayın.

Başlangıç Şablonları

Dreamweaver ile paketlenmiş başlangıç şablonlarından birini açın. 

Giriş

Başlangıç ekranına geri dönmek için Giriş'i tıklatın. 

Çalıştığınız son dosyaları başlangıç ekranında görüntüleyebilirsiniz. Son kullanılan dosyanız yoksa bu sekme boş olur.

Ayrıca bu ekranın sağ üst köşesindeki Arama simgesini kullanarak arama işlevselliğini de kullanabilirsiniz. Bir arama sorgusu yazdığınızda, uygulama arama sorgusuyla eşleşen son dosyalarınızı, Creative Cloud varlıklarınızı, yardım bağlantılarını ve hazır görüntüleri görüntüler.

Not:

Bu Başlangıç ekranı etkinleştirildi ve varsayılan olarak açıldı. 

Bu Başlatma ekranına ihtiyacınız yoksa Tercihler > Genel iletişim kutusunda Başlangıç Ekranını Göster seçimini kaldırın.

Yeni Dreamweaver dosyaları oluşturmaya başlamak için Yeni Oluştur'u tıklatabilirsiniz. Sisteminizde zaten dosyalarınız varsa 'ı tıklatın. Dreamweaver'da belgeleri oluşturma ve açma ile ilgili bilgi için bkz. Dosyaları oluşturma ve açma.

Çalışma alanına genel bakış

Dreamweaver çalışma alanı, belgeleri ve nesne özelliklerini görüntülemenize olanak sağlar. Çalışma alanı ayrıca araç çubuklarına en yaygın olarak kullanılan birçok işlemi de yerleştirir, böylece belgelerinizde hızlıca değişiklik yapabilirsiniz.

Dreamweaver çalışma alanı (CC)
Dreamweaver çalışma alanı

A. Uygulama çubuğu B. Belge araç çubuğu C. Belge penceresi D. Çalışma alanı değiştiricisi E. Paneller F. Kod Görünümü G. Durum çubuğu H. Etiket seçici I. Canlı Görünüm J. Araç Çubuğu 

Çalışma alanı öğelerine genel bakış

Çalışma alanında aşağıdaki öğeler bulunur:

Uygulama çubuğu

Uygulama penceresinin üst kısmında bulunur ve bir çalışma alanı değiştiricisi, menüler (yalnızca Windows) ve diğer uygulama denetimlerini içerir.

Belge araç çubuğu

Belge penceresinin farklı görünümleri için seçenekler sunan düğmeler içerir (Tasarım görünümü, Canlı görünüm ve Kod görünümü gibi).

Standart araç çubuğu

Standart araç çubuğunu görüntülemek için Pencere > Araç Çubukları > Standart seçeneğini belirleyin. Araç çubuğu, Dosya ve Düzen menülerindeki sık kullanılan işlemler için düğmeler içerir: Yeni, , Kaydet, Tümünü Kaydet, Kodu Yazdır, Kes, Kopyala, Yapıştır, Geri Al ve Yenile.

Araç çubuğu

Uygulama penceresinin sol tarafındadır ve görünüme özel düğmeler içerir.

Belge penceresi

Hazırlama ve düzenleme sırasında geçerli belgeyi gösterir.

Özellik denetçisi

Seçili nesne veya metnin çeşitli özelliklerini görüntülemenizi ve değiştirmenizi sağlar. Her nesne farklı özelliklere sahiptir.

Etiket seçici

Belge penceresinin en altındaki Durum çubuğunda bulunur. Geçerli seçimin çevresindeki etiketlerin hiyerarşisini gösterir. Hiyerarşideki herhangi bir etiketi tıklatıp o etiketi ve tüm içeriğini seçin.

Paneller

Çalışmanızı izlemenize ve değiştirmenize yardım eder. Örnekler arasında Ekle paneli, CSS Tasarımcısı paneli ve Dosyalar paneli bulunur. Bir paneli genişletmek için ilgili sekmeyi çift tıklatın.

Extract paneli

PSD dosyalarınızı Creative Cloud'a yüklemenize ve burada görüntülemenize olanak verir. Bu paneli kullanarak PSD kompozisyonlarınızdaki CSS, metin, görüntü, font, renk, degrade ve ölçüleri belgenize ayıklayabilirsiniz.

Ekle paneli

Bir belgeye görüntü, tablo ve medya öğesi gibi çeşitli nesne türleri eklemeniz için düğmeler içerir. Her nesne, eklerken çeşitli nitelikleri belirlemenize olanak veren bir HTML kodu parçasıdır. Örneğin, Ekle panelindeki Tablo düğmesini tıklatarak bir tablo ekleyebilirsiniz. İsterseniz, Ekle paneli yerine Ekle menüsünü kullanarak da nesne ekleyebilirsiniz.

Dosyalar paneli

Dosya ve klasörlerinizi, bir Dreamweaver sitesinin parçası veya uzak bir sunucu üzerinde olup olmamasına bakılmaksızın yönetmenizi sağlar. Dosyalar paneli ayrıca yerel diskinizdeki tüm dosyalara erişmenizi sağlar. Daha fazla bilgi için, bkz. Dosyaları ve klasörleri yönetme.

Parçacıklar paneli

Kod parçacıklarınızı farklı web sayfaları, farklı siteler ve Dreamweaver'ın farklı kurulumlarında (senkronizasyon ayarlarını kullanarak) kaydetmenizi ve yeniden kullanmanızı sağlar. Daha fazla bilgi için bkz. Parçacıklar ile kodu tekrar kullanma.

CSS Tasarımcısı paneli

ortam sorgularıyla birlikte “görsel olarak” CSS stilleri, dosyalar ve ayarlanmış özellikler oluşturmanızı sağlayan bir CSS Özellik Denetimi'dir.

Not:

Dreamweaver birçok başka panel, denetçi ve pencere sağlar. Panelleri, denetçileri ve pencereleri açmak için Pencere menüsünü kullanın.

Belge penceresine genel bakış

Belge penceresi geçerli belgeyi gösterir. Belge görünümleri arasında geçiş yapmak için Belge araç çubuğunda görünüm seçeneklerini kullanın. 

Ayrıca Görünüm menüsündeki Görünüm seçeneklerini kullanarak da görünümler arasında geçiş yapabilirsiniz.

Canlı görünüm

belgenizin tarayıcıda nasıl görüneceğine ilişkin daha gerçekçi bir sunum görüntüler ve tarayıcıda yapacağınız gibi belgeyle etkileşim kurmanızı sağlar. HTML öğelerini doğrudan Canlı Görünüm'de düzenleyebilir ve yaptığınız değişiklikleri aynı görünümde anında önizleyebilirsiniz. Canlı Görünüm'ü düzenleme hakkında daha fazla bilgi için bkz. HTML öğelerini Canlı Görünüm'de düzenleme.

Tasarım görünümü

görsel sayfa mizanpajı, görsel düzenleme ve hızlı uygulama geliştirme için bir tasarım ortamıdır. Bu görünümde Dreamweaver, sayfayı tarayıcıda görüntülediğinizde gördüğünüze benzer bir şekilde belgenin tamamen düzenlenebilir, görsel temsilini gösterir.

Kod görünümü

HTML, JavaScript ve diğer türdeki kodları yazmak ve düzenlemek için kullanılan el ile kod yazma ortamıdır.

Kod - Kod

Aynı anda belgenin farklı bölümleri arasında geçiş yaparak çalışmanızı sağlayan bölünmüş bir Kod görünümüdür. 

Kod - Canlı

aynı belgeyi tek pencerede hem Kod görünümünde hem de Tasarım görünümünde görmenizi sağlar.

Kod - Tasarım

aynı belgeyi tek pencerede hem Kod görünümünde hem de Tasarım görünümünde görmenizi sağlar.

Canlı Kod

tarayıcının sayfayı yürütmek için kullandığı gerçek kodu gösterir ve Canlı görünümde sayfayla etkileşim kurulurken dinamik olarak değişir.

Belge penceresi büyütüldüğünde (varsayılan), sekmeler tüm açık belgelerin dosya adlarını göstererek Belge penceresinin üstünde görüntülenir. Dosya üzerinde değişiklikler yaptıysanız ve henüz bu değişiklikleri kaydetmediyseniz Dreamweaver, dosya adının sonunda bir yıldız işareti görüntüler.

Dreamweaver ayrıca, belge sekmesinin altında (veya belgeleri ayrı pencerelerde görüntülüyorsanız belgenin başlık çubuğunun altında) İlgili Dosyalar araç çubuğunu görüntüler. İlgili belgeler CSS dosyaları veya JavaScript dosyaları gibi, geçerli dosya ile ilişkilendirilmiş olan belgelerdir. Bu ilgili dosyalardan birini Belge penceresinde açmak için, İlgili Dosyalar araç çubuğunda dosya adını tıklatın.

Görünümler arasında geçiş yapma

Farklı görünümler arasında hızlı bir şekilde geçiş yapmak için Belge araç çubuğunu kullanın. Daha fazla bilgi için bkz. Belge araç çubuğuna genel bakış.

Ayrıca Görünüm menüsündeki aşağıdaki seçenekleri kullanarak da görünümler arasında geçiş yapabilirsiniz:

  • Yalnızca Kod görünümü: Kod'u seçin
  • Bölünmüş görünüm: Böl'ü seçin ve bölme seçeneklerinden birini belirleyin
  • Görünüm modu: Canlı görünüm ve Tasarım görünümü arasında geçiş yapın
  • Görünümleri Değiştir: Bir görünümden diğerine geçmek için.
Görünüm menüsü seçeneklerini kullanarak görünümler arasında geçiş yapma
Görünüm menüsü seçeneklerini kullanarak görünümler arasında geçiş yapma

Belge pencerelerini basamaklama, döşeme veya yeniden sıralama

Aynı anda birçok belgeniz açık ise, bunları basamaklayabilir veya döşeyebilirsiniz.

Belge pencerelerini döşemek için: Pencere > Yerleştir > Basamakla'yı seçin.

Belge pencerelerini döşemek için: 

  • (Windows) Pencere > Yerleştir > Yatay Döşe veya Dikey Döşe'yi seçin.
  • (Macintosh) Pencere > Yerleştir > Döşe'yi seçin.

Birden çok dosya açtığınızda Belge pencereleri sekmeli olur. Sekmeli olan Belge pencerelerinin sırasını yeniden düzenlemek için pencerenin sekmesini grupta yeni bir konuma sürükleyin.

Belge penceresini yeniden boyutlandırma

Durum çubuğu, Belge penceresinin geçerli boyutlarını (piksel olarak) gösterir. Belirli bir boyutta en iyi görüntülenen bir sayfa tasarlamak için Belge penceresini istediğiniz bir önceden belirlenmiş boyuta ayarlayabilir, bu önceden belirlenmiş boyutları düzenleyebilir veya boyutlar oluşturabilirsiniz.

Tasarım görünümünde veya Canlı Görünüm'de sayfanın görüntüleme boyutunu değiştirdiğinizde yalnızca görüntüleme boyutunun boyutları değişir. Belge boyutu değişmez.

Önceden belirlenmiş ve özel boyutların yanı sıra, Dreamweaver ayrıca bir ortam sorgusunda belirtilen boyutları da listeler. Bir ortam sorgusuna karşılık gelen boyut seçtiğinizde Dreamweaver sayfayı görüntülemek için ortam sorgusunu kullanır. Ayrıca, sayfa mizanpajının aygıtın tutuluş şekline göre değiştiği mobil aygıtlar için sayfanın önizlemesini yapmak üzere sayfa yönlendirmesini de değiştirebilirsiniz.

Belge penceresini yeniden boyutlandırmak için Belge penceresinin alt tarafındaki Pencere Boyutu açılır menüsündeki boyutlardan birini seçin.

Belge yeniden boyutlandırma seçenekleri
Belge yeniden boyutlandırma seçenekleri

Gösterilen pencere boyutu, tarayıcı penceresinin kenarlıklar olmadan iç boyutlarını yansıtır; monitör boyutu veya mobil aygıt sağda listelenmiştir.

Not:

Daha az hassas yeniden boyutlandırma için işletim sisteminizin bir pencerenin alt sağ köşesini sürükleme gibi, standart pencere yeniden boyutlandırma yöntemlerini kullanın.

Not:

(Yalnızca Windows için) Belge penceresindeki belgeler varsayılan olarak ekranı kaplar ve ekranı kaplayan bir belgeyi yeniden boyutlandıramazsınız. Belgenin ekranı kaplamasını geri almak için, belgenin sağ üst köşesindeki ekranı kaplamayı geri al düğmesini tıklatın.

Pencere Boyutu açılır menüsünde listelenen değerleri değiştirme

  1. Pencere Boyutu açılır menüsünden Boyutları Düzenle'yi seçin.

  2. Pencere Boyutları listesindeki genişlik veya yükseklik değerlerinden birini tıklatın ve yeni bir değer girin. Belge penceresini yalnızca belirli bir genişliğe ayarlanabilecek (yükseklik değişmeden kalacak) şekilde ayarlamak için yükseklik değerini seçip silin.

  3. Açıklama kutusunu tıklatıp belirli bir boyut hakkında açıklama metni girin.

Pencere Boyutu açılır menüsüne yeni bir boyut ekleme

  1. Pencere Boyutu açılır menüsünden Boyutları Düzenle'yi seçin.

    Pencere boyutu açılır menüsüne pencere boyutları ekleme
    Pencere boyutu açılır menüsüne pencere boyutları ekleme

  2. Genişlik sütununda son değerin altındaki boş alanı tıklatın.

  3. Genişlik ve Yükseklik değerlerini girin.

    Yalnızca Genişlik veya Yükseklik değerini belirlemek için bu alanlardan birini boş bırakmanız yeterlidir.

  4. Eklediğiniz boyut hakkında açıklama metni girmek için Açıklama alanını tıklatın.

    Örneğin, 832 x 624 piksellik monitörün yanındaki girişe 800 x 600 piksel çözünürlükte 17 inç Mac monitörün yanındaki girişe SVGA veya ortalama PC yazabilirsiniz. Çoğu monitör çeşitli piksel boyutlarına ayarlanabilir.

  5. Uygula'yı tıklatın ve iletişim kutusunu kapatın.

    Yeni pencere boyutu artık Pencere Boyutu açılır menüsünde kullanılabilir.

Belge araç çubuğuna genel bakış

Belge araç çubuğu, belgenizin farklı görünümleri arasında hızla geçiş yapmanıza olanak veren düğmeler içerir. Araç çubuğu ayrıca belgeyi görüntüleme ve yerel ve uzak siteler arasında aktarma ile ilgili bazı ortak komutlar ve seçenekler de içerir.

Belge araç çubuğu (CC)
Belge araç çubuğu

Belge araç çubuğunda aşağıdaki seçenekler görüntülenir:

Kod Görünümü

Belge penceresinde yalnızca Kod görünümünü görüntüler.

Bölünmüş Görünüm

Belge penceresini Kod ve Canlı/Tasarım görünümlerine böler. Tasarım görünümü seçeneği değişken ızgara belgeleri için kullanılamaz.

Canlı Görünüm

HTML5 projelerini doğru bir şekilde oluşturan ve değişiklikleri yapılırken gerçek zamanlı olarak güncelleştiren etkileşimli bir önizlemedir. HTML öğelerini Canlı Görünüm'de de düzenleyebilirsiniz. Canlı görünüm seçeneklerinin yanındaki açılır liste Canlı görünüm ve Tasarım görünümü arasında geçiş yapabilmenizi sağlar. Bu açılır liste değişken ızgara belgelerinde kullanılamaz.

Tasarım Görünümü

Kullanıcının belgeyi bir web tarayıcısında nasıl göreceğine dair bir gösterim sunar. 

Standart araç çubuğuna genel bakış

Standart araç çubuğu

Standart araç çubuğunu görüntülemek için Pencere > Araç Çubukları > Standart seçeneğini belirleyin. Araç çubuğu, Dosya ve Düzen menülerindeki sık kullanılan işlemler için düğmeler içerir: Yeni, , Kaydet, Tümünü Kaydet, Kodu Yazdır, Kes, Kopyala, Yapıştır, Geri Al ve Yenile.

Tarayıcı Gezinmesi araç çubuğuna genel bakış

Tarayıcı Gezinmesi araç çubuğu, Canlı Görünüm'de etkin hale gelir (yalnızca Pencere->Araç Çubukları->Standart öğesini seçerek bu özelliği etkinleştirdiyseniz) ve Belge penceresinde baktığınız sayfanın adresini gösterir. Canlı görünüm normal bir tarayıcı görevi görür; bu nedenle, yerel siteniz dışında bir siteye (örneğin, http://www.adobe.com/tr/) gözatsanız bile, Dreamweaver sayfayı Belge penceresine yükler.

Tarayıcı gezinmesi araç çubuğu (CC)
Tarayıcı gezinmesi araç çubuğu

A. Tarayıcı kontrolleri B. Adres kutusu 

Varsayılan olarak bağlar Canlı görünümde etkin değildir. Etkin olmayan bağlarınızın olması, başka bir sayfaya gitmeden Belge penceresinde bağ metnini seçmenize veya tıklatmanıza olanak sağlar. Canlı görünümde bağları test etmek için Görünüm > Canlı Görünüm Seçenekleri'ni seçerek Bağları İzle (Ctrl+Bağı Tıklatma) veya Bağları Sürekli İzle ile bir defa tıklatma ya da sürekli tıklatmayı etkinleştirebilirsiniz.

Araç çubuğuna genel bakış

Araç çubuğu, Belge penceresinin sol tarafında dikey olarak görüntülenir ve tüm görünümlerde (Kod, Canlı ve Tasarım) görünebilir. Araç çubuğundaki düğmeler görünüme özeldir ve yalnızca çalışmakta olduğunuz görünümde geçerli olması halinde görünür. Örneğin, Canlı görünümde çalışıyorsanız Kaynak Kodu Formatla gibi Kod görünümüne özel seçenekler görünmez. 

Araç çubuğunu özelleştirme

Bu araç çubuğunu, menü seçenekleri ekleyerek veya araç çubuğundan istemediğiniz menü seçeneklerini kaldırarak ihtiyaçlarınıza uygun şekilde özelleştirmeyi seçebilirsiniz.

Araç çubuğunu özelleştirmek için aşağıdakileri yapın:

  1. Araç Çubuğunu Özelleştir iletişim kutusunu açmak için Araç Çubuğu'nda  simgesini tıklatın.

    Araç çubuklarını özelleştirme
    Araç çubuklarını özelleştirme

  2. Araç çubuğunda kullanılabilir olmasını istediğiniz menü seçeneklerini seçin veya seçimlerini kaldırın ve araç çubuğunuzu kaydetmek için Bitti'yi tıklatın.

Varsayılan araç çubuğu düğmelerini geri yüklemek için Araç Çubuğunu Özelleştir iletişim kutusunda Varsayılanı Geri Yükle'yi tıklatın.

Durum çubuğuna genel bakış

Belge penceresinin altındaki Durum çubuğu, oluşturmakta olduğunuz belge hakkında ek bilgi sağlar.

Durum çubuğu (CC)
Durum çubuğu

A. Etiket seçici B. Çıktı paneli C. Kod renklendirme D. Ekle ve Üzerine Yaz arasında geçiş yapma E. Satır ve sütun sayısı 

Etiket seçici

Geçerli seçimin çevresindeki etiketlerin hiyerarşisini gösterir. Hiyerarşideki herhangi bir etiketi tıklatıp o etiketi ve tüm içeriğini seçin. <body> etiketini tıklatıp belgenin tüm gövdesini seçin. Etiket seçicide etiketin class veya ID niteliklerini belirlemek için etiketi sağ tıklatın (Windows) veya Control tuşunu basılı tutarak (Macintosh) tıklatın ve bağlam menüsünden sınıf ya da kimlik seçin.

Çıktı paneli

Belgenizdeki kodlama hatalarını gösteren Çıktı panelini görüntülemek için bu simgeyi tıklatın.

Kod renklendirme

(Yalnızca Kod görünümünde kullanılır)

Kodu programlama diline uygun olarak görüntülemek amacıyla kodun rengini değiştirmek için bu açılır menüdeki kodlama dillerinden birini seçin.

Ekle ve Üzerine Yaz arasında geçiş yapma

(Yalnızca Kod görünümünde kullanılır)

Kod görünümünde çalışırken Ekle ve Üzerine Yaz modları arasında geçiş yapmanızı sağlar.

Satır ve sütun sayısı

(Yalnızca Kod görünümüne kullanılır.)

İmlecin bulunduğu konumun satır numarasını ve sütun numarasını görüntüler.

Özellik denetçisine genel bakış

Özellik Denetçisi (Pencere > Özellikler) metin veya eklenmiş bir nesne gibi o anda seçili durumdaki sayfa öğesinin en sık kullanılan özelliklerini incelemenize ve düzenlemenize olanak verir.

Özellik Denetçisi'nin içeriği, seçili öğeye göre değişir. Örneğin sayfanızda bir görüntü seçerseniz, Özellik Denetçisi görüntünün özelliklerini gösterecek şekilde değişir (görüntüye giden dosya yolu, görüntünün genişliği ve yüksekliği, varsa görüntünün çevresindeki kenarlık vb.).

Özellik Denetçisi (CC)
Özellik Denetçisi

Özellik Denetçisi varsayılan olarak çalışma alanının alt kenarında yer alır, ancak çalışma alanında denetçiyi serbest bırakabilir ve kayar panel haline getirebilirsiniz.

Not:

Belirli bir etiketin özellikleriyle ilişkilendirilmiş her niteliği görüntülemek ve düzenlemek için Etiket denetçisini kullanın.

Belirli bir Özellik Denetçisi'ne yönelik yardım içeriğine erişmek için Özellik denetçisinin sağ üst köşesindeki yardım düğmesini tıklatın veya Özellik denetçisinin Seçenekler menüsünden Yardım'ı seçin.

Sayfa öğesinin özelliklerini görüntüleme ve değiştirme

  1. Belge penceresinde sayfa öğesini seçin.

    Seçili öğenin tüm özelliklerini görüntülemek için Özellik denetçisini genişletmeniz gerekebilir.

  2. Özellik denetçisinde istediğiniz özelliği değiştirin.

    Not:

    Belirli özellikler hakkında bilgi için öğeyi Belge penceresinde seçin ve Özellik denetçisinin sağ üst köşesindeki Yardım simgesini tıklatın.

  3. Değişiklikleriniz Belge penceresine hemen uygulanmazsa değişiklikleri aşağıdaki yöntemlerden biriyle uygulayın:

    • Özellik düzenleme metin alanlarının dışında bir alanı tıklatın.
    • Enter (Windows) ya da Return (Macintosh) tuşuna basın.
    • Başka bir özelliğe geçmek için Sekme tuşuna basın.

Bağlam menüleri

Bağlam menüleri, üzerinde çalıştığınız nesne veya pencere ile ilişkili en yararlı komutlara ve özelliklere kolay erişim sağlar. Bağlam menüleri yalnızca geçerli seçime uygulanabilen komutları listeler.

Bağlam menüsünü açmak için Kod görünümünde kodun bir bölümüne veya Canlı Görünüm'de ya da Tasarım Görünümü'nde bir nesneye (Windows) sağ tıklatın veya (Mac) Ctrl tuşunu basılı tutarak tıklatın.

Dreamweaver'da panelleri yeniden düzenleme

Tüm Dreamweaver panellerinin yerleşimini ve görünümünü gereksinimlerinize göre özelleştirebilirsiniz.

Panelleri sabitleme ve serbest bırakma

  • Bir paneli sabitlemek için sekmesinden sabitleme alanındaki diğer panellerin üstüne, altına ya da arasına sürükleyin.
  • Bir panel grubunu sabitlemek için başlık çubuğundan (sekmelerin üstündeki düz renkli boş çubuk) sabitleme alanına sürükleyin.
  • Paneli ya da panel grubunu kaldırmak için sekmesinden ya da başlık çubuğundan sabitleme alanının dışına sürükleyin. Başka bir sabitleme alanına sürükleyebilir ya da yüzer durumda bırakabilirsiniz.

Panelleri taşıma

Panelleri taşırken paneli götürebileceğiniz alanlar olan maviyle vurgulanmış bırakma bölgeleri görürsünüz. Örneğin bir paneli başka bir panelin üstündeki ya da altındaki dar mavi bırakma bölgesine sürükleyerek paneli yukarı ya da aşağı taşıyabilirsiniz. Bırakma bölgesi olmayan bir alana taşırsanız panel çalışma alanında yüzer duruma gelir.

  • Paneli taşımak için sekmesinden sürükleyin.
  • Bir panel grubunu taşımak için başlık çubuğunu sürükleyin.

Not:

Sabitlenmesini önlemek için paneli taşırken Ctrl (Windows) ya da Command (Mac OS) tuşuna basın. İşlemi iptal etmek için panel taşırken Esc tuşuna basın.

Panel ekleme ve kaldırma

Sabitleme alanındaki tüm panelleri kaldırırsanız sabitleme alanı kaybolur. Bırakma bölgesi görüntülenene kadar panelleri çalışma alanının sağ kenarına taşıyarak yuva oluşturabilirsiniz.

  • Paneli kaldırmak için sekmesini sağ tıklatıp (Windows) veya Control tuşu basılı olarak tıklatıp (Mac) Kapat'ı seçin ve Pencere menüsünden seçimini kaldırın.
  • Panel eklemek için paneli Pencere menüsünden seçin ve istediğiniz yere sabitleyin.

Panel gruplarında değişiklik yapma

  • Paneli bir grubun içine taşımak için panelin sekmesini gruptaki vurgulu bırakma bölgesine sürükleyin.
  • Gruptaki panelleri yeniden düzenlemek için panelin sekmesini grupta yeni bir konuma sürükleyin.
  • Paneli serbestçe yüzmesi için gruptan kaldırmak amacıyla sekmesinden grubun dışına sürükleyin.
  • Grubu taşımak için başlık çubuğunu (sekmelerin altındaki alan) sürükleyin.

Yüzen panelleri yığınlama

Paneli yuva dışına, bırakma bölgesi dışında bir yere sürüklediğinizde panel serbestçe yüzer. Yüzen panel çalışma alanında istediğiniz yere koymanızı sağlar. Yüzen panelleri ya da panel gruplarını yığınlayarak, en üstteki başlık çubuğunu sürüklediğinizde bir bütün olarak taşınmalarını sağlayabilirsiniz.

  • Yüzen panelleri yığınlamak için paneli sekmesinden başka bir panelin altındaki bırakma bölgesine sürükleyin.
  • Yığınlama sırasını değiştirmek için paneli sekmesinden yukarı ya da aşağı sürükleyin.
  • Paneli ya da panel grubunu yığından kaldırarak tek başına yüzer duruma getirmek için sekmesinden ya da başlık çubuğundan dışarı sürükleyin.

Panelleri yeniden boyutlandırma

  • Paneli, panel grubunu, panel yığınını simge durumuna ya da ekran boyutuna getirmek için sekmeyi çift tıklatın. Sekme alanını (sekmenin yanındaki boş alan) çift de tıklatabilirsiniz.
  • Paneli yeniden boyutlandırmak için panelin herhangi bir kenarından sürükleyin. 

Panel simgelerini daraltma ve genişletme

Çalışma alanındaki karmaşayı azaltmak için panelleri simge olarak daraltabilirsiniz. Bazı durumlarda varsayılan çalışma alanında paneller düğme olarak daraltılmıştır.

  • Bir sütundaki tüm panel simgelerini daraltmak ya da genişletmek için sabitleme alanının üstündeki çift oku tıklatın.
  • Tek panel simgesini genişletmek için simgeyi tıklatın.
  • Yalnızca simgeleri görmek (etiketleri değil) amacıyla panel simgelerini yeniden boyutlandırmak için metin kaybolana kadar sabitleme alanı genişliğini ayarlayın. Simge metnini yeniden görüntülemek için sabitleme alanını genişletin.
  • Genişletilmiş bir paneli tekrar simge olarak daraltmak için panelin sekmesini veya simgesini tıklatın ya da panelin başlık çubuğundaki çift oku tıklatın.

Özel çalışma alanları oluşturma

Gereksinimlerinize göre paneller ekleyip kaldırarak çalışma alanınızı özelleştirebilirsiniz. Bu değişiklikleri, daha sonra Belge araç çubuğundaki Çalışma Alanı Değiştiricisi'nden erişmek için çalışma alanına kaydedebilirsiniz.

Panellerin geçerli boyutunu ve konumunu adlandırılmış bir çalışma alanı olarak kaydederek, o paneli taşısanız ya da kapatsanız da o çalışma alanını geri yükleyebilirsiniz.

Özel bir çalışma alanını kaydetmek için:

  1. Pencere > Çalışma Alanı Mizanpajı > Yeni Çalışma Alanı seçeneğini belirleyin.
  2. Çalışma alanı için bir ad yazın.

Çalışma alanı kaydedilir ve Belge araç çubuğunda Çalışma Alanı değiştiricisinde görünür.

Özel çalışma alanını silmek için:

Çalışma Alanlarını Yönet iletişim kutusunu açmak için uygulama çubuğunda çalışma alanı değiştiriciden Çalışma Alanlarını Yönet'i seçin. Çalışma alanını seçin ve ardından Sil'i tıklatın.

Çalışma alanlarını görüntüleme ya da değiştirme

Belge araç çubuğunda çalışma alanı değiştiriciden çalışma alanını seçin.

Çok kullanıcılı sistemlerde Dreamweaver'ı özelleştirme

Dreamweaver uygulamasını, Windows XP veya Mac OS X gibi çok kullanıcılı işletim sistemlerinde bile gereksinimlerinize uygun olarak özelleştirebilirsiniz.

Dreamweaver, bir kullanıcının özelleştirilmiş yapılandırmasının diğer kullanıcıların özelleştirilmiş yapılandırmasını etkilemesini önler. Bu görevi gerçekleştirmek için Dreamweaver'ı tanıdığı çok kullanıcılı işletim sistemlerinden birinde ilk defa çalıştırdığınızda, uygulama çeşitli yapılandırma dosyalarının birer kopyasını oluşturur. Bu kullanıcı yapılandırma dosyaları size ait bir klasörde saklanır.

Dreamweaver'ı yeniden yükler veya yükseltirseniz Dreamweaver otomatik olarak kullanıcı yapılandırma dosyalarının yedek kopyalarını oluşturur. Böylece, bu dosyaları elle yapılandırdıysanız yaptığınız değişikliklere yine de erişebilirsiniz.

Sekmeli belgeleri gösterme (Yalnızca Mac'te)

Her bir belgeyi tanımlamak için sekmeler kullanarak birden çok belgeyi tek bir Belge penceresinde görüntüleyebilirsiniz. Ayrıca bunları, içinde her belgenin kendi penceresinde görüntülendiği kayar bir çalışma alanının parçası olarak da görüntüleyebilirsiniz.

Sekmeli bir belgeyi ayrı bir pencerede açma

Sekmeyi Control tuşuna basıp tıklatın ve bağlam menüsünden Yeni Pencereye Taşı'yı seçin.

Varsayılan sekmeli belge ayarını değiştirme

  1. Dreamweaver > Tercihler'i, sonra da Genel kategorisini seçin.
  2. Belgeleri Sekmede Aç'ı seçin veya bu seçeneğin seçimini kaldırın ve Tamam'ı tıklatın.

Dreamweaver, tercihleri değiştirdiğinizde o anda açık olan belgelerin görüntülenme biçimini değiştirmez. Ancak siz yeni bir tercih belirledikten sonra açılan belgeler belirlediğiniz tercihe göre gösterilir.

Karşılama ekranı, Dreamweaver'ı açtığınızda ve açık belgeniz olmadığı zamanlarda gösterilir. Karşılama ekranını gizlemeyi seçebilir ve daha sonra yeniden gösterebilirsiniz. Karşılama ekranı gizli olduğunda ve herhangi bir belge açık değilken Belge penceresi boştur.

Genel Dreamweaver panelleri

Dreamweaver uygulamasında bir dizi panel ile çalışırsınız. Burada yaygın olarak kullanılan panellerin bazıları açıklanmaktadır.

Ekle paneline genel bakış

Ekle panelindeki (Pencere > Ekle) tablo, görüntü ve bağ gibi nesneler oluşturmak ve eklemek için düğmeler bulunur. Düğmeler, üst kısımdaki açılır listeden istediğiniz kategoriyi seçerek aralarında geçiş yapabileceğiniz birkaç kategoride düzenlenmiştir.

Ekle paneli
Ekle paneli

Bazı kategorilerin açılır menüleri olan düğmeleri vardır. Açılır menüden bir seçenek belirlediğinizde, düğmenin varsayılan eylemi olur. Örneğin, Karakter düğmesinin açılır menüsünden Satır Kesme'yi seçerseniz Karakter düğmesini bir sonraki tıklatmanızda Dreamweaver, bir satır kesme ekler. Açılır menüden yeni bir seçenek belirlediğiniz her seferde düğmenin varsayılan eylemi değişir.

Ekle paneli aşağıdaki kategorilerde düzenlenmiştir:

HTML

div etiketleri gibi en sık kullanılan HTML öğeleri ile görüntüler ve tablolar gibi nesneleri oluşturmanızı ve eklemenizi sağlar.

Form

Form oluşturmak ve arama, ay ve şifre gibi form öğeleri eklemek için düğmeler içerir.

Şablonlar

Belgeyi şablon olarak kaydetmenize ve belirli alanları düzenlenebilir, isteğe bağlı, yinelenen ya da düzenlenebilir isteğe bağlı bölge olarak işaretlemenize olanak sağlar.

Bootstrap bileşenleri

Dinamik projelerde kullanabileceğiniz gezinme, kaplar, açılır listeler ve daha fazlasını sunan Bootstrap bileşenlerini içerir.

jQuery Mobile

jQuery Mobile kullanan siteler oluşturmak için düğmeler içerir.

jQuery Kullanıcı Arabirimi

Akordeon, sürgüler ve düğmeler gibi jQuery Kullanıcı Arabirimi öğeleri eklemenize olanak sağlar.

Sık Kullanılanlar

Tek bir genel alanda en çok kullandığınız Ekle paneli düğmelerini gruplamanıza ve düzenlemenize olanak sağlar.

Not:

 XML, JavaScript, Java ve CSS gibi belirli dosya türleriyle çalışıyorsanız Ekle paneli ve Tasarım görünümü seçeneği, bu kod dosyalarına herhangi bir öğe ekleyemeyeceğiniz için soluktur.

Nesne ekleme

Ekle panelini kullanarak nesne eklemek için:

  1. Ekle panelinin Kategori açılır menüsünden uygun kategoriyi seçin.

  2. Aşağıdakilerden birini yapın:

    • Bir nesne düğmesini tıklatın veya düğmenin simgesini Belge penceresine (Tasarım, Canlı veya Kod Görünümü'ne) sürükleyin.

    • Düğmedeki oku tıklatın, sonra menüden bir seçenek belirleyin.

      Nesneye bağlı olarak, karşılık gelen bir nesne ekleme iletişim kutusu belirebilir, sizden bir dosyaya gitmeniz veya bir nesnenin parametrelerini belirtmeniz istenebilir. Dreamweaver bunun yerine, belgeye kod ekleyebilir veya kod eklenmeden önce bilgi girmeniz için bir etiket düzenleyici ya da panel açabilir.

      Bazı nesnelerde nesneyi Tasarım görünümünde eklerseniz hiçbir iletişim kutusu açılmaz, ancak nesneyi Kod görünümünde eklerseniz bir etiket düzenleyici açılır. Bazı nesneleri Tasarım görünümünde eklemek, Dreamweaver'ın nesneyi eklemeden önce Kod görünümüne geçmesine neden olur.

Ekle paneli tercihlerini düzenleme

  1. Düzen > Tercihler'i (Windows) veya Dreamweaver > Tercihler'i (Macintosh) seçin.

  2. Tercihler iletişim kutusunun Genel kategorisinde, görüntü, tablo, komut dosyası ve başlık öğesi eklerken veya nesne oluşturma sırasında Control tuşunu (Windows) veya Option tuşunu (Macintosh) basılı tutarken açılan iletişim kutularını engellemek için Nesne Eklerken İletişim Kutusunu Göster'in işaretini kaldırın.

Not:

Bu seçenek kapalı olarak bir nesne eklediğinizde nesneye varsayılan nitelik değerleri verilir. Nesneyi ekledikten sonra özelliklerini değiştirmek için Özellik denetçisini kullanın.

Ekle panelinin Sık Kullanılanlar kategorisinde öğe ekleme, silme veya yönetme

  1. Ekle panelinde herhangi bir kategoriyi seçin.

  2. Düğmelerin görüntülendiği alanda sağ tıklatın (Windows) veya Control basılıyken tıklatın (Macintosh) ve Sık Kullanılanları Özelleştir öğesini seçin.

  3. Sık Kullanılan Nesneleri Özelleştir iletişim kutusunda gerekli değişiklikleri yapın ve Tamam'ı tıklatın.

    Bir nesne eklemek için soldaki Kullanılabilir Nesneler bölmesinde bir nesne seçin ve ardından iki bölme arasındaki oku tıklatın veya Kullanılabilir Nesneler bölmesinde bir nesneyi çift tıklatın.

    Ekle panelinde sık kullanılanları özelleştirme
    Ekle panelinde sık kullanılanları özelleştirme

    Not:

    Bir kerede bir nesne ekleyebilirsiniz. Sık kullanılanlar listenize tüm kategoriyi eklemek için Genel gibi bir kategori adını seçemezsiniz.

    • Bir nesneyi veya ayırıcıyı silmek için sağdaki Sık Kullanılan Nesneler panelinde bir nesneyi seçin ve ardından bölmenin üzerindeki Seçili Nesneyi Sık Kullanılan Nesneler Listesinden Kaldır düğmesini tıklatın.
    • Bir nesneyi taşımak için sağdaki Sık Kullanılan Nesneler bölmesinde bir nesneyi seçin ve ardından bölmenin üzerindeki Yukarı veya Aşağı ok düğmesini tıklatın.
    • Bir nesnenin altına ayırıcı eklemek için sağdaki Sık Kullanılan Nesneler bölmesinde bir nesneyi seçin ve ardından bölmenin altındaki Ayırıcı Ekle düğmesini tıklatın.
  4. Ekle panelinin Sık Kullanılanlar kategorisinde değilseniz değişikliklerinizi görmek için bu kategoriyi seçin.

Dosyalar paneline genel bakış

Dreamweaver sitenizdeki dosyaları görüntülemek ve yönetmek için Dosyalar panelini kullanın.

Dosya ve klasörleri görüntüleme, bir Dreamweaver sitesiyle ilişkili olup olmadığına bakma ve dosyaları açma veya taşıma gibi standart dosya işlemlerini gerçekleştirmek için Dosyalar panelini kullanabilirsiniz.

Dosyalar paneli ayrıca dosyaları yönetmenize ve uzak sunucu ile dosya alışverişi yapmanıza yardımcı olur. 

Dosyalar paneli
Dosyalar paneli

Dosyalar paneliyle tüm yapabilecekleriniz hakkında daha fazla bilgi için bkz. Dosyaları ve klasörleri yönetme.

CSS Tasarımcısı

CSS Tasarımcısı paneli (Pencereler > CSS Tasarımcısı), ortam sorgularıyla birlikte “görsel olarak” CSS stilleri, dosyalar, kurallar ve ayarlı özellikler oluşturmanıza olanak sağlayan bir CSS Özellik Denetimi'dir.

CSS Tasarımcısı'nda gerçekleştirdiğiniz tüm eylemleri geri almak için Ctrl/Cmd+ Z veya yinelemek için Ctrl/Cmd + Y tuşlarını kullanabilirsiniz. Değişiklikler otomatik olarak Canlı Görünüm'de yansıtılır ve ilgili CSS dosyası da yenilenir. İlgili dosyanın değiştiğini size bildirmek için etkilenen dosyanın sekmesi bir süreliğine (yaklaşık 8 saniye kadar) vurgulanır.

CSS Tasarımcısı paneli (CC)
CSS Tasarımcısı paneli

CSS Tasarımcısı paneli şu bölmelerden ve seçeneklerden oluşur:

Tümü Geçerli belgeyle ilişkilendirilmiş tüm CSS'yi, ortam sorgularını ve seçicileri listeler. Gerekli CSS kuralları için filtreleme yapabilir ve özellikleri değiştirebilirsiniz. Seçiciler veya ortam sorguları oluşturmaya başlamak için de bu modu kullanabilirsiniz.

Bu mod seçime duyarlı değildir. Bir başka deyişle, sayfada bir öğeyi seçtiğinizde CSS Tasarımcısı'nda ilgili seçici, ortam sorgusu veya CSS vurgulanmaz.

Geçerli Geçerli belgenin Tasarım görünümünde veya Canlı görünümde seçili olan herhangi bir öğe için hesaplanan stillerini listeler. Kod görünümünde bir CSS dosyası için bu modu kullandığınızda odaktaki seçicinin tüm özellikleri gösterilir.

Bu mod bağlama duyarlıdır. Belgede seçili olan öğelerle ilişkilendirilmiş seçicilerin özelliklerini düzenlemek için bu seçeneği kullanın.

Kaynaklar Belgeyle ilişkilendirilmiş tüm CSS stil sayfalarını listeler. Bu bölmeyi kullanarak bir CSS oluşturabilir ve belgeye ekleyebilir veya belge içindeki stilleri tanımlayabilirsiniz.

@Ortam Kaynaklar bölmesinde seçilen kaynaktaki tüm ortam sorgularını listeler. Belirli bir CSS seçmezseniz bu bölme, belgeyle ilişkilendirilmiş tüm ortam sorgularını görüntüler.

Seçiciler Kaynaklar bölmesinde seçilen kaynaktaki tüm seçicileri listeler. Bir ortam sorgusu da seçerseniz, bu bölme o ortam sorgusu için seçicilerin listesini daraltır. Herhangi bir CSS veya ortam sorgusu seçilmezse, bu bölme belgedeki tüm seçicileri görüntüler.

@Ortam bölmesinde Global seçeneğini belirlediğinizde seçili kaynağın ortam sorgusuna dahil edilmeyen tüm seçiciler görüntülenir.

Özellikler Belirtilen seçici için ayarlayabileceğiniz özellikleri görüntüler. Daha fazla bilgi için bkz. Özellikleri ayarlama.

CSS Tasarımcısı'ndaki bölmeleri daralttığınızda veya genişlettiğinizde, bölmelerin boyutları oturum süresince hatırlanır. Kaynaklar ve Ortam bölmeleri siz boyutlarını yeniden değiştirene kadar özelleştirilmiş boyutlarında kalır.

Not: Bir sayfa öğesi seçtiğinizde Seçiciler bölmesinde en belirgin Seçici belirlenir. Belirli bir Seçici'nin özelliklerini görüntülemek için bölmede bu Seçici'nin adını tıklatın.

Tüm seçicileri görüntülemek için Kaynaklar bölmesinde Tüm Kaynaklar'ı seçebilirsiniz. Seçili kaynakta herhangi bir ortam sorgusuna ait olmayan seçicileri görüntülemek için @Ortam bölmesinde Global seçeneğini tıklatın.

Görsel kılavuzlara genel bakış

Dreamweaver, belgeleri tasarlamanıza ve tarayıcılarda yaklaşık nasıl görüneceklerini tahmin etmenize yardım etmek üzere çok çeşitli görsel kılavuzlar sunar. Aşağıdakilerden herhangi birini yapabilirsiniz:

  • Öğelerin sayfaya nasıl oturduğunu görmek için Belge penceresini anında istenen pencere boyutuna yerleştirin.

  • Adobe® Photoshop® veya Adobe® Fireworks® gibi bir resim veya görüntü düzenleme uygulamasında oluşturulan tasarımı çoğaltmanıza yardım etmesi için izleyen görüntüyü sayfa arka planı olarak kullanın.

  • Sayfa öğelerini hassas konumlandırma ve yeniden boyutlandırma için görsel ipucu sağlamak üzere kılavuzları ve cetvelleri kullanın.

  • Katı biçimde konumlandırılmış öğelerin (AP öğeleri) hassas konumlandırması ve yeniden boyutlandırılması için ızgarayı kullanın.

    Sayfadaki ızgara işaretleri, AP öğelerini hizalamanıza ve yapışma etkinleştirildiğinde, AP öğeleri taşındığında veya yeniden boyutlandırıldığında bunların otomatik olarak en yakın ızgara noktasına yapışmasına yardım eder. (Görüntüler ve paragraflar gibi diğer nesneler ızgaraya yapışmaz.) Yapışma özelliği, kılavuz görünür olsa da olmasa da çalışır.

Sayfayı yakınlaşma ve uzaklaşma

Dreamweaver, Belge penceresinde büyütme (yakınlaştırma) oranını artırmanıza olanak sağlar. Böylece grafiklerin piksel doğruluğunu kontrol edebilir, küçük öğeleri daha kolay seçebilir, küçük metin olan sayfalar tasarlayabilir, geniş sayfalar tasarlayabilir ve daha fazlasını yapabilirsiniz.

Sayfayı yakınlaştırmak ve uzaklaştırmak için Görünüm > Tasarım Görünümü Seçenekleri > Büyütme'yi seçin ve kullanılabilir büyütme seçeneklerinden birini belirleyin.

Çeşitli büyütme seçenekleri arasından seçim yapabilirsiniz. Ayrıca şunları da seçebilirsiniz:

  • Seçimi Sığdır: Nesneyi veya metni seçin ve Belge penceresini seçimle doldurmak için bu seçeneği belirleyin.
  • Tümünü Sığdır: Belge penceresini tüm sayfayla doldurun.
  • Genişliğe Sığdır: Belge penceresini tüm sayfa genişliğiyle doldurun.

Not:

Control+= (Windows) veya Command+= (Macintosh) tuşlarına basarak Yakınlaştırma aracını kullanmadan da yakınlaştırabilirsiniz. Control+= (Windows) veya Command+= (Macintosh) tuşlarına basarak Yakınlaştırma aracını kullanmadan da uzaklaştırabilirsiniz.

Genel Dreamweaver tercihlerini belirleme

  1. Düzen > Tercihler'i (Windows) veya Dreamweaver > Tercihler'i (Macintosh) seçin.

  2. Aşağıdaki seçeneklerden birini belirleyin:

    Belgeleri Sekmede Aç Tüm belgeleri, belgeler arasında geçiş yapmanıza olanak sağlayan tek bir pencerede açar (yalnızca Mac).

    Başlangıç Ekranını Göster Dreamweaver'ı başlattığınızda veya açık belgeniz olmadığı zamanlarda Dreamweaver Karşılama ekranını gösterir.

    Belgeleri Başlangıçta Yeniden Aç Dreamweaver'ı kapattığınızda açık olan belgeleri açar. Bu seçenek belirlenmemişse, Dreamweaver'ı başlattığınızda uygulama Karşılama ekranını veya boş bir ekran görüntüler (Karşılama Ekranını Göster ayarınıza bağlı olarak).

    Salt Okunur Dosyaları Açarken Uyar Salt okunur (kilitli) bir dosya açtığınızda sizi uyarır. Dosyanın kilidini açma/teslim alma, dosyayı görüntüleme veya iptal etme seçeneklerinden birini belirleyin.

    İlgili Dosyaları Etkinleştir Geçerli belgeye hangi dosyaların bağlı olduğunu görmenizi sağlar (örneğin CSS veya JavaScript dosyaları). Dreamweaver, belgenin üst kısmında her ilgili dosya için bir düğme gösterir ve düğmeyi tıklatırsanız o dosyayı açar.

    Dinamik Olarak İlgili Dosyaları Keşfet Dinamik Olarak İlgili Dosyaların, İlgili Dosyalar araç çubuğunda otomatik olarak mı yoksa el ile yapılan bir müdahaleden sonra mı görüntüleneceğini seçmenize izin verir. Dinamik Olarak İlgili Dosyaların keşfini etkisiz hale getirmeyi de seçebilirsiniz.

    Dosyaları Taşırken Bağları Güncelleştir Bir belgeyi siteniz içinde taşıdığınızda, yeniden adlandırdığınızda veya sildiğinizde ne olacağını belirler. Bağları otomatik olarak her zaman güncelleştirmek, bağları hiçbir zaman güncelleştirmemek veya bir güncelleştirme için uyarılmak üzere bu tercihi ayarlayın. (Bkz. Bağları otomatik güncelleştirme.)

    Nesneleri Eklerken İletişim Kutusu Göster Dreamweaver uygulamasının, Ekle panelini ya da Ekle menüsünü kullanarak görüntü, tablo, Shockwave filmleri ve belirli diğer nesneleri eklerken ek bilgiler girmenizi isteyip istemeyeceğini belirler. Bu seçenek kapalı olarak ayarlanmışsa, iletişim kutusu görüntülenmez ve görüntülerin kaynak dosyasını, tablodaki satır sayısını belirtmek için Özellik denetçisini kullanmanız gerekir. Rollover görüntüleri ve Fireworks HTML'i için, bu seçenek ayarına bakılmaksızın bir nesne eklediğinizde her zaman bir iletişim kutusu görüntülenir. (Bu ayarı geçici olarak geçersiz kılmak için, nesneleri oluştururken ve eklerken Control tuşu (Windows) ya da Command tuşu (Macintosh) basılıyken tıklatın.)

    Çift Bayt Satır İçi Girişi Etkinleştir Geliştirme ortamı veya çift bayt metni (Japonca karakterler gibi) kolaylaştıran dil seti kullanıyorsanız Belge penceresine doğrudan çift bayt metin girmenize olanak sağlar. Bu seçeneğin işareti kaldırıldığında, çift bayt metni girmeniz ve dönüştürmeniz için bir metin giriş penceresi görüntülenir; kabul edildikten sonra metin Belge penceresinde görüntülenir.

    Başlıktan Sonra Düz Paragrafa Geç Tasarım görünümünde veya Canlı görünümde başlık paragrafının sonunda Enter (Windows) veya Return (Macintosh) tuşuna basmanın p etiketiyle etiketlenmiş yeni paragraf etiketi oluşturacağını belirtir. (Başlık paragrafı h1 veya h2 gibi başlık etiketiyle etiketlenmiş paragraftır). Bu seçenek devre dışı bırakıldığında başlık paragrafının sonunda Enter veya Return tuşuna basma, aynı başlık etiketiyle etiketlenmiş yeni bir paragraf oluşturur (bir satırda birden fazla başlık yazmanıza ve ardından geri gidip ayrıntıları doldurmanıza olanak sağlar).

    Birden Çok Ardışık Boşluğa İzin Ver Tasarım görünümünde veya Canlı görünümde iki veya daha fazla boşluk yazmanın, tarayıcıda birden çok boşluk olarak görünen bölünemez boşluk oluşturacağını belirtir. (Örneğin daktilodaki gibi cümleler arasında iki boşluk yazabilirsiniz.) Bu seçenek özel olarak kelime işlemcilerde yazmaya alışmış kişiler için tasarlanmıştır. Bu seçenek devre dışı bırakıldığında, çok sayıda boşluk tek boşluk gibi ele alınır (tarayıcılar çok sayıda boşluğu tek boşluk olarak işlediği için).

    <b> ve <i> Yerine <strong> ve <em> Kullan Dreamweaver'ın strong etiketini, genellikle b etiketi uygulayacağınız bir eylemi gerçekleştirdiğinizde ve em etiketini, i etiketini uygulayacağınız bir eylem gerçekleştirdiğinizde uygulayacağını belirtir. Bu eylemler HTML modunda metin Özellik denetçisinde Kalın veya İtalik düğmelerini tıklatmanızı ve Format > Stil > Kalın'ı veya Format > Stil > İtalik'i seçmenizi içerir. Belgelerinizde b ve i etiketlerini kullanmak için bu seçeneğin işaretini kaldırın.

    Not: World Wide Web Konsorsiyumu b ve i etiketlerinin kullanılmasını önermez; strong ve em etiketleri b ve i etiketlerinin yaptığından daha fazla anlamsal bilgi sağlar.

    <p> veya <h1> - <h6> etiketleri içine düzenlenebilir bölgeler yerleştirirken uyar Paragraf veya başlık etiketinde düzenlenebilir bölümü olan bir Dreamweaver şablonunu kaydederken bir uyarı mesajının görüntülenip görüntülenmeyeceğini belirtir. Bu mesaj size, kullanıcıların bölgede daha fazla paragraf oluşturamayacaklarını belirtir. Varsayılan olarak etkindir.

    Geri alma işlemlerini etkin belgeyle sınırla Geri alma işlemlerini etkin dosyayla sınırlar. Örneğin, bir CSS dosyası düzenliyorsanız yalnızca CSS dosyasında yapılan değişiklikleri geri alabilirsiniz.

    Ancak bu onay kutusu devre dışı bırakılırsa HTML kaynağı ve tüm ilişkili CSS dosyaları tek bir geri alma geçmişini kullanır ve HTML kodu veya ilişkili bir CSS dosyasında çalıştığınıza bakılmaksızın işlemlerinizi geri alabilirsiniz.

    Geçmiş Adımlarının Maksimum Sayısı Dreamweaver tarafından hatırlanan adım sayısını belirler. (Varsayılan değer çoğu kullanıcının ihtiyaçları için yeterli olmalıdır.) Belirtilen adım sayısını aşarsanız en eski adımlar atılır.

    Yazım Denetimi Sözlüğü Mevcut yazım denetimi sözlüklerini listeler. Sözlükte birden fazla diyalekt veya yazım denetimi kuralı varsa (Amerikan İngilizcesi ve İngiliz İngilizcesi gibi), diyalektler Sözlük açılır menüsünde ayrı olarak listelenir.

Dreamweaver'da belgelerin Fontlar tercihlerini belirleme

Belge kodlaması, belgenin bir tarayıcıda nasıl görüntüleneceğini belirler. Dreamweaver font tercihleri, kodlamayı tercih ettiğiniz font ve boyutta görmenize olanak sağlar. Ancak Font Tercihleri iletişim kutusunda seçtiğiniz fontlar, yalnızca fontların Dreamweaver'da görüntülenme şeklini etkiler; belgenin ziyaretçinin tarayıcısındaki görüntülenme şeklini etkilemez. Fontların tarayıcıdaki görüntülenme şeklini değiştirmek için Özellik denetçisini kullanarak veya bir CSS kuralı uygulayarak metni değiştirmeniz gerekir.

Yeni belgeler için bir varsayılan kodlama ayarlamayla ilgili bilgi için bkz. Belge oluşturma ve açma.

  1. Düzen > Tercihler (Windows) veya Dreamweaver > Tercihler (Mac) seçeneğini belirleyin.

  2. Soldaki Kategori listesinden Fontlar'ı seçin.

  3. Font Ayarları listesinden bir kodlama türü (Batı Avrupa veya Japonca gibi) seçin.

    Not:

    Bir Asya dili görüntülemek için çift bayt fontları destekleyen bir işletim sistemi kullanıyor olmalısınız.

  4. Seçili kodlamanın her kategorisi için kullanılacak font ve boyutu seçin.

    Not:

    Font açılır menülerinde görüntülenmesi için bir fontun bilgisayarınızda yüklü olması gerekir. Örneğin Japonca metni görmek için yüklü Japonca fontunuz olmalıdır.

    Orantısal Font

    Dreamweaver'ın normal metni (örneğin paragraf, başlık ve tablolardaki metni) görüntülemek için kullandığı fonttur. Varsayılan font, sisteminizde yüklü olan fontlara bağlıdır. Birçok ABD sistemi için varsayılan font Windows'ta Times New Roman 12 pt. (Orta) ve Mac OS'ta Times 12 pt.'dir.

    Karışık Font

    Dreamweaver'ın pre, code ve tt etiketleri içindeki metni görüntülemek için kullandığı fonttur. Varsayılan font, sisteminizde yüklü olan fontlara bağlıdır. Birçok ABD sistemi için varsayılan font Windows'ta Courier New 10 pt. (Küçük) ve Mac OS'ta Monaco 12 pt.'dir.

    Kod Görünümü

    Kod görünümünde ve Kod denetleyicide görüntülenen tüm metinlerde kullanılan fonttur. Varsayılan font, sisteminizde yüklü olan fontlara bağlıdır.

Dreamweaver vurgulama renklerini özelleştirme

Dreamweaver'da şablon bölgelerini, kitaplık öğelerini, üçüncü taraflara ait etiketleri, mizanpaj öğelerini ve kodu özelleştirmek için Vurgulama tercihlerini kullanın.

  1. Düzen > Tercihler'i, sonra da Vurgulama kategorisini seçin.

  2. Vurgulama rengini değiştirmek istediğiniz nesnenin yanındaki renk kutusunu tıklatın, sonra yeni bir renk seçmek için renk seçiciyi kullanın veya onaltılık bir değer girin.

  3. Belirli bir seçenek için vurgulamayı etkinleştirmek veya devre dışı bırakmak amacıyla Göster seçeneğini işaretleyin veya bu seçeneğin işaretini kaldırın.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi