Kullanıcı Kılavuzu İptal

Dosyaları oluşturma ve açma

  1. Dreamweaver Kullanıcı Kılavuzu
  2. Giriş
    1. Dinamik web tasarımı hakkında temel bilgiler
    2. Dreamweaver'daki yenilikler
    3. Dreamweaver ile web geliştirme - Genel bakış
    4. Dreamweaver / Yaygın Sorular
    5. Klavye kısayolları
    6. Dreamweaver sistem gereksinimleri
    7. Özellik özeti
  3. Dreamweaver ve Creative Cloud
    1. Dreamweaver ayarlarını Creative Cloud ile senkronize etme
    2. Dreamweaver'da Creative Cloud Libraries
    3. Dreamweaver'da Photoshop dosyalarını kullanma
    4. Adobe Animate ve Dreamweaver ile çalışma
    5. Web için en iyileştirilmiş SVG dosyalarını Libraries'den ayıklama
  4. Dreamweaver çalışma alanları ve görünümleri
    1. Dreamweaver çalışma alanı
    2. Dreamweaver çalışma alanını görsel geliştirme açısından en iyileştirme
    3. Dosya adına veya içeriğe göre dosya arama | Mac OS
  5. Site kurma
    1. Dreamweaver siteleri hakkında
    2. Sitenizin yerel bir sürümünü kurma
    3. Yayımlama sunucusuna bağlanma
    4. Test sunucusu kurma
    5. Dreamweaver site ayarlarını içe ve dışa aktarma
    6. Mevcut web sitelerini uzak sunucudan yerel site köküne getirme
    7. Dreamweaver'daki erişilebilirlik özellikleri
    8. Gelişmiş ayarlar
    9. Dosya aktarmak için site tercihlerini ayarlama
    10. Dreamweaver'da proxy sunucu ayarlarını belirtme
    11. Dreamweaver ayarlarını Creative Cloud ile senkronize etme
    12. Dreamweaver'da Git'i kullanma
  6. Dosyaları yönetme
    1. Dosyaları oluşturma ve açma
    2. Dosyaları ve klasörleri yönetme
    3. Sunucunuzdan dosya alma ve dosyaları sunucunuza koyma
    4. Dosyaları teslim etme ve teslim alma
    5. Dosyaları senkronize etme
    6. Dosyaları farklılıklar açısından karşılaştırma
    7. Dreamweaver sitenizde dosya ve klasör perdeleme
    8. Dreamweaver siteleri için Tasarım Notları'nı etkinleştirme
    9. Olası Gatekeeper zaafını önleme
  7. Mizanpaj ve tasarım
    1. Mizanpaj için görsel yardımcılar kullanma
    2. Sayfanızın mizanpajını hazırlamak için CSS'yi kullanma hakkında
    3. Bootstrap kullanarak dinamik web siteleri tasarlama
    4. Dreamweaver'da ortam sorguları oluşturma ve kullanma
    5. Tablolara sahip içerik sunma
    6. Renkler
    7. Değişken ızgara mizanpajlarını kullanarak dinamik tasarım
    8. Dreamweaver'da Extract
  8. CSS
    1. Basamaklı Stil Sayfaları'nı anlama
    2. CSS Tasarımcısı'nı kullanarak sayfa mizanpajını yapma
    3. Dreamweaver'da CSS ön işlemcilerini kullanma
    4. Dreamweaver'da CSS Stili tercihlerini ayarlama
    5. Dreamweaver'da CSS kurallarını taşıma
    6. Dreamweaver'da satır içi CSS'yi CSS kuralına dönüştürme
    7. Div etiketleriyle çalışma
    8. Arka plana degradeler uygulama
    9. Dreamweaver'da CSS3 geçiş efektleri oluşturma ve düzenleme
    10. Kodu formatlama
  9. Sayfa içeriği ve varlıklar
    1. Sayfa özelliklerini ayarlama
    2. CSS başlığı özelliklerini ve CSS bağ özelliklerini ayarlama
    3. Metinle çalışma
    4. Metni, etiketleri ve nitelikleri bulma ve değiştirme
    5. DOM paneli
    6. Canlı Görünüm'de düzenleme
    7. Dreamweaver'da belgeleri kodlama
    8. Belge penceresinde öğe seçme ve görüntüleme
    9. Özellik denetiminde metin özelliklerini belirleme
    10. Web sayfası üzerinde yazım denetimi gerçekleştirme
    11. Dreamweaver'da yatay cetveller kullanma
    12. Dreamweaver'da font birleşimlerini ekleme ve değiştirme
    13. Varlıklarla çalışma
    14. Dreamweaver'da tarih ekleme ve güncelleştirme
    15. Dreamweaver'da sık kullanılan varlıklar oluşturma ve yönetme
    16. Dreamweaver'da görüntü ekleme ve düzenleme
    17. Medya nesneleri ekleme
    18. Dreamweaver'da video ekleme
    19. HTML5 video ekleme
    20. SWF dosyaları ekleme
    21. Ses efektleri ekleme
    22. Dreamweaver'da HTML5 ses ekleme
    23. Kitaplık öğeleriyle çalışma
    24. Dreamweaver'da Arapça ve İbranice metin kullanma
  10. Bağlama ve gezinme
    1. Bağlama ve gezinme hakkında
    2. Bağ oluşturma
    3. Görüntü eşlemeleri
    4. Bağlantı sorunlarını giderme
  11. jQuery bileşenleri ve efektleri
    1. Dreamweaver'da jQuery UI ve Mobile bileşenlerini kullanma
    2. Dreamweaver'da jQuery efektlerini kullanma
  12. Web sitelerini kodlama
    1. Dreamweaver'da kod yazma hakkında
    2. Dreamweaver'da kodlama ortamı
    3. Kodlama tercihlerini ayarlama
    4. Kod rengini özelleştirme
    5. Kod yazma ve düzenleme
    6. Kod ipuçları verme ve kod tamamlama
    7. Kodu daraltma ve genişletme
    8. Parçacıklar ile kodu tekrar kullanma
    9. Lint kodu
    10. Kodu en iyileştirme
    11. Tasarım görünümünde kod düzenleme
    12. Sayfaların başlık içeriğiyle çalışma
    13. Dreamweaver'da sunucu tarafı içerikleri ekleme
    14. Dreamweaver'da etiket kitaplıkları kullanma
    15. Dreamweaver'a özel etiketleri içe aktarma
    16. JavaScript davranışlarını kullanma (genel talimatlar)
    17. Yerleşik JavaScript davranışları uygulama
    18. XML ve XSLT hakkında
    19. Dreamweaver uygulamasında sunucu tarafı XSL dönüşümleri gerçekleştirme
    20. Dreamweaver uygulamasında istemci tarafı XSL dönüşümleri gerçekleştirme
    21. Dreamweaver'da XSLT için karakter varlıkları ekleme
    22. Kodu formatlama
  13. Ürünler arası iş akışları
    1. Dreamweaver uzantılarını yükleme ve kullanma
    2. Dreamweaver uygulama içi güncelleştirmeleri
    3. Dreamweaver'da Microsoft Office belgeleri ekleme (yalnızca Windows)
    4. Fireworks ve Dreamweaver ile çalışma
    5. Contribute ile Dreamweaver sitelerindeki içeriği düzenleme
    6. Dreamweaver-Business Catalyst entegrasyonu
    7. Kişiselleştirilmiş e-posta kampanyaları oluşturma
  14. Şablonlar
    1. Dreamweaver şablonları hakkında
    2. Şablonları ve şablon tabanlı belgeleri tanıma
    3. Dreamweaver şablonu oluşturma
    4. Şablonlarda düzenlenebilir bölgeler oluşturma
    5. Dreamweaver'da yinelenen bölgeler ve tablolar oluşturma
    6. Şablonlarda isteğe bağlı bölgeler kullanma
    7. Dreamweaver'da düzenlenebilir etiket niteliklerini tanımlama
    8. Dreamweaver uygulamasında yuvalanmış şablonlar oluşturma
    9. Şablonları düzenleme, güncelleştirme ve silme
    10. Dreamweaver'da xml içeriğini dışa ve içe aktarma
    11. Mevcut bir belgenin şablonunu uygulama veya kaldırma
    12. Dreamweaver şablonlarındaki içerikleri düzenleme
    13. Dreamweaver'daki şablon etiketleri için sözdizimi kuralları
    14. Şablon bölgeleri için vurgulama tercihlerini belirleme
    15. Dreamweaver'da şablon kullanmanın avantajları
  15. Mobil ve çoklu ekran
    1. Ortam sorguları oluşturma
    2. Mobil cihazlar için sayfa yönlendirmesini değiştirme
    3. Dreamweaver kullanarak mobil cihazlar için web uygulamaları oluşturma
  16. Dinamik siteler, sayfalar ve web formları
    1. Web uygulamalarını anlama
    2. Bilgisayarınızı uygulama geliştirme için ayarlama
    3. Veritabanı bağlantılarında sorun giderme
    4. Dreamweaver uygulamasında bağlantı komut dosyalarını kaldırma
    5. Dinamik sayfalar tasarlama
    6. Dinamik içerik kaynaklarına genel bakış
    7. Dinamik içerik kaynaklarını tanımlama
    8. Sayfalara dinamik içerik ekleme
    9. Dreamweaver'da dinamik içeriği değiştirme
    10. Veritabanı kayıtlarını görüntüleme
    11. Dreamweaver'da canlı veri sağlama ve ilgili sorunları giderme
    12. Dreamweaver'da özel sunucu davranışı ekleme
    13. Dreamweaver ile form oluşturma
    14. Kullanıcılardan bilgi toplamak için formları kullanma
    15. Dreamweaver'da ColdFusion formları oluşturma ve etkinleştirme
    16. Web formları oluşturma
    17. Form öğeleri için geliştirilmiş HTML5 desteği
    18. Dreamweaver uygulamasını kullanarak bir form geliştirme
  17. Uygulamaları görsel olarak oluşturma
    1. Dreamweaver'da kalıp ve ayrıntı sayfaları oluşturma
    2. Arama ve sonuç sayfaları oluşturma
    3. Kayıt ekleme sayfası oluşturma
    4. Dreamweaver'da güncelleme kaydı sayfası oluşturma
    5. Dreamweaver'da kayıt silme sayfaları oluşturma
    6. Dreamweaver'da veritabanını değiştirmek için ASP komutları kullanma
    7. Kayıt sayfası oluşturma
    8. Oturum açma sayfası oluşturma
    9. Yalnızca yetkili kullanıcıların erişebileceği bir sayfa oluşturma
    10. Dreamweaver ile ColdFusion'daki klasörlerin güvenliğini sağlama
    11. Dreamweaver'da ColdFusion bileşenleri kullanma
  18. Web sitelerini test etme, önizleme ve yayımlama
    1. Sayfaları önizleme
    2. Dreamweaver web sayfalarını birden fazla cihazda önizleme
    3. Dreamweaver sitenizi test etme

 

Dreamweaver'da dosyalar oluşturun, açın, düzenleyin, kaydedin ve dönüştürün. Şablon oluşturun ve ilgili dosyaları açın.

Dreamweaver, çeşitli web belgeleriyle çalışmak için esnek bir ortam sağlar. HTML belgelerine ek olarak JavaScript, PHP ve Basamaklı Stil Sayfaları (CSS) gibi çeşitli metin tabanlı belgeler oluşturabilir ve açabilirsiniz.

Dreamweaver yeni bir belge oluşturmak için birkaç seçenek sağlar. Aşağıdakilerden herhangi birini oluşturabilirsiniz:

  • Yeni bir boş belge ya da şablon

  • Dreamweaver ile birlikte gelen ve önceden tasarlanmış sayfa mizanpajlarından birini temel alan bir belge (30'dan fazla CSS tabanlı sayfa mizanpajı da dahildir)

  • Varolan şablonlarınızdan birini temel alan bir belge

    Ayrıca belge tercihlerini de ayarlayabilirsiniz. Örneğin genelde tek bir belge türüyle çalışıyorsanız, oluşturacağınız yeni sayfalar için bu belge türünü varsayılan belge olarak ayarlayabilirsiniz.

    Tasarım görünümünde ya da Kod görünümünde meta etiketleri, belge başlığı ve arka plan renkleri gibi belge özelliklerini ve diğer birçok sayfa özelliğini kolayca tanımlayabilirsiniz.

Dreamweaver dosya türleri

Dreamweaver'da farklı dosya türleriyle çalışabilirsiniz. Çalışacağınız birincil tür dosya HTML dosyasıdır. HTML dosyaları (Köprü Metni İşaretleme Dili dosyaları) web sayfalarını tarayıcıda görüntüleme işlevini üstlenmiş etiket tabanlı dili içerir. HTML dosyalarını .html ya da .htm uzantısıyla kaydedebilirsiniz. Dreamweaver, dosyaları varsayılan olarak .html uzantısını kullanarak kaydeder.

Dreamweaver HTML5 tabanlı web sayfaları oluşturmanıza ve düzenlemenize izin verir. Ayrıca en baştan HTML5 sayfaları oluşturmak için başlangıç mizanpajları da mevcuttur.

Dreamweaver uygulamasıyla çalışırken kullanabileceğiniz diğer bazı yaygın kullanılan dosya türleri aşağıda verilmiştir:

CSS

Basamaklı Stil Sayfası dosyaları .css uzantılıdır. HTML içeriğini formatlamak ve çeşitli sayfa öğelerinin konumlandırmalarını kontrol etmek için kullanılır.

GIF

Graphics Interchange Format dosyaları .gif uzantılıdır. GIF formatı karikatürler, logolar, saydam alanlı grafikler ve animasyonlar için yaygın kullanılan bir web grafik formatıdır. GIF dosyaları en fazla 256 renk içerir.

JPEG

Joint Photographic Experts Group dosyaları (formatı oluşturan kuruluşun adı verilmiştir) .jpg uzantılıdır ve genellikle fotoğraf ya da yüksek renkli görüntü biçimindedir. JPEG formatı dijital ya da taranmış fotoğraflar, doku kullanan görüntüler, degrade renk geçişleri bulunan görüntüler ve 256'dan fazla renk gerektiren tüm görüntüler için en iyisidir.

XML

Genişletilebilir İşaretleme Dili dosyaları .xml uzantılıdır. XSL (Genişletilebilir Stil Sayfası Dili) kullanılarak formatlanabilecek ham formda veri içerir.

Yeni Belge iletişim kutusu

Yeni Belge iletişim kutusu PHP, XML ve SVG dahil olmak üzere tüm desteklenen belge dosya türlerini görüntüler.

Bu iletişim kutusundan ayrıca önceden tanımlanmış mizanpajlara, şablonlara ve çerçevelere erişebilirsiniz.

Not:

Tüm özellikli başlangıç mizanpajları dinamik web sitelerini desteklemek için oluşturulmuştur ve HTML-5 ile uyumludur.

Boş sayfa kullanarak bir HTML mizanpajı oluşturma

Önceden tasarlanmış CSS mizanpajı içeren bir sayfa oluşturabilirsiniz ya da tümüyle boş bir sayfa oluşturabilir ve sonra kendi mizanpajınızı oluşturabilirsiniz.

  1. Dosya > Yeni seçeneğini belirleyin.

  2. Yeni Belge kategorisinde Belge Türü sütunundan oluşturmak istediğiniz sayfa türünü seçin. Örneğin, düz bir HTML sayfası oluşturmak için HTML seçeneğini belirleyin.

  3. Belge Türü açılır menüsünden bir belge türü seçin. Çoğu durumda varsayılan seçim olan HTML5 seçeneğini kullanabilirsiniz.

  4. Oluşturmak istediğiniz sayfanın türüne göre ek seçenekler belirleyin.

    • Yok: Bu seçeneği çerçeve kullanmadan basit bir web sayfası oluşturmak istiyorsanız seçin.
    • Bootstrap: Bootstrap şablonları, Bootstrap çerçevesi kullanan önceden tanımlanmış mizanpajlardır. Bu seçeneği, Bootstrap çerçevesi kullanarak dinamik web sayfaları oluşturmak istiyorsanız seçin. Varsayılan olarak, bir Bootstrap 4.0.0 belgesi oluşturulur.
    Not:

    Dinamik web sayfaları oluşturmayı planlıyorsanız Bootstrap çerçevesini seçin.

  5. Çerçeve kullanmıyorsanız, bu durumda:

    • Belge Başlığı: Bu alana Belge Başlığını girdiğinizde Dreamweaver bu başlığı otomatik olarak belgenin <head> bölümüne ekler.
    • Belge Türü: Belge Türü açılır menüsünden bir belge türü seçin. Çoğu durumda varsayılan seçim olan, HTML5 seçeneğini kullanabilirsiniz.

    Belge Türü menüsündeki XHTML belge türü tanımlamalarından birini seçtiğinizde, sayfanız XHTML uyumlu olur. Örneğin menüden XHTML 1.0 Transitional ya da XHTML 1.0 Strict'i seçerek bir HTML belgesini XHTML uyumlu yapabilirsiniz. XHTML (Genişletilebilir Köprü Metni İşaretleme Dili), HTML'nin bir XML uygulaması olarak yeniden formüle edilmiş halidir. XHTML kullanmak genellikle XML'nin avantajlarını ve aynı zamanda web belgelerinizin geriye ve ileriye dönük uyumluluğunu sağlar.

    Not:

    XHTML hakkında daha fazla bilgi için XHTML 1.1 - Modül Tabanlı XHTML (www.w3.org/TR/xhtml11/) ve XHTML 1.0 (www.w3c.org/TR/xhtml1/) özellikleriyle birlikte web tabanlı dosyalar için XHTML doğrulayıcı sitelerinin (http://validator.w3.org/) ve yerel dosyalar (http://validator.w3.org/file-upload.html) özelliklerini içeren World Wide Web Konsorsiyumu (W3C) web sitesine bakın.

    • CSS Ekle: Sayfaya mevcut bir CSS mizanpajı ekleyin.  Bunu yapmak için CSS Dosyası Ekle bölmesinin yanındaki Stil Sayfası Ekle simgesini  tıklatın ve bir CSS stil sayfası seçin.
    Çerçeve kullanmadan yeni bir HTML sayfası oluşturma
    Çerçeve kullanmadan yeni bir HTML sayfası oluşturma

    Photoshop kompozisyonunu temel alan yeni bir sayfa oluşturmak isterseniz Photoshop kompozisyonlarınızdan sayfa oluşturmak için Extract'i kullanın. 

    Bu seçeneği belirlemek, bir PSD dosyası yükleyebileceğiniz ve HTML sayfanızı oluşturmaya başlayacağınız Extract panelini açar.

  6. Bootstrap çerçevesini kullanarak dinamik bir web sayfası oluşturmak istiyorsanız:

    • Bootstrap CSS: Yeni bir Bootstrap CSS oluşturma veya mevcut bir CSS dosyasını kullanma seçeneği. Mevcut bir CSS dosyası kullanıyorsanız dosya yolunu belirtin. CSS dosyasının sitenizin kök klasörü içinde olduğundan emin olun.
    • CSS Ekle: Sayfaya mevcut bir CSS mizanpajı ekleyin.  Bunu yapmak için CSS Dosyası Ekle bölmesinin yanındaki Stil Sayfası Ekle simgesini  tıklatın ve bir CSS stil sayfası seçin.
    • Önceden oluşturulmuş bir mizanpaj ekle: Mizanpajınız zaten varsa bu seçeneği belirleyin. Izgarayı ve kesme noktası değerlerini düzenlemek için Özelleştir’i tıklatın.
    Bootstrap çerçevesini kullanarak yeni bir HTML sayfası oluşturma
    Bootstrap çerçevesini kullanarak yeni bir HTML sayfası oluşturma

    Photoshop kompozisyonunu temel alan yeni bir sayfa oluşturmak isterseniz Photoshop kompozisyonlarınızdan sayfa oluşturmak için Extract'i kullanın. 

    Bu seçeneği belirlemek, bir PSD dosyası yükleyebileceğiniz ve HTML sayfanızı oluşturmaya başlayacağınız Extract panelini açar.

  7. Belge türü, kodlama ve dosya uzantısı gibi varsayılan belge tercihlerini ayarlamak istiyorsanız Tercihler'i tıklatın.

  8. Oluştur düğmesini tıklatın.

  9. Yeni belgeyi kaydedin (Dosya > Kaydet).

  10. Görüntülenen iletişim kutusunda, dosyayı kaydetmek istediğiniz klasöre gidin.
    Not:

    Dosyayı bir Dreamweaver sitesine kaydetmeniz akıllıca olur.

  11. Dosya Adı kutusuna dosya için bir ad yazın.

    Dosya ve klasör adlarında boşluk ve özel karakterler kullanmayın ve dosya adını sayıyla başlatmayın. Özellikle, uzak bir sunucuya koymayı planladığınız dosyaların adlarında özel karakterler (örneğin é, ç veya ¥) ya da noktalama işaretleri (örneğin iki nokta üst üste, bölme çizgisi ya da nokta) kullanmayın; birçok sunucu yükleme sırasında bu karakterleri değiştirir ve bu da dosyalara oluşturulmuş bağların kopmasına neden olur.

Boş şablon oluşturma

Dreamweaver şablonları oluşturmak için Yeni Belge iletişim kutusunu kullanabilirsiniz. Şablonlar varsayılan olarak sitenizin Şablonlar klasörüne kaydedilir.

Not:

Şablon oluşturmak için öncelikle bir site oluşturmalısınız. Siteler ve site oluşturma hakkında daha fazla bilgi için bkz. Dreamweaver siteleri hakkında.

  1. Dosya > Yeni seçeneğini belirleyin.

  2. Yeni Belge iletişim kutusunda Site Şablonları kategorisini seçin.

  3. Belge Türü açılır menüsünden bir belge türü seçin. Çoğu durumda varsayılan olarak seçili olan XHTML 1.0 Geçişli seçeneğini değiştirmezsiniz.

    DocType (DTD) menüsündeki XHTML belge türü tanımlamalarından birini seçtiğinizde sayfanız XHTML uyumlu olur. Örneğin menüden XHTML 1.0 Transitional ya da XHTML 1.0 Strict'i seçerek bir HTML belgesini XHTML uyumlu yapabilirsiniz. XHTML (Genişletilebilir Köprü Metni İşaretleme Dili), HTML'nin bir XML uygulaması olarak yeniden formüle edilmiş halidir. XHTML kullanmak genellikle XML'nin avantajlarını ve aynı zamanda web belgelerinizin geriye ve ileriye dönük uyumluluğunu sağlar.

    Not:

    XHTML hakkında daha fazla bilgi için XHTML 1.1 - Modül Tabanlı XHTML (www.w3.org/TR/xhtml11/) ve XHTML 1.0 (www.w3c.org/TR/xhtml1/) özellikleriyle birlikte web tabanlı dosyalar için XHTML doğrulayıcı sitelerinin (http://validator.w3.org/) ve yerel dosyalar (http://validator.w3.org/file-upload.html) özelliklerini içeren World Wide Web Konsorsiyumu (W3C) web sitesine bakın.

  4. Şablonu düzenlediğinizde sayfanın otomatik olarak güncelleştirilmesini istiyorsanız Şablon Değiştiğinde Sayfayı Güncelleştir seçeneğini belirleyin.

  5. Oluştur düğmesini tıklatın.

  6. Yeni belgeyi kaydedin (Dosya > Kaydet). Şablona henüz düzenlenebilir bölgeler eklemediyseniz belgede düzenlenebilir bölge olmadığını belirten bir iletişim kutusu görüntülenir. İletişim kutusunu kapatmak için Tamam'ı tıklatın.

  7. Farklı Kaydet iletişim kutusunda şablonun kaydedileceği bir site seçin.
  8. Dosya Adı kutusuna yeni şablon için bir ad yazın. Şablonun adına dosya uzantısı eklemeniz gerekmez. Kaydet'i tıklattığınızda, sitenizin Şablonlar klasörüne kaydedilen yeni şablona .dwt uzantısı eklenir.

    Dosya ve klasör adlarında boşluk ve özel karakterler kullanmayın ve dosya adını sayıyla başlatmayın. Özellikle, uzak bir sunucuya koymayı planladığınız dosyaların adlarında özel karakterler (örneğin é, ç veya ¥) ya da noktalama işaretleri (örneğin iki nokta üst üste, bölme çizgisi ya da nokta) kullanmayın; birçok sunucu yükleme sırasında bu karakterleri değiştirir ve bu da dosyalara oluşturulmuş bağların kopmasına neden olur.

Şablonu temel alan sayfa oluşturma

Mevcut şablonlarınızdan veya Dreamweaver'ın başlangıç şablonlarından birini kullanarak yeni bir belge seçebilir, önizleyebilir ve oluşturabilirsiniz. Dreamweaver tarafından tanımlanmış sitelerinizin herhangi birinden şablon seçmek için Yeni Belge iletişim kutusunu kullanabilirsiniz ya da varolan bir şablondan yeni belge oluşturmak için Varlıklar paneli öğesini kullanabilirsiniz.

Şablonu temel alan belge oluşturma

  1. Dosya > Yeni seçeneğini belirleyin.

  2. Yeni Belge iletişim kutusunda, Şablondan Sayfa kategorisini seçin.

  3. Site sütununda, kullanmak istediğiniz şablonu içeren Dreamweaver sitesini seçin ve ardından sağdaki listeden bir şablon belirleyin.

  4. Bu sayfanın temel aldığı şablonda yaptığınız her değişiklikte sayfanın güncelleştirilmesini istemiyorsanız Şablon Değiştiğinde Sayfayı Güncelleştir seçeneğinin işaretini kaldırın.

  5. Belge türü, kodlama ve dosya uzantısı gibi varsayılan belge tercihlerini ayarlamak istiyorsanız Tercihler'i tıklatın.

  6. Daha fazla sayfa tasarımı içeriği yükleyebileceğiniz Dreamweaver Exchange uygulamasını açmak istiyorsanız Daha Fazla İçerik Al'ı tıklatın.

  7. Oluştur'u tıklatın ve belgeyi kaydedin (Dosya > Kaydet).

Varlıklar panelinde şablondan belge oluşturma

  1. Açık değilse Varlıklar panelini açın (Pencere > Varlıklar).

  2. Varlıklar panelinde, mevcut sitenizdeki şablonların listesini görüntülemek için soldaki Şablonlar simgesini  tıklatın.

    Not:

    Uygulamak istediğiniz şablonu yeni oluşturduysanız, şablonu görmek için Yenile düğmesini tıklatmanız gerekebilir.

  3. Uygulamak istediğiniz şablonu sağ tıklatın (Windows) veya Control tuşu basılıyken tıklatın (Macintosh), ardından Şablondan Yeni seçeneğini belirleyin.

    Belgeniz Belge penceresinde açılır.

  4. Belgeyi kaydedin.

Dreamweaver başlangıç şablonunu temel alan bir sayfa oluşturma

Dreamweaver, mobil uygulamalara yönelik profesyonel olarak geliştirilmiş çeşitli başlangıç dosyası ile birlikte gelir. Bu örnek dosyaları, sitenizdeki sayfaları tasarlamak için başlangıç noktaları olarak kullanabilirsiniz.

Başlangıç şablonunu temel alan bir belge oluştururken Dreamweaver, dosyanın bir kopyasını oluşturur. Böylece başlangıç dosyasının üzerine yazmazsınız.

Yeni Belge iletişim kutusunda örnek dosyayı önizleyebilir ve belgenin tasarım öğelerinin kısa bir açıklamasını okuyabilirsiniz.

  1. Dosya > Yeni seçeneğini belirleyin.

  2. Yeni Belge iletişim kutusunda Başlangıç Şablonları kategorisini seçin.

    Dreamweaver'daki başlangıç şablonları
    Dreamweaver'daki başlangıç şablonları

    Farklı seçenekleri belirledikçe, örnek sayfa ayrıntılarını ve görselleştirmesini panelin sağında görürsünüz.

  3. Oluştur düğmesini tıklatın.

    Yeni belge ve ilgili tüm dosyalar Belge penceresinde açılır.

  4. Belgeyi kaydedin (Dosya > Kaydet).

Farklı kodlama dilleri için yeni kod dosyaları oluşturma

Dreamweaver'da bir dizi kodlama dili için kod dosyaları oluşturabilirsiniz.

Dreamweaver'da kodlama desteği hakkında daha fazla bilgi için bkz. Dreamweaver'da kodlama hakkında.

Dreamweaver'da yeni bir kod dosyası oluşturmak için aşağıdaki talimatları kullanın:

  1. Dosya > Yeni Belge'yi seçin.

  2. Belge Türü altından, oluşturmak istediğiniz kod dosyasını seçin.

  3. Oluşturmak istediğiniz belge türünü (PHP dosyası gibi) Belge Türü sütunundan seçin.

    Yeni bir PHP sayfası oluşturma
    Yeni bir PHP sayfası oluşturma

  4. Seçtiğiniz dosya türüne bağlı olarak, belge oluştururken ek seçenekler kullanılabilir. 

    Örneğin, PHP dosyası oluşturuyorsanız Belge Türü seçeneklerini ve bazı CSS seçeneklerini seçebilirsiniz.

  5. Oluştur düğmesini tıklatın. Ardından belgeyi kaydedin (Dosya > Kaydet).

Belgeleri kaydetme ve dönüştürme

Belgeyi geçerli adını ve konumunu kullanarak kaydedebilir veya farklı bir ad ve konumla belgenin kopyasını kaydedebilirsiniz.

Not:

Dosyaları adlandırırken, dosya ve klasör adlarında boşluk ve özel karakter kullanmaktan kaçının. Özellikle, uzak bir sunucuya koymayı planladığınız dosyaların adlarında özel karakterler (örneğin é, ç veya ¥) ya da noktalama işaretleri (örneğin iki nokta üst üste, bölme çizgisi ya da nokta) kullanmayın; birçok sunucu yükleme sırasında bu karakterleri değiştirir ve bu da dosyalara oluşturulmuş bağların kopmasına neden olur. Ayrıca, dosya adlarına sayı ile başlamayın.

Belge kaydetme

  1. Aşağıdakilerden birini yapın:
    • Diskteki geçerli sürümün üzerine yazmak ve yaptığınız değişiklikleri kaydetmek için Dosya > Kaydet seçeneğini belirleyin.
    • Dosyayı farklı bir klasöre veya farklı bir ad kullanarak kaydetmek için Dosya > Farklı Kaydet'i seçin.
  2. Görünen Farklı Kaydet iletişim kutusunda, dosyayı kaydetmek istediğiniz klasöre gidin.
  3. Dosya Adı metin kutusuna dosya için bir ad yazın.

  4. Dosyayı kaydetmek için Kaydet'i tıklatın.

Açık tüm belgeleri kaydetme

  1. Dosya > Tümünü Kaydet seçeneğini belirleyin.

  2. Kaydedilmemiş açık belge varsa Farklı Kaydet iletişim kutusu kaydedilmemiş her belge için görüntülenir.

    Görüntülenen iletişim kutusunda, dosyayı kaydetmek istediğiniz klasöre gidin.

  3. Dosya Adı kutusuna dosya için bir ad yazın ve Kaydet'i tıklatın.

Belgenin en son kaydedilen sürümüne geri dönme

  1. Dosya > Geri Dön seçeneğini belirleyin.

    Değişikliklerinizi atmak ve kaydedilen önceki sürüme dönmek isteyip istemediğinizi soran bir iletişim kutusu görüntülenir.

  2. Önceki sürüme geri dönmek için Evet'i; değişikliklerinizi korumak için Hayır'ı tıklatın.

    Not:

    Bir belgeyi kaydedip ardından Dreamweaver uygulamasından çıkarsanız Dreamweaver'ı yeniden başlattığınızda önceki sürüme geri dönemezsiniz.

Varsayılan belge türünü ve kodlama tercihlerini ayarlama

Sitenizdeki sayfaların çoğu belli bir dosya türündeyse (HTML, PHP veya JavaScript gibi), yeni belgeleri belirttiğiniz dosya türünde otomatik olarak oluşturan belge tercihlerini ayarlayabilirsiniz.

  1. Düzen > Tercihler (Windows) veya Dreamweaver > Tercihler (Macintosh) seçeneğini belirleyin.

    Not:

    Yeni bir belge oluştururken yeni belge tercihlerini ayarlamak için Yeni Belge iletişim kutusundaki Tercihlerdüğmesini de tıklatabilirsiniz.

  2. Soldaki kategori listesinden Yeni Belge'yi tıklatın.

  3. Tercihleri gerektiği şekilde ayarlayın ya da değiştirin ve kaydetmek için Tamam'ı tıklatın.

    Varsayılan Belge

    Oluşturduğunuz sayfalar için kullanılacak bir belge türü seçin.

    Varsayılan Uzantı

    Oluşturduğunuz yeni HTML sayfaları için tercih ettiğiniz dosya uzantısını belirtin (.htm ya da .html).

    Not: Bu seçenek diğer dosya türleri için devre dışı bırakılmıştır.

    Default Document Type (DDT - Varsayılan Belge Türü)

    Yeni sayfaları XHTML uyumlu yapmak için XHTML belge türü tanımlamalarından (DTD) birini seçin. Örneğin menüden XHTML 1.0 Transitional ya da XHTML 1.0 Strict'i seçerek bir HTML belgesini XHTML uyumlu hale getirebilirsiniz.

    Varsayılan Kodlama

    Yeni sayfa oluşturulduğunda ve herhangi bir kodlama belirtmeyen bir belge açıldığında kullanılacak kodlamayı belirtin.

    Belge kodlaması olarak Unicode (UTF‑8) kodlamasını seçerseniz varlık kodlaması gerekmez çünkü UTF-8 tüm karakterleri güvenli şekilde temsil edebilir. Başka bir belge kodlaması seçerseniz belirli karakterleri temsil etmek için varlık kodlaması gerekebilir. Karakter varlıkları hakkında daha fazla bilgi için bkz. www.w3.org/TR/REC-html40/sgml/entities.html.

    Varsayılan kodlama olarak Unicode (UTF‑8) kodlamasını seçerseniz, Unicode İmzası İçer (BOM) seçeneğini işaretleyerek belgeye bir Byte Order Mark (BOM) ekleyebilirsiniz.

    BOM bir metin dosyasının başında bulunan ve dosyayı Unicode olarak tanımlayan ve ayrıca izleyen baytların bayt sırasını da tanımlayan 2-4 bayttır. UTF‑8'in bayt sırası olmadığı için UTF‑8 BOM eklemek isteğe bağlıdır. UTF‑16 ve UTF‑32 için bu gereklidir.

    Unicode Normalleştirme Formu

    Varsayılan kodlama olarak Unicode (UTF-8) seçeneğini belirlerseniz bu seçeneklerden birini işaretleyin.

    Dört adet Unicode Normalleştirme Formu vardır. World Wide Web için Karakter Modeli'nde en yaygın olarak kullanılan olduğundan, en önemlisi Normalizasyon Formu C'dir. Adobe bütünlük sağlamak için diğer üç Unicode Normalleştirme Formunu da sağlar.

    Ctrl+N Tuşlarına Basıldığında Yeni Belge İletişim Kutusunu Göster

    Tuş komutunu kullandığınızda varsayılan belge türünde bir belgeyi otomatik olarak oluşturmak için bu seçeneğin işaretini kaldırın (Macintosh için “Command+N”).

    Unicode'da görsel olarak benzer ancak belgede farklı yollarla saklanabilecek karakterler vardır. Örneğin, “ë” (e‑umlaut) tek bir karakter olarak, “e‑umlaut” veya iki karakter olarak, “normal Latin e” + “birleştirilen iki nokta” olarak görüntülenebilir. Unicode birleştirme karakteri, önceki karakterle kullanılan karakterdir, böylece çift nokta “Latin e” harfinin üzerinde görüntülenir. Her iki form da aynı görsel tipografiyle sonuçlanır ancak dosyaya kaydedilen her form için farklıdır.

    Normalizasyon, farklı formlarda kaydedilebilecek tüm karakterlerin aynı form kullanılarak kaydedilmesini sağlamak için yapılan işlemdir. Diğer bir deyişle, belgedeki tüm “ë” karakterleri tek bir “e‑çift nokta” veya “e” + “birleştirilen iki nokta” olarak kaydedilir. Bunlar, belgede her iki formda da kaydedilmez.

    Unicode Normalleştirme ve kullanılabilecek belirli formlar hakkında daha fazla bilgi için www.unicode.org/reports/tr15 adresindeki Unicode web sitesine bakın.

Varolan belgeleri açma ve düzenleme

Dreamweaver uygulamasında oluşturulmuş olsun ya da olmasın, varolan bir web sayfasını ya da metin tabanlı belgeyi açabilir ve Tasarım görünümünde veya Kod görünümünde düzenleyebilirsiniz.

Açtığınız belge HTML belgesi olarak kaydedilmiş bir Microsoft Word dosyası ise Word'ün HTML dosyalarına eklediği yabancı işaretleme etiketlerini silmek için Araçlar > Word HTML'sini Temizle komutunu kullanabilirsiniz.

Microsoft Word tarafından oluşturulmayan HTML ya da XHTML'leri temizlemek için Araçlar > HTML'yi temizle komutunu kullanın. Daha fazla bilgi için bkz. Microsoft Word HTML dosyalarını temizleme.

Ayrıca JavaScript dosyaları, XML dosyaları, CSS stil sayfaları ya da sözcük işlemciler veya metin düzenleyiciler tarafından kaydedilmiş metin dosyaları gibi HTML olmayan metin dosyalarını da açabilirsiniz.

  1. Dosya > seçeneğini belirleyin.

    Not:

    Dosyaları açmak için Dosyalar panelini de kullanabilirsiniz.

  2. Açmak istediğiniz dosyaya gidin ve dosyayı seçin.
    Not:

    Henüz yapmadıysanız, başka bir konumdan açmak yerine Dreamweaver sitesinde açmayı ve düzenlemeyi planladığınız dosyaları düzenlemek yararlı olacaktır. Dreamweaver siteleri hakkında daha fazla bilgi için bkz. Dreamweaver siteleri hakkında.

  3. 'ı tıklatın.

    Belgeniz Belge penceresinde açılır. JavaScript, metin ve CSS Stil Sayfaları varsayılan olarak Kod görünümünde açılır. Dreamweaver uygulamasında çalışırken belgeyi güncelleştirebilir ve dosyadaki değişiklikleri kaydedebilirsiniz.

Dreamweaver, ana belgenizle ilgili dosyaları ana belgenin odağını kaybetmeden görüntülemenize olanak tanır. Örneğin, ana belgeye eklenmiş CSS ve JavaScript dosyalarına sahipseniz Dreamweaver, bu ilgili belgeleri Belge penceresinde, ana belgeyi görünür şekilde tutarak görüntülemenize olanak tanır.

Dinamik olarak ilgili dosyalar hakkında daha fazla bilgi için bkz. Dinamik Olarak İlgili Dosyaları Açma.

Not:

HTML dosyalarıyla çalışırken dosyaya gitmeden ilgili CSS, JavaScript veya PHP dosyalarında hızlı değişiklikler yapmak isterseniz Hızlı Düzenleme'yi kullanabilirsiniz. Daha fazla bilgi için bkz. Hızlı Düzenleme.

Varsayılan olarak Dreamweaver, İlgili Dosyalar araç çubuğundaki ana belgeyle ilgili tüm dosyaların adlarını ana belge başlığının altında görüntüler. Araç çubuğundaki düğmelerin sırası, ana belge içinde bulunan ilgili dosyaların sırasını takip eder.

Not:

İlgili bir dosya kayıpsa, Dreamweaver yine de İlgili Dosyalar araç çubuğunda karşılık gelen düğmeyi görüntüler. Düğmeyi tıklatsanız da Dreamweaver bir şey görüntülemez.

Dreamweaver, şu tür ilgili dosyaları destekler:

  • İstemci tarafı komut dosyaları
  • Sunucu Tarafı İçerikleri
  • Harici CSS stil sayfaları (iç içe stil sayfaları dahil)

Aşağıdakilerden birini yapın:

  • Belgenin üst kısmındaki İlgili Dosyalar araç çubuğunda, açmak istediğiniz ilgili dosyanın adını tıklatın.

  • İlgili Dosyalar araç çubuğunda, açmak istediğiniz ilgili dosyanın adını sağ tıklatın ve içerik menüsünden Ayrı Dosya Olarak Aç'ı seçin. Bu yöntemi kullanarak ilgili bir dosya açtığınızda, ana belge aynı anda görünür kalmaz.

  1. Ekleme noktasını, ilgili dosyanın etkilediğini bildiğiniz bir satır üzerine veya alana taşıyın.

  2. Kod Gezgini göstergesinin görünmesini bekleyin ve ardından Kod Gezgini'ni açmak için göstergeyi tıklatın.

  3. Kod Gezgini'ndeki öğeler hakkında daha fazla bilgi görüntülemek için üzerlerine gelin. Örneğin, belirli bir CSS renk özelliğini değiştirmek istiyor, ancak hangi kural içinde bulunduğunu bilmiyorsanız; Kod Gezgini'nde varolan kuralların üzerine gelerek özelliği bulabilirsiniz.

  4. Karşılık gelen ilgili dosyayı açmak için ilgilendiğiniz öğeyi tıklatın.

Ana belgenin kaynak koduna dönme

  1. İlgili Dosyalar araç çubuğunda Kaynak Kodu düğmesini tıklatın.

Tasarım görünümünden veya Kod ve Tasarım görünümlerinden (Bölünmüş görünüm) ilgili bir sayfa açtığınızda ilgili sayfa Bölünmüş görünümde görüntülenir.

Görünüm > Böl'ü seçebilir ve Bölünmüş görünümü özelleştirmek istiyorsanız farklı Bölünmüş görünüm seçeneklerinden birini belirleyebilirsiniz.

İlgili dosyaları yalnızca Kod görünümünde görmek istiyorsanız araç çubuğunun üst kısmında Kod'u seçin.

Not:

Standart Kod görünümü ilgili Belgeleri, ana belgenin kaynak koduyla aynı anda görüntülemenize izin vermez.

Not:

Görüntüleme seçeneğindeki Kod Görünümü, ana belgenin kaynak kodunu ifade eder. Örneğin, Görünüm > Kod Görünümü Üstte öğelerini seçtiğinizde, Dreamweaver, ana belgenin kaynak kodunu Belge penceresinin üst yarısında görüntüler. Görünüm > Kod Görünümü Solda öğelerini seçtiğinizde ise Dreamweaver, ana belgenin kaynak kodunu Belge penceresinin sol yarısında görüntüler.

Varsayılan olarak bir HTML dosyası açtığınızda Dreamweaver ilgili dosyaları ayrı sekmelerde görüntüler. Bu işlevi devre dışı bırakmak isterseniz bunu Tercihler panelinden yapabilirsiniz.

  1. Düzen > Tercihler (Windows) veya Dreamweaver > Tercihler (Macintosh) seçeneğini belirleyin.

  2. Genel kategorisinde, İlgili Dosyaları Etkinleştir öğesinin seçimini kaldırın.

Dinamik Olarak İlgili Dosyalar özelliği, İlgili Dosyalar özelliğinin işlevselliğini, dinamik sayfaların ilgili dosyalarını İlgili Dosyalar araç çubuğunda görmenize izin vererek genişletir. Belirli bir biçimde, Dinamik Olarak İlgili Dosyalar özelliği, WordPress, Drupal ve Joomla! gibi popüler açık kaynaklı PHP İçerik Yönetimi Sistemi (CMS) çerçeveleri için çalışma zamanı kodu üretmek üzere gereken birçok içeriği görmenize izin verir.

Dinamik Olarak İlgili Dosyalar özelliğini kullanmak için, WordPress, Drupal veya Joomla! çalıştıran yerel veya uzak bir PHP uygulama sunucusuna erişiminizin olması gerekir. Sayfaları test etmek için kullanılan yaygın uygulamalardan biri localhost PHP uygulama sunucusu kurmak ve sayfaları yerel olarak test etmektir.

Sayfaları test etmeden önce şu adımları gerçekleştirmeniz gerekir:

  • Bir Dreamweaver sitesi kurun ve Site Kurulumu iletişim kutusunda Web URL'si metin kutusunu doldurduğunuzdan emin olun.

  • Bir PHP uygulama sunucusu kurun.

    Not: Dreamweaver'da Dinamik Olarak İlgili Dosyalarla çalışmayı denemeden önce sunucu çalışır durumda olmalıdır.

  • Uygulama sunucusunda WordPress, Drupal veya Joomla! çerçevesini yükleyin. Daha fazla bilgi için bkz:

  • Dreamweaver'da CMS dosyalarınızı indireceğiniz ve düzenleyeceğiniz yerel bir klasör tanımlayın.

  • Uzak ve test klasörünüz olarak yüklü WordPress, Drupal veya Joomla dosyalarının konumunu tanımlayın.

  • CMS dosyalarını uzak klasörünüzden indirin (alın).

Dinamik Olarak İlgili Dosyalarla ilişkili bir sayfa açtığınızda, Dreamweaver, dosyaları otomatik olarak keşfedebilir veya dosyaları el ile keşfetmenize izin verir (sayfanın üstündeki Bilgi çubuğundaki bir bağı tıklatarak yapabilirsiniz). Varsayılan ayar el ile keşfetmedir.

  1. Düzen > Tercihler (Windows) veya Dreamweaver > Tercihler (Macintosh OS) seçeneğini belirleyin.

  2. Genel kategorisinde İlgili Dosyaları Etkinleştir seçeneğinin belirlendiğinden emin olun.

  3. Dinamik Olarak İlgili Dosyalar açılır menüsünden El İle veya Otomatik Olarak'ı seçin. Ayrıca keşfetme özelliğini Devre Dışı öğesini seçerek tamamen devre dışı bırakabilirsiniz.

  1. Dinamik Olarak İlgili Dosyalarla ilişkisi olan bir sayfa açın (örneğin, bir WordPress, Drupal veya Joomla! sitesinin site kökü index.php) sayfası.

  2. Dinamik Olarak İlgili Dosyaların keşfi el ile (varsayılan) ayarlanmışsa, Belge penceresinde sayfanın üzerinde görüntülenen Bilgi çubuğundaki Keşfet bağını tıklatın.

    Dinamik Olarak İlgili Dosyaların keşfi otomatik olarak etkinleştirildiyse, bir Dinamik Olarak İlgili Dosyalar listesi, İlgili Dosyalar araç çubuğunda görüntülenir.

İlgili ve Dinamik Olarak İlgili Dosyaların İlgili Dosyalar araç çubuğunda sırası şöyledir:

  • Statik ilgili dosyalar (herhangi bir dinamik işlem gerektirmeyen ilgili dosyalar)
  • Dinamik yol sunucusuna dahil edilen dosyalara eklenmiş harici ilgili dosyalar (.css ve .js dosyaları)
  • Dinamik yol sunucusuna dahil edilen dosyalar (.php, .inc ve modül dosyaları)

İlgili Dosyalar ve Dinamik Olarak İlgili Dosyalar genellikle çok çeşitli olabileceğinden, Dreamweaver çalışmak istediğiniz dosyaların konumunu tam olarak bulabilmeniz için İlgili Dosyaları filtrelemenize izin verir.

  1. Kendisiyle ilişkili İlgili Dosyaları olan bir sayfa açın.

  2. Gerekirse Dinamik Olarak İlgili Dosyaları keşfedin.

  3. İlgili Dosyalar araç çubuğunun sağ tarafındaki İlgili Dosyaları Filtrele simgesini tıklatın.

  4. İlgili Dosyalar araç çubuğunda görmek istediğiniz dosya türlerini seçin. Varsayılan olarak, Dreamweaver tüm İlgili Dosyaları seçer.

  5. Özel bir filtre oluşturmak için İlgili Dosyaları Filtrele simgesini tıklatın ve Özel Filtre seçeneğini belirleyin.

    Özel Filtre iletişim kutusu yalnızca tam dosya adlarının (style.css), dosya uzantılarının (.php) ve joker karakter ifadelerinin yıldız işareti kullanılarak (*menu*) filtrelenmesine izin verir. Her ifadeyi noktalı virgül ile ayırarak birden fazla joker karakter ifadesini filtreleyebilirsiniz (örneğin, style.css;*.js;*tpl.php).

Not:

Filtre ayarları dosyayı kapattığınızda gider.

Microsoft Word HTML dosyalarını temizleme

Microsoft Word (Microsoft Word 97 veya sonraki sürümler) tarafından HTML dosyaları olarak kaydedilen belgeleri açabilir ve Word tarafından oluşturulan yabancı HTML kodunu silmek için Araçlar > Word HTML'sini Temizle komutunu kullanabilirsiniz.

Dreamweaver uygulamasının kaldırdığı kod, Word tarafından öncelikle belgeleri biçimlendirmek ve Word'de görüntülemek için kullanılır ve HTML dosyasını görüntülemek için gerçekten gerekli değildir.

HTML dosyasını temizlediğinizde HTML belgesini Word'de tekrar açamayabilirsiniz, bu nedenle özgün Word (.doc) dosyanızın yedek bir kopyasını oluşturun.

Not:

Microsoft Word tarafından oluşturulmayan HTML ya da XHTML'leri temizlemek için Araçlar > HTML'yi temizle komutunu kullanın.

  1. Microsoft Word belgenizi HTML dosyası olarak kaydedin.
    Not:

    Windows'ta, paylaşım ihlalini önlemek için dosyayı Word'de kapatın.

  2. HTML dosyasını Dreamweaver'da açın.

    Word tarafından oluşturulan HTML kodunu görüntülemek için Kod görünümüne (Görünüm > Kod) geçin.

  3. Araçlar > Word HTML'sini Temizle seçeneğini belirleyin.

    Not:

    Dreamweaver, dosyayı kaydetmek için hangi Word sürümünün kullanıldığını belirleyemezse, doğru sürümü açılır menüden seçin.

  4. Temizleme işlemiyle ilgili seçenekleri işaretleyin (ya da işaretlerini kaldırın). Girdiğiniz tercihler varsayılan temizleme ayarları olarak kaydedilir.

    Dreamweaver, temizleme ayarlarını HTML belgesine uygular ve değişikliklere ilişkin bir günlük görünür (iletişim kutusunda bu seçeneğin işaretini kaldırmadıysanız).

    Microsoft Word HTML temizleme seçenekleri
    Microsoft Word HTML temizleme seçenekleri

    Word'e Özgü Tüm İşaretlemeyi Kaldır

    HTML etiketlerinden XML'yi, belgenin başlığındaki Word özel meta veri ve bağ etiketlerini, Word XML işaretlemesini, koşullu etiketler ve bunların içeriğini, stillerden boş paragrafları ve kenar boşluklarını kaldırma da dahil olmak üzere, Microsoft Word'e özgü tüm HTML'yi kaldırır. Ayrıntılı sekmesini kullanarak bu seçeneklerden her birini ayrı ayrı seçebilirsiniz.

    CSS'yi Temizle

    Mümkün olduğunda satır içi CSS stillerini (üst stilin özellikleri aynı olduğunda), “mso” ile başlayan satır niteliklerini, CSS olmayan stil bildirimlerini, tablolardan CSS stil niteliklerini ve kullanılmayan tüm stil tanımlamalarını başlıktan kaldırma da dahil olmak üzere, Word'e özgü tüm CSS'yi kaldırır. Ayrıntılı sekmesini kullanarak bu seçeneği daha da özelleştirebilirsiniz.

    <font> Etiketlerini Temizle

    Varsayılan gövde metni boyutunu 2 HTML metnine dönüştürerek HTML etiketlerini kaldırır.

    Geçersiz Şekilde Yuvalanmış Etiketleri Onar

    Word tarafından paragraf ve başlık (blok düzeyi) etiketleri dışına eklenmiş font işaretleme etiketlerini kaldırır.

    Kaynak Formatını Uygula

    HTML Formatı tercihlerinde ve SourceFormat.txt dosyasında belirttiğiniz kaynak biçimlendirme seçeneklerini belgeye uygular.

    Tamamlandığında Günlüğü Göster

    Temizleme işlemi biter bitmez belgede yapılan değişiklikler hakkında ayrıntıların olduğu bir uyarı kutusu görüntüler.

  5. Tamam'ı tıklatın ya da Word'e Özgü Tüm İşaretlemeyi Kaldır ve CSS'yi Temizle seçeneklerini daha fazla özelleştirmek istiyorsanız Ayrıntılı sekmesini tıklatın ve ardından Tamam'ı tıklatın.

 Adobe

Daha hızlı ve daha kolay yardım alın

Yeni kullanıcı mısınız?