查看如果圖稿貼上速度變慢,或您發現 Illustrator 檔案內包含未預期的資料時的解決辦法。

問題

當您在 Illustrator 檔案內或是在檔案之間貼上圖稿,執行動作的速度比預期來得慢,或是目標文件中出現非預期的全域物件 (例如色票、符號及筆刷)。

解決方案

視您所使用的 Illustrator 版本而定,請嘗試以下一個或更多的解決方案。

選擇您的 Illustrator 版本:

修正不良的增校模組全域物件名稱 (Mac 和 Windows;CS6 和 CC)

  1. 請確定您正在使用最新版本的 Illustrator。請選擇「說明 > 更新」,或透過 Creative Cloud 桌面應用程式更新 Illustrator。

  2. 下載以下 ZIP 檔,並解壓縮出檔案中包含的指令碼 (JSX 檔)。

    下載

  3. 啟動 Illustrator ,然後執行指令碼: 選擇「檔案選單 > 指令碼 > 其他指令碼」或將指令碼拖曳至 Illustrator 中,以執行指令碼。接著您會看到「已經開啟 fixBadPluginGlobalObjectNames 偏好設定」訊息。

  4. 如果您看到「已經關閉 fixBadPluginGlobalObjectNames 偏好設定」訊息,請重新執行指令碼。

  5. 結束並重新啟動 Illustrator,然後開啟受影響的 Illustrator 檔案,確認問題已修正。

CS5 及更早版本的解決方案

需要以下兩種解決方案之一來解決 Illustrator CS5 及更早版本的問題。如果第一種解決方案無法修正問題,請嘗試第二種方案。

解決方案 1 (CS5 及更早版本): 啟用內容復原模式

  1. 結束 Illustrator。

  2. 找到 Adobe Illustrator 偏好設定檔案。例如,Illustrator CS5 的偏好設定檔案位於以下位置:

    • Mac OS: /[使用者]/Library/Preferences/Adobe Illustrator CS5 Settings/[語言]/
    • Windows 7/Vista: Users/[使用者]/AppData/Roaming/Adobe/Adobe Illustrator CS5 Settings/[語言]/AIPrefs
    • Windows XP: Documents and Settings/[使用者]/Application Data/Adobe/Adobe Illustrator CS5 Settings/AIPrefs

    註解:

    Windows 系統上的 Application 和 AppData 檔案預設為隱藏。如果您需要顯示隱藏檔案方面的協助,請參閱顯示隱藏的檔案

  3. 以純文字編輯器,如 TextWrangler (Mac OS) 或記事本 (Windows) 開啟偏好設定檔案。(您也可以使用更傳統的文字處理應用程式。若這麼做,請在不讓 .txt 副檔名隱藏的情況下,將檔案儲存為純文字檔。)

  4. 在偏好設定檔案中,找到看起來如下的區段:

    /aiFileFormat {

    /PDFCompatibility 1

    /enableATEReadRecovery 0

    /enableContentRecovery 0

    /enableATEWriteRecovery 0

    /clipboardPSLevel 3

    }

  5. 將 enableContentRecovery 的值從 0 變更為 1。如果 /aiFileFormat 區段中沒有 enableContentRecovery 這一行,請自行加入。編輯之後,看起來會像這樣:

    /enableContentRecovery 1

  6. 儲存偏好設定檔案,且不允許名稱或副檔名變更。

解決方案 2 (CS5 及更早版本): 編輯已復原的檔案

  1. 啟動 Illustrator。
  2. 若要開啟文件,請選擇「檔案 > 開啟」或按 Command+O

    不要按兩下開啟文件,請使用「最近的檔案清單」,或將檔案拖曳到 Illustrator 應用程式圖示上,以開啟文件。 

  3. 在瀏覽檔案對話方塊中,選取您要修復的檔案。

  4. Command+Option+Shift (Mac OS) 或按 Ctrl+Alt+Shift (Windows),然後按一下「開啟」對話方塊中的「開啟」

  5. 直接關閉空白視窗而不要儲存。

  6. 在 Finder (Mac OS) 或 Windows 檔案總管 (Windows)中,原始檔案所在的同一目錄內會出現開頭多出底線的複本。例如,若開啟「BrokenFile.ai」,則會看到名為「_BrokenFile.ai」的新檔案。

  7. 以純文字編輯器,如 TextWrangler (Mac OS) 或 UltraEdit (Windows),開啟有底線檔案。(Windows 使用者也能使用 WordPad 或記事本)。如果受損檔案很大,可能需要花一些時間開啟。如果您的文字編輯器對於可開啟的檔案有大小上限,請使用其他文字編輯器。

  8. 在有底線的檔案中,搜尋每一個這樣的實例:

    %AI8_BeginPluginObject

  9. 檢查其下那一行是否符合以下任一字串:
    (Adobe Calligraphic Brush Tool)
    (Adobe Scatter Brush Tool)
    (Adobe ArtOnPath Brush Tool)
    (Adobe Pattern Brush Tool)

  10. 如果該行未與這四個字串當中的任一者完全相符 (包括大小寫),請選取 %AI8_BeginPluginObject 注釋內的所有文字,以及其後第一個 %AI8_EndPluginObject 注釋。接著刪除註解本身,並刪除選取的文字。

  11. 針對檔案中每個出現的 %AI8_BeginPluginObject 註解,重複步驟 9 和 10。

  12. 儲存檔案。
  13. 在 Illustrator 中開啟這個檔案。
  14. 刪除所有符號,然後刪除所有筆刷。或者,如果您懷疑檔案內包含必要的符號或筆刷,請執行「刪除未使用的面板項目」動作 (選擇 「動作 > 刪除未使用的面板項目」,然後按一下「執行目前選項」)。

  15. 以新名稱儲存檔案 (例如,「Fixed File.ai」)。

  16. (重要) 關閉檔案。

  17. 在 Illustrator 中重新開啟這個檔案。選取任何物件,並將其複製並貼到新的空白檔案,以確認檔案是否已獲修正。

其他資訊

舊版 Illustrator 未預期內容的問題,在最新版本的 Illustrator 已獲修正。如果您目前使用的檔案由舊版 Illustrator 所儲存,則在最新版本中開啟檔案可能無法解決問題。

未預期的全域物件有時可能會顯示在個別面板中。若嘗試刪除未預期的全域物件,可能會刪除失敗;或者,可能會造成 Illustrator 變得不穩定及無故結束。

若您儲存文件,則文件大小會因為文件中多了許多全域物件而顯著增加。這類無效資料可能在被發現之前就已在文件中存在已久,因此使用舊版開啟文件不一定能解決問題。當您將文件中的圖稿複製到其他檔案,就有可能散播無效資料。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策