瞭解如何在 macOS 上提升 Illustrator 的速度及效率。

有數種因素會影響 Adobe Illustrator 的執行速度及效率,例如:作業系統、硬體設定、工作流程、選取選項。若您發現 Illustrator 的執行速度慢於往常,可嘗試幾種方法將 Illustrator 及其他應用程式的效能最佳化。

當您處理大型檔案時,會更容易注意到效能提升。

開始之前

在進行以下工作前,請確認 Illustrator 為最新版本或更新任何您目前使用的版本。軟體更新經常包含與效能相關的修正及增強。

若您使用 Illustrator CC,可透過 Creative Cloud 桌面應用程式更新 Illustrator。

最佳化 macOS

設定作業系統以便有效執行,可增加應用程式的可用記憶體容量,協助更流暢地執行應用程式。嘗試使用這些技術將 macOS 最佳化並提升 Illustrator 的效能。

管理字型

您安裝的每種字體都會增加 macOS 的記憶體使用量。 為了改善系統與應用程式存取字型的效能,請安裝您需要的字型就好。使用字體管理公用程式來協助管理多種字體。

使用 PostScript 印表機驅動程式

PostScript 以外的印表機驅動程式可能會與 Illustrator 衝突。因此,Adobe 建議您將 PostScript 印表機驅動程式設定為 macOS 的預設印表機。

步驟 1. 將 PostScript 印表機設定為預設印表機

註解:

若要完成此程序,請確認 PostScript 印表機已直接或透過網路連線至電腦。

  1. 在 Apple 選單上,選擇「系統偏好設定」,然後按一下「印表機與掃描器」

  2. 如果未列出 PostScript 印表機,請按一下「+」,導覽至 PostScript 印表機,然後按一下「新增」

  3. 「預設印表機」彈出式選單中選取一部 PostScript 印表機。

步驟 2. 設定 Illustrator 以列印至非預設印表機

  1. 在 Illustrator 中開啟任何文件,然後選擇「檔案 > 列印」

  2. 在「列印」對話方塊中,選擇「Adobe PostScript 檔案」 ,或從「印表機」選單中選擇印表機名稱。

  3. 按一下「儲存」

最佳化硬體設定

您使用的硬體會影響 Illustrator 效能: 處理器或硬碟的速度越快,Illustrator 處理資訊的速度就越快。其他硬體增強,例如安裝額外的記憶體、使用多處理器系統、最佳化及重組磁碟,都可提升效能。您可嘗試以下工作來最佳化硬體設定,並提升 Illustrator 的效能。

使用更快的處理器

電腦中央處理器 (CPU) 的速度會影響 Illustrator 的速度。因為 Illustrator 會操縱大量資料且執行許多計算,所以其速度取決於處理器的速度。請考慮使用配備高速處理器的電腦。

安裝額外的 RAM

如果 Illustrator 的記憶體不足,則會使用硬碟空間 (即暫存磁碟) 來處理資訊。 Illustrator 如果能在記憶體中處理資訊,不須使用硬碟空間,處理速度就會更快。

最佳化磁碟空間

以下有些方法可最佳化磁碟空間:

  • 檢查硬碟錯誤,或透過其他廠商的磁碟公用程式重組檔案 (例如 Norton Utilities)。 如果您執行 macOS,則不需重組磁碟機,而可能必須以其他廠商的磁碟公用程式修復磁碟機。
  • 以較快的存取速度將檔案儲存至磁碟。例如,使用內部硬碟,而非網路伺服器 (網路磁碟機) 或外部磁碟機。

有效率地使用 Illustrator 功能

您以 Illustrator 作業的方式,特別是檢視圖稿的方式,會影響 Illustrator 的效能。以下有些方法可使用 Illustrator 的功能來協助其保持順暢運作。

以大綱模式作業

「大綱模式」會隱藏上色屬性,並以未填色的路徑顯示圖稿。以外框模式操作可以加快處理複雜圖稿的速度,例如包含漸層或圖樣的物件。外框模式也可以讓您更容易編輯藏在其他已填色物件後方的物件。

若要以「大綱模式」顯示 Illustrator 文件,請選擇「檢視 > 大綱」

建立自訂檢視

您可以為文件建立自訂檢視。自訂檢視能讓您快速變更檢視模式、縮放比例、捲動位置以及圖層選項。

若要為 Illustrator 文件建立自訂檢視,請設定您想要儲存的檢視屬性。接著選擇「檢視 > 新增檢視」,然後在「新增檢視」對話方塊中輸入名稱。自訂檢視會顯示在「檢視」選單。

變更點陣效果設定

變更點陣效果的解析度,即可最佳化 Illustrator 的效能。

若要更改點陣效果的解析度,請選擇「效果 > 文件點陣效果設定」,然後從「解析度」 下拉式選單中選擇下列其中一項:

  • 若要編輯檔案,請按一下「畫面」。Illustrator 會針對點陣效果使用 72 ppi 的解析度,可加快顯示速度。
  • 若要列印檔案,請按一下「高」。Illustrator 會針對點陣效果使用 300 ppi 的解析度,雖然會減慢列印速度,但可提升列印品質。

然後,按一下「確定」

隱藏圖層並移除縮圖

若隱藏的圖層包含複雜圖稿或高解析度點陣圖影像,Illustrator 重新顯示畫面的速度會更快。

若要隱藏圖層,請按一下圖層名稱左側的眼睛圖示,清除「顯示圖層」,然後按一下「確定」。若要隱藏所選圖層以外的所有圖層,請按 Alt,同時按一下眼睛圖示。

「圖層」面板會針對頂層圖層、巢狀圖層、群組及物件顯示縮圖。若要減少縮圖數量,讓 Illustrator 更快重新顯示畫面,請從「圖層」面板選單中選擇「面板選項」 ,然後減少縮圖數量。

  • 若要從「圖層」面板移除所有縮圖,請在「資料列大小」區段中選取「小」 ,然後按一下「確定」
  • 若要在「圖層」面板中移除特定元素的縮圖,請取消選取「縮圖」區段中的「圖層」「群組」「物件」 ,然後按一下「確定」

停用疊印預視

「疊印預視」提供「油墨預視」效果,可模擬漸變、透明和疊印在分色輸出時呈現的結果。若要增強效能,請避免使用「疊印預視」。

若要啟用「疊印預視」,請選擇「檢視 > 疊印預視」

刪除未使用的工作區域

工作區域代表可以包含可列印圖稿的區域。若要最佳化效能,請考慮刪除未使用或不必要的工作區域。

若要管理工作區域,請選擇「視窗 > 工作區域」。接著選取要移除的工作區,然後按一下「刪除」

更改暫存磁碟偏好設定

當您處理內嵌點陣圖影像,但是系統的記憶體不足時,Illustrator 會使用硬碟空間做為暫存磁碟。相較於存取記憶體上的資訊,存取硬碟上的資訊會花費更多時間。因此,使用硬碟的一部分做為虛擬記憶體會降低效能。若需要更多記憶體來執行 Illustrator,請嘗試增加更多記憶體。

Illustrator 依預設會使用系統磁碟做為主要暫存磁碟。請將 Illustrator 的主要暫存磁碟設定變更為速度更快的硬碟。

若要變更暫存磁碟偏好設定,請執行下列動作:

  1. 選擇「Illustrator > 偏好設定 > 增效模組和暫存磁碟」

  2. 從「主要」快顯選單中選擇硬碟。若您要處理大型影像,並且擁有多個硬碟,請從「次要」快顯選單中選擇其他磁碟。
  3. 按一下「確定」,並重新啟動 Illustrator。

從文件描述檔中移除未使用的元素

Illustrator 文件描述檔內含預設圖樣、漸層、圖形設計、色彩、色彩庫與筆刷,且會顯示於新的 Illustrator 文件中。這些檔案會決定新文件的縮放等級、視窗大小、檢視偏好設定以及捲動位置。從 Illustrator 新文件描述檔中移除不需要的色票與筆刷,能將新文件的檔案大小降至最低。

如需有關建立自訂文件設定檔的說明,請參閱啟動設定檔: 自訂新文件的實用工具

從範本中移除未使用的元素

範本可讓您建立共用一般設定和設計元素的文件。 您可以從範本中移除不需要的色票、符號、圖形樣式和筆刷,藉以將新文件的檔案大小降至最低。

如需有關建立範本檔案的說明,請參閱檔案和範本

啟用影像連結

內嵌點陣圖影像 (例如 TIFF、BMP 或 Photoshop EPS) 會顯著增加 Illustrator 文件的大小,導致效能下降。若要改善效能,請在置放點陣圖影像時啟用「連結」選項。「連結」選項會參照影像置放於硬碟中的位置。

  • 前往「檔案 > 位置」。在「位置」對話方塊中選擇「連結」

如果輸出中心要求內嵌的影像,那麼請儲存檔案副本。在「Illustrator 原生格式選項」 「EPS 格式選項」對話方塊選擇「加入連結的檔案」

使用低解析度的 EPS 預視

如果文件內含的已連結 EPS 影像有高解析度預視,Illustrator 在您編輯圖稿時重繪速度會變慢。若要讓 Illustrator 重繪畫面的速度更快,請使用低解析度的 EPS 預視。請執行下列動作:

  1. 選擇「Illustrator > 偏好設定 > 檔案處理和剪貼簿」

  2. 選取「針對已連結的 EPS 使用低解析度代理」並按一下「確定」

停用「顯示 DCS 透明度互動」

「連結面板選項」對話方塊包括「顯示 DCS 透明度互動」選項。若選取此選項,「連結」面板會顯示黃色圖示,以便識別連結 DCS EPS 圖形為透明或重疊透明物件。由於此選項會強制 Illustrator 定期判斷連結 EPS 檔案是否與透明度互動,因此會降低效能。

若要停用「顯示透明度互動」選項,請執行下列動作:

  1. 選取「視窗 > 連結」。從「連結」面板選單中選擇「面板選項」。

  2. 清除「顯示 DCS 透明度互動」 ,再按一下「確定」

隱藏「導覽」面板

「導覽」面板會顯示目前圖稿的縮圖視圖,以便輕鬆導覽。每次變更文件時,更新縮圖所需的處理時間取決於圖稿的複雜性。若要提升在複雜文件中重新顯示畫面的速度及效能,請隱藏「導覽」面板。

  • 在「視窗」選單下,取消選取「導覽」。 

您可以設定自訂檢視以更有效率地縮放文件中的特定區域。

停用「消除圖稿鋸齒」

「消除圖稿鋸齒」選項可混合物件邊緣像素及相鄰像素的顏色,讓文字和圖形變得平滑。然而,這個處理程序會造成畫面重繪速度遲緩。若要停用此選項,請執行下列動作:

  1. 選擇「Illustrator > 偏好設定 > 一般」

  2. 清除「以反鋸齒功能處理圖稿」,再按一下「確定」

套用「簡化」命令

「簡化」命令會減少路徑與路徑形狀的錨點數量,藉此降低檔案大小並提升效能。若要套用「簡化」命令,請選取想要套用的路徑或物件,然後選擇「物件 > 路徑 > 簡化」

如需有關「簡化」命令的更多資訊,請參閱編輯路徑

停用「智慧型參考線」

「智慧型參考線」可讓您建立、對齊、編輯及轉換相對於其他物件的 Illustrator 物件。若圖稿中有許多物件,則 Illustrator 需要更多時間才能顯示「智慧型參考線」。

  • 若要停用「智慧型參考線」請按一下「視圖」選單,然後取消選取「智慧型參考線」

尋找有關「智慧型參考線」的更多資訊。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策