瞭解如何讓 Illustrator 在 Windows 上執行得又快又有效率。

能夠影響 Adobe Illustrator 執行的速度與效率的因素很多,例如作業系統、硬體設定、工作流程,以及選取的選項。如果您發現 Illustrator 執行得比平常慢,請嘗試以下技巧,不僅能最佳化 Illustrator 的效能,也能最佳化其他應用程式的效能。(當您在進行大檔案的作業時,效能的改善會更加明顯。)

開始之前

在進行以下工作之前,請務必先安裝 Illustrator 的最新版本,或更新任何目前使用的版本。軟體更新經常包含與效能相關的修正及增強。 

如果您使用 Illustrator CC,您可以透過 Creative Cloud 桌面應用程式來更新 Illustrator

註解:

本文件的程序根據 的預設介面編寫。如果您自訂介面,則程序便會有所不同。舉例來說,導覽至控制台的路徑可能不同。選擇「開始 > 設定 > 控制台」「開始 > 控制台」,要依您的 Windows 版本而定。如需 Windows 的疑難排解提示與一般資訊,請諮詢 Adobe 支援Microsoft 支援

最佳化 Windows

設定作業系統,使其運作更有效率,您就可以提高應用程式可用的記憶體總量,使得應用程式執行更順暢。以下為最佳化 Windows 並改善 Illustrator 效能的幾項技巧。

增加可用記憶體

虛擬記憶體能讓您使用硬碟空間來儲存通常會儲存於 RAM 的資訊。不過在硬碟上存取資訊會比在記憶體存取資訊更花時間。因此,如果您的系統必須大量依賴虛擬記憶體,就會降低效能。

若要提高效能,請選擇適當的大小供分頁檔案 (硬碟用來儲存虛擬記憶體的區域) 使用。您需要管理員權限才能變更分頁檔案大小。分頁檔案的最大大小約為已安裝 RAM 的三倍時,Illustrator 效能最佳。

  1. 結束所有應用程式。

  2. 選擇「開始 > 控制台 > 系統 > 進階系統設定」

  3. 在「系統內容」對話方塊中,選擇「進階」標籤。

  4. 在「效能」區段中,按一下「設定」,然後選擇「進階」標籤。

  5. 在「虛擬記憶體」區段按一下 「變更」

  6. 清除「自動管理所有磁碟的分頁檔案大小」核取方塊。

  7. 從磁碟清單中選取至少為安裝於電腦中的 RAM 三倍大的硬碟。舉例來說,如果您的電腦有 64MB 的 RAM,則選取至少有 192 MB 未使用空間的硬碟。為了取得最佳效能,請選擇並未用於 Illustrator 暫存磁碟的硬碟。

停用驅動程式功能

有些視訊介面卡驅動程式會提供能夠加速或修改圖形顯示的進階設定。有時這些設定會對 Illustrator 在畫面重繪的效能產生不良影響。請嘗試停用特定驅動程式的功能,以判斷用於 Illustrator 的最佳設定為何。如需更多資訊,請參閱視訊介面卡說明文件。

管理字型

您所擁有的每一種字型都會增加 Windows 的 RAM 使用量。為了改善系統與應用程式存取字型的效能,請安裝您需要的字型就好。請使用字型管理公用程式來協助您管理大量字型。

限制啟動應用程式

如果應用程式會在 Windows 上自動啟動,就會與 Illustrator 爭奪可用的 RAM。若要避免應用程式自動啟動,請執行下列動作:

  1. 結束所有應用程式。

  2. 啟動 Windows Explorer。
  3. 若要停用啟動應用程式,請將所有圖示和捷徑從「啟動」資料夾 (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) 移至另一個資料夾。

  4. 重新啟動 Windows。

若要關閉登錄時指定為自動啟動的應用程式,請執行下列動作:

  1. 重新啟動 Windows。
  2. Ctrl + Shift + Esc

  3. 選擇「處理程序」標籤。

  4. 選取應用程式名稱,然後按一下「結束工作」

  5. 重新啟動 Illustrator。如果 Illustrator 的效能確實有所改善,請聯絡應用程式製造商,要求協助永久停用該應用程式自動啟動。針對其他每一個啟動應用程式重複步驟 2 到 5。

重新啟用圖示和捷徑

如果 Illustrator 的效能並未在重新啟動後改善,請在 Windows 檔案總管將圖示與捷徑放回「啟動」資料夾,藉此重新啟用這些圖示與捷徑。

如果 Illustrator 的效能確實有改善,請找出造成效能問題的一個或多個程式,並使用 Windows Explorer 將它們的圖示與捷徑放在「啟動」資料夾,藉此重新啟用這些圖示與捷徑。

在重新啟用每一組圖示和捷徑之後,請重新啟動電腦並測試 Illustrator 的效能。

重複進行此程序,直至 Illustrator 的效能降低。在您找出造成效能問題的圖示或捷徑之後,請再次將它移除。聯絡程式製造商,瞭解能否取得更新。

最佳化硬體

您使用的硬體會影響 Illustrator 效能: 處理器或硬碟的速度越快,Illustrator 處理資訊的速度就越快。其他硬體增強方法 (例如安裝額外的 RAM、使用多處理器系統,或最佳化與磁碟重組磁碟),也可以改善效能。請嘗試下列技巧以最佳化硬體。

使用更快的處理器

中央處理器 (CPU) 的速度會影響 Illustrator 的速度。Illustrator 需操作大量資料並執行許多計算,因此其執行速度就取決於處理器的速度。請考慮使用配備高速處理器的電腦。

安裝額外的 RAM

如果 Illustrator 能使用的 RAM 不足,就會使用硬碟空間 (虛擬記憶體、暫存磁碟或兩者皆用) 來處理資訊。Illustrator 如果能在記憶體中處理資訊,不須使用硬碟空間,處理速度就會更快。

最佳化磁碟空間

以下有些方法可最佳化磁碟空間:

  • 請檢查您的硬碟是否存在錯誤、磁碟重組檔案,並使用 CHKDSK.exe 和磁碟重組工具程式來將現有硬碟空間做最佳利用。如需相關資訊,請參閱 Windows 文件或改善 Windows 效能。
  • 將檔案儲存在存取速度較快的磁碟機。舉例來說,盡可能優先使用內部硬碟,而非網路伺服器 (網路磁碟機) 或外接磁碟機。
  • 如果您想將檔案儲存至網路或外接磁碟機,請先儲存在內部硬碟。接著請關閉檔案,再用 Windows 檔案總管將檔案複製到網路或外接磁碟機。

使用 PostScript 印表機

為了在 Illustrator 列印時取得最佳效果,請使用 PostScript 印表機。多數非 PostScript 印表機都需要依賴顯示資訊、主機電腦資源,以及專屬印表機驅動程式將列印資訊轉送至印表機。因此,相較於 PostScript 印表機會花費更長的列印時間。

有效率地使用 Illustrator 功能

您使用 Illustrator 的方式 (尤其是檢視圖稿的方式) 會影響 Illustrator 的效能。以下為更有效率地使用 Illustrator 功能的幾種方法。

在外框模式中操作

外框模式會隱藏繪圖屬性,以未填色的路徑顯示圖稿。以外框模式操作可以加快處理複雜圖稿的速度,例如包含漸層或圖樣的物件。外框模式也可以讓您更容易編輯藏在其他已填色物件後方的物件。

若要在外框模式中顯示 Illustrator 文件,請選擇「檢視 > 外框」

建立自訂檢視

您可以為文件建立自訂檢視。自訂檢視能讓您快速變更檢視模式、縮放比例、捲動位置以及圖層選項。

若要為 Illustrator 文件建立自訂檢視,請設定您想要儲存的檢視屬性。接著選擇「檢視 > 新增檢視」,然後在「新增檢視」對話方塊輸入名稱。自訂檢視會顯示在「檢視」選單。

變更點陣效果設定

您可以變更點陣效果的解析度,藉此最佳化 Illustrator 的效能。

若要變更點陣效果的解析度,請選擇「效果 > 文件點陣效果設定」。在「解析度」彈出式選單中,依照下列步驟執行:

  • 如果您正在編輯檔案,請選擇「螢幕」。Illustrator 會在點陣效果中使用 72 ppi 的解析度,藉以提高顯示速度。
  • 如果您正在列印檔案,請選擇「高」。Illustrator 會在點陣效果中使用 300 ppi 的解析度,雖然會降低列印速度,但能提升列印品質。

然後,按一下「確定」

隱藏圖層並移除縮圖

使用「圖層」面板來組織及修改圖稿。如果您將內含複雜圖稿或高解析度點陣圖影像的圖層隱藏起來,Illustrator 就能夠更快地重繪畫面。

若要隱藏特定圖層,請按一下圖層名稱左邊的眼睛圖示。若要隱藏選取圖層以外的全部部分,請按住 Alt 再 按一下 (在 Mac 則按住 Option 再按一下) 眼睛圖示。

「圖層」面板會顯示最上層圖層、巢狀圖層、群組,以及物件的縮圖。若要減少縮圖數量以讓 Illustrator 的重繪速度更快,請在「圖層」面板選單選擇「面板選項」,接著再減少縮圖數量。

選項面板

停用疊印預視

「疊印預視」提供「油墨預視」效果,可模擬漸變、透明和疊印在分色輸出時呈現的結果。若要增強效能,請避免使用「疊印預視」。

若要啟用「疊印預視」,請選擇「檢視 > 疊印預視」

刪除未使用的工作區域

工作區域代表可以包含可列印圖稿的區域。若要最佳化效能,請考慮刪除未使用或不需要的工作區域。

若要管理工作區域,請選擇「視窗 > 工作區域」。選取您想要移除的工作區域,接著按一下「刪除」

變更暫存磁碟偏好設定

如果在處理內嵌點陣圖影像時,系統的 RAM 不敷使用,Illustrator 就會使用硬碟空間做為暫存磁碟。在硬碟上存取資訊所需時間會比在記憶體存取資訊更久。因此,將一部份硬碟當作虛擬記憶體使用會降低效能。如果您需要更多記憶體才能處理 Illustrator 的工作,Adobe 建議您安裝更多 RAM。

依預設,Illustrator 會以系統磁碟當作主要暫存磁碟。請將 Illustrator 的主要暫存磁碟設定變更為速度更快的硬碟。

若要變更暫存磁碟偏好設定,請執行下列動作:

  1. 選擇「編輯 > 偏好設定 > 增效模組與暫存磁碟」

  2. 「主要」彈出式選單中選擇硬碟。如果您需要處理大型影像,且擁有多個硬碟,請從「次要」彈出式選單中選擇另一個硬碟。

  3. 按一下「確定」,並重新啟動 Illustrator。

從文件描述檔中移除未使用的元素

Illustrator 文件描述檔內含預設圖樣、漸層、圖形設計、色彩、色彩庫與筆刷,且會顯示於新的 Illustrator 文件中。這些檔案會決定新文件的縮放等級、視窗大小、檢視偏好設定以及捲動位置。從 Illustrator 新文件描述檔中移除不需要的色票與筆刷,能將新文件的檔案大小降至最低。

如需在 Illustrator 中建立自訂文件描述檔的指示,請參閱啟動描述檔: 自訂新文件的理想工具

移除範本中未使用的元素

範本可讓您建立共用一般設定和設計元素的文件。 您可以從範本中移除不需要的色票、符號、圖形樣式和筆刷,藉以將新文件的檔案大小降至最低。

如需建立範本檔案的指示,請參閱檔案與範本

啟用影像連結

內嵌點陣圖影像 (例如 TIFF、BMP 或 Photoshop EPS) 會使得 Illustrator 文件的大小暴增,導致效能不彰。若要改善效能,請在置放點陣圖影像時啟用「連結」選項。「連結」選項會參照影像置放於硬碟中的位置。

  • 選取「檔案 > 位置」。在「位置」對話方塊中選擇「連結」

如果輸出中心要求內嵌的影像,那麼請儲存檔案副本。在「Illustrator 原生格式選項」「EPS 格式選項」 對話方塊選擇「加入連結的檔案」

使用低解析度的 EPS 預視

如果文件內含的已連結 EPS 影像有高解析度預視,Illustrator 在您編輯圖稿時重繪速度會變慢。若要讓 Illustrator 重繪畫面的速度更快,請使用低解析度的 EPS 預視。請執行下列動作:

  1. 選擇「編輯 > 偏好設定 > 檔案處理和剪貼簿」

  2. 選取「針對已連結的 EPS 使用低解析度代理」並按一下「確定」

停用「顯示 DCS 透明度互動」

「連結面板選項」對話方塊中包含「顯示 DCS 透明度互動」選項。如果您已選取該選項,則「連結」面板會顯示黃色圖示來辨識透明或重疊透明物件的已連結 DCS EPS 圖形。因為此選項會迫使 Illustrator 定期判斷已連結的 EPS 檔案是否與透明度互動,所以會降低效能。

若要停用「顯示透明度互動」選項,請執行下列動作:

  1. 選取「Windows > 連結」。從「連結」面板選單中選擇「面板選項」。

  2. 清除「顯示 DCS 透明度互動」,再按一下「確定」

隱藏「導覽器」面板

「導覽器」面板會顯示目前圖稿的縮圖,以便導覽。每次變更文件而更新縮圖的處理時間,取決於圖稿的複雜性。若要改善複雜文件的畫面重繪的速度,請隱藏「導覽器」面板。在「視窗」選單下方取消選取「導覽器」

您可以設定自訂檢視以更有效率地縮放文件中的特定區域。

停用「以反鋸齒功能處理圖稿」

「以反鋸齒功能處理圖稿」選項能夠藉由將物件邊緣像素的色彩與相鄰像素的色彩混合在一起,進而使文字和圖形變得平滑。然而,這個處理程序會造成畫面重繪速度遲緩。若要停用此選項,請執行下列動作:

  1. 選擇「編輯 > 偏好設定 > 一般」

  2. 清除「以反鋸齒功能處理圖稿」 ,再按一下「確定」

套用「簡化」命令

「簡化」命令會減少路徑及路徑圖形中的錨點數量,藉此減少檔案大小並提升效能。 若要套用「簡化」命令,請選取想要套用的路徑或物件,然後選擇「物件 > 路徑 > 簡化」

如需更多簡化命令的資訊,請參閱 Illustrator 說明

停用智慧型參考線

智慧型參考線能讓您對照其他物件建立、對齊、編輯與變形 Illustrator 物件。如果您的圖稿中有許多物件,Illustrator 就需要花費更多時間顯示智慧型參考線。若要停用智慧型參考線,請在「檢視」選單中取消選取「智慧型參考線」

如需更多智慧型參考線的資訊,請參閱尺標、格點、參考線及裁切標記

點陣化毛刷筆刷路徑與停用 PDF 功能

毛刷筆刷筆觸是由數個重疊所組成,並以透明路徑填色。這些路徑就如同 Illustrator 中任何其他填色路徑,會與其他物件的上色互動,包括其他的毛刷筆刷路徑。

在著手處理大尺寸圖稿之前,請先行測試及試驗毛刷筆刷與上色轉譯。變更筆刷屬性並重新套用,會再次重新轉譯所有使用過的筆刷。

使用「毛刷筆刷」時,您可以執行下列步驟以減少文件的複雜性與檔案大小:

  • 點陣化部分毛刷筆刷路徑。在點陣化之前,務必儲存原始圖稿的副本。

如果圖稿內含大量 (>30) 毛刷筆刷,請降低毛刷筆刷路徑的複雜性與數量。選取「毛刷筆刷」路徑,並選擇「物件 > 點陣化」

  • 停用 PDF 功能。

依預設,Illustrator 會儲存使 Illustrator (*ai) 檔案與其他 Adobe 應用程式相容的 PDF 資料。請選擇「檔案 儲存」「檔案 > 另存新檔」,然後按一下「儲存」在「Illustrator 選項」對話方塊中取消選取 「建立 PDF 相容檔案」

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策