Експорт матеріалу документа в XML

Перед тим, як ви будете експортувати матеріал з документа InDesign у XML, ви повинні зробити наступне:

  • Створити або завантажити теги елементу.

  • Застосувати теги до пунктів на сторінках вашого документа.

  • Відрегулювати ієрархію елементів з тегами у вікні «Структура", якщо потрібно.

Можна експортувати весь вміст XML або його частину у ваш документ. Експортувати можна лише вміст, що містить теги.

Примітка.

Якщо ви експортуєте документ, що містить таблиці, ви повинні додати теги до таблиць InDesign або не експортувати їх як частину XML.

  1. Якщо ви хочете експортувати лише частину документа, виділіть елемент у вікні «Структура", куди необхідно розпочати експортування.
  2. Виберіть «Файл» > «Експорт».
  3. У меню Тип файлу (Windows) або «Формат» (Mac OS) виберіть XML.
  4. Задайте ім’я та знаходження файлу XML і після цього натисніть на «Зберегти".
  5. На закладці «Загальні» діалогового вікна «Експорт XML» виберіть будь-що з наступного:

    Включити декларацію DTD

    Експортує посилання на DTD разом з файлом XML. Даний параметр доступний тільки у тому випадку, якщо є елемент DOCTYPE у вікні «Структура".

    Переглянути XML за допомогою

    Відкриває експортований файл у переглядач, програму редагування XML чи текстовий редактор. Виберіть переглядач або програму зі списку.

    Експорт з виділеного елемента

    Починає експорт з елемента, котрий ви вибрали у вікні «Структура". Даний параметр доступний тільки у тому випадку, якщо ви виділили елемент до вибору Файл > Експортувати.

    Експорт таблиць без тегів як CALS XML

    Експортує таблиці без тегів у формат CALS XML. Щоб її експортували, таблиця повинна знаходитись у кадрі з тегами і таблиця повинна бути без тегів.

    Переназначити кінці, порожнє місце та спеціальні символи

    Експортує кінці, порожнє місце та спеціальні символи як десяткові символьні об’єкти, а не як звичайні символи.

    Застосувати XSLT

    Застосовує видавничу інструкцію для визначення трансформування експортованої XML у, наприклад, модифіковане дерево XML чи HTML. Виділіть Переглянути (Windows) чи Обрати (Mac OS) щоб виділити XSLT із системи файлів. Настройка за замовчуванням, «Використати видавничу інструкцію з XML», використовує вказівку трансформування XSLT, якщо на таку є посилання у XML, котра застосовується до експорту.

  6. Виберіть тип кодування з меню «Кодування".
  7. Для того, щоб вказати параметри експорту для зображень, натисніть на закладці «Зображення» і потім виділіть одне чи більше з наступного:

    Початкові зображення

    Розміщує копію вихідних файлів із зображеннями у вкладену теку із зображеннями.

    Оптимізовані початкові зображення

    Оптимізує та стискує початкові файли із зображеннями та вміщує копії файлів у підтеку із зображеннями.

    Оптимізовані форматовані зображення

    Оптимізує первинні файли із зображеннями, що містять застосовану трансформацію (таку, як обертання чи зміна масштабу) та розміщає їх у підтеку із зображеннями. Наприклад, якщо документ містить два зображення, одне кадроване, а одне — ні, тільки кадроване зображення оптимізується та копіюється до підтеки із зображеннями.

  8. Якщо ви виділили «Оптимізовані первинні зображення» або «Оптимізовані форматовані зображення", виберіть параметри для оптимізації зображень.
  9. Натисніть кнопку «Експорт».

Примітка.

У XML підтримуються не всі спеціальні символи (такі, як символ автоматичного номера сторінки). InDesign попереджає вас, якщо не може включити символ до експортованого файлу XML. Це попередження з’являється також у тому випадку, коли ви не додали теги до таблиці.

Параметри експорту оптимізованого зображення

Доступні наступні параметри, коли ви обираєте «Оптимізовані первинні зображення» чи «Оптимізовані форматовані зображення» на закладці зображень діалогового вікна «Експортувати XML".

Перетворення зображення

Вказує, який формат файлу застосовувати для перетвореного зображення. Якщо ви оберете «Автоматичний", InDesign обирає найкращий тип файлу на основі зображення. Отже, вам, можливо, захочеться вказати як параметри GIF, так і параметри JPEG.

Параметри GIF

Вкажіть форматування для зображень, котрі перетворюються у формат GIF під час експортування у XML. Ви можете задати наступні параметри:

Палітра

Вказує палітру кольорів, котрій ви хочете щоб відповідало зображення під час перетворення. Оберіть палітру для остаточного формату відображення матеріалу XML. Адаптивна (тремтіння відсутнє) добре діє на зображення з первинно чистими кольорами та може застосовуватись тоді, коли кінцевим результатом буде декілька форматів.

Черезрядковий

Завантажує кожну другу лінію зображення з кожним проходом, замість того, щоб завантажувати все зображення за один прохід. Чергування зображень дозволяє швидко завантажувати перегляд зображення, оскільки кожен успішний прохід додає роздільну здатність, аж поки не досягнуто остаточної якості.

Параметри JPEG

Вкажіть форматування для зображень, котрі перетворюються у формат JPEG під час експортування у XML. Ви можете задати наступні параметри:

Якість зображення

Вказує якість перетвореного зображення. Чим вище параметр якості, тим більший розмір файлу та треба більше часу для завантаження.

Метод форматування

Визначає спосіб, яким JPEG-зображення відформатовано для завантаження. Базова лінія завантажує зображення з остаточною якістю за один прохід так, що файл відображається з остаточною якістю як тільки він відкривається; можливо, для завантаження цього формату треба буде більше часу, аніж для форматованого зображення, що поступово прорисовується. "Що поступово прорисовує» завантажує зображення у декілька проходів, перший прохід — з варіантом з низькою роздільною здатністю, а кожен наступний прохід збільшує роздільну здатність зображення до досягнення остаточної якості.

Збереження тегів лише як XML

Збережіть теги так, щоб ви могли завантажити теги у документ InDesign та використати їх там.

  1. Оберіть «Зберегти теги» в меню панелі «Теги".
  2. Введіть ім’я, вкажіть розташування і після цього натисніть «Зберегти".

    Теги у вашому документі, разом з призначеними кольорами, записуються у файлі XML

Редагування експортованого файлу XML

Після того, як ви використали InDesign для створення та експорту файлу XML, ви можете внести зміни у XML, використовуючи якийсь один з цих методів:

  • Щоб внести зміни безпосередньо у файл XML, відкрийте його у текстовому чи XML редакторі.
  • Щоб внести зміни, котрі буде збережено у первинному документі, відкрийте файл InDesign, з якого було експортовано цю XML. Після того, як ви внесете зміни у матеріал в InDesign, ви можете експортувати йог до XML знову, використовуючи первинне ім’я файлу XML, якщо ви хочете замінити цей файл.

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності