Докладніші відомості та інструкції можна переглянути за наведеними нижче посиланнями.

Методи імпортування XML та створення макета

Після імпорту даних XML імпортований вміст з’являється як елементи (основні конструктивні елементи XML) на панелі «Структура». InDesign не створює нові кадри або сторінки, коли ви імпортуєте XML.

Додати чи об’єднати?

XML можна імпортувати двома способами: додаванням чи об’єднанням. Метод, котрий ви обираєте, залежить від ваших робочих процесів (вручну чи автоматизований), як ви хочете обробляти існуючий матеріал у вашому документі, та чи бажаєте ви мати додаткові настройки для обробки імпортованих даних.

Режим додавання.

Коли ви додаєте імпортований матеріал, існуюча структура та вміст документа залишаються такими, як були, новий матеріал XML розміщується в нижній частині панелі «Структура», у формі елементів.

Режим об’єднання.

Коли ви об’єднуєте імпортований матеріал, InDesign порівнює вхідну XML зі структурою та назвами елементів, що вже є у вашому документі. Якщо елементи точно відповідають одне одному, імпортовані дані заміняють матеріал документа й об’єднуються в кадри (або заповнювачі), яким правильно присвоїли теги в макеті. (Елементи, для яких InDesign не може знайти відповідне ім’я та ієрархічний клас, розміщуються на панелі «Структура» таким чином, щоб можна було вміщувати їх вручну.) Режим об’єднання не тільки робить можливим автоматизоване створення макета, він надає додаткові настройки імпорту, включаючи здатність фільтрувати вхідний текст та розмножувати елементи для даних, що повторюються.

Макет вмісту

Після імпорту матеріалу XML наступним кроком буде розміщення його у вашому документі. Ви можете вставити матеріал вручну, автоматично чи використовуючи створення сценаріїв. Метод, котрий ви оберете, залежить від імпортованого вами матеріалу, макета вашого документа та від процесу робочих потоків.

Вставлення матеріалу вручну.

У ручному режимі елементи перетягують із панелі «Структура» на сторінки вашого документа або в кадри. Даний метод потребує незначних настройок чи планування. Використовуйте цей метод, якщо тип імпортованого матеріалу міняється чи ви отримуєте матеріал з декількох джерел.

Вставлення імпортованого матеріалу XML вручну
Вставлення імпортованого матеріалу XML вручну

Вставлення матеріалу автоматично.

Плануючи наперед, можна автоматизувати процес вставки даних XML у ваш макет Щоб вставити матеріал XML, спочатку підготуйте документ шляхом створення шаблонних кадрів з тегами для того, щоб вони містили вхідну XML. До тих пір, поки структура XML та імена тегів для вхідного матеріалу повністю збігаються з іменами тегів та структурою шаблонних кадрів, InDesign може вставляти імпортовану XML у ваш документ. InDesign може також розмножувати елементи щоб керувати даними, що повторюються, наприклад, матеріалом списків адрес та каталогів. Використовуйте метод автоматичного макета як частину структурованого процесу робочих потоків щоб зменшити час виконання операції та збільшити ефективність.

Обраний шаблонний кадр марковано елементом матеріалу
Обраний шаблонний кадр (зверху) марковано елементом матеріалу. Коли імпортуються дані XML (внизу), у шаблонному кадрі елемента матеріалу автоматично з’являється вміст елемента матеріалу.

Примітка.

InDesign розпізнає особливі атрибути простору імен, котрі можуть вказати стилі абзацу чи символу в XML. Докладніші відомості див. у технічно-довідковому посібнику з XML.

Про об’єднання

Дані XML можна вставити в документ, використовуючи режим об’єднання чи режим додавання. Режим об’єднання дозволяє автоматизувати вставку матеріалу. Можна також відфільтрувати дані у файлі XML щоб вставити лише певні частини матеріалу.

Об’єднуйте вхідний матеріал XML, коли:

  • Документ містить шаблонні кадри та ви хочете заповнити їх імпортованим вмістом XML.

  • Документ містить матеріал XML і ви хочете замінити його імпортованим матеріалом XML.

  • Документ не містить будь-які структури XML, а ви хочете, щоб InDesign замінив кореневий каталог за замовчуванням кореневим каталогом вхідного файлу XML.

Режим об’єднання порівнює вхідні дані XML з елементами, що вже знаходяться в документі. Відбувається переміщення по файлу, елемент за елементом, одночасно відбувається порівняння вхідних елементів з існуючими наступним способом:

1. InDesign починає порівняння біля елемента кореневого каталогу

  • Якщо елементи кореневого каталогу імпортованого файлу XML і документ InDesign не узгоджуються та на панелі «Структура» немає існуючої структури, InDesign замінює кореневий каталог документа InDesign кореневим каталогом вхідного XML-файлу та імпортує файл.

  • Якщо елементи кореневого каталогу не збігаються та панель «Структура» вже містить елементи, InDesign додає цей файл у кінці існуючої структури.

  • Якщо елементи кореневого каталогу все-таки збігаються, процес об’єднання продовжується.

2. InDesign переміщується до елемента під кореневим каталогом

Починаючи з елемента безпосередньо під кореневим каталогом у вхідному файлі XML, InDesign здійснює пошук елемента, що збігається, на панелі «Структура». Щоб відбувся збіг, вхідний елемент XML повинен мати таке ж ім’я, що й існуючий елемент на панелі «Структура», а два елементи повинні існувати на одному й тому самому рівні в ієрархії.

  • Якщо InDesign знаходить на панелі «Структура» елемент, що збігається, то вона замінює цей елемент на панелі «Структура» елементом із вхідного файлу XML.

  • Якщо InDesign не знаходить відповідника, то вона вставляє вхідний елемент на панелі «Структура» у відправній точці пошуку. Наприклад, якщо пошук починається безпосередньо під кореневим каталогом та відповідник не знайдено, вхідний елемент вставляється безпосередньо під кореневим каталогом.

3. InDesign продовжує порівнювати елементи

Елемент за елементом, InDesign продовжує порівнювати вхідну XML з існуючою структурою. Вихідний пункт пошуку на панелі «Структура» змінюється в міру просування пошуку, при цьому кожен пошук починається під останнім елементом що вставляється чи замінюється. InDesign завжди переміщується від поточного місця розташування; вона ніколи не вставляє елементи над попереднім елементом, який вона вставила чи замінила.

Імпорт та експорт даних XML

Коли імпортують матеріал XML, нові елементи з’являються на панелі «Структура». Звідти можна переміщувати елементи щоб вставити їх у ваш документ.

  1. Відкрийте документ InDesign або створіть новий документ щоб отримати матеріал XML.
  2. Відкрийте панель «Структура». (Оберіть «Перегляд» > «Структура» > «Показати структуру».)
  3. Закрийте Файл> Імпорт XML (або виберіть Імпорт XML у меню панелі «Структура») та виберіть файл XML, який ви хочете імпортувати.
  4. Виділіть «Показати параметри імпорту XML».
  5. Виділіть Додати матеріал, а потім натисніть «Відкрити».
  6. Щоб зв’язати матеріал XML з оригінальним файлом XML, виберіть «Створити зв’язок».

    InDesign занесе до списку файл XML на панелі «Зв’язки» та відобразить жовтий попереджувальний трикутник у вікні, якщо файл XML зміниться.

  7. Натисніть кнопку «OK».

Розробка макета XML вручну

Можна вручну вставити матеріал XML у ваш матеріал документа, переміщуючи елементи з вікна «Структура» на сторінку чи в існуючі кадри. Коли ви вставляєте якийсь елемент, його дочірні елементи (та всі дочірні елементи під ними, якщо якісь є) вставляються також.

На панелі «Структура» на ярлику елемента з’являється притаманний структурі синій ромб, якщо елемент було вставлено в документ; елементи, що не було вставлено, показують відповідний значок невставленого елемента.

Примітка.

Якщо XML імпортовано з використанням параметра «Об’єднати матеріал», деякі елементи, можливо, вже було розроблено. Коли ви об’єднуєте імпортований вміст, InDesign автоматично вбудовує елементи в існуючі кадри, якщо їх таким же чином структуровано та додано до них теги.

  1. Відкрийте панель «Структура» (Перегляд > Структура > Показати структуру) та виділіть елемент, макет якого ви хочете розробити.
  2. Виконайте будь-що з наступного для кожного елемента, який ви хочете вставити у ваш документ:
    • Перетягніть елемент на сторінку. InDesign створює кадр для цього елемента.

    • Перетягніть елемент на існуючий кадр. Якщо в кадрі є вміст, він заміняється вмістом з даних XML.

  3. Щоб відформатувати пункти, для яких ви створюєте макет, виконайте що-небудь з наступного:
    • Призначте теги XML абзацу, символу, таблиці та стилям комірки.

    • Застосуйте стилі до елементів.

    • Відформатуйте вручну обраний вміст, вибираючи параметри тексту на панелі управління

Призначення XML-тегів стилям

Теги XML — це просто описи даних, вони не містять вказівок з форматування. По суті, вам треба відформатувати вміст XML після того, як його імпортовано, та зробити його макет. Один зі способів це зробити — призначити теги XML стилям параграфів, символів, таблиць чи сегментів. Наприклад, тег Byline, у якому розміщується прізвище автора, можна було б призначити стилю символу автора, так що весь імпортований та поміщений вміст XML,який маркується ярликом Byline автоматично призначається стилю символу автора. Призначення тегів стилям полегшує форматування імпортованого вмісту XML та скорочує потрібний для цього час.

Не потрібно призначати кожен тег стилю параграфів чи символів. Деякі елементи можуть не з’являтися ву макеті, а інші, можливо, легше форматувати один за раз. Окрім того, дочірні елементи приймають стиль абзаців чи символів, котрий призначено їх вихідним елементам, що може створити плутанину, якщо з обережності не призначати вихідні та дочірні елементи окремо.

Примітка.

Команда «Призначити теги стилям» повторно застосовує стилі по всьому документу, іноді з небажаними результатами. Коли призначають тег стилю, текст, котрий до цього було призначено одному стилю, може бути перепризначено іншому, у залежності від його тега XML. Якщо ви вже відформатували якийсь текст, можливо, ви застосуєте стилі вручну щоб запобігти перекриванню вибраного стилю абзаців та символів.

  1. Оберіть «Призначити теги стилям» з меню панелі «Теги» або меню панелі «Структура».
    Діалогове вікно «Призначити теги стилям»
    Меню стилів з’явиться для кожного тега в діалоговому вікні «Призначити теги стилям».

  2. Виконайте одну з описаних нижче дій.
    • Щоб імпортувати стилі, теги та визначення призначення з іншого документа, натисніть «Завантажити», оберіть документ та клацніть «Відкрити».

    • Щоб призначити теги стилям індивідуально, натисніть на колонці «Стиль», що примикає до тега, та оберіть стиль абзацу чи символу з меню, котре з’являється. (Символ абзацу визначає стилі абзаців у меню; «А» визначає стилі символів.) Повторіть для кожного тега, який ви хочете призначити.

    • Щоб автоматично призначити теги стилям з тими ж іменами, натисніть «Призначити по імені». Стилі з іменами, що збігаються з іменами тегів виділяються в колонці «Стиль». Для того, щоб співпадали, тег і стиль не тільки повинні мати одне й те ж саме ім’я, але й однакове положення; H1 та h1, наприклад, не є відповідниками. (Якщо одне й те саме ім’я стилю існує у двох різних групах стилів, «Призначити за іменем» не працює, а вас попереджають перейменувати один зі стилів.)

  3. Натисніть кнопку «OK».

Про автоматичне створення макета

Використовуючи InDesign, можна автоматично помістити імпортований вміст XML у макет. Щоб це зробити, спочатку створіть шаблонні кадри чи таблиці, та додайте до них теги з тими самими іменами тегів, що й елементи XML, котрі ви хочете помістити в них. Потім імпортують вміст XML у заповнювачі в режимі «Об’єднати». Коли теги збігаються за іменем і структурною ієрархією, InDesign об’єднує вміст XML, замінюючи існуючий вміст у документі.

Дана технологія корисна, коли хочуть використати один і той же макет для різних наборів вмісту. Наприклад, щотижнева газета може мати один і той же макет з тижня в тиждень, але пропонувати різний вміст з кожною публікацією.

Щоб імпортована XML об’єднувалась безпосередньо в макет, ваш документ повинен відповідати таким вимогам:

  • Кадри (чи таблиці) в документі повинні бути позначені такими ж самими іменами тегів, що й елементи у файлі XML, який ви маєте намір імпортувати.

  • Структура документа (як показано на панелі «Структура») повинна відповідати структурі імпортованого файлу XML. Інакше кажучи, елементи з однаковими іменами повинні знаходитись у одних і тих самих місцях у структурній ієрархії обох файлів. Щоб досягти цієї паралельної структури, слід впорядкувати елементи та змінити їх порядок (і дочірніх елементів також) на панелі «Структура» або використати параметр «Застосувати XSLT», коли імпортують файл XML.

Примітка.

InDesign вбудовує об’єднаний вміст XML тільки в існуючі кадри. Будь-який елемент, що не входить у кадр (або серії зв’язаних кадрів), стає витісненим текстом.

Робота з даними, що повторюються

XML повторюється, якщо та сама конфігурація елемента з’являється декілька разів підряд, але містить унікальні дані в кожному прикладі. Наприклад, записи в базі даних повторюються. Адреси в таблиці бази даних містять інформацію, що повторюється — прізвище, адресу вулиці, місто, державу (штат), поштовий індекс — для декількох осіб.

Під час імпорту вмісту XML можна вибрати параметр «Клонувати текстові елементи, що повторюються» у діалоговому вікні «Параметри імпорту XML». Якщо вибрати цей параметр, InDesign клонує повторювані елементи в структурі. Розмноження дозволяє об’єднувати дані XML, що повторюються, у документ, без створення шаблонних елементів на панелі «Структура» (або шаблонного тексту в кадрі) для кожного окремого запису. Наприклад, щоб імпортувати список адрес XML з 25 словами, створіть відповідну структуру елемента для одного слова на панелі «Структура». Коли ви імпортуєте весь список, InDesign розмножить ту структуру щоб створити елементи для 25 слів.

Повторюваний вміст XML вбудовується як єдиний матеріал, коли об’єднується в документ. Якщо шаблонні кадри вже були зв’язані одне з одним, вміст вбудовується з одного кадру до наступного. Якщо в шаблонних кадрах недостатньо місця для розміщення вмісту XML, можна автоматично зверстати вміст, що залишається, створенням та зв’язуванням додаткових кадрів; не потрібно вручну перетягувати елементи з панелі «Структура» у окремі кадри.

Макет
Зв’язані заповнювачі в макеті (зліва) та макет після імпорту (справа)

Створення заповнювачів для автоматичного створення макета

Створіть шаблонні кадри або таблиці у вашому документі, коли хочете, щоб InDesign автоматично об’єднав імпортовану XML у ваш макет.

Примітка.

InDesign вбудовує об’єднаний вміст XML тільки в існуючі кадри. Будь-який вміст, що не вміщається в кадри, що додаються, стає витісненим текстом.

Можна також створити шаблонний текст щоб гарантувати, що дані XML поміщено та відформатовано правильно на сторінці. Шаблонний текст можна також використовувати для включення табуляторів, інтервалів чи позначок (що називаються статичний текст) між елементами XML, що з’являться в кадрі.

Шаблонний текст із тегами й макет після імпорту
Шаблонний текст із тегами (зліва) й макет після імпорту (справа)

A. Повернення й статичний текст, що додається між елементами B. Шаблонний текст 

Наприклад, якщо ви імпортуєте та поміщуєте інформацію про товар, то можна розділити ім’я, опис та ціну товару табуляцією, та включати ярлики, такі, як «Товар:» або «Ціна:» перед словами шаблонного тексту для тих елементів. Коли дані XML об’єднуються в кадр, між елементами вмісту зберігаються статичні ярлики, інтервали та табуляція.

Примітка.

Якщо ви об’єднуєте повторювані дані XML у ваш документ та віддаєте команду InDesign розмножити елементи, що повторюються, текст позначки та інтервали також розмножуються для кожного зразку даних.

Створення шаблонного кадру

  1. Використовуючи інструмент «Текст», створіть текстовий кадр для вмісту XML.

    Примітка.

    Якщо хочете вбудувати імпортований вміст XML з одного кадру до іншого, створіть кілька кадрів та зв’яжіть їх разом.

  2. Відкрийте панель «Структура» («Перегляд» > «Структура» > «Показати структуру») та панель «Теги» («Вікно» > «Утиліти» > «Теги»).
  3. Якщо панель «Теги» не містить теги з іменами, що збігаються з елементами XML, які ви плануєте імпортувати, створіть теги або завантажте теги з файлу XML.
  4. Промаркуйте шаблонний кадр відповідним тегом із панелі «Теги». (Коли ви маркуєте кадр, будь-які кадрам, зв’язаним з ним, призначається один і той же самий тег.)
  5. Якщо це потрібно, встановіть або додайте елементи на панелі «Структура», щоб відповідали елементам та структурі XML, котру ви будете імпортувати.

Створення шаблонної таблиці

Можна імпортувати елементи XML і в шаблонну таблицю, і в шаблонний кадр. У таблиці кожна клітина представлена елементом. InDesign поміщає вміст XML у таблицю клітинка за клітинкою, елемент за елементом, починаючи з лівого верхнього кутка, узгоджуючи елемент з клітинкою з тегом. Під час створення шаблонних таблиць ви повинні додавати теги як до таблиці, так і до кожної клітинки в таблиці. (Об’єднані клітинки вважаються однією клітинкою.)

Оскільки InDesign не розрізняє рядки та колонки під час імпорту, кількість колонок у заповнювачі повинна відповідати кількості колонок у імпортованому вмісті. Окрім того, всі елементи клітинки таблиці повинні міститися в одному елементі таблиці. Інакше кажучи, клітинки є елементами-братами одного й того ж самого батька.

Шаблонна таблиця
Шаблонна таблиця (вгорі) та розміщення вмісту XML у шаблонну таблицю (внизу)

  1. Відкрийте панель «Теги» («Вікно» > «Утиліти» > «Теги») та панель «Структура» («Перегляд» > «Структура» > «Показати структуру»).
  2. Якщо в панелі «Теги» нема імен, що збігаються з іменами елементів таблиці XML, котрі ви плануєте імпортувати, або завантажте теги з існуючого документа, або створіть теги.

    Примітка.

    Як мінімум, у вас повинні бути теги для батьківських елементів клітинок таблиці, клітинки таблиці та елементи, у котрих буде розміщуватись таблиця.

  3. Створіть таблицю з відповідною кількістю колонок для вмісту XML. Вам не потрібно створювати точну кількість рядків, оскільки InDesign додасть рядки в таблицю, якщо це буде необхідно.
  4. Маючи точку вставки в таблиці, оберіть Таблиця > Виділити >Таблиця та виділіть відповідний тег на панелі «Теги».
  5. Маркуйте кожну клітинку таблиці бажаним тегом. У залежності від структури вашого вмісту XML ви можете або виділити тег та маркувати клітинки окремо, або ж виділити весь рядок чи колонку — наприклад, якщо ви хочете додати теги до першого рядка чи рядка заголовку — та маркувати виділені клітинки, використовуючи один і той же самий тег.
  6. Якщо потрібно, впорядкуйте та додайте елементи на панелі «Структура» так, щоб ваш документ містив ті ж елементи та структуру, що й файл XML, котрий ви будете імпортувати.

Створення шаблонної структури для даних, що повторюються

Ті ж самі правила для об’єднання XML також застосовуйте при об’єднанні XML, що повторюються. Структура елементів на панелі «Структура» повинна відповідати структурі імпортованих даних XML, а будь-які шаблонні кадри повинні бути промарковані тими ж самими іменами тегів, що й батьківські елементи у файлі XML.

Панель «Структура», котре зображає структуру шаблонного тексту
Панель «Структура», котре зображає структуру шаблонного тексту

A. Елемент, що буде містити всі повторювані елементи. B. Елемент, що буде розмножений за імпорту вмісту XML, що повторюється C. Дочірні елементи для даних, що містяться в елементі, що повторюється 
  1. Спочатку вам потрібен батьківський елемент або елемент кореневого каталогу, що описує збір інформації, або записів, котру(і) ви будете імпортувати.

    Наприклад, елемент Chapter, котрий буде містити серію рецептів.

  2. Під цим батьком створіть один елемент, котрий описує інформацію (або запис), що буде повторюватись.

    Наприклад, під елементом Chapter можна було б створити елемент Recipe. Це елемент, котрий буде розмножуватись для кожного запису в імпортованій XML.

  3. Під цим елементом створіть дочірні елементи для опису одиниць інформації (або полів), що складають цей запис.

    наприклад, під елементом Recipe можна було б створити елементи Recipename, Ingredients, Instructions, Notes та Serving.

Примітка.

Щоб включити позначки, повернення чи табулятори між елементами «полів» у повторюваних даних XML, створіть шаблонні елементи в кадрі, у котрий буде об’єднано імпортований вміст. І додайте інтервали чи ярлики, якщо потрібно, між заповнювачами.

Створення шаблонного тексту

  1. Відкрийте існуючий документ або створіть новий документ для XML.
  2. Відкрийте панель «Теги» («Вікно» > «Утиліти» > «Теги») та панель «Структура» («Перегляд» > «Структура» > «Показати структуру»).
  3. Упевніться, що панель «Теги» містить імена тегів, що збігаються з іменами елементів, котрі ви будете імпортувати файлом XML, і створіть нові теги чи завантажте потрібні теги, якщо необхідно.

    Примітка.

    Імпорт зразку вмісту XML є найпростішим способом отримання всіх необхідних тегів та упевнитись, що структура документа співпадає з файлом XML.

  4. Створіть шаблонні кадри (і зв’яжіть їх разом), якщо необхідно для вашого вмісту XML.
  5. Використовуючи інструмент «Текст», натисніть у першому кадрі щоб створити точку вставки, та наберіть шаблонний текст для кожного елемента, що ви хочете об’єднати в той кадр. Включіть будь-які інтервали, котрі ви хочете мати між елементами, і будь-який текст позначки.

    Примітка.

    Якщо ви будете імпортувати дані, що повторюються, вам потрібно лише створити один зразок тексту для елементів, що будуть повторюватись.

  6. Відформатуйте текст так, щоб він мав такий вигляд, у якому ви хочете щоб він з’являвся в остаточному документі.
  7. Маркуйте текстовий кадр тегом для батьківського елемента, котрий буде містити елементи (чи дані, що повторюються), які ви хочете імпортувати в той кадр.
  8. Розташуйте точку вставки в шаблонному тесті та оберіть Правка > Редагувати в редакторі матеріалу.
  9. Оберіть Перегляд > Структура > Показати маркери з тегами.
  10. Виберіть меню «Правка» > пункт Виділити все.
  11. У панелі тегів виділіть «Додати тег», а потім натисніть на тому тегові, котрий ви призначили кадру.

    InDesign здійснює обтікання шаблонного тексту тегом, і додає елемент на панель «Структура».

  12. Виділіть текст, котрий представляє перший дочірній елемент та натисніть на його тегові на панелі «Теги». Повторюй те доти, поки ви не додали теги до усього дочірнього шаблонного тексту.

    Примітка.

    Під час додавання тегів до шаблонного тексту не виділяйте інтервал чи текст позначки, котрі ви хочете зберегти між елементами. Додавайте теги тільки до того тексту, котрий ви хочете замінити вмістом XML

  13. На панелі «Структура» перегляньте ієрархію, створену вашим маркуванням для забезпечення її відповідності структурі вмісту XML, котрий ви будете імпортувати.

Імпорт і об’єднання XML

Після створення та маркування шаблонних кадрів, таблиць та тексту — після того, як ви впевнились, що ваш документ і вхідний файл XML має одні й ті ж самі теги та структуру — можна імпортувати вміст XML у ваш макет.

Для імпорту XML у заповнювачі слід застосовувати параметр Об’єднати вміст (або замінити існуючий вміст у вашому документі). Під час об’єднання вмісту InDesign заміняє елементи з однаковими тегами та структурами у вашому документі імпортованими елементами XML. Ви можете скористатись додатковими параметрами імпорту для виключення імпортованого вмісту , котрий не відповідає структурі документа, стерти елементи документа, котрі не співпали з або не були замінені імпортованим XML, та розмножити елементи XML, що повторюються.

Якщо імпортований файл XML містить елементи, котрих нема в документі, InDesign поміщає ці елементи на панелі «Структура», не створюючи їх макет у нашому документі.

Щоб успішно об’єднати XML у заповнювачі, пам’ятайте такі правила:

  • Маркуйте заповнювачі тим ж іменем тега, що й в елемента XML, котрий його замінить (або буде в нього вбудовано).

  • У шаблонному тексті переконайтеся, що інтервали, повернення, табуляція чи статичний текст позначки знаходяться поза тегами шаблонних елементів, але в батьківському елементі для матеріалу.

  • Коли ви імпортуєте XML, виділіть «Не імпортувати вміст елементів, що містять тільки пробіли». (Це зберігає інтервали та текст позначки, якщо імпортовані вами елементи складаються тільки з пробілів.)

Об’єднання XML в існуючий вміст або заповнювачі

  1. Відкрийте документ InDesign, котрий містить заповнювачі для вмісту XML.
  2. Відкрийте панель «Структура» (Переглянути > Структура > Показати структуру).
  3. Оберіть «Файл» > «Імпорт XML» (або оберіть «Імпорт XML» у меню панелі «Структура»), а потім виберіть файл XML, який потрібно імпортувати.
  4. Виділіть «Показати параметри імпорту XML».
  5. Виберіть «Об’єднати вміст», а потім натисніть «Відкрити».
  6. Щоб зв’язати матеріал XML з оригінальним файлом XML, виберіть «Створити зв’язок».

    InDesign занесе до списку файл XML на панелі «Зв’язки» й відобразить жовтий попереджувальний трикутник на панелі, якщо первинний файл XML зміниться.

  7. Виділіть додаткові параметри імпорту, якщо потрібно:

    Розмножити текстові елементи, що повторюються.

    Якщо ви імпортуєте XML, що повторюються, розмножте одинарний шаблонний елемент щоб створити контейнер для кожного запису у файлі.

    Імпортувати тільки елементи, що збігаються з існуючою структурою.

    Фільтрує вхідну XML так, що елементи, котрих немає на панелі «Структура», не імпортуються.

    Не імпортувати матеріали, що містять тільки пробіли.

    Зберігає будь-які інтервали або текст позначки, вставлені між елементами в шаблонному кадрі.

    Видалити елементи, кадри та вміст, що не відповідають імпортованому XML

    Після імпорту XML стирає будь-які елементи чи заповнювачі у вашому документі, що не відповідали (або не були замінені) вхідними даними.

  8. Натисніть кнопку «OK».

InDesign об’єднує вміст у документ починаючи з першого елемента, що співпадає, у файлі XML.

Параметри імпорту XML

Під час імпорту й поміщення даних XML із використанням параметра «Об’єднати вміст» вікно параметрів імпорту XML пропонує наступні параметри:

Створити зв’язок.

Створює зв’язок із файлом XML таким чином, що коли файл XML оновлюється, можна оновити його дані XML у вашому документі InDesign.

Застосувати XSLT.

Застосовує таблицю стилів для визначення трансформування імпортованого XML. Виберіть «Переглянути» (Windows) чи «Обрати» (Mac OS) щоб виділити файл XSLT (.xsl або .xslt) у файловій системі. Використати видавничу інструкцію з XML, параметр за замовчуванням змушує InDesign використовувати інструкцію обробки XSL, якщо якась є у файлі XML, щоб трансформувати дані XML.

Розмножити текстові елементи, що повторюються.

Повторити форматування, застосоване до шаблонного тексту з тегами для вмісту, що повторюється. Створіть один зразок форматування (наприклад, адресу), а потім повторно використайте його макет для автоматичного створення інших зразків. (Дивіться Робота з даними, що повторюються.)

Імпортувати тільки елементи, що збігаються з існуючою структурою.

Фільтрує імпортований вміст таким чином, що імпортуються тільки елементи з імпортованого файлу з елементами, що збігаються, у документі.

Імпортувати текстові елементи в таблиці, якщо теги збігаються.

Імпортує елементи в таблицю, якщо теги співпадають з тегами, застосованими до шаблонної таблиці та її клітинок. Наприклад, використайте цей параметр для того, щоб помістити записи бази даних у таблицю під час створення прейскурантів чи аркушів списків.

Не імпортувати матеріали, що містять тільки пробіли.

Залишає існуючий вміст на місці, якщо вміст XML, що збігається, містить тільки пробіли (такі, як повернення чи знак табуляції). Використовуйте цей параметр, якщо ви включили текст між елементами у ваших шаблонних кадрах та ви хочете зберегти цей текст. Наприклад, під час створення макета рецептів, генерованих з бази даних, можна було б додати такі ярлики, як «Ingredients» чи «Instructions». До тих пір, поки батьківський елемент, котрий обтікає кожний рецепт, містить тільки пробіл, InDesign залишає взамін ярлик.

Видалити елементи, кадри та вміст, що не відповідають імпортованому XML.

Видаляє елементи з панелі «Структура» та макета документа, якщо вони не відповідають будь-яким елементам у імпортованому файлі XML. Використовуйте даний параметр для фільтрування даних з документа. Наприклад, під час імпорту імен та адрес можна мати шаблонний текст для елемента, що містить назву компанії. Якщо одне з імен не містить елемент компанії, InDesign видаляє елемент, що містить текст позначки.

Імпортувати таблиці CALS як таблиці InDesign.

Імпортує будь-які таблиці CALS у файл XML як таблиці InDesign.

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності