User Guide Cancel

Customize your workspace in InDesign

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Customize your workspace in InDesign
      3. Toolbox
      4. Set preferences
      5. Properties panel
      6. Touch workspace
      7. Default keyboard shortcuts
      8. Document recovery and undo
    3. Generative AI
      1. Text to Image
      2. Generative AI FAQ
  3. Create and layout documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Convert PDFs to InDesign files in InDesign (Beta)
      7. Create book files
      8. Add basic page numbering
      9. Number pages, chapters, and sections
      10. Convert QuarkXPress and PageMaker documents
      11. Share content
      12. Understand a basic managed-file workflow
      13. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
      2. Align and distribute objects using rulers
      3. Measure objects using the Measure tool
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. South-East Asian Scripts
      4. Arabic and Hebrew features in InDesign
      5. Create type on a path
      6. Bullets and numbering
      7. Glyphs and special characters
      8. Text composition
      9. Text variables
      10. Generate QR codes
      11. Edit text
      12. Align text
      13. Wrap text around objects
      14. Anchored objects
      15. Linked content
      16. Format paragraphs
      17. Format characters
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Auto Style text
      3. Work with Style Packs
      4. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Spell check and language dictionaries
      1. Check spelling, autocorrect, and dynamic spelling
      2. Create, add, and manage dictionaries and words
      3. Change dictionary preferences
      4. Duden dictionary
    6. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    7. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    8. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    9. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    10. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Frames and objects
      10. Align and distribute objects
      11. Linked and embedded graphics
      12. Integrate AEM assets
    11. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Understand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Find and replace
    1. Find and replace text
    2. Find and replace fonts
    3. Find and replace glyphs
    4. Find and replace using GREP expressions and queries
    5. Find and replace objects
    6. Find and replace colors
    7. Search options to find and replace
  6. Share
    1. Save and access cloud documents
    2. Organize, manage, and share cloud documents
    3. View and manage versions in cloud documents
    4. Common questions about InDesign cloud documents
    5. Share and collaborate        
    6. Share for Review
    7. Review a shared InDesign document
    8. Manage feedback 
  7. Publish
    1. Place, export, and publish
      1. Publish online
      2. Publish online dashboard
      3. Copy, insert graphics
      4. Export content for EPUB
      5. Adobe PDF options
      6. Export content to HTML
      7. Export to Adobe PDF
      8. Export to JPEG format
      9. Export HTML
      10. DPS and AEM Mobile overview
      11. Supported File Formats
      12. Export and import User Settings
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  8. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  9. Troubleshooting
    1. Fixed issues
    2. Known issues
    3. Crash on launch
    4. Preference folder read-only issue
    5. Troubleshoot file issues
    6. Unable to export PDF
    7. InDesign document recovery

Learn to customize your workspace and efficiently organize windows and panels.

Discover how to arrange windows, access panels effortlessly, and create a workspace that caters to your unique workflow.

Manage windows and panels

You can create a custom workspace by moving and adjusting document windows and panels. You can also save these custom workspaces so that you can easily switch back to them whenever required.

Rearrange, dock, or undock document windows

When you open more than one file, the Document windows are tabbed.

  • To rearrange tabbed Document windows, drag a window’s tab to a new location in the group.
  • To dock a Document window to a separate group of Document windows, drag the window into the group.
  • To undock (float or untab) a Document window from a group of windows, drag the window’s tab out of the group.

Watch this short clip to learn how to dock, undock and rearrange Document windows.

Dock and undock panels

A dock is a collection of panels or panel groups displayed together, generally in a vertical orientation. You dock and undock panels by moving them into and out of a dock.

  • To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.

  • To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

  • To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock or make it free-floating.

Watch this short clip to learn how to dock and undock panels.

Hide or show all panels

  • To hide or show all panels, including the Tools, and Control panels, press Tab.

  • To hide or show all panels except the Tools, and Control panels, press Shift+Tab.

Add, remove, and move panels

If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge of the workspace until a drop zone appears.

  • To add a panel, select it from the Window menu and dock it wherever you want.
  • To remove a panel, right-click (Windows) or Control-click (macOS) its tab, and then select Close.
  • To move a panel, drag it by its tab.
  • To move a panel group, drag the title bar.
Note:

The position of the mouse (rather than the position of the panel) activates the drop zone, so if you don’t see the drop zone, try to drag the mouse to the place where the drop zone should be.

Stack floating panels

The panel floats freely when you drag a panel out of its dock but not into a drop zone. The floating panel allows you to position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when you drag the topmost title bar.

  • To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.

  • To change the stacking order, drag a panel up or down by its tab.

Collapse and expand panel icons

You can collapse panels to icons to reduce clutter in the workspace. In some cases, panels are collapsed to icons in the default workspace.

  • Select   at the top of the dock to collapse or expand all panel icons in a column. To expand a single panel icon, select the icon.
  • Adjust the dock width to resize panel icons and hide labels for a more streamlined view. Expand the dock width to display icon text.
  • Drag panel icons to rearrange them within the dock, between docks, or as floating icons.
Collapsed and expanded panels
Collapsed and expanded panel icons

Use panel menus

Access the panel menu options using the panel menu icon  .

The options that you see when you click on the panel menu icon.
Panel menu options

Scale the user interface

You can adjust User Interface Scaling of InDesign based on your requirement. When you launch InDesign with fresh preference settings, it identifies your screen resolution and adjusts the application scale factor accordingly.

To scale the user interface on your screen, follow these steps: 

  1. Select Edit > Preferences User Interface (Windows) or  InDesign > Preferences > User Interface (macOS).

  2. Select UI Sizing slider to increase or decrease the size of the UI based on your screen resolution. 

    You can check the preview of the scaled UI, which is displayed next to the slider.

    UI scaling

  3. Select the Scale Cursor Proportionately option to scale the cursor icons in proportion to the user interface.

  4. Use the slider to scale Anchor Points, handle, and Bounding Box Display Size.

  5. Relaunch InDesign to apply the updated settings. If you don't relaunch InDeisgn now, the changes will take effect the next time when you launch InDesign.

Create and switch workspaces

Create and save the current panel size and position as a named workspace to easily restore it, even if panels are moved or closed. The names of saved workspaces appear in the workspace switcher in the Application bar.

  1. Select Window > Workspace > New Workspace and type a name for the workspace.

  2. Under Capture, select one or more options:

    Panel Locations

    Saves the current panel locations.

    Menu Customization

    Saves the current set of menus.

Reset and delete workspaces

  • To modify a workspace, select Windows > Workspace > Reset <Name of the workspace>.
  • To delete a workspace, select Windows > Workspace > Delete Workspace.

More like this

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

 Adobe

Get help faster and easier

New user?