Remarque :

pour les versions de Photoshop antérieures à Photoshop CC, certaines fonctionnalités décrites dans le présent article peuvent être disponibles que si vous disposez de Photoshop Extended. Photoshop CC ne dispose d’aucune offre Extended séparée. Toutes les fonctions de Photoshop Extended font partie de Photoshop CC.

A propos de la fonction Mesure

La fonction Mesure de Photoshop vous permet de mesurer n’importe quelle zone définie à l’aide de l’outil Règle ou d’un outil de sélection, y compris des zones irrégulières sélectionnées avec les outils Lasso, Sélection rapide ou Baguette magique. Vous pouvez également calculer la hauteur, la largeur, la zone et le périmètre ou effectuer le suivi des mesures d’une ou plusieurs images. Les données des mesures sont enregistrées dans le panneau Journal des mesures. Vous pouvez personnaliser les colonnes du journal des mesures, trier les données des colonnes et exporter les données du journal dans un fichier texte Unicode délimité par des tabulations.

Pour consulter une vidéo sur la fonction Mesure, rendez-vous à l’adresse www.adobe.com/go/vid0029_fr.

Echelle de mesure

Définissez une échelle de mesure pour spécifier qu’un nombre donné de pixels dans l’image équivaut à un nombre d’unités d’échelle, telles que les pouces, les millimètres ou les microns. Lorsque vous avez créé une échelle, vous pouvez mesurer des zones et recevoir les calculs et les résultats du journal dans les unités d’échelle sélectionnées. Vous pouvez créer plusieurs échelles de mesure prédéfinies bien qu’une seule échelle puisse être utilisée à la fois dans le document.

Marqueurs d’échelle

Vous pouvez placer des marqueurs d’échelle sur une image pour afficher l’échelle de mesure. Les marqueurs d’échelles sont accompagnés ou non d’une légende affichant les unités d’échelle des mesures.

Définition de l’échelle de mesure

Utilisez l’outil Règle pour définir l’échelle de mesure d’un document. Vous pouvez créer des échelles de mesure prédéfinies pour les mesures d’échelle couramment utilisées. Les paramètres prédéfinis sont ajoutés au sous-menu Image > Analyse > Définir l’échelle de mesure. Dans le sous-menu, une coche est visible en regard de l’échelle de mesure utilisée pour le document actif ; l’échelle est également indiquée dans le panneau Informations.

Remarque :

l’échelle de mesure est définie automatiquement pour les fichiers DICOM. Voir A propos des fichiers DICOM.

Choisissez Image > Analyse > Définir l’échelle de mesure > Par défaut pour rétablir l’échelle de mesure par défaut, à savoir 1 pixel = 1 pixel.

Définition de l’échelle de mesure

  1. Ouvrez un document.
  2. Choisissez Image > Analyse > Définir l’échelle de mesure > Personnalisée. L’outil Règle est automatiquement sélectionné. Faites glisser l’outil pour mesurer une distance en pixel dans l’image, ou entrez une valeur dans la zone de texte Longueur de pixel. Le paramètre actif est restauré lorsque vous refermez la boîte de dialogue Echelle de mesure.

  3. Entrez la longueur logique et les unités logiques que vous souhaitez faire correspondre à la longueur de pixel.

    Par exemple, si la longueur de pixel est de 50 et que vous souhaitez définir une échelle de 50 pixels par micron, entrez 1 dans la zone Longueur logique, puis microns dans la zone Unités logiques.

  4. Cliquez sur OK dans la boîte de dialogue Echelle de mesure pour appliquer l’échelle de mesure au document.
  5. Choisissez Fichier > Enregistrer pour enregistrer le document avec le paramètre d’échelle de mesure actif.

    Pour afficher l’échelle dans le panneau Informations, choisissez la commande Options de panneau dans le menu du panneau , puis sélectionnez l’option Echelle de mesure dans la zone Informations sur l’état.

    Remarque :

    Pour afficher l’échelle de mesure au bas de la fenêtre du document, choisissez Afficher > Echelle de mesure dans le menu de la fenêtre du document.

Création d’une échelle de mesure prédéfinie

  1. Ouvrez un document.
  2. Choisissez Image > Analyse > Définir l’échelle de mesure > Personnalisée.

  3. Créez une échelle de mesure.
  4. Cliquez sur Enregistrer l’échelle prédéfinie, puis donnez un nom au paramètre prédéfini.
  5. Cliquez sur OK. Le paramètre prédéfini que vous venez de créer est ajouté au sous-menu Image > Analyse > Définir l’échelle de mesure.

Suppression d’une échelle de mesure prédéfinie

  1. Choisissez Image > Analyse > Définir l’échelle de mesure > Personnalisée.

  2. Sélectionnez le paramètre prédéfini que vous souhaitez supprimer.
  3. Cliquez sur Supprimer l’échelle prédéfinie puis sur OK.

Utilisation de marqueurs d’échelle

Les marqueurs d’échelle de mesure affichent l’échelle de mesure utilisée dans votre document. Il convient de définir l’échelle de mesure d’un document avant de créer un marqueur d’échelle. Vous pouvez définir la longueur du marqueur dans une unité logique, inclure une légende indiquant la longueur et définir la couleur du marqueur et de la légende sur noir ou sur blanc.

Pour consulter une vidéo sur la fonction Mesure, rendez-vous à l’adresse www.adobe.com/go/vid0029_fr.

Création d’un marqueur d’échelle

  1. Choisissez Image > Analyse > Marqueur d’échelle de mesure.

  2. Dans la boîte de dialogue Marqueur d’échelle de mesure, définissez les options suivantes :

    Longueur

    Entrez une valeur pour définir la longueur du marqueur d’échelle. La longueur en pixel du marqueur dépend de l’échelle de mesure active pour le document.

    Police

    Choisissez la police de caractères du texte affiché.

    Corps de la police

    Choisissez le corps de la police du texte affiché.

    Afficher le texte

    Sélectionnez cette option pour afficher la longueur et les unités logiques du marqueur d’échelle.

    Position du texte

    Affiche la légende au-dessus ou au-dessous du marqueur d’échelle.

    Couleur

    Définit l’affichage du marqueur d’échelle et de la légende en noir ou en blanc.

  3. Cliquez sur OK.

Le marqueur d’échelle se trouve dans l’angle inférieur gauche de l’image. Le marqueur ajoute un groupe de calques au document, qui contient un calque de texte (si l’option Afficher le texte est sélectionnée) et un calque graphique. Vous pouvez utiliser l’outil Déplacement pour déplacer le marqueur d’échelle ou l’outil Texte pour modifier la légende ou changer la taille, la police ou la couleur du texte.

Ajout ou remplacement de marqueurs d’échelle

Vous pouvez placer plusieurs marqueurs d’échelle dans un document ou remplacer les marqueurs existants.

Remarque :

les marqueurs d’échelle supplémentaires sont placés à la même position sur l’image, et il est possible qu’ils se recouvrent les uns les autres, selon leur longueur. Pour afficher un marqueur sous-jacent, désactivez le groupe de calques du marqueur d’échelle.

  1. Choisissez Image > Analyse > Marqueur d’échelle de mesure.

  2. Cliquez sur Supprimer ou Conserver.
  3. Entrez les paramètres du nouveau marqueur, puis cliquez sur OK.

Suppression d’un marqueur d’échelle

  1. Dans le panneau Calques, sélectionnez le groupe de calques Marqueur d’échelle de mesure correspondant au marqueur d’échelle à supprimer.
  2. Cliquez avec le bouton droit de la souris sur le groupe de calques, puis sélectionnez Supprimer le groupe dans le menu contextuel, ou cliquez sur le bouton Supprimer le calque.
  3. Cliquez sur Le groupe et son contenu.

Prise d’une mesure

Les mesures peuvent être prises à l’aide des outils de sélection, de l’outil Règle et de l’outil Comptage de Photoshop. Choisissez un outil de mesure adapté au type de données que vous souhaitez enregistrer dans le journal des mesures.

  • Créez une zone de sélection pour mesurer des valeurs telles que la hauteur, la largeur, le périmètre, la zone et les valeurs de gris des pixels. Vous pouvez mesurer une ou plusieurs sélections à la fois.

  • Dessinez un trait à l’aide de l’outil Règle pour mesurer la distance linéaire et l’angle.

  • Utilisez l’outil Comptage pour compter les éléments présents sur l’image et enregistrer ce nombre. Voir Comptage d’objets dans une image.

    Chacune des mesures calcule un ou plusieurs points de données. Les points de données sélectionnés déterminent les informations enregistrées dans le journal des mesures. Les points de données correspondent au type d’outil avec lequel vous prenez les mesures. Les points de données disponibles pour mesurer les sélections sont la zone, le périmètre, la hauteur et la largeur. Pour les mesures prises avec l’outil Règle, les points de données disponibles sont la longueur et l’angle. Vous pouvez créer et enregistrer des groupes de points de données pour des types de mesures donnés afin d’accélérer votre flux de production.

  1. Ouvrez un document existant.
  2. Choisissez Image > Analyse > Définir l’échelle de mesure, puis sélectionnez une échelle de mesure prédéfinie pour le document (voir Définition de l’échelle de mesure), ou sélectionnez Personnalisée et définissez une échelle de mesure personnalisée.

    Les mesures sont calculées et enregistrées dans le journal des mesures à l’aide des unités d’échelle actives lorsqu’une mesure est enregistrée. Si aucune échelle de mesure n’existe, l’échelle par défaut est 1 pixel = 1 pixel.

  3. (Facultatif) Choisissez Image > Analyse > Sélectionner des points de données, puis utilisez l’une des méthodes suivantes :

    • Choisissez Personnalisés pour sélectionner les points de données à mesurer.

    • Sélectionnez un paramètre prédéfini de points de données existant dans le sous-menu.

    Dans la boîte de dialogue Sélectionner des points de données, les points de données sont regroupés en fonction de l’outil qui peut les mesurer. Les points de données de la catégorie Commun sont disponibles pour tous les outils. Ils ajoutent des informations utiles au journal des mesures, par exemple le nom du fichier mesuré, l’échelle de mesure et la date et l’heure de la mesure.

    Par défaut, tous les points de mesure sont sélectionnés. Vous pouvez sélectionner un sous-ensemble de points de données pour un type de mesure spécifique et enregistrer la combinaison comme paramètre prédéfini de points de données.

    Remarque :

    lorsque vous prenez une mesure avec un outil spécifique, seuls les points de données associés à cet outil s’affichent dans le journal, et ce même si d’autres points de données sont sélectionnés. Par exemple, si vous prenez une mesure avec l’outil Règle, seuls les points de données de la catégorie Outil Règle figurent dans le journal des mesures, de même que les points de données sélectionnés dans la catégorie Commun.

  4. Choisissez un élément de l’image et un outil de mesure qui correspondent aux points de données sélectionnés. Utilisez l’une des méthodes suivantes :
    • Créez une ou plusieurs sélections sur l’image.

    • Choisissez Image > Analyse > Outil Règle, ou cliquez sur l’outil Règle dans la palette d’outils, puis utilisez l’outil pour mesurer la longueur d’une zone de l’image.

    • Choisissez Image > Analyse > Outil Comptage, ou cliquez sur l’outil Comptage dans la palette d’outils, puis comptez les éléments présents sur l’image.

  5. Choisissez la commande Fenêtre > Journal des mesures pour ouvrir le panneau Journal des mesures.
  6. Choisissez la commande Image > Analyse > Enregistrer les mesures ou cliquez sur le bouton Enregistrer les mesures dans le panneau Journal des mesures.

    Remarque :

    si les points de données sélectionnés ne correspondent pas à l’outil de mesure actif, un message vous invite à sélectionner des points de données pour cet outil.

    Le journal des mesures possède des colonnes pour chacun des points de données sélectionnés dans la boîte de dialogue Sélectionner des points de données. Pour chaque mesure, une nouvelle rangée est ajoutée dans le journal des mesures.

    Si vous mesurez plusieurs zones sélectionnées sur l’image, une rangée de données est créée dans le journal contenant les données de synthèse ou les données cumulatives de toutes les zones sélectionnées, suivie par une rangée de données pour chacune des zones de sélection. Chaque zone de sélection est répertoriée comme un élément distinct dans la colonne Libellé du journal et se voit attribuer un numéro unique.

    Vous pouvez répéter les étapes 2 à 6 pour différentes sélections effectuées dans un ou plusieurs documents. La colonne Document du journal des mesures reflète la source des données de mesure.

Points de données de mesure

Angle

Angle de l’orientation (±0-180) de l’outil Règle.

Zone

Zone de la sélection en pixels carrés ou exprimée dans l’unité correspondant au paramètre d’échelle de mesure actif (millimètres carrés, par exemple).

Circularité

4 pi (zone/périmètre2). Une valeur équivalant à 1 indique un cercle parfait. Lorsque la valeur se rapproche de 0, il s’agit d’un polygone de forme de plus en plus allongée. Il est possible que les valeurs ne soient pas valides pour les très petites sélections.

Nombre

Variable selon l’outil de mesure utilisé. Outil de sélection : nombre de zones de sélection discontiguës sur l’image. Outil Comptage : nombre d’éléments comptés sur l’image. Outil Règle : nombre de lignes de règle visibles (1 ou 2).

Date et heure

Applique un tampon indiquant la date et l’heure de la mesure.

Document

Identifie le document (fichier) mesuré.

Valeur de gris

Mesure de la luminosité, comprise entre 0 et 255 (pour les images 8 bits), 0 et 32 768 (pour les images 16 bits) ou 0 et 10 (pour les images 32 bits). Pour toutes les mesures associées aux valeurs de gris, l’image est convertie en interne en niveaux de gris (équivaut à choisir la commande Image > Mode > Niveaux de gris) à l’aide du profil de niveaux de gris par défaut. Les calculs nécessaires (moyenne, médiane, minimum, maximum) sont effectués pour chaque objet et pour le résumé.

Hauteur

Hauteur de la sélection (y max - y min), exprimée dans l’unité correspondant au paramètre d’échelle de mesure actif.

Histogramme

Génère des données d’histogramme pour chacune des couches de l’image (trois pour les images RVB, quatre pour les images CMJN, etc.), enregistrant le nombre de pixels pour chaque valeur de 0 à 255 (les valeurs 16 ou 32 bits sont converties en valeurs 8 bits). Lorsque vous exportez des données du journal des mesures, les données numériques de l’histogramme sont exportées dans un fichier CSV (comma separated values, valeurs séparées par une virgule). Ce fichier est placé dans son propre dossier, au même emplacement que l’exportation, dans un fichier texte délimité par tabulation, du journal des mesures. Les fichiers d’histogramme se voient attribuer un numéro unique, commençant à 0 et progressant par incréments de 1. Lorsque plusieurs sélections sont mesurées à la fois, un fichier d’histogramme est généré pour la totalité de la zone sélectionnée, ainsi que des fichiers d’histogramme supplémentaires pour chacune des sélections.

Densité intégrée

Somme des valeurs des pixels de la sélection. Elle équivaut au produit de la zone (en pixels) et de la valeur de gris moyenne.

Libellé

Identifie et numérote automatiquement chacune des mesures Mesure 1, Mesure 2, et ainsi de suite. Lorsque plusieurs sélections sont mesurées à la fois, chacune des sélections se voit attribuer un libellé et un numéro supplémentaire.

Longueur

Distance linéaire définie par l’outil Règle sur l’image, exprimée dans l’unité correspondant au paramètre d’échelle de mesure actif.

Périmètre

Périmètre de la sélection. Lorsque plusieurs sélections sont mesurées à la fois, une mesure est générée pour le périmètre total de toutes les sélections, ainsi que des mesures supplémentaires pour chacune des sélections.

Echelle

Echelle de mesure du document source (par exemple, 100 pixels = 3 miles).

Unités d’échelle

Unités logiques de l’échelle de mesure.

Facteur d’échelle

Nombre de pixels attribués à l’unité d’échelle.

Source

Source de la mesure : outil Règle, outil Comptage ou outil de sélection.

Largeur

Largeur de la sélection (x max - x min), exprimée dans l’unité correspondant au paramètre d’échelle de mesure actif.

Création d’un paramètre prédéfini de points de données

  1. Choisissez Image > Analyse > Sélectionner des points de données > Personnalisés.

  2. Sélectionnez les points de données à inclure dans le paramètre prédéfini.
  3. Cliquez sur Enregistrer l’échelle prédéfinie, puis donnez un nom au paramètre prédéfini.
  4. Cliquez sur OK. Le paramètre prédéfini est enregistré et est désormais disponible à partir du sous-menu Analyse > Sélectionner des points de données.

Modification d’un paramètre prédéfini de points de données

  1. Choisissez Image > Analyse > Sélectionner des points de données > Personnalisés.

  2. Choisissez le paramètre prédéfini à modifier dans le menu.
  3. Sélectionnez ou désélectionnez des points de données. Le nom du paramètre prédéfini devient Personnalisés.
  4. Cliquez sur Enregistrer le paramètre prédéfini. Entrez le nom du paramètre prédéfini d’origine pour remplacer le paramètre prédéfini existant, ou saisissez un nouveau nom pour créer un autre paramètre prédéfini.

Suppression d’un paramètre prédéfini de points de données

  1. Choisissez Image > Analyse > Sélectionner des points de données > Personnalisés.

  2. Choisissez le paramètre prédéfini à supprimer dans le menu.
  3. Cliquez sur Supprimer l’échelle prédéfinie, puis sur Oui pour confirmer la suppression.
  4. Cliquez sur OK.

Utilisation du journal des mesures

Le panneau Journal des mesures enregistre les données de mesure de l’objet que vous mesurez. Chacune des rangées du journal représente un ensemble de mesures, et les colonnes représentent les points de données d’un ensemble de mesure.

Lorsque vous mesurez un objet, une nouvelle rangée apparaît dans le journal des mesures. Vous pouvez réorganiser les colonnes du journal, trier les données des colonnes, supprimer des rangées ou des colonnes ou exporter les données du journal dans un fichier CSV.

Pour consulter une vidéo sur la fonction Mesure, rendez-vous à l’adresse www.adobe.com/go/vid0029_fr.

Affichage du journal des mesures

  1. Utilisez l’une des méthodes suivantes :
    • Choisissez Image > Analyse > Enregistrer les mesures.

    • Choisissez Fenêtre > Journal des mesures.

Sélection de rangées dans le journal

  1. Utilisez l’une des méthodes suivantes :
    • Cliquez sur une rangée du journal pour la sélectionner.

    • Pour sélectionner plusieurs rangées contiguës, cliquez sur la première rangée et faites glisser le curseur sur les rangées à ajouter, ou cliquez sur la première rangée et cliquez tout en maintenant la touche Maj enfoncée sur la dernière rangée.

    • Pour sélectionner des rangées non contiguës, cliquez sur la première rangée et cliquez tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée sur les rangées à ajouter.

    • Pour sélectionner toutes les rangées, cliquez sur Sélectionner toutes les mesures.

    • Pour désélectionner toutes les rangées, cliquez sur Désélectionner toutes les mesures.

Sélection de colonnes dans le journal

  1. Utilisez l’une des méthodes suivantes :
    • Cliquez sur l’en-tête d’une colonne.

    • Pour sélectionner plusieurs colonnes contiguës, cliquez sur un en-tête de colonne et faites glisser le curseur sur les colonnes à ajouter, ou cliquez sur le premier en-tête de colonne et cliquez sur le dernier en-tête de colonne tout en maintenant la touche Maj enfoncée.

    • Pour sélectionner des colonnes non contiguës, cliquez sur le premier en-tête de colonne et cliquez tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée sur les colonnes à ajouter.

Réorganisation, redimensionnement ou tri des colonnes dans le journal

  1. Utilisez l’une des méthodes suivantes :
    • Faites glisser les colonnes sélectionnées pour les réorganiser dans le journal. La position des colonnes est indiquée par une double ligne noire.

    • Pour redimensionner une colonne, cliquez sur son en-tête et faites glisser le séparateur.

    • Pour trier les données d’une colonne, cliquez sur son en-tête afin de modifier l’ordre de tri, ou cliquez avec le bouton droit de la souris sur l’en-tête et choisissez l’option Trier par ordre croissant ou Trier par ordre décroissant (les rangées ne peuvent pas être réorganisées manuellement).

Suppression de rangées ou de colonnes du journal

  1. Sélectionnez une ou plusieurs rangées ou colonnes du journal.
  2. Utilisez l’une des méthodes suivantes :
    • Choisissez Supprimer la sélection dans le menu du panneau Journal des mesures.

    • Cliquez sur l’icône de corbeille en haut du panneau.

    • Cliquez avec le bouton droit de la souris sur une rangée ou l’en-tête d’une colonne, puis sélectionnez la commande Supprimer dans le menu contextuel.

Exportation des données du journal des mesures

Vous pouvez exporter les données du journal des mesures dans un fichier texte au format CSV. Vous pouvez ouvrir ce fichier dans un tableur et y réaliser des opérations statistiques ou analytiques à partir des données de mesure.

  1. Sélectionnez une ou plusieurs rangées de données dans le journal.
  2. Utilisez l’une des méthodes suivantes :
    • Choisissez Exporter la sélection dans le menu du panneau Journal des mesures.

    • Cliquez sur l’icône Exporter les mesures sélectionnées, en haut du panneau.

    • Cliquez avec le bouton droit de la souris sur une rangée, puis sélectionnez la commande Exporter dans le menu contextuel.

  3. Entrez un nom de fichier et un emplacement, puis cliquez sur Enregistrer.

    Les mesures sont exportées dans un fichier texte UTF-8 au format CSV.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne